OBiTALK Community

General Support => Day-to-Day Use => Topic started by: GreenView on October 05, 2017, 02:07:42 pm



Title: TCP connection to 125.141.125.74 failed
Post by: GreenView on October 05, 2017, 02:07:42 pm
After working fine for years, suddenly my Obi200 device refuses to make or receive calls.  On outgoing calls it says "No Service Configured error".  Logging into obitalk.com it shows "Backing off:  TCP connection to 125.141.125.74 failed".  That address is in Korea.  A ping to that address works fine.

What is going on?

Adding, the device has one line configured, to use Google.  The Google account works fine using Hangouts on my mobile phone.  Inbound ports 10000-10099 are routed to the ObiTalk device.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on October 05, 2017, 04:18:00 pm
What DNS server are you pointing at?  You might want to change your DNS to Google's public DNS servers (8.8.8.8 and/or 8.8.4.4) just to see if it makes any difference. Once you change your DNS I would restart your modem, router, and OBi device in that order.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kevin-in-sa on October 30, 2017, 08:48:14 am
Did you ever solve this? I am having the same problem with OBi100. I tried everything I could find on the web with the exception of upgrading the firmware. It seems the link to the firmware is a broken link http://fw.obihai.com/OBi-latest.fw . That URL returns a "404 Not Found" error. So I can't upgrade the firmware. Did OBi cease supporting the OBi100?

UPDATE: I just ran across this announcement from OBi - http://blog.obihai.com/2016/08/end-of-life-announcement-obi100-and.html

I guess we were warned.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on October 30, 2017, 09:11:54 am

UPDATE: I just ran across this announcement from OBi - http://blog.obihai.com/2016/08/end-of-life-announcement-obi100-and.html


This issue (whatever the hell it is!) is unrelated to the 1xx series being End Of Life. As long as you have the latest firmware (1.3.0 Build: 2886) your OBi 100 should continue to function just fine.

http://fw.obihai.com/OBi110-1-3-0-2886.fw (http://fw.obihai.com/OBi110-1-3-0-2886.fw)

Just to be clear, you are located in the U.S. and you are not using a VPN? Correct?


Does ANYONE have any ideas on what could be causing this? I'm getting a brain cramp trying to figure out what could be generating these Korean IP addresses.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on October 31, 2017, 03:09:11 pm
See this on both obi's here too.  Can't dial out with gv. Inbound works fine because it goes through callcentric.

Reboot doesn't help.

-------------------

Edit:  Will give this a few hours to resolve.  If not, then it's plan b.  I was hoping to keep the obi boxes completely separated from the pbx.  But looks it's time to add the gv lines to it and point the obi to the pbx rather than gv directly.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on October 31, 2017, 04:07:34 pm
With logging enabled in the firewall I see this.

(https://i.imgur.com/EoVnnd5.png)

So it's not a Korean IP the box is trying to access, but rather google gv. No clue why status is showing the octets backwards.  

Edit:  I realize the IP is different than in the subject, but if you flip the octets around, 74.125.141.125 resolves back to google.

http://www.ip-tracker.org/locator/ip-lookup.php?ip=74.125.141.125


Title: Re: TCP connection to 125.141.125.74 failed
Post by: snomo on October 31, 2017, 04:45:34 pm
I'm having the same or very similar issue:
'Backing Off :
TCP connection to 173.194.198.125 failed"

I have tried removing the "SP1" settings, and re-configuring the account, as well as adding a "DMZ" in my router. Nothing has changed.

This started sometime this afternoon, after ~ 2years of working fine.

Mark


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Lensor on October 31, 2017, 05:48:02 pm
I also have this issue with both of my Obi devices... but with a different IP reported in the error.

I used the IP lookup at www.ultratools.com/tools/ipWhoisLookup and found the IP reported in the error that I see is in a block owned by a company called BIGLOBE Inc. in Tokyo.  The IP in the title of this one appears to be from KR.

One user reports 173.194.198.125 which appears to be a Google IP address... strange.


My Obi1062 and Obi202 - both working well for over 10 months - both have this issue and it started this afternoon as others have reported.  (GV accounts are not working, SIP accounts register without problems.)

I'm at the edge of my seat to understand why this is happening and hoping it will be fixed soon.

L


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Webslinger on October 31, 2017, 06:54:50 pm


I used the IP lookup at www.ultratools.com/tools/ipWhoisLookup and found the IP reported in the error that I see is in a block owned by a company called BIGLOBE Inc. in Tokyo.  The IP in the title of this one appears to be from KR.

Reverse those IP address numbers, and then do a whois on them.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Ryan_Chicago on October 31, 2017, 07:38:15 pm
Same here with my Obi 110 attempting to reconnect to Google Voice (GV) :(

Backing Off : TCP connection to 209.85.234.125 failed
Backing Off : TCP connection to 74.125.69.125 failed

Is this because Google has permanently shutdown their XMPP API?

https://cloud.google.com/appengine/docs/deprecations/xmpp

I fear all of the Obi GV users may be SOL.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on October 31, 2017, 07:49:05 pm
Same here with my Obi 110 attempting to reconnect to Google Voice (GV) :(

Backing Off : TCP connection to 209.85.234.125 failed
Backing Off : TCP connection to 74.125.69.125 failed

Is this because Google has permanently shutdown their XMPP API?

https://cloud.google.com/appengine/docs/deprecations/xmpp

I fear all of the Obi GV users may be SOL.

No,  "all of the OBi GV users" are not SOL.  This is not impacting every user.  It's a bug that Obihai is investigating, and will fix.  Google Voice is still available and supported by Obihai.

And, No, the deprecation you referenced does not apply in this situation.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: mikeb0 on October 31, 2017, 08:15:13 pm
My OBi 200 worked flawlessly for 1.5 years and today get the same issue here...
Phone LED is off, no inbound calls, and outbound I hear "No service configured error".
Echo test (**9 222 222 222) works perfectly.

SP1 Service Status: Backing Off (2s):TCP connection to 125.132.125.74 failed

Tried updating firmware but no luck.
SoftwareVersion   3.2.1 (Build: 5735EX)

Hope there's a fix soon.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: FireSQer on October 31, 2017, 08:47:37 pm
I followed these directions on two different boxes with great success:
https://www.obitalk.com/info/faq/GV-and-the-OBi/Using-openDNS-GV-Status-BackingOff
Quick summary:
1. Log into obitalk.com
2. Choose Obi Expert Configuration
3. Choose Enter Obi Expert
4. Click on System Management
5. Choose WAN Settings
6. UNcheck ObiTalk Settings by DNSServer1
7. UNcheck Device Default
8. Enter 8.8.4.4 in DNSServer1 field
9. Scroll to bottom and Submit

I also upgraded firmware while I was at it.
10. Back to the Obi Dashboard.
11. Click on the yellow triangle to upgrade firmware.

Now I'm dialing out as well as receiving calls.

HTH.

Mike


Title: Re: TCP connection to 125.141.125.74 failed
Post by: phonebob on November 01, 2017, 12:18:07 am
I followed these directions on two different boxes with great success:
https://www.obitalk.com/info/faq/GV-and-the-OBi/Using-openDNS-GV-Status-BackingOff
Quick summary:
1. Log into obitalk.com
2. Choose Obi Expert Configuration
3. Choose Enter Obi Expert
4. Click on System Management
5. Choose WAN Settings
6. UNcheck ObiTalk Settings by DNSServer1
7. UNcheck Device Default
8. Enter 8.8.4.4 in DNSServer1 field
9. Scroll to bottom and Submit

I also upgraded firmware while I was at it.
10. Back to the Obi Dashboard.
11. Click on the yellow triangle to upgrade firmware.

Now I'm dialing out as well as receiving calls.

HTH.

Mike
I tried this, and it didn't change anything.  Then I followed the link in the quoted post.  I noticed it said to use 4.2.2.2 (not 8.8.4.4).  I tried that, and it works.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Ryan_Chicago on November 01, 2017, 12:52:34 am
Yup changing DNS servers seems to have fixed the issue. My Obi110 was previously using the RCN DNS servers:

207.172.3.9
207.172.3.11

I switched to Comodo DNS servers and this resolved the issue for now:

8.26.56.26
8.20.247.20

I would guess that Google recently changed the DNS records for it's XMPP servers and the RCN DNS servers are still serving up the old/stale A records.

Also, FWIW I'm specifically avoiding using the Google DNS servers because strangely, and albeit many years ago, I encountered an issue with the Obi110 whereas the message indicator light on my phone would not function when using Google DNS.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 01, 2017, 02:04:05 am
Ryan,

Good find.  It's surprising this server dns change wasn't staggered or done over a weekend.  I guess the way the pbx or simonics connects to gv is different from the way obi does it.  Chances are by morning all the cached records will be expired and everything will work again without any changes.



Title: Re: TCP connection to 125.141.125.74 failed
Post by: Lensor on November 01, 2017, 04:54:14 am
Thank you Mike (FireSQer) and Ryan_Chicago!  The DNS change worked here :)!

I'm not a networking expert but felt something about the dns, perhaps a  propagation issue, might have been to blame...

I've changed my devices to use the Comodo DNS as suggested by Ryan and both my devices are up and running again!

Happy days!

L



Title: Re: TCP connection to 125.141.125.74 failed
Post by: NikTalk on November 01, 2017, 05:31:09 am
The OBI202 boxes started working automatically this morning.  Looks like Obi updated them.
The Obi101 was still not working with the "backing up" message persisting.

Using advice from FireSQer and Ryan_Chicago, I changed the DNS manually and the OBI101 box started working again.  Success!


Title: Re: TCP connection to 125.141.125.74 failed
Post by: rfryar on November 01, 2017, 06:30:18 am
Stopped working for my obi last night.  Tried both DNS servers with no luck.

Tried:
4.2.2.2
8.8.4.4

[Edit] Magically it started working now.  I assume Google changed what IPs pointed and various servers were lagged behind.

Rick


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Ryan_Chicago on November 01, 2017, 07:48:32 am
All credit is due to @SteveInWA and @FireSQer
Without their helpful insight I would not have guessed this was a DNS issue.

It's a bit difficult to pin down the stale records as it seems like Google is using a fairly large round-robin pool of IP addresses for the XMPP servers, for which I believe the FQDNs are:

xmpp-server.l.google.com
alt1.xmpp-server.l.google.com
alt2.xmpp-server.l.google.com
alt3.xmpp-server.l.google.com
alt4.xmpp-server.l.google.com

@rfryar: last night I also tested the Level3 DNS (e.g. 4.2.2.1-.4) and unfortunately they were also returning stale DNS records just like the RCN DNS servers.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: jeeva on November 01, 2017, 08:29:49 am
I have two obi200 devices in two different homes. Only one of them is failing and so I tried the adding the ips on it, but no luck and it's been an hour.

[EDIT] Of course it starts to work after I post this.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: mikeb0 on November 01, 2017, 09:07:58 am
My OBi200 is still down, unable to make / receive calls...
Tried both configuration thru the obitalk web site and locally with the new DNS server IPs, 4.2.2.2 and 8.8.4.4. Nothing seems to work.

Is there a fix coming? If not, I may have to do the unthinkable and buy a Vonage box. :/
Yes, this is the first time in years, but I cannot afford to be down for days on end like this.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 01, 2017, 09:42:24 am
Something still not right.

Reverted back to opendns, same error

Try the following

8.8.8.8 = fail
4.2.2.2 = fail
ISP's dns = fail

What's strange, trying the commodo servers fails too now.

Edit:  Seems to connect after a minute or two using comodo dns... And only comodo.  

This is very strange because one would expect dns propagation to be completed by now, especially to google dns servers.  This issue started ~1600 Central time (UTC -5)  for us yesterday.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: mikeb0 on November 01, 2017, 09:58:08 am
The IP address my OBi200 is trying to use has changed...
It went from 74.125.132.125 to 209.85.234.125, but still fails:
Backing Off (1s):TCP connection to 125.234.85.209 failed

Did a reverse lookup on the address to find the domain name (FQDN):
root@rhel6:~ # dig +short -x 209.85.234.125
jn-in-f125.1e100.net.

Then did forward lookups on the name to see if the IP address matched.
The name returns two possible IP addresses, and the order changes depending on which DNS server I query:
root@rhel6:~ # dig +short a jn-in-f125.1e100.net @4.2.2.2
209.85.234.125
216.239.38.125
root@rhel6:~ # dig +short a jn-in-f125.1e100.net @8.8.4.4
216.239.38.125
209.85.234.125
root@rhel6:~ # dig +short a jn-in-f125.1e100.net @8.8.8.8
209.85.234.125
216.239.38.125
root@rhel6:~ # dig +short a jn-in-f125.1e100.net [note: my personal DNS server]
216.239.38.125
209.85.234.125

Still not working...

[Update: modified DNS Server 1 to 4.2.2.2 and left DNS Server 2 blank in OBi Expert Configuration, reconfigured Voice Service Provider SP1, and it's working again... making and receiving calls.]


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 01, 2017, 10:06:38 am
^^209.85.234.125 comes back to google @ iplocation.net .

Few minutes following a reboot (with comodo servers) on the obi202, one sp shows connected while the other backing off.  After another reboot both are connected.  I'm leaving well enough alone at this point.

My guess is there's more to it than simple dns resolution.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Danny1 on November 01, 2017, 04:19:47 pm
My OBi 200 worked flawlessly for 1.5 years and today get the same issue here...
Phone LED is off, no inbound calls, and outbound I hear "No service configured error".
Echo test (**9 222 222 222) works perfectly.

Thank you working in second perfect solution. Tried others but not work this is work like charm
Thanks lot


Title: Re: TCP connection to 125.141.125.74 failed
Post by: pro450 on November 02, 2017, 07:15:23 am
Having the problem here.  I have an Obi 202. 

Can someone explain again where to set the DNS servers?  In Expert Configuration, I have "Router Configuration" and then "WAN Settings" but to change DNS there, I assume I have to turn off DHCP. 

What about resetting my home router which may be caching DNS?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 02, 2017, 07:28:03 am
Having the problem here.  I have an Obi 202. 

Can someone explain again where to set the DNS servers?  In Expert Configuration, I have "Router Configuration" and then "WAN Settings" but to change DNS there, I assume I have to turn off DHCP. 

What about resetting my home router which may be caching DNS?
If the OBi is set to DHCP it will be using your router for DNS.  Your router is probably being given DNS address(es) by your internet service provider.  On some routers you can set them manually.

Any cached DNS entries in the router will be in RAM.  Power cycling the router will clear them out. 


Title: Re: TCP connection to 125.141.125.74 failed
Post by: steve45 on November 02, 2017, 07:31:39 am

[Update: modified DNS Server 1 to 4.2.2.2 and left DNS Server 2 blank in OBi Expert Configuration, reconfigured Voice Service Provider SP1, and it's working again... making and receiving calls.]

FYI. Tried this last night and it worked. Still working this AM. This has shook my confidence in OBi + GV. Thanks to all who posted help offerings in this thread and the other 5 threads about this topic. Special thanks to mikeb0. How can we find out if/when OBi sorts this out?

re pro450 - I set the DNS Servers via Expert Configurations -> System Management -> uncheck the OBiTALK box and put in new setting. I'm not at all experienced with this stuff, but that worked for me. Good luck.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: OBiSupport on November 02, 2017, 08:02:58 am
Obihai support team is still looking into this issue.  In the mean time, please try the following in your OBiTALK account:

Click your OBi number 510xxxxxx (300XXXXXX, 200XXXXXX, 500XXXXXX, 630XXXXXX, 610XXXXXX, 600XXXXXX).

At SP1, delete your Google Voice account.

Click SP1 again, follow steps to re-authenticate back to your Google Voice account.

When “Connected”, please make test calls in/out.

If status "Backing off..." remain, then click the OBi Expert Configuration blue button at bottom / Enter OBi Expert blue button.

Modify the DNSServer1 parameter value:  Select System Management / Network Settings / to DNSServer1 / input 4.2.2.2 (or 8.8.8.8 ).

Click Submit to save and your OBi device will reboot automatically.

Allow up to 1 minute to complete, check your Google Voice status for "Connected" then make test calls.

Please stay tuned and we will do a follow-up.


Thank you and best regards,
Obihai Technology, Inc


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 08:34:01 am

Modify the DNSServer1 parameter value:  Select System Management / Network Settings / to DNSServer1 / input 4.2.2.2 (or 8.8.8.8 ).


Correct me if I'm wrong, but won't this DNS server change take effect only if AddressingType is set to Static? And isn't the default setting set to DHCP?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: WelshPaul on November 02, 2017, 08:40:18 am

Modify the DNSServer1 parameter value:  Select System Management / Network Settings / to DNSServer1 / input 4.2.2.2 (or 8.8.8.8 ).


Correct me if I'm wrong, but won't this DNS server change take effect only if AddressingType is set to Static? And isn't the default setting set to DHCP?

You shouldn't need to configure a device with a static IP to change DNS.

Confirmed, just changed my 202 to use Google DNS while set to DHCP:
(https://image.prntscr.com/image/uhV1ZWPsSguWdGGmtrmJpg.png)


Title: Re: TCP connection to 125.141.125.74 failed
Post by: 1user on November 02, 2017, 08:43:09 am
Stopped working for my obi last night.  Tried both DNS servers with no luck.

Tried:
4.2.2.2
8.8.4.4

[Edit] Magically it started working now.  I assume Google changed what IPs pointed and various servers were lagged behind.

Rick

Same here. All of my Obi 1062 phones now no longer work! Could this be why Obi cut the price of the 1062 from $249 to $150? I emailed support and they are saying DMZ is to blame lol 


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 08:51:20 am

You shouldn't need to configure a device with a static IP to change DNS.


Thanks. I was confused by the informational text shown when clicking on the ? next to the DNSServer fields which says:

Quote
IP address of the alternative DNS server for this interface when the Addressing Type is set to Static.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: WelshPaul on November 02, 2017, 08:58:36 am
Thanks. I was confused by the informational text shown when clicking on the ? next to the DNSServer fields which says:

Quote
IP address of the alternative DNS server for this interface when the Addressing Type is set to Static.
I didn't even think to click or hover on that lol, I understand your confusion though.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 09:00:15 am

I didn't even think to click or hover on that lol, I understand your confusion though.

The admin guide makes it very clear your assessment is the correct one.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 09:05:58 am
@OBiSupport

Can you explain how reauthenticating the GV account corrects the issue if it's DNS related?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 02, 2017, 09:39:27 am
Are OBi support saying that only devices with OBi numbers beginning 500 and 510 are affected?  I don't have any of those - 200, 300 (3 off OBi1x0) and 610 (OBi1032).  The 1032 is the only one with GV and so far is working normally.

Are numbers beginning 500 and 510 only on OBi2xx devices?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Mayjin on November 02, 2017, 10:06:04 am
Are OBi support saying that only devices with OBi numbers beginning 500 and 510 are affected?  I don't have any of those - 200, 300 (3 off OBi1x0) and 610 (OBi1032).  The 1032 is the only one with GV and so far is working normally.

Are numbers beginning 500 and 510 only on OBi2xx devices?

I have obi1022 ip phone , 2 obi 202. None of them works.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 10:16:00 am
Are OBi support saying that only devices with OBi numbers beginning 500 and 510 are affected?

OBiSupport post has been edited.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 10:28:32 am
Here's something interesting.

Test was done by forcing dns on the pc to 8.8.8.8 and the comodo dns 8.26.56.26.  Each nslookup was repeated at least 30 times, noting the resolved ip for talk.google.com.  Here's the values received.  Ipconfig /flushdns was run after changing dns server setting.

-=}nslookup talk.google.com

Using 8.8.8.8 for dns server
results:
173.194.192.125
209.85.234.125
74.125.69.125


Using 8.26.56.26 for dns server
results:
74.125.133.125
66.102.1.125
64.233.184.125
74.125.71.125


During the test, the values would often repeat, but the above were the unique values resolved. Note that there is *NO* overlap in results between the two dns servers.

Next, to put this theory to a test, I forced talk.google.com to point to each of the 4 ip's in my firewall - albeit a bit limited because the firewall does not support a host dns pool (multiple ip's for a single FQDN) so each ip had to be added manually then tested.

I then pointed the obi to my firewall's dns service.  Rebooted (several times after each ip change for talk.google.com).

Results:  After each and every reboot the obi connected just fine to GV.  No backing off message.

Conclusion:  First, it's unclear why comodo dns is the only one resolving to these ip's. I tried opendns, 8.8.8.8 and 4.2.2.2.  4.2.2.2 did come up with a few other values but it's unclear if those would work or not. I believe there may be some misconfiguration on google's part.  However, it doesn't doesn't address why gv works just fine through the pbx and hangouts.

I looked at the source code for the freepbx gv module - https://github.com/FreePBX/motif/archive/release/12.0.4.2.zip .  Looks like it just references talk.google.com - functions.inc.php file, line 160.

Could be the _way_ obi is authenticating with gv is different from that of the pbx module.

Second, it's unclear exactly how talk.google.com is referenced by the obibox.  Is it using strictly talk.google.com, or something else.  Is there a pool of talk.google.com hostnames (talk.1.google.com?).  Based on the results, I'd say it's simply referencing talk.google.com.

It will be interesting to see whether the fix involves a firmware update..





Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 10:44:45 am

It will be interesting to see whether the fix involves a firmware update..


Indeed. And if it does I would assume that means all 1xx EOL devices are SOL.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 10:52:43 am
http://check-host.net/check-dns?host=talk.google.com

All those working IP's show up on European servers. I bet some google pixie dust will fix this.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kelemvor on November 02, 2017, 11:08:47 am
Howdy,

I have this same error so came looking for an answer.  Lots of ideas are being tossed around and some work for some people and some work for others.

I'm currently set to DHCP but I do have 8.8.8.8 and 8.8.4.4 as my DNS servers.

My error shows: Backing Off (1s):TCP connection to 74.125.132.125 failed

Not sure which thing I should follow for the best results or if it's best just to wait it out?  Any thoughts?  It's been down for a few days now.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: pro450 on November 02, 2017, 11:09:08 am
Modify the DNSServer1 parameter value:  Select System Management / Network Settings / to DNSServer1 / input 4.2.2.2 (or 8.8.8.8 ).

I don't have "Network Settings" under "System Management".  Under "System Management" I see "Auto Provisioning" and "Device Admin".  The only place I see to change the DNS is under "Router Configuration" then "WAN Settings".  It looks like I have to uncheck the column where it says "OBiTALK Settings" and then enter the DNS value.  I would assume that it would not override the DHCP values, but I'll give it a try.

So then when I enter 4.2.2.2 in the DNSServer1 field and save it, when I go back into it the field has a red exclamation point next to it.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: n0xlf on November 02, 2017, 11:12:03 am
This does not appear to be a DNS issue, or at least one that isn't Google's fault.  The authoritative DNS servers for google (ie - the servers that other DNS servers query) are ns1-4.google.com, which is the place to look for the "right" answer.

If you query those directly (216.239.[32,34,36,38].10), or put them in as the name server(s) in your Obi device, it still [mostly] doesn't work.  If you test these, don't leave them there as they will only resolve google.com IPs and nothing else so you'll break Obitalk, FW updates, other SIP services, etc.

At this point it's just luck if you happen to get a working GV server via whatever DNS you are using.  If you are desperate for service, these IPs are the most likely to get it working for you though, as the responses constantly change based on Google's load balancing and aren't cached like all other DNS servers.  Put one of these as the primary DNS and a public DNS server as secondary and that gives you the best chances for everything working for now.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 11:16:50 am
For me and a number of others that have posted, the only dns servers that allow gv to work seem to be

8.26.56.26   
8.20.247.20

I've had no luck with 8.8.8.8, 8.8.4.4, 4.2.2.2, opendns, isp's dns or some others i've tried.

I'd say at least for this issue, obi's knowledge base article is outdated.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: pro450 on November 02, 2017, 11:17:35 am
Performed the instructions from OBiSupport.  When I can catch it connecting in the OBi dashboard, it says "Connecting to 74.125.69.125" for about a minute, then displays "Backing Off :TCP connection to 125.69.125.74 failed"


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kirk on November 02, 2017, 11:42:38 am

I don't have "Network Settings" under "System Management".  Under "System Management" I see "Auto Provisioning" and "Device Admin".  

So therefore the instructions are confusing at best, thanks!

Any ideas?  Thanks


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 11:48:09 am
Performed the instructions from OBiSupport.  When I can catch it connecting in the OBi dashboard, it says "Connecting to 74.125.69.125" for about a minute, then displays "Backing Off :TCP connection to 125.69.125.74 failed"


Look carefully at the numbers.  The IP in the backing off message is reverse of the connecting.

@Kirk, System management, Wan settings for the obi200.  For obi202, router configuration, wan settings.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kelemvor on November 02, 2017, 11:49:26 am
I just tried:
DNSServer1    8.26.56.26
DNSServer2    8.20.247.20

Still getting:
Status   Backing Off (4s):TCP connection to 74.125.206.125 failed


Title: Re: TCP connection to 125.141.125.74 failed
Post by: W7VFR on November 02, 2017, 11:54:07 am
Switching DNS servers fixed the problem for me too! Yay! Thank you


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kirk on November 02, 2017, 12:00:50 pm

[/quote]
@Kirk, System management, Wan settings for the obi200.  For obi202, router configuration, wan settings.
[/quote]

Thanks @, GPz1100 --  OBI202 here.  Under Router configuration>wan settings, There is DNS server 1 and DNS server 2. Both are blank, does not allow me to enter a number, regardless of checking or unchecking associated boxes.

Thanks for the help, frustrating, obi support seems to be clueless with the faulty inaccurate instructions.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: ceg3 on November 02, 2017, 12:02:37 pm
Thanks!  I didn't think it included me until you pointed out the edit.  I have a 510 device, but I've had no backing off issue.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 12:19:07 pm
@kelemvor  Give it a minute or two then refresh the status page.  I've seen a number connection attempts where it'll show backing off, then in a minute or two connect successfuly.

@kirk It may be because you have it set to use obitalk to configure the device.  Obitalk is the web portal where you enter your gv info, token created, etc.  It then 'pushes' the configuration to your obi device.

Initially when I did the setup here (obi200 & 202 boxes), after getting gv tokens provisioned I disabled all the obitalk settings, auto firmware updates, and anything else that talks back to the obi mothership. All my changes are done directly on the obi device itself. 

Without going through this disabling process on your device, I think you can access similar settings using the 'obiexpert' button on the obitalk dashboard.  Click on your device on the dashboard.  Way at the bottom look for Obi Expert Configuration, click it, then click ok.

Click on Enter Obi Expert. In the left margin you should see this.
(https://i.imgur.com/bmz4F3s.png?1).

Note the two boxes are uncheck for each dns row.

WARNING: DON'T TOUCH ANYTHING ELSE OR ANYTHING YOU'RE NOT FAMILIAR WITH.  There's nothing in there that will brick it, but changing certain entries will make it inoperable, requiring a factory reset.

I think the obitalk portal is a double edged sword. It's great for ease of initial configuration and for non tech people. It's also required to create the gv tokens.  Without this gv will not work.  There is a way of generating these tokens manually but obi doesn't provide the necessary information to do so.  Also, there is no place even in obiexpert mode to enter these tokens. Although the obi box is has embedded linux, shell access is denied.  One of these days I'll see if I can connect to it via a serial console, but that's beyond the scope of this discussion.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 02, 2017, 12:24:59 pm

It will be interesting to see whether the fix involves a firmware update..


Indeed. And if it does I would assume that means all 1xx EOL devices are SOL.
I don't think you should assume that if a firmware update is necessary, Obihai would not provide one for 1x0 devices, despite their EOL status.

And I'm far from convinced that this current problem is of Obihai's making.  I'm keeping an open mind until the cause is identified and proven.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kelemvor on November 02, 2017, 12:30:31 pm
Yep.

I can confirm that after changing it to the Comodo DNS entries, my phone is now working. Of course, the first call I got was from a Telemarketer.  Maybe I'll just change it back and enjoy the silence.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 12:39:43 pm
And I'm far from convinced that this current problem is of Obihai's making.  I'm keeping an open mind until the cause is identified and proven.

I'm sure it's not.  Change probably originated with google, now to figure out how to make it work for everyone using the least invasive method.  We got our obi's in the last 2 years, after oauth 2 became a requirement.  If I recall correctly sometime in 2014 this change did require a firmware update.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 12:47:00 pm

I don't think you should assume that if a firmware update is necessary, Obihai would not provide one for 1x0 devices, despite their EOL status.


http://blog.obihai.com (http://blog.obihai.com)

Quote
However, any services that cannot be supported with the current software (firmware) will not work on the OBi100 and OBi110.

I infer (assume) from that statement there will be no new firmware for 1xx series. Do you disagree?



Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 02, 2017, 01:12:36 pm
I infer that new services such as things like OBiEXTRAS will not be backported into an update to support them. And I expect that any minor bugs which have no significant effect on functionality will not be fixed.

I don't agree that Obihai will never under any circumstances make an update for 1x0 devices.

If, and it is a big if, the current GV problem is Obihai's fault, the cost to them of making a new 1x0 firmware incorporating the same fix that they need to make for 2xx ATAs, 10x2 phones (and 5xx models?) will be minimal compared to the cost of lost future business if they do not.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 02, 2017, 01:14:20 pm
@drgeoff Check your private messages please.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 02, 2017, 01:26:12 pm
@drgeoff Check your private messages please.
I have replied.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 02, 2017, 05:27:59 pm

I don't agree that Obihai will never under any circumstances make an update for 1x0 devices.


Perhaps. However, I just got new firmware [3.2.1 (Build: 5757EX)] pushed to my 200 (yellow triangle) even though it's been out of warranty for a couple years. I'd guess that it must address something important for Obihai to do that.

Nothing showing for my 110.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Scott_MSP on November 03, 2017, 04:30:39 pm
 :)

Hi, I used the Comodo DNS entries and all is well with my OBI 100.

Thanks GPz1000 !


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 03, 2017, 04:45:06 pm
:)

Hi, I used the Comodo DNS entries and all is well with my OBI 100.

Thanks GPz1000 !
Don't pin your hopes on that being anything more than a short-term workaround.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 04:50:28 pm
I've already stated, definitively, that this is not a DNS issue.  I pointed out that changing the two DNS servers to use Google's DNS can avoid other issues unrelated to this particular one, such as the DNS server you are using misdirecting requests, but this issue is not caused by DNS.  It is a complete waste of time to speculate and experiment with DNS changes to fix this bug.

This bug was caused by Google updating their XMPP servers.  The fix is to upgrade to the 5757EX firmware for the 20x series, and to the 4666EX series for the 10x2 series.  There is no firmware fix for the 1x0 series.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 03, 2017, 05:02:10 pm
:)

Hi, I used the Comodo DNS entries and all is well with my OBI 100.

Thanks GPz1000 !

You're welcome but it was actually Ryan_Chicago who discovered the Comodo servers still pointed to not yet updated talk.google.com servers in this thread - https://www.obitalk.com/forum/index.php?topic=13022.msg83980#msg83980 .

It's just a matter of time until they're all updated.  The cheapest solution is to just use the simonics gateway.  It's a one time fee of $6. Takes minutes to setup (probably a half hour realistically). The only free solution is setting up your own pbx to handle gv connectivity.  You pay it in terms of time and effort.



Title: Re: TCP connection to 125.141.125.74 failed
Post by: Tiberious on November 03, 2017, 06:20:01 pm
Updating my DNS to 8.26.56.26
is the only thing that has worked for my Obi110.

It is working now....11/3 at 8:25pm CDT


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 06:21:50 pm
Updating my DNS to 8.26.56.26
is the only thing that has worked for my Obi110.

It is working now....11/3 at 8:25pm CDT

That solution is bogus, and it's only working by chance, until that DNS server syncs up.

OBi 100/110 devices will not connect to Google after the update finishes rolling out, and there is no firmware update available.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 06:39:44 pm
Any posts here in this forum that suggest changing DNS servers will fix this are bogus.  Changing to the Google DNS server pair (8.8.8.8 primary and 8.8.4.4 secondary) is a good idea in general, as it's a very high-performance DNS with no re-directions to advertisements or to websites selling domain names.

However, this problem was caused by Google updating certificates on their servers, and not a network issue.

Updating OBi device firmware is the only solution for 200 series OBi ATAs or 10x2 series OBi IP phones.  There is no update for OBi 100/110 devices.


Title: Simonics Gateway FTW!
Post by: Jasper on November 03, 2017, 09:26:48 pm
I knew our days with Obi100 were numbered after Obihai's EOL announcement last year.

Was ready to buy the OBI202 when this problem began a few days ago. Wife insisted we explore other options before investing in another box that's destined to become outdated again. Fixed income does that to you. Came across some references on here to gvsip and simonics gateways.  Researching both I discovered gvsip is no longer in business.  Simonics gateway got lots of hits and good reviews everywhere.

Trying to find actual configuration instructions was more difficult. Howto bits and pieces scattered everywhere. Started by creating my account here https://simonics.com/gw/ . SIP ID and password is on the main gateway page after paying a $5.99 fee.

Sip Login = GV18005551212 (replace 8005551212 with your actual Google Voice number)
Sip Password = 12 character alphanumeric sequence; if you do a copy/paste make sure to remove the trailing space before pasting
Server = gvgw.simonics.com

Armed with this information I logged into obitalk.com dashboard.  I didn't see a specific option for Simonics gateway under service providers.  Common sense suggested I try the "Generic Service Provider" option. I filled it in like this.

Service Provider Proxy Server = gvgw.simonics.com
Service Provider Proxy Server Port = 5060
Outbound Proxy Server = gvgw.simonics.com
Outbound Proxy Server Port = 5060
Username = GV18005551212
Password = {PASSWORD}
URI = <blank> (nothing)

Don't forget to hit save.  This reboots the Obi100.  After a few moments try a test call.  Mine went through right away.  Good luck!

Google chat must be selected as a forwarding option under Phones in the google voice settings for incoming calls to work.  Short time later a telemarketing call came in.  An unexpected surprise was the name along with the number.  Only the number came through before, no names.  Nice!

The whole process took about 10 minutes to set up after I got my bearings.  Getting to this point took much longer ;)

We'll keep the Obi100 until it stops working or until the gateway goes away. Although we've gotten our money's worth over the years it would be a terrible shame to throw away a perfectly good piece of equipment because the manufacturer finds innovative ways to force an upgrade.




Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 10:01:50 pm
Quote
because the manufacturer finds innovative ways to force an upgrade.

Conspiracy theory bullshit.  Obihai had nothing to do with causing this issue.  If you want to use Simonics GVGW, feel free to do so, as long as it works. 


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Icall on November 03, 2017, 10:12:10 pm
Any update for Obi110 for this issue?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 10:30:38 pm
Any update for Obi110 for this issue?

This is getting comical, to say the least.  Did you not read any of the other posts before asking?

NO.  There is no firmware update available for the 100/110 models.  Your options are:
  • Buy a new OBi 200 or other current OBi device.  It is highly likely that they will be on sale soon for "Black November" or "Cyber Monday" sales.
  • Use the Simonics Google Voice Gateway, a service that coverts Google's XMPP protocol to SIP, which the 100 series still supports.  https://simonics.com/gw/ (https://simonics.com/gw/)


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Taoman on November 03, 2017, 10:49:03 pm

This is getting comical, to say the least. 


Which is why I think we should have a separate thread/post for OBi100/OBi110 users. You managed to get a post pinned and locked regarding the June 2016 OBi100/110 firmware issue which is now no longer relevant.

http://www.obitalk.com/forum/index.php?topic=11384.0 (http://www.obitalk.com/forum/index.php?topic=11384.0)

Can you get it updated with current information regarding the OBi100/OBi110 situation?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 03, 2017, 10:57:57 pm
I just updated my post about the issue, to include mention that there is no update for the 100 series, and I mentioned the same two alternatives that you did in your post(s).

I didn't even want to wade into the swamp about the 100 series, since there are many people who believe that products should be supported forever.  That's why I'm reluctant to be the source of this position statement, with a pinned post.

I believe that Obihai will probably make a blog post about this, which is where the "official" statement should originate.

I predict that we'll see some OBi 100/110s for sale on eBay or Craigslist soon, with people posting here about why they don't work.  Sigh...

Oh, and I just deleted the old 100 series sticky post you mentioned.  Thanks for reminding me.

Thanks!


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Jasper on November 03, 2017, 11:45:48 pm


Conspiracy theory bullshit.  Obihai had nothing to do with causing this issue.  If you want to use Simonics GVGW, feel free to do so, as long as it works.  

When a simple certificate update causes the adapter to stop working with the only fix a firmware update, then yes, in my view it's a design flaw.  Or from your perspective, a feature.

If you don't like what others say, don't respond.  Your post count does not entitle you to act like an asshole.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Lavarock7 on November 03, 2017, 11:54:58 pm
Don't know if this helps anyone in the future to troubleshoot. You can verify A records here: https://www.whatsmydns.net

They check various name servers.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: spencer on November 04, 2017, 05:56:47 am
I thought they were ending support on Dec. 31st, not Nov. 1st.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 04, 2017, 06:13:15 am
I thought they were ending support on Dec. 31st, not Nov. 1st.
http://blog.obihai.com/


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Stuart_505 on November 04, 2017, 02:10:36 pm
This problem started for me sometime last night with my Obi200 (which is connected to Google Voice); I noticed the phone indicator (right hand LED) was off this morning, and started Googling the problem, winding up on this thread.  I've only had my Obi200 since August, and it was working fine up to now.  I had set the device to automatically check for firmware updates by following the directions on this Obitalk webpage:  https://www.obitalk.com/info/faq/Troubleshooting-sec/How-do-I-automate-upgrades   but apparently it had not actually been checking for updates, since my firmware version this morning was 3.1.1.5463.  I tried forcing the update by dialing ***6, but the robot voice told me no updates were available, which I didn't believe based on earlier posts in this thread.  I also looked at some Google results about manually updating the Obi's firmware, but in the Obi Expert configuration settings under System Management, there was no Device Update selection available, so that wouldn't have worked for me.

Anyway, in the Obi Expert menu I inadvertently clicked on the Revert to ObiTALK button, not realizing that it would remove my specific changes in Obi Expert, which were basically the settings for auto updating.  When I realized that, I went back in and reset those selections.  Then I noticed the Obi200 resetting itself a couple of times (the left hand LED going to red), and then it started working again.  When I checked the firmware version (***0, then 1#) I discovered it had updated to 3.2.1.5757.  Outgoing and incoming calls are working again, and the Anveo 911 test says that's all working as well.

Sorry to be so wordy, but I wanted to describe the things which were supposed to be working but weren't.  It appears that a firmware update solved the problem for me.  It's just that I couldn't initiate that update in the way that is supposed to work, and I'm not sure exactly what it was that I did that made it happen.  And without that manual update option, I guess I'm going to have to pay Obihai after next August if I want to keep the Obi200 working.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 04, 2017, 02:30:46 pm
All you had to do was click the yellow triangle against your OBi200 on your Dashboard.  http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139

The other update methods do normally work but Obihai has by necessity pushed this update out very quickly.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Stuart_505 on November 04, 2017, 04:42:03 pm
Ah ha, I see the yellow triangle mentioned in two of the posts of the four earlier pages of the thread.  I guess I didn't realize the significance because at the time I didn't realize my Obi200 wasn't updating itself.  I don't remember seeing a yellow triangle on the Obitalk dashboard (of course there isn't one now) but I'm guessing it was there, although if the Obi200 didn't think it needed updating when I did the ***6 thing, maybe not.  Next time something like this happens, I'll know what to look for.  Thanks for letting me know.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: JonX on November 05, 2017, 08:11:35 am
http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

I have an OBi200 with firmware 3.0.1 (Build: 4581) and have seen no issue as of yet with my google voice connections. DNSServer 1 and 2 are blank and default checked. At the OBiTALK online dashboard, google voice SPs are shown as connected. I do have a yellow triangle with an exclamation mark indicating "firmware update." Clicking on and selecting cancel I get redirected to a form thread that has a link to the latest (http://fw.obihai.com/OBi2-latest.fw which appears to be the same as http://fw.obihai.com/OBi202-3-1-1-5463EX.fw) which when I download appears to be version  OBi2XX_FW_PACK00
v3.1.1 (Build: 5463EX) (MD5SUM: b7c15c8a7146e27795cbc4a050165f59). From a forum search it appears this was released sometime in Dec 2016 or before. If I had clicked "ok" instead of "cancel" I'm not sure what version would be installed.

I've seen reference to OBi 2xx series: 3.2.1 (Build: 5757EX) (http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139) as a fix which seems to be found at:

   http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

(MD5SUM: f5e249b85b99f29bf9b94c651161d16e).

A thread wiki for this issue would be nice.




Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 05, 2017, 08:32:16 am
http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

I have an OBi200 with firmware 3.0.1 (Build: 4581) and have seen no issue as of yet with my google voice connections. DNSServer 1 and 2 are blank and default checked. At the OBiTALK online dashboard, google voice SPs are shown as connected. I do have a yellow triangle with an exclamation mark indicating "firmware update." Clicking on and selecting cancel I get redirected to a form thread that has a link to the latest (http://fw.obihai.com/OBi2-latest.fw which appears to be the same as http://fw.obihai.com/OBi202-3-1-1-5463EX.fw) which when I download appears to be version  OBi2XX_FW_PACK00
v3.1.1 (Build: 5463EX) (MD5SUM: b7c15c8a7146e27795cbc4a050165f59). From a forum search it appears this was released sometime in Dec 2016 or before. If I had clicked "ok" instead of "cancel" I'm not sure what version would be installed.

I've seen reference to OBi 2xx series: 3.2.1 (Build: 5757EX) (http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139) as a fix which seems to be found at:

   http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

(MD5SUM: f5e249b85b99f29bf9b94c651161d16e).

A thread wiki for this issue would be nice.



Just click the yellow triangle, click OK and get on with the rest of your life.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Troyer on November 05, 2017, 10:01:48 am
There wasn't a firmware update available for my 200, but changing the DNSServer1 to 4.2.2.2 corrected the problem.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 05, 2017, 10:10:14 am
There wasn't a firmware update available for my 200, but changing the DNSServer1 to 4.2.2.2 corrected the problem.
How many times does it have to be said!!!???

This is not a DNS problem and changing DNS is not a lasting fix.

For an OBi200 you need firmware 3.2.1 (Build: 5757EX).  Currently the only way to get that is log into your Dashboard at obitalk.com and click the yellow triangle.

http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 05, 2017, 03:43:12 pm

How many times does it have to be said!!!???


If only people with "write only memory" would stop posting the same nonsense again and again, but I guess that's too much to expect.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Brenda72 on November 06, 2017, 12:08:30 pm
I am confused by this.  I have an Obi100

What do I need to do to get my service working again?  Everyone is talking about the Obi200 but I have Obi100


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 06, 2017, 12:23:39 pm
I am confused by this.  I have an Obi100

What do I need to do to get my service working again?  Everyone is talking about the Obi200 but I have Obi100

READ:  http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139 (http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139)



Title: Re: TCP connection to 125.141.125.74 failed
Post by: mstbone67a on November 07, 2017, 04:32:19 pm
 well poop sticks.  interesting read about using a rpi for a fix.
https://narahari.wordpress.com/2017/11/07/obi110-reuse-using-raspbx-how/



Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 07, 2017, 04:53:21 pm
well poop sticks.  interesting read about using a rpi for a fix.
https://narahari.wordpress.com/2017/11/07/obi110-reuse-using-raspbx-how/



Take note:  that solution uses the outdated and less-secure Google account login method, with a userID and password stored on the Pi.  Doing that gives that box full access to everything on that Google account.  Google strongly discourages it. 

By contrast, OBi devices and the Simonics GVGW use the Google-approved OAUTH 2.0 authentication, which only grants access to the XMPP service on the Google account.  No Google account password is stored on the device.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: omegastar on November 07, 2017, 07:03:29 pm
So I take it ObiTalk is gonna screw all the OBI110 owners now. Cant see how they still sell this device but dont support it.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 07, 2017, 07:04:48 pm
So I take it ObiTalk is gonna screw all the OBI110 owners now. Cant see how they still sell this device but dont support it.

They don't still sell the device.  Any that you might find for sale are not being sold by authorized retailers.

I predict that a metric ton of used 100s and 110s will appear for sale on Craigslist and eBay soon.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: GPz1100 on November 07, 2017, 07:33:56 pm
This solves the issue of Oauth 2 for the Raspberry Pi Zero W.

http://nerdvittles.com/?p=21777

The $6 gateway option will save you days in terms of configuration time.

Asterisk 14.7 and above already has direct support for oauth 2 (for manually edited config files).  Presently it's a matter of the motif module getting updated to support this in freepbx flavors.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Icall on November 08, 2017, 06:44:03 am
Thanks @GPZ1100. I will be updating my setup to remove app password with the Oauth2. Found some info here. http://www.dslreports.com/forum/r30021383-Upgrade-Asterisk-to-an-OAUTH2-0-connection-with-Google-Voice~start=30


Title: Re: TCP connection to 125.141.125.74 failed
Post by: adymax on November 08, 2017, 06:44:47 pm
Just got this issue today, Changing the DNS IPs on the router to 8.26.56.26 & 8.20.247.20 fixed it for me. Thank you all for your help!


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 08, 2017, 06:46:28 pm
Just got this issue today, Changing the DNS IPs on the router to 8.26.56.26 & 8.20.247.20 fixed it for me. Thank you all for your help!

This is not a DNS issue.  Eventually, yours will fail.

Read this:  http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139 (http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139)


Title: Re: TCP connection to 125.141.125.74 failed
Post by: adymax on November 08, 2017, 07:13:22 pm
If that's the case I  have OBI100 so no FW update for us?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 08, 2017, 07:18:54 pm
If that's the case I  have OBI100 so no FW update for us?

I explained it, right in the linked post, along with a workaround.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: adymax on November 08, 2017, 07:36:51 pm
Thank you Steve, I see the workaround now. On the long run, I believe is better to get OBI20x.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on November 08, 2017, 08:27:03 pm
Agreed, and if you want to wait, I am pretty sure that one or more of the 2xx product line will go on sale this month for the US holidays.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: MRTT on November 09, 2017, 08:11:03 pm
I was wondering what was up again...Been a couple years since I last posted or visited here. 

I only wish I saw the simonics gateway ealier, that's a pretty decent deal.   The 110's are, otherwise, a perfectly good ATA, IMO.

-MRTT


Title: Re: TCP connection to 125.141.125.74 failed
Post by: JonX on November 10, 2017, 09:04:50 am
https://www.obitalk.com/forum/index.php?topic=13022.msg84276#msg84276

Ok so I have now moved on with my life after my resident Obi200 failed on one gv (google voice) account and then the other after a reboot. The yellow triangle (at the obitalk site under my account) did indeed install http://fw.obihai.com/OBi202-3-2-1-5757EX.fw . For my Obi110, I used https://simonics.com/gw/ . Both seem to be working at this point. Quick easy solution (though not very interesting or challenging in the hobbyist sense).


Title: Re: TCP connection to 125.141.125.74 failed
Post by: azrobert on November 10, 2017, 09:13:34 am
https://www.obitalk.com/forum/index.php?topic=13022.msg84276#msg84276
Quick easy solution (though not very interesting or challenging in the hobbyist sense).

See:
http://www.obitalk.com/forum/index.php?topic=13136.0


Title: Re: TCP connection to 125.141.125.74 failed
Post by: Stuart_505 on November 12, 2017, 01:26:54 pm
I discovered about an hour ago that my Obi200, which somehow got firmware update last weekend to 3.2.1.5757 and has worked fine since, was not working.  Checking the firmware version, it seems that it had somehow reverted to 3.1.1.5463.  Apparently setting the auto update as I described in an earlier post is a bad idea.  To get back to the proper update I chose to try the manual method rather than simply clicking the yellow triangle next to the Obi200, since both should give the same result.  I went to http://fw.obihai.com/OBi2-latest.fw  and downloaded the update, then entered the Obi200's setup via its web portal using its IP address.  When I attempted to update the firmware, I got the message that the update I was trying to apply was the same as the current version.  So I went to an earlier post in this thread from JonX and followed the link http://fw.obihai.com/OBi202-3-2-1-5757EX.fw  and repeated the update process, and this time got the right update.  So this leaves me wondering a couple of things, including, why the link http://fw.obihai.com/OBi2-latest.fw doesn't actually give you the latest firmware; and how to find a specific link to a particular update version.  I know drgeoff is just going to tell me to click the yellow triangle and get on with my life, but I'm curious why Obihai doesn't put the latest version in the file they call OBi2-latest.fw.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: drgeoff on November 12, 2017, 02:06:46 pm
... I'm curious why Obihai doesn't put the latest version in the file they call OBi2-latest.fw.
Just one of the many unanswered questions about Obihai.   :)

It is easy to think of Obihai as a company with plenty of staff to do this that and the other but I suspect the reality is rather different.  Estimate how many ATAs and phones are bought each month.  Estimate how much profit they net from each one.  Multiply the two together and divide by how much it costs to employ someone for a month (salary and all the overheads).  How many people does that give you?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: wecen on November 17, 2017, 08:17:27 pm
Today I found out that my google voice cant dial out. So I check the forum.

Thank you for "rfryar" message. I tried:

DNSServer1: 4.2.2.2
DNSServer2: 8.8.4.4

It works.

Thank you so much.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: DaniloC on November 24, 2017, 12:30:00 pm
Same for me. I had to put both to start working. Thanks a lot guys for the guidance!

Cheers!


Title: Re: TCP connection to 125.141.125.74 failed
Post by: helpful55 on December 01, 2017, 02:04:53 pm
This worked for me (4.2.2.2). Thanks
Obihai support team is still looking into this issue.  In the mean time, please try the following in your OBiTALK account:

Click your OBi number 510xxxxxx (300XXXXXX, 200XXXXXX, 500XXXXXX, 630XXXXXX, 610XXXXXX, 600XXXXXX).

At SP1, delete your Google Voice account.

Click SP1 again, follow steps to re-authenticate back to your Google Voice account.

When “Connected”, please make test calls in/out.

If status "Backing off..." remain, then click the OBi Expert Configuration blue button at bottom / Enter OBi Expert blue button.

Modify the DNSServer1 parameter value:  Select System Management / Network Settings / to DNSServer1 / input 4.2.2.2 (or 8.8.8.8 ).

Click Submit to save and your OBi device will reboot automatically.

Allow up to 1 minute to complete, check your Google Voice status for "Connected" then make test calls.

Please stay tuned and we will do a follow-up.


Thank you and best regards,
Obihai Technology, Inc


Title: Re: TCP connection to 125.141.125.74 failed
Post by: maorsela on December 04, 2017, 10:39:04 am
I have an Obi110, I paid Simon's Gateway the $6 and now GV works again for me.


Title: Re: Simonics Gateway FTW!
Post by: C6silver on December 06, 2017, 10:55:37 am
I knew our days with Obi100 were numbered after Obihai's EOL announcement last year.

Was ready to buy the OBI202 when this problem began a few days ago. Wife insisted we explore other options before investing in another box that's destined to become outdated again. Fixed income does that to you. Came across some references on here to gvsip and simonics gateways.  Researching both I discovered gvsip is no longer in business.  Simonics gateway got lots of hits and good reviews everywhere.

Trying to find actual configuration instructions was more difficult. Howto bits and pieces scattered everywhere. Started by creating my account here https://simonics.com/gw/ . SIP ID and password is on the main gateway page after paying a $5.99 fee.

Sip Login = GV18005551212 (replace 8005551212 with your actual Google Voice number)
Sip Password = 12 character alphanumeric sequence; if you do a copy/paste make sure to remove the trailing space before pasting
Server = gvgw.simonics.com

Armed with this information I logged into obitalk.com dashboard.  I didn't see a specific option for Simonics gateway under service providers.  Common sense suggested I try the "Generic Service Provider" option. I filled it in like this.

Service Provider Proxy Server = gvgw.simonics.com
Service Provider Proxy Server Port = 5060
Outbound Proxy Server = gvgw.simonics.com
Outbound Proxy Server Port = 5060
Username = GV18005551212
Password = {PASSWORD}
URI = <blank> (nothing)

Don't forget to hit save.  This reboots the Obi100.  After a few moments try a test call.  Mine went through right away.  Good luck!

Google chat must be selected as a forwarding option under Phones in the google voice settings for incoming calls to work.  Short time later a telemarketing call came in.  An unexpected surprise was the name along with the number.  Only the number came through before, no names.  Nice!

The whole process took about 10 minutes to set up after I got my bearings.  Getting to this point took much longer ;)

We'll keep the Obi100 until it stops working or until the gateway goes away. Although we've gotten our money's worth over the years it would be a terrible shame to throw away a perfectly good piece of equipment because the manufacturer finds innovative ways to force an upgrade.



Wanted to thank you for writing this up. Paid the $5.99 and used your guide. Got setup in only a minute or two. Inbound and outbound calls working again. Appreciate it!


Title: Re: TCP connection to 125.141.125.74 failed
Post by: kelemvor on December 06, 2017, 12:22:18 pm
I fixed mine earlier by using the Comodo DNS (or whatever it was).  Now today it seems to have broken again.

TCP connection to 64.233.166.125 failed


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on December 06, 2017, 04:41:27 pm
This has been answered over and over.  You cannot fix this permanently by changing the DNS.  Either buy a new OBi or use the Simonics GVGW, as explained in the two sticky posts in the Google Voice section of this forum.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: castaneda247 on December 07, 2017, 10:30:28 am
Just some final thoughts as I have read through ALL the messages for this post (@SteveInWA ;-).

I switched over to Simonics.com workaround described in a previous post to restore telephone service to 3 locations/OBi100 devices (my own, my parents and my in-laws). For those intimidated by the setup, don't fret, it's simple, so don't go out and buy the latest OBi device if you don't have to. Just follow the instructions laid out in the post and you will be fine.

I'm not convinced, though, of the issue Obihai is reporting with Google making changes, but I also don't want to spent too much time trying to investigate a problem that only takes $6 bucks to fix. The reason I'm skeptical is because Obihai does not seem to have the greatest backdoor communications with Google. Years ago, like 4-5, they said that Google would be discontinuing Google Voice and that we'd all have to move to some other service. Well, that was a major blunder on their part as Google Voice never went offline and still continues to this very day. Wish I still had that message they put out.

My service only recently went offline (like as of 12/3/17 or 12/4/17) when others reported it over a month ago and Obihai posting the cause of the issue on 11/7/17 on their blog. So why did mine still continue to work when Google supposedly change something.

Something just seems fishy.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on December 07, 2017, 02:24:09 pm
Just some final thoughts as I have read through ALL the messages for this post (@SteveInWA ;-).

I switched over to Simonics.com workaround described in a previous post to restore telephone service to 3 locations/OBi100 devices (my own, my parents and my in-laws). For those intimidated by the setup, don't fret, it's simple, so don't go out and buy the latest OBi device if you don't have to. Just follow the instructions laid out in the post and you will be fine.

I'm not convinced, though, of the issue Obihai is reporting with Google making changes, but I also don't want to spent too much time trying to investigate a problem that only takes $6 bucks to fix. The reason I'm skeptical is because Obihai does not seem to have the greatest backdoor communications with Google. Years ago, like 4-5, they said that Google would be discontinuing Google Voice and that we'd all have to move to some other service. Well, that was a major blunder on their part as Google Voice never went offline and still continues to this very day. Wish I still had that message they put out.

My service only recently went offline (like as of 12/3/17 or 12/4/17) when others reported it over a month ago and Obihai posting the cause of the issue on 11/7/17 on their blog. So why did mine still continue to work when Google supposedly change something.

Something just seems fishy.

None of your speculation of "fishy" circumstances is accurate nor meaningful.  I'm not going to re-hash all of the history.  The only thing that matters is:
  • The current issue is completely unrelated to any past history with regard to Google Voice availability on OBi products.
  • Google has a large pool of servers that support access to Google Voice via the old Google Chat/Talk (XMPP) protocol.  Google updated the servers.  It's likely that one or more of those servers wasn't yet updated when it continued to work for you.  Google doesn't routinely tell anyone of their maintenance schedules or changes, so Obihai had no way to know about this until it happened.
  • Google has no intention of discontinuing support for the current OBi product line.


Title: Re: TCP connection to 125.141.125.74 failed
Post by: ponyboy3399 on December 09, 2017, 08:44:41 am
How do you change the DNS settings?


Title: Re: TCP connection to 125.141.125.74 failed
Post by: SteveInWA on December 09, 2017, 03:30:17 pm
How do you change the DNS settings?

There is no point to changing DNS settings.  It will not solve this problem.

Read:

http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139 (http://www.obitalk.com/forum/index.php?topic=13113.msg84139#msg84139)

and

http://www.obitalk.com/forum/index.php?topic=13147.0 (http://www.obitalk.com/forum/index.php?topic=13147.0)