OBiTALK Community

Firmware, Software Updates => Firmware / Advisories / Notifications for OBi Products => Topic started by: JohnE on May 18, 2018, 11:39:23 am



Title: SPAM calls on the OBITALK network
Post by: JohnE on May 18, 2018, 11:39:23 am
I am receiving a call every two minutes from 9001, 8000, 700, etc.  even from 4444971892.  They do not register on my service providers so must be hitting the OBI202 box directly.  Have tried the incoming call route methods listed in 2013 on the web with little success.  I have to unplug the phone to stop this for a while. What is the 2018 method for blocking these?


Title: Re: SPAM calls on the OBITALK network
Post by: TomHere on May 18, 2018, 12:30:27 pm
I am having the same issue. I also am having to unplug the phone for relief.


Title: Re: SPAM calls on the OBITALK network
Post by: Mango on May 18, 2018, 12:33:43 pm
Strictly speaking, these calls are not arriving via the OBiTALK network.

Please see the following thread for an explanation of why the issue exists and how to solve it: https://www.obitalk.com/forum/index.php?topic=13948.0


Title: Re: SPAM calls on the OBITALK network
Post by: JohnE on May 18, 2018, 04:20:27 pm
Thank you for your fast response.  I am using the OBI202 as the Router. The defaults are DMZ not enabled, but I see a lot of Firewall stuff is not enabled either.  I could go back to using my Apple Airport as the router - forget QOS.

John


Title: Re: SPAM calls on the OBITALK network
Post by: Kage on May 19, 2018, 09:30:17 am
In the InboundCallRoute I had used this to ban incoming calls with the less than seven digits:

{(x|xx|xxx|xxxx|xxxxx|xxxxxx):},{ph}

Does anyone know if when you update google voice these settings become non-functional?

The Phone OutboundCallRoute is set up with the 911 to call an emergency number, would hate to lose that. I've got the whole configuration backed up to make it easy to restore if a factory reset is needed to re-register with obi but that is with the old google voice settings and not the new one.   


Title: Re: SPAM calls on the OBITALK network
Post by: drgeoff on May 19, 2018, 09:51:18 am
In the InboundCallRoute I had used this to ban incoming calls with the less than seven digits:

{(x|xx|xxx|xxxx|xxxxx|xxxxxx):},{ph}

Does anyone know if when you update google voice these settings become non-functional?
There is no change to the functioning of InboundCallRoute.


Title: Re: SPAM calls on the OBITALK network
Post by: azrobert on May 19, 2018, 10:09:03 am
GV started sending a plus sign with the CallerID after the switch to SIP. You can verify this by looking at the OBi Call History.
http://www.obitalk.com/forum/index.php?topic=13885.0

Try the following:
{(+x|+xx|+xxx|+xxxx|+xxxxx|+xxxxxx):},{ph}


Title: Re: SPAM calls on the OBITALK network
Post by: Kage on May 19, 2018, 10:14:21 am
In the InboundCallRoute I had used this to ban incoming calls with the less than seven digits:

{(x|xx|xxx|xxxx|xxxxx|xxxxxx):},{ph}

Does anyone know if when you update google voice these settings become non-functional?
There is no change to the functioning of InboundCallRoute.

Then {(x|xx|xxx|xxxx|xxxxx|xxxxxx):},{ph} should work for the OP who was receiving calls from 9001, 8000 etc. If it doesn't will try azrobert's suggestion of adding pluses. Although to be sure enabling X_AcceptSipFromRegistrarOnly and setting a high port number should help to stop it as well.


Title: Re: SPAM calls on the OBITALK network
Post by: Taoman on May 19, 2018, 10:18:38 am

Try the following:
{(+x|+xx|+xxx|+xxxx|+xxxxx|+xxxxxx):},{ph}


Since the SIP scanner calls are not originating from GV I'm unclear why you would want to do this?


Title: Re: SPAM calls on the OBITALK network
Post by: Mango on May 19, 2018, 10:22:19 am
Idly:

Does anyone know if X_AcceptSipFromRegistrarOnly rejects unwanted packets or drops them?

The latter is preferable as it gives the hacker no indication VoIP equipment exists.  If packets are rejected, the hacker will likely keep trying to break in.


Title: Re: SPAM calls on the OBITALK network
Post by: JohnE on May 19, 2018, 10:33:58 am
Fix was to set X_AcceptSipFromRegistrarOnly 

Phew!