OBiTALK Community

General Support => Day-to-Day Use => Topic started by: SJMaye on October 04, 2021, 05:47:46 am



Title: How do I get rid of echo?
Post by: SJMaye on October 04, 2021, 05:47:46 am
I am a long time GV user with OBI202.   From the beginning i have had an echo.  When placing calls I will hear an echo of whatever I say to the recipient.  They do not claim to hear an echo on their side.  I have not noticed if the same is true on calls I receive.

Is there a setting that will eliminate the echo?


Title: Re: How do I get rid of echo?
Post by: drgeoff on October 04, 2021, 10:52:42 am
There is no specific setting for echo on any OBi.

How long is the delay between what you speak and what you hear?

All ordinary POTS telephones not operating in loudspeaker mode are deliberately designed to give some echo otherwise the speaker gets the impression that it isn't working.  This echo will have no delay.  In this case if the echo is too loud try another phone and ensure that the OBi's PHONE port impedance is correctly set to match.  If using a phone intended for use with US standard phone lines the OBi's default setting of 600 ohms should be correct.

If there is perceptible delay in the echo it is very unlikely to be the phone.  Could be "far end echo".  You can reduce that by lowering the ChannelTxGain and/or ChannelRxGain of the OBi's PHONE port.  Those refer to the signals to and from the phone.  Lowering the Tx one will lower the volume of everything you hear via the OBi.  Lowering the Rx one will lower the level of the audio that the OBi sends out towards the other party.


Title: Re: How do I get rid of echo?
Post by: SJMaye on October 06, 2021, 02:24:38 am
I notice the echo most when I call my father who is also on VOIP.  I received a call from a cell yesterday with no echo at all.

Really hard to figure out.