OBiTALK Community

General Support => Installation and Set-Up (Devices) => Topic started by: OBiSupport on November 19, 2010, 02:55:33 pm



Title: SIP registration problem? Disable SIP ALG in your router config.
Post by: OBiSupport on November 19, 2010, 02:55:33 pm
If you have any problems with SIP registration, not being able to receive a call or one-way audio, try to disable the SIP ALG (Application Level Gateway) feature in your router's configuration settings.

The SIP ALG feature available with may off-the-shelf routers is oftentimes not able to translate signaling messages properly such that users may experience registration problems and/or issues with one-way audio.

In these cases, when troubleshooting, it is best to go to your router's configuration and disable SIP ALG.

This wiki article mentions that SIP-ALG functions added in many routers are not properly implemented, hence it is better disable.  www.voip-info.org/wiki/view/Routers+SIP+ALG

Obihai Support



Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: OBi-Guru on April 08, 2011, 02:10:02 pm
SIP registration problem due to broken ALG on D-Link router Model Dir-655,   Hardware Version: B1

There are two firmwares available:

1/ Latest:   2.01 NA, released in Feb 2011, SIP ALG added
    -- By default, SIP ALG is disabled -- and this mode for some reason BLOCKS the SIP packets from going thru
    -- And you must ENABLE SIP ALG to allow SIP packets to pass


2/ Shipping version: 2.00 NA, released in Sep 2010.
    -- By default, there is no SIP ALG function, and works well with SIP


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: texasguy on April 12, 2011, 07:42:17 am
I have DLink DIR-655 Hardware version: A2, Firmware: 1.34NA, SPI enabled in Advanced tab, Firewall Settings. Everything works OK so far.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: VirtualMonitoring on May 09, 2011, 07:15:45 am
SIP ALG's and the like do not just affect Obi devices. Here is a list of routers that we have found do not work correctly with Linksys devices:

D-link DI-624M
D-link DIR655
D-link DIR 615
Linksys WRT-54G 1.0.03


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: SkOrPn on June 06, 2011, 12:24:58 pm
I have DLink DIR-655 Hardware version: A2, Firmware: 1.34NA, SPI enabled in Advanced tab, Firewall Settings. Everything works OK so far.
They were not talking about SPI Firewall settings, they were speaking of SIP Application Layer Gateway a.k.a SIP ALG.

SIP ALG's and the like do not just affect Obi devices. Here is a list of routers that we have found do not work correctly with Linksys devices:

D-link DI-624M
D-link DIR655
D-link DIR 615
Linksys WRT-54G 1.0.03
Exactly what Linksys devices are you speaking of? I have a DIR-655 and it works just fine with my Linksys modem. And seems to work ok with my Motorola SB6120 also. You talking perhaps about Linksys/Cisco PAP2/PAP2T devices, or the like?

EDIT: I just noticed that the D-Link DIR-655 is on the OBi recommended router list below. That's VERY good news to my eyes/ears, lol....

http://www.obihai.com/recommended.html


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: R_Chandra on August 11, 2011, 06:33:48 pm
I was wondering what people (who are using it as a router of course) thought of the SIP connection tracking module for the Linux kernel.  I was going to set that up on my Ubuntu 10.04 (LTS) system I'm preparing to be my next router, but I won't bother if the people here think that's going to interfere.  I've looked at the source for it, and it SEEMED to be reasonable, but maybe there was something I know nothing about which causes grief for OBi firmware.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: buhuo on November 04, 2011, 01:28:20 pm
If you have any problems with SIP registration, not being able to receive a call or one-way audio, try to disable the SIP ALG (Application Level Gateway) feature in your router's configuration settings.

The SIP ALG feature available with may off-the-shelf routers is oftentimes not able to translate signaling messages properly such that users may experience registration problems and/or issues with one-way audio.

In these cases, when troubleshooting, it is best to go to your router's configuration and disable SIP ALG.

This wiki article mentions that SIP-ALG functions added in many routers are not properly implemented, hence it is better disable.  www.voip-info.org/wiki/view/Routers+SIP+ALG

Obihai Support



My router is Dlink DVA-G3810BN/TL. There is no item to disable SIP ALG. I have read dlink DVA-G3810BN manual, it can disable SIP ALG. Who knows how to do it?


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: BrokenArts on March 06, 2012, 11:06:18 am
Hello everyone!

Many thanks for this thread. I just finished setting up the Obi110 for Google Voice and InTalk. Google Voice worked fine, but InTalk did not, so this thread pointed me in the right direction. Disabling SIP ALG on the Netgear WGR614 v7 fixed it right up.

Overall the Obi110 setup was pretty simple, and is working great!


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Bob5678 on March 20, 2012, 05:14:06 pm
Just FYI, and thanks to this forum for all of the help! :)

The latest firmware for the D-Link DIR-655 router is 2.07NA , 14, Jan, 2012.  Using this release I was able to register the OBi110 with no difficulty with SIP enabled.  These were also the default settings for the Firewall with this release of firmware.

D-Link DIR-655 router
Hardware Version: B1      Firmware Version: 2.07NA

My Firewall Settings are:

Enable SPI: Enabled    
UDP Endpoint Filtering: Address Restricted
TCP Endpoint Filtering: Port And Address Restricted
Anti-Spoof checking: Disabled
DMZ Host: Not used
Application Level Gateway (ALG) Configuration
PPTP: Enabled   
IPSec (VPN): Enabled
RTSP: Enabled
SIP: Enabled  


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: zhanzhangphd on July 06, 2012, 09:46:13 am
Hi,
I just got a OBI 100 and my 2WIRE Router does not let me register.
Any expert can help me with disabling the SIP?

Thanks in advance


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Felix on July 06, 2012, 10:23:02 am
Hi,
I just got a OBI 100 and my 2WIRE Router does not let me register.
Any expert can help me with disabling the SIP?

Thanks in advance
Hi, zhanzhangphd and welcome to this forum
You may want to start a topic (probably in the "new user" forum), rather than hijack a sticky with unrelated question. You will probably benefit from Googling a little; at least until you understand that "disabling the SIP" on a VoIP adapter is like "disabling the engine" on the car. An expert can probably do it; but you may not like the results!  ;)


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: lacibaci on August 19, 2012, 04:49:38 pm
For ZyXEL ZyWALL USG series firewalls (firmware 3.0 and later) you have turn SIP ALG on.  By default, it is off and you will not be able to receive calls.  No other change was necessary for me.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Hyrules on February 11, 2013, 12:54:34 pm
For the Asus RT-N56U there is only one way of disable the SIP ALG function with the latest firmware.

Activate the telnet function of the router and do it by hand.

nvram set nf_sip=0
nvram commit
reboot

That's it the SIP ALG should be disable.

This should solve alot of head ache. Not only sip registration.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Lucycan on March 25, 2013, 03:33:08 pm
Latest firmware for the DIR-655 is 2.10 NA

I have disabled SIP but still unable to connect to the Anveo e911.

Any thoughts?  Thanks!


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Sampratt on April 17, 2013, 03:38:07 am
According to me you are getting this problem because SIP ALG or resource manager. I would like to recommend you to upgrade the firmware. Otherwise look for a professional help to know the root cause and Debug it.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Jimbob on May 16, 2013, 09:52:34 am
Starting roughly on 9 May 2013, I was having trouble sometimes (Mostly calls from T-Mobile cell phones).  Our home phone would ring, but would not pick up (they would still hear ringing), or it would pick up, but we could not hear the caller. Sometimes it would go to voicemail/

I had to ENABLE SIP ALG on my Linksys DIR-655 (HW: B1, FW: 2.10NA) under "Advanced", then "Firewall Settings".

Then everything started working again!

Callcentric noted that this may be related to the Colorado DID provider, not T-Mobile specifically, as they have had similar reports.

My experience, YMMV, "The opinions expressed herein are not my own", etc.

[UPDATE:] Perhaps the fix was just the reboot of the router that was required for the SIP ALG change.  It seems to work intermittently, regardless of the SIP ALG setting.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: Jackson on May 16, 2013, 10:09:36 am
Hi,
I just got a OBI 100 and my 2WIRE Router does not let me register.
Any expert can help me with disabling the SIP?

Thanks in advance

Maybe?

Quote
2Wire 3800

I have UVerse from AT&T and my VoIP calls were horrible until I realized that I had this device. I found the instructions found at the Verizon on-line support site to be quite simple and accurate. The Verizon site has actual screen shots. For those of you who don't need a picutre, these are the steps:
Open browser, point to router's IP address followed by /mdc
e.g. http://192.168.1.254/mdc
Enter password and click submit (or press Enter)
Click on Configure Services link on left navigation bar under Advanced
Uncheck the Enable box under SIP Application Layer Gateway
Click submit
Enjoy unfettered VoIP calls!

http://wiki.freeswitch.org/wiki/ALG


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: SIMPLE_desires on May 17, 2013, 02:32:00 pm
Some users of Verizon FIOS have coax/ethernet routers wherein on CANNOT disable SIP ALG

What then is suggested when one cannot swap out routers?

(Yes, I would suggest splitting TV/guide to coax and internet over ethernet,  but not everyone is willing to do that)



Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: derekpittx on February 17, 2020, 10:40:56 pm
SIP registration problem due to broken ALG on D-Link router Model Dir-655,   Hardware Version: B1

There are two firmwares available:

1/ Latest:   2.01 NA, released in Feb 2011, SIP ALG added
    -- By default, SIP ALG is disabled -- and this mode for some reason BLOCKS the SIP packets from going thru
    -- And you must ENABLE SIP ALG to allow SIP packets to pass


2/ Shipping version: 2.00 NA, released in Sep 2010.
    -- By default, there is no SIP ALG function, and works well with SIP


I also have this problem, if someone has a solution, please tell me get-9apps.com (https://get-9apps.com/index/) get-cartoonhd.com (https://get-cartoonhd.com)


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: leaschaden on August 31, 2020, 02:30:42 am
SIP registration problem due to broken ALG on D-Link router Model Dir-655,   Hardware Version: B1

There are two firmwares available:

1/ Latest:   2.01 NA, released in Feb 2011, SIP ALG added
    -- By default, SIP ALG is disabled -- and this mode for some reason BLOCKS the SIP packets from going thru
    -- And you must ENABLE SIP ALG to allow SIP packets to pass


2/ Shipping version: 2.00 NA, released in Sep 2010.
    -- By default, there is no SIP ALG function, and works well with SIP


I also have this problem, if someone has a solution, please tell me  hill climb racing (https://hillclimb-racing.com/)
Go to Advanced > QoS Engine. This will bring up your QoS settings (bandwidth management).
Click the box next to Enable Traffic Shaping to enable WAN Traffic Shaping.
Set the Manual Uplink Speed to an appropriate value based on your Internet connection. Note: Automatic Uplink Speed is disabled in 8x8ís QoS configuration as the feature adds some additional delay in the boot up time of the router.
Check the box next to Enable QoS Engine in the QoS Engine Setup portion of the screen.
hope this can help you!


Title: Re: Suddenly offline?
Post by: APCgirl on September 23, 2020, 01:51:22 pm
Have had Obi with Anveo for over a year now, and it is suddenly offline? Can't figure out how to fix it, & have no idea why it suddenly changed. I have little experience with this, I literally set it up last year and haven't messed with it since.
Thank you in advance for any help!


Title: Re: Suddenly offline?
Post by: drgeoff on September 23, 2020, 02:50:27 pm
Have had Obi with Anveo for over a year now, and it is suddenly offline? Can't figure out how to fix it, & have no idea why it suddenly changed. I have little experience with this, I literally set it up last year and haven't messed with it since.
Thank you in advance for any help!
What is the state of the power LED?

Dial ***1.  What message is read out to you?

Dial **9 222 222 222.  What message do you hear?


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: APCgirl on September 23, 2020, 04:30:25 pm
The lights on the Obi are green, but it says offline on the website.

When I dial  ***1, says IP address is not available and the DHCP is enabled.

**9 222 222 222 says IP not available please review FAQ reason 00.



Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: drgeoff on September 23, 2020, 04:45:27 pm
The lights on the Obi are green, but it says offline on the website.

When I dial  ***1, says IP address is not available and the DHCP is enabled.

**9 222 222 222 says IP not available please review FAQ reason 00.


There is a contradiction between the first two of those.

Try this.  Power off both the OBi and your router. Wait 30 seconds before powering the router on again.  Then wait 3 minutes before powering on the OBi.  Answer my 3 questions again.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: APCgirl on September 23, 2020, 05:04:28 pm
Ok, now power light is on, middle light is rapid flash, one with the phone icon has no light. ***1 is giving me my IP now but saying the DHCP is disabled.
**9...  now says no service available to complete the call.



Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: drgeoff on September 23, 2020, 05:14:14 pm
Ok, now power light is on, middle light is rapid flash, one with the phone icon has no light. ***1 is giving me my IP now but saying the DHCP is disabled.
**9...  now says no service available to complete the call.


Do you have another ethernet cable you could try between the OBi and router?  If yes try it, preferably into a different LAN socket on the router.  Unpower the OBi, wait 30 seconds and power up again.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: APCgirl on September 23, 2020, 05:25:04 pm
I so appreciate your help!
Unfortunately, that didn't work either!
Same messages on both the numbers/starts to dial. And still says offline on the site.
Ugh.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: drgeoff on September 25, 2020, 12:26:17 pm
I still cannot reconcile the symptoms you are reporting.  Initially DHCP was enabled.  Now it is not.  Yet all you have done in the meantime is power off and on again.

If DHCP is now disabled and the OBi is reporting an IP address then you must have set a static one.  Did you?  And if so what address did you give it?  There is no security risk with posting that address.


Title: Re: SIP registration problem? Disable SIP ALG in your router config.
Post by: APCgirl on October 17, 2020, 12:47:08 pm
Hello,
 I never reset it, I don't even know how.

 I did however today open a ticket, still have gotten nowhere. I went ahead and deleted off my account. Now, it won't reconnect. I reset my router, with help, and I think it's just not getting to the router. I don't how to get it past a firewall, I tried plugging it right into the modem but that didn't work either. I know the ethernet cords I have tried work, I tested all of them on different hook ups.
 Either it's a firewall (I guess) on the ASUS router, or the thing is broken. I have spent hours trying to fix it with the help of the support ticket, and got no where. I finally, like I said, just removed it and tried to reset it up.
Frustrating, and disappointed how much I have to know about this stuff to buy something that claims you just plug it in, click some buttons, and it works.... it did, at first. Who knows.  ??? :-\