OBiTALK Community

General Support => Installation and Set-Up (Devices) => Topic started by: obiuser2011 on January 23, 2011, 12:36:49 am



Title: OBi110 doesn't receive incoming calls to Google Voice number
Post by: obiuser2011 on January 23, 2011, 12:36:49 am
Google Voice is configured as Service Provider 1 and will call out on the connected phone successfully.  Calls to Google number do not ring same phone connected to OBi110 that successfully calls out. Connected same phone to telco and it rings when called.

- Updated to latest firmware (OBi110-1-1-0-1832.fw) prior to configuring.

- Created new Google account and phone number for exclusive use with OBi.

- Not logged into associated Google account.

- New Google Voice account works with "Call" feature within Google Voice.

- Disabled SIP ALG on router.

- Bypassed router altogether.

- Deleted device in OBiTALK twice - once before new Google account and number and once after.





Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: obiuser2011 on January 23, 2011, 11:07:13 pm
The fix was:

Went into Google Voice, "Settinging" > "Phones" > "Forwards to", put a check mark in the box next to "Google chat". It was not checked after I created the account.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Agate on January 25, 2011, 03:05:48 pm
My fix:
1) Ensure that in http://google/voice  under Settings/Voice Settings/Phones, Forwards to: that Google Chat is checked
2) If you want to remain logged into the gmail account that hosts your google voice number, then in Gmail under  Settings, then the Chat tab, change the Call Phones setting to Call Phones:   choosing Disable outbound voice calling.

The down side to this is you can not use the chat function in Gmail, not only does a Gtalk not work in gmail but the Send SMS (from gmail labs) does not work either. A work around for Windows based PC's  would be to install http://desktop.google.com/ then add the GTalk gadget to the desktop. Now you will have chat back on your desktop. If your MAC/OsX based use an IM client like iChat or Adium.

If your using a chrome browser, the Extension: Google Voice (by Google) still shows your google voice message count and clicking on it allows you from your browser tool bar area the ability to call, text, or see your google voice inbox.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: QBZappy on January 25, 2011, 04:15:26 pm
Agate

Another workaround for your second scenario if you use firefox is to install the "Google Voice Add-on" found here http://thatsmith.com/2009/03/google-voice-add-on-for-firefox . This add on gives you the ability to send SMS, and Google voice dial out from the  browser. Just another way to get around that problem.

Best way really is to have a dedicated Google voice account.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Agate on January 26, 2011, 01:57:50 pm
A better way, that does not involve changing our outbound call phones settings:

Better fix:
1) Ensure that in http://google.com/voice  under Settings/Voice Settings/Phones, Forwards to: that Google Chat is checked
2) Sign out of chat in http://gmail.com . Your Chat window is likely on the left side unless you are using a Labs feature to place in on the right of your gmail. Sign out of chat by locating the chat area an finding the "Sign out of chat" option in the pull down along side your name. Your successful when you see a gray offline icon ball next to your name.

The advantages to this better scheme, is that you keep your google account with all its history/contacts/voiceMail etc.  If your on the road and need to make or receive calls through your browser, simply sign back into Chat (the Sign into chat option is just below your chat name in the chat side bar). Now you can receive inbound calls in gmail. (No need to switch the forwarding settings in http://google.com/voice, you can safely leave #1 above set to forward to Google Chat).


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: kb_hunter on September 10, 2011, 06:31:57 pm


If you are signed into chat, there is another issue worth noting. You cannot set your mode to "invisible". Because Obitalk is also active on the Gchat, Google says "oops I am sorry, you cannot become invisible".

So, logging out of chat is really the only good option if you are using a non-dedicated account GV.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jmsnyc on September 12, 2011, 05:40:40 pm
I have a different solution.

I have a free sipgate account on SP2 of my obi110.   Instead of forwarding my incoming calls to Google Chat I forward them to my sipgate number.  It rings the same phone so to me no difference.  Outgoing calls work the same.

Please comment if you think there are flaws in this solution.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: earthtoobi on September 13, 2011, 12:59:09 am
Jmsnyc: Outgoing calls are not the same. Note that you are registered with Sipgate from your ATA device. when you place a call, it goes through SIpgate and is no more free ....with google chat, calling to US destinatons is free.

your outgoing call through sipgate might have gone through fine since they might have given some starter credits...


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jmsnyc on September 13, 2011, 05:10:31 am
I have money with sipgate because I pay for 911 with them so it is possible that I am eating into that money but how are my calls going through sipgate?

If I dial out on sp1 I am using obihai's method of connecting to google voice, the ring back is not working properly so my method might be flawed anyway but I still do not think the call is being charged to sipgate unless I diall the **2 code first.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: earthtoobi on September 13, 2011, 08:20:00 am
jmsync:
you have not said what you use for Sp1.
1. what have you configured in SP1?
2. Assume SIpgate in Sp2.
3. what you have setup as primary line for the phone port.(sp1 or sp2)?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: RonR on September 13, 2011, 09:16:06 am
jmsnyc,

Simply looking the OBi Call History should clear up any mystery of what path your calls are actually taking.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jmsnyc on September 26, 2011, 05:39:39 pm
jmsync:
you have not said what you use for Sp1.
1. what have you configured in SP1?
2. Assume SIpgate in Sp2.
3. what you have setup as primary line for the phone port.(sp1 or sp2)?

SP1 is Google Voice and primary

A work around for Windows based PC's  would be to install http://desktop.google.com/ then add the GTalk gadget to the desktop. Now you will have chat back on your desktop. If your MAC/OsX based use an IM client like iChat or Adium.

If your using a chrome browser, the Extension: Google Voice (by Google) still shows your google voice message count and clicking on it allows you from your browser tool bar area the ability to call, text, or see your google voice inbox.


So If I use Google Desktop, I can be logged into Google Chat without it affecting my incoming calls?  I do not really want to install it because I feel it takes over your whole pc.

I currently have the GV Extension in Chrome but that doesnt help me if I want to use to chat.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: newtothescene on November 11, 2011, 09:45:08 am
 I'm having the same problem with my phone not ringing  with goggle voice.
 I changed the setting - goggle voice>setting>phones>forward to ...to the goggle chat icon and the phone is still not ringing. I've tried clicking on both home and goggle chat icons and phone doesn't ring. The phone calls out good though.
 Any suggestions?  


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Yardvaark on February 27, 2012, 05:09:32 am
Not sure if this problem in right category here.

I had GV number working fine with Obi 110. Tried to add another GV number as SP2. Could not get both numbers to work and finally deleted SP2. Now, when I try to call GV number with my mobile, I get Google Voicemail wanting me to enter my PIN number. I just want to be able to call my original GV number (using my mobile that is linked to that account) and have it ring the phone that is connected to the OBI. (I get me messages off of that answering machine.) Explored many setting changes but cannot find anything that fixes this. Do not know if I need to fix in Obitalk or GV settings. I am easily stumped by any language beyond "phone" or "mobile phone" so please go easy on tech talk.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Stewart on February 27, 2012, 06:20:01 am
GV settings, Phones tab, click Edit for your mobile phone, click Show advanced settings.  Under "Direct access to voicemail ...", choose no.  Click Save.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Detoxer on February 29, 2012, 03:40:32 pm
I just tried to install the Obi110.  It will call out with Google Voice.  However, in GV under phones there is no option for "forward to google chat."  I have looked on the internet and there are a number of people complaining about this. 

Does anyone have a solution?

Thanks.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: RonR on February 29, 2012, 03:49:23 pm
You have to make at least one outgoing call from your Gmail account for the Google Chat forwarding phone to be created in your Google Voice account.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: getstarted on March 04, 2012, 06:37:04 am
I have the same problem.  Not able to receive calls to obi connected phone. outgoing calls are okay.  I have tried all the suggestions in this thread.  and followed the instructions (http://obihai.com/tutorial1.html) couple of times, still no use.  Any help?  is it a defective item? 


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jimates on March 04, 2012, 03:20:02 pm
I have the same problem.  Not able to receive calls to obi connected phone. outgoing calls are okay.  I have tried all the suggestions in this thread.  and followed the instructions (http://obihai.com/tutorial1.html) couple of times, still no use.  Any help?  is it a defective item?  
If outgoing calls using google voice from the Obi are successful then the problem is not likely the device. If you have an Obi110 with a land line connected, make sure the outgoing calls are indeed going out over google voice and not the land line.

1 - Did you make one successful call from within gmail using google chat.
2 - Did you check the box for "Google Talk" as a forwarding phone on your google voice page.
3 - Make sure you do not have your gmail account open in a browser window while trying to receive calls to the Obi.
4 - Make sure you do not have any conflicting apps running on a smart phone while trying to receive calls to the Obi (Groove IP, Talkatone etc.)
5 - Make sure the X_InboundCallRoute for the google voice SP includes "ph".


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: getstarted on March 04, 2012, 06:28:36 pm
1 - Did you make one successful call from within gmail using google chat.

I missed the first one itself.  I was able to setup the rest of the steps, so i thought it is fine.  Once i make a call using gmail, it started working.  Thanks for pointing out that. 


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: MrPaul on April 01, 2012, 01:21:05 pm
I use an existing GV number because there are no new numbers available in my area code. I went through all of the other suggestions in this thread without luck. Today I realized that although I had Google chat enabled in GV, the email address associated with Google chat in GV was not my gmail account. I removed the other email from GV, deleted the chat from the Phones page, then made a call from Gmail to get the chat to return to the Phones page. When I returned to GV, the chat option was back, and it had my Gmail account instead of my other email account. Now I can receive incoming calls on the Obi!


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Wayne_for_Obi on April 05, 2012, 07:21:12 pm
Obi110 will not ring when calling the GV#. Goes to voice mail.

Would appreciate some hints, as I've done all the following:

-- Made two successful calls from within gmail using google chat.
-- Checked the box for "Google Talk" as a forwarding phone on your google voice page.
-- Made sure gmail or gv account is not open in a browser window while trying to receive calls to the Obi.
-- Logged out of chat in gmail.
-- Made sure there are no conflicting apps running on a smart phone while trying to receive calls to the Obi (Groove IP, Talkatone etc.) (no such apps installed anywhere)
-- Made sure the X_InboundCallRoute for the google voice SP includes "ph". (Is only set to "ph")
-- Updated to latest firmware
 


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jimates on April 05, 2012, 07:26:56 pm
Another thing to add to that list,
Verify calls to the google voice number ring into google chat when the gmail page is open.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: RonR on April 05, 2012, 07:39:43 pm
Obi110 will not ring when calling the GV#. Goes to voice mail.

The problem may be widespread and not just with you : Inbound calls just plain stopped tonight? (http://www.obitalk.com/forum/index.php?topic=2957.0)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Zaatari on April 06, 2012, 06:59:19 am
I am having the same problem, I tested all the following except this:
-- Made sure the X_InboundCallRoute for the google voice SP includes "ph". (Is only set to "ph")
not really sure how to do that?

Also, as per the prior comment, it turns out my google voice isn't working on gmail either... not really sure what to do at that point... I tried multiple accounts following the guide...

Appreciate the help.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: QBZappy on April 06, 2012, 07:01:47 am
Zaatari,

At the moment I think there is nothing to do. It seems GV is experiencing system problems. Just wait for a fix from GV. (See various other recent posts related to GV issues)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: paulsalem on April 06, 2012, 07:54:11 am
OBi110 will not recive inbound calls.  Outbound calls are hit or miss with an intermittent 503 error.

The OBi 110 is in Singapore and has worked for over a year now.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Wayne_for_Obi on April 06, 2012, 11:41:22 am
inbound calls now ring the phone connected to obi.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Zaatari on April 06, 2012, 07:42:49 pm
It worked...

Just my luck, the day I buy the OBI110. GV decides to drop incoming calls. I spent 6 hours scratching my head on what I could be doing wrong... Thanks google ;)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: robkaier99 on April 13, 2012, 03:02:24 pm
Thanks all of you guys for valuable information. Hopefully this make the situation more comfortable for my call center.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: onecanobi on May 03, 2012, 09:42:53 pm

Since having this problem after the MOST RECENT firmware update on the obi100, and trying all sorts of different things, I ended up doing a hard-reset (soft clears didn't work), and deregistering it from my obi devices, and then re-adding everything from scratch as if it was a brand new device.

All of a sudden everything is working again.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Thor on May 24, 2012, 12:01:32 pm
This is my problem today, too, with new OBI hardware.  Time invested in troubleshooting is upwards of 3 hours, now.

0. Google Voice single outbound call went okay / confirmed.  (I had to install a google ap to make the call...)
1. Outbound and echo test, okay.  Inbound, not okay (no possible mobile conflicting aps).
2. I didn't check "forward calls to google chat" before I ran connection on Obitalk website; but I did it afterwards, including verifying that "direct access to voicemail" was off (it was).   Equipment shows "connected" in Obi dashboard to GV as SP1.  Ran that connection step a second time, just to see if it would find/make the connection.  It did.  Still shows connected.
3. Everything associated with google chat inside g-mail is turned off (chat itself as well as disable outbound calls inside chat setting and any other 'disable' that I could find, I think.)

I don't know how to check if "5 - Make sure the X_InboundCallRoute for the google voice SP includes "ph"."

Any thoughts?

Is it a Google Voice problem?  If so, the equipment has to get returned, I think (it's useless for its purpose).

Is it time to just delete everything and just try it over from the beginning (someone had success doing that)?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: goswick on June 09, 2012, 07:07:59 pm
I got my device today and am experiencing the same problem as you...able to make outbound calls but not receiving any inbound calls via GV.

As it stands right now the Obi110 is going to be returned on Monday for a refund. is a great idea but doesn't work for me.

I'm always leery of any product that does not offer any support via a human.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: pc44 on June 09, 2012, 08:21:43 pm
Hi goswick,

Are you running the latest firmware?  ***6 will let you know.

Have you performed an outgoing test call using Google Chat first?

Have you double-checked that you have Google Voice's settings configured to forward all incoming calls to Google Chat?  And, have you disabled Google's Call Screening?

Lastly, when you look in your OBI settings under Status -> System Status -> SPx Service Status, does it say Status: Connected?

Just a few ideas that *might* help, :)
pc44


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: goswick on June 10, 2012, 04:28:54 am
Yes to all...


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: QBZappy on June 10, 2012, 06:19:59 am
goswick,

Does the call make it to the call history of GV and the OBi?

Show us your setup here:
ITSP InboundCallRoute = ?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: onecanobi on June 12, 2012, 10:45:57 am

Since having this problem after the MOST RECENT firmware update on the obi100, and trying all sorts of different things, I ended up doing a hard-reset (soft clears didn't work), and deregistering it from my obi devices, and then re-adding everything from scratch as if it was a brand new device.

All of a sudden everything is working again.


I wanted to follow up as now I have more of an idea as to what went awry.
It had to do with non-default codec setup, I was trying to force g729 bothways, and prior to the firmware update it worked fine. But since the latest update, 729 only works outbound, and inbound is negotiated at g711 from the provider. Enforcing g729 bothways makes it not work. This is why defaulting the device to original config works. Troubleshooted with someone from obi devices for almost an hour and they ended up blaming the voip provider ( freephoneline/fongo ) for causing the problem, although I kept saying it used to work fine on g729 both ways until this firmware update.

So for now, I had to leave it default.. or atleast allow g711 in order for incoming to work. That's the only reason that I can think of. Even though it can get choppy if other things are happening on a low bandwidth line.


Title: SOLVED for me!! Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Pres on September 21, 2012, 10:12:57 pm
I had the same problem: ringing of incoming calls.

I tried the suggestions here and elsewhere. Deleting this or that, changing settings, making a call etc...

I solved the issue by installing google video and some other google product that was offered with video.  I do not remember what the name of the other product is but they were offered together.  After installing them incoming calls ring and have not had an issue since. :D


Title: Re: SOLVED for me!! Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: jimates on September 21, 2012, 10:54:58 pm
I had the same problem: ringing of incoming calls.

I tried the suggestions here and elsewhere. Deleting this or that, changing settings, making a call etc...

I solved the issue by installing google video and some other google product that was offered with video.  I do not remember what the name of the other product is but they were offered together.  After installing them incoming calls ring and have not had an issue since. :D
That would be the Google Voice and Video plug in. It is required to be installed in order to receive calls in gmail (Obi uses the gmail interface).


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: tulipox on October 01, 2012, 06:35:48 pm
OK - let me add my two cents to hopefully save others from hours of frustration.  I too was having this issue.  i followed many of the suggestions I found, but could not find a solution that worked for me.  eventually i discovered the key was having my gmail address as the e-mail address for google chat forwarding.  if you can make calls but can't receive them, this is most likely your issue.   steps: delete the non-gmail address from the settings / phones page.  then go to your gmail account make a call - look for the phone icon on the left side of the page.  once you do that, return to the settings / phones section in google voice, and your gmail address should now show and give you the option to forward to google chat.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Kyleishere on November 09, 2015, 07:19:01 pm
Another solution that worked for me - in case someone stumbles into here looking for answers.  I am reposting from SteveinWA on a similar question/answer in this forum since I did not find his response until after 3 hours of searching, trial and error:


Log into Gmail, not Google Voice, on a laptop or desktop computer, not a mobile device.  On your main Gmail inbox page, look on the left side of the page for your avatar.  This is either a generic head and shoulders icon, or your photo or GIF that you uploaded to represent yourself.  If you don't see your avatar at all, scroll all the way down to the bottom of the Gmail page, and click the small grey "chat balloon" to toggle it on or off.

Click your avatar to open up Hangouts options.  Look down at the bottom of the white options box for the small link "Revert to old Chat" and click it.  See my attached screenshot.

After you have reverted to old chat, click the telephone handset icon to pop up the Chat dialer to make a call.  This should re-install the Chat forwarding destination to Google Voice.

After you confirm that it did so, you can reverse the procedure in Gmail by clicking "Try the new Hangouts".  Your Chat "phone" will not go away.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: phines on April 18, 2016, 08:40:12 pm
No incoming calls here.  I was on Vestalink until recently.  So I removed the Obi110 from Vestalink and GV.  I removed the Obi110 from obitalk webpage, factory reset the Obi110, unchecked/rechecked the google talk checkmark, reinstalled the obi110 to my GV.  It says "connected" for the GV on obitalk, and I can call out.  But when I try to call the GV number, the ob110 does not ring.  

I tried all the steps in the thread (including reverting to the old google chat).  Still no incoming calls.

UPDATE: I found a solution myself.  Maybe this will help others:

I removed the obi110 from obitalk.  Then I created a new Gmail account with no GV number attached, transferred my old GV number to the new account, then installed my obitalk to that new account.  Now it works like a charm!

I suspect if I remove the obi110 again, and transfer the GV number back to the old GV account and install the obi110 again, it will still work.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: phines on April 22, 2016, 04:55:16 am

No incoming calls here.  I was on Vestalink until recently.  So I removed the Obi110 from Vestalink and GV.  I removed the Obi110 from obitalk webpage, factory reset the Obi110, unchecked/rechecked the google talk checkmark, reinstalled the obi110 to my GV.  It says "connected" for the GV on obitalk, and I can call out.  But when I try to call the GV number, the ob110 does not ring.  

I tried all the steps in the thread (including reverting to the old google chat).  Still no incoming calls.

UPDATE: I found a solution myself.  Maybe this will help others:

I removed the obi110 from obitalk.  Then I created a new Gmail account with no GV number attached, transferred my old GV number to the new account, then installed my obi110 on obitalk using that new account.  Now it works like a charm!

I suspect if I remove the obi110 again, and transfer the GV number back to the old GV account and install the obi110 again, it will still work.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: yorktown on May 18, 2016, 09:48:40 pm
This solution works for Obi100 devices: http://www.obitalk.com/forum/index.php?topic=11256.msg73954#msg73954 (http://www.obitalk.com/forum/index.php?topic=11256.msg73954#msg73954)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Ev77 on July 14, 2016, 05:15:28 pm
I was using Obi & PhonePower rather than GV with my Obi.  I was using GV to forwardcalls to my PhonePower number.  I reconfigured my Obi to use Google Voice and outgoing calls worked fine but not incoming calls.  "Forward Calls to Google Chat" was already checked.

SOLUTION:  Uncheck it & let GV save that then check it again & let GV save that.

Problem solved.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: Anivoc on August 10, 2016, 06:47:11 pm
Faced  the same issue of setting up a new obihai 110 with google voice and a freshly ported number, I could call out on my "Landline" phone connected to my Obihai 110 but the incoming calls were going directly to Google Voice voicemail...arrrrrgh!

Going here and searching the net I figured it out that you need to have Google Chat checked "on"  in the google voice settings..

After I checked it on my "landline" received calls no problem..

Very excited about the powerful call screening and blocking features of Google voice now empowered on my Obihai 110...Yay!



Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 07, 2016, 02:31:06 pm
After deleting Google chat (tried unchecking first and with check) it goes away, but when I refresh the browser it comes back and the default is checked.  In no case do I see a gamil call phone.

Please help.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 07, 2016, 04:59:24 pm
After deleting Google chat (tried unchecking first and with check) it goes away, but when I refresh the browser it comes back and the default is checked.  In no case do I see a gamil call phone.

Please help.

This is a very old thread, and your problem is likely unrelated.  Nonetheless, you are here, so let's try to understand:  what is the problem you are trying to solve?  Deleting Google Chat doesn't do anything special.  The more detailed you can be in your post, the better chance of us understanding your actual issue.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 08, 2016, 12:11:33 pm
Yes. I made a call using the plug-in on the gmail web page.  Can call out no problem.  Incoming calls do not ring the phone and go to voice mail.  This has been going on for some time.  Maybe since I paid Amazon $10 for a firmware update.  Today is 8 Sep 2016 and the update was many months ago, so maybe it's a firmware problem?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 08, 2016, 02:23:26 pm
We need more details.

Pick up the phone plugged into the OBi and key in ***0 then 1#.  What are the last four digits it reads back to you?

Log into your Google Voice account from a laptop or desktop computer's web browser, not from a mobile phone, and go here:  https://www.google.com/voice#phones (https://www.google.com/voice#phones)

Look at the left side of the web page.  Do you see the exact two words, "Your number", and underneath it is your inbound Google Voice number?  Or, do you see the words "Access number" or "Get a Voice number"?

IF you see "Your number" and not one of the other phrases, then:

Go to this page:  https://www.google.com/voice#callsettings (https://www.google.com/voice#callsettings)

Temporarily enable "Do not disturb" for 10 minutes or so.  Call "Your number" from some phone number other than any phone listed on the Phones tab of Settings.  Your call should go directly to Google Voice's voicemail system, and you should hear your greeting.  Does that work?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 09, 2016, 12:28:04 pm
Hi Steve:

After a hard wired phone calls: ***1 1# the response is: 1.3.0.2886

On the left of the Google Voice page is says "Your Number".

Yes, there is no ring and immediately I get the voice mail greeting.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 09, 2016, 12:35:43 pm
OK, so that confirms:
  • Your OBi is at the correct, latest firmware level
  • You have a valid inbound Google Voice phone number
  • That Google Voice phone number is working properly

So, what is the problem, in detail, that you are trying to solve?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 09, 2016, 01:57:14 pm
OBi110 doesn't receive incoming calls to Google Voice number


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 09, 2016, 02:03:25 pm
You must have a check mark to the left of the Google Chat forwarding destination on this page:

https://www.google.com/voice#phones (https://www.google.com/voice#phones)

If you do have a check mark there, then call some other phone number from the phone attached to your OBi.  Look at the caller ID display on THAT called phone.  Does it display your Google Voice telephone number, or does it say "Unknown" or "Private Caller"?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 09, 2016, 02:12:21 pm
Caller ID is my Google Voice phone number.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 09, 2016, 02:15:25 pm
In that case, log into the OBiTALK web portal, completely delete your OBi off of the portal, wait a few minutes for it to remotely reset the OBi (you will see the red power light come on and then go off, and the other lights will blink for a while).  Then, on the phone attached to the OBi, dial ***8, then 1, to restore factory defaults.

Now, use the **5 procedure to add your OBi back to the OBiTALK web portal.

Follow these instructions to set up your OBi with your Google Voice account again.

http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460 (http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: BrookeUkiah on September 09, 2016, 02:42:50 pm
Hi Steve:

Thanks very much it now works for both making and receiving calls!
Have Fun,
Brooke


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 09, 2016, 02:44:43 pm
Great!  Thanks for working through it with me.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: KSSteve on September 13, 2016, 07:43:59 pm
Steve,

I'm having the same trouble with my OBi100 and Google Voice that Brooke had.  GV and the OBi worked fine together for quite a while, but now I can only make outgoing calls. If I try to call my GV number from another phone it goes straight to GV voicemail.

I've followed all the instructions on this page several times.  Firmware is 2886.  Google chat is checked.  Google voice says "my number."  Do not disturb is not enabled. 

I've deleted and added the OBi on Obi "Device Configuration" several times. 

Outer two lights are solid green.

Please help!


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on September 13, 2016, 08:02:13 pm
Steve,

I'm having the same trouble with my OBi100 and Google Voice that Brooke had.  GV and the OBi worked fine together for quite a while, but now I can only make outgoing calls. If I try to call my GV number from another phone it goes straight to GV voicemail.

I've followed all the instructions on this page several times.  Firmware is 2886.  Google chat is checked.  Google voice says "my number."  Do not disturb is not enabled. 

I've deleted and added the OBi on Obi "Device Configuration" several times. 

Outer two lights are solid green.

Please help!

Let's see what your Google Voice account looks like.

Please log into your Google Voice account from a laptop or desktop computer, not from a mobile phone or tablet, and then take a screenshot of this page:  https://www.google.com/voice#phones (https://www.google.com/voice#phones)

If you need help learning how to take a screenshot, see these instructions:  http://www.take-a-screenshot.org/ (http://www.take-a-screenshot.org/)

Obscure (cover up/black out) the first six digits of all phone numbers, leaving the last four digits exposed.  Obscure any email addresses, too.  You can use any basic image or photo editing program, such as MS Paint, to cover up the private fields.

Attach the file to your reply here, by clicking the "+ Additional Options..." link below the post editor.  Thanks.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: KSSteve on September 14, 2016, 07:14:51 am
I fixed it.  It was something with Google Voice, not OBI. 


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: LTN1 on September 14, 2016, 09:24:25 am
I fixed it.  It was something with Google Voice, not OBI. 

Let us know what it was so the next person, having similar issues, can see the mistakes that you made and hopefully use what you learned to correct it.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: alexmarz850 on April 01, 2017, 09:41:12 am
This worked for me,

Another solution that worked for me - in case someone stumbles into here looking for answers.  I am reposting from SteveinWA on a similar question/answer in this forum since I did not find his response until after 3 hours of searching, trial and error:


Log into Gmail, not Google Voice, on a laptop or desktop computer, not a mobile device.  On your main Gmail inbox page, look on the left side of the page for your avatar.  This is either a generic head and shoulders icon, or your photo or GIF that you uploaded to represent yourself.  If you don't see your avatar at all, scroll all the way down to the bottom of the Gmail page, and click the small grey "chat balloon" to toggle it on or off.

Click your avatar to open up Hangouts options.  Look down at the bottom of the white options box for the small link "Revert to old Chat" and click it.  See my attached screenshot.

After you have reverted to old chat, click the telephone handset icon to pop up the Chat dialer to make a call.  This should re-install the Chat forwarding destination to Google Voice.

After you confirm that it did so, you can reverse the procedure in Gmail by clicking "Try the new Hangouts".  Your Chat "phone" will not go away.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: rramstad on May 03, 2017, 05:58:32 pm
I've been having the same problem listed here, but when I attempted to reconfigure things, when I sign into the old chat, I get the message

"Google Talk will be replaced with Hangouts on June 26, 2017"

and when I click on the handset, the dialer pops up, and says

"To make or receive phone calls in this browser, please enable Hangouts"

Now, oddly, the destination Google Chat still shows up in phones, and I have it checked and all that (have also tried to uncheck and recheck it, also tried deleting it and setting it up again) but in my case, nothing works.  I get 503 errors on outbound calls (though I can reach the echo server), and inbound calls ring four to six times then go to voicemail (Google Voice voicemail -- I can see the call in the Google Voice logs).

Anyhow I thought I'd post as the previous post (from a month ago) said they were able to load the dialer from within the old Chat, which seems to no longer work.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on May 03, 2017, 06:06:04 pm
I've been having the same problem listed here, but when I attempted to reconfigure things, when I sign into the old chat, I get the message

"Google Talk will be replaced with Hangouts on June 26, 2017"

and when I click on the handset, the dialer pops up, and says

"To make or receive phone calls in this browser, please enable Hangouts"

Now, oddly, the destination Google Chat still shows up in phones, and I have it checked and all that (have also tried to uncheck and recheck it, also tried deleting it and setting it up again) but in my case, nothing works.  I get 503 errors on outbound calls (though I can reach the echo server), and inbound calls ring four to six times then go to voicemail (Google Voice voicemail -- I can see the call in the Google Voice logs).

Anyhow I thought I'd post as the previous post (from a month ago) said they were able to load the dialer from within the old Chat, which seems to no longer work.

You don't need to use Chat in Gmail.  The Chat client GUI is being discontinued, after more than two years of transition time, to Hangouts.  However, the underlying Chat/XMPP protocol is being left in place, to support OBi users.  All you need to do is to check-mark the box to the left of Chat, on the old, "Legacy" Google Voice settings page.

The rest of your post is unclear.  Did you previously have a Google Voice number that was working properly, and it just mysteriously stopped working, or what?  Something changed; what was it?


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on May 03, 2017, 06:17:01 pm
There may be an outage for certain (not all) Google Voice / OBi users.

I'd suggest posting in, or following, this discussion thread:
https://productforums.google.com/d/topic/voice/DeXjzSzcEKU/discussion (https://productforums.google.com/d/topic/voice/DeXjzSzcEKU/discussion)


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: JamesOnObi on August 26, 2017, 06:30:02 pm
Hello,

I am unable to find the "Revert to old chat" link in GMAIL or Hangout or anywhere, does anyone have a workaround for this?

Thanks,
JW


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: drgeoff on August 27, 2017, 06:59:28 am
Hello,

I am unable to find the "Revert to old chat" link in GMAIL or Hangout or anywhere, does anyone have a workaround for this?

Thanks,
JW
You are probably looking in the wrong place.

Log in to google.com/voice.  At the bottom of the left side click on the 3 vertical dots. Near the bottom of the left hand side click on 'Legacy Google Voice'.  Near the top on the right hand side click on the gear icon and click 'Settings'. You should get 6 tabs, the left-most one being 'Phones'.  If that one is not selected click on it.  Under 'Forward calls to' The 'Google Chat' option should be there.


Title: Re: OBi110 doesn't receive incoming calls to Google Voice number
Post by: SteveInWA on August 27, 2017, 02:02:33 pm
You no longer need to "revert to old chat".  Just go to the legacy version of Google Voice settings, and ensure that you have a check-mark to the left of "Google Chat". 

In order to use any of the Google Voice calling services, you need to have made at least one outbound call from Google Voice (via a conventional mobile or landline phone), or from Google Hangouts.  This is so that Google can display its Terms of Service to you, and you can click the button to accept them (legal requirement).