December 17, 2017, 07:52:13 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: block nuisance calls  (Read 29712 times)
npr1
Newbie
*
Posts: 15


« on: October 12, 2015, 11:08:12 am »

I'm trying to configure my Obi110 to block nuisance calls which have the caller ID displayed as "INTERNATIONAL".

Line Port settings
InboundCallRoute:  {(00xx.|INTERNATIONAL|01600469009):},{ph}

Unfortunately I'm still getting these "INTERNATIONAL" calls as shown in the attached call history screen capture.
Can anyone please advise what I'm doing wrong.
Does the above method only work with caller ID "peer number" and not "peer name"?


* international.jpg (219.48 KB, 1118x631 - viewed 732 times.)
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #1 on: October 12, 2015, 11:32:03 am »

Quote
Does the above method only work with caller ID "peer number" and not "peer name"

That's right. Only the CallerID (Peer Number) is used for screening. I see the "INTERNATIONAL" call has no CallerID. It is possible to block calls with no CallerID using "?" like so:

Line Port settings
InboundCallRoute:  {(00xx.|?|01600469009):},{ph}

This would block all calls with no CallerID.
Logged
npr1
Newbie
*
Posts: 15


« Reply #2 on: October 12, 2015, 12:21:00 pm »

Thanks for the speedy reply.

Unfortunately, very occasionally I get important calls from organisations which think it's clever to withhold their caller ID.
eg:
Peer Name   WITHHELD   
Peer Number   

Don't see that blocking calls with no peer number can work for me.
Logged
npr1
Newbie
*
Posts: 15


« Reply #3 on: October 20, 2015, 02:03:36 pm »

I've now found a method to screen anonymous calls with my Obi110 which I think will satisfy my requirements.
Hopefully the following method will stop nuisance ( automated ) calls yet give an option for real people to still get through.

1) I recorded the following message in Auto Attendants "User1 Prompt"
"Welcome to Obi call screening.
The number you are calling is not accepting anonymous calls.
Please speak your name, then dial 1 to be connected."

2) User2 Prompt was left blank.

3) I then configured Auto Attendant as show in the following screen capture.

Note:
I don't use the Obitalk service.

4) Configured the Line Port.
InboundCallRoute: {(?):AA},{(00xx.|01600469009):},{ph}

Anonymous calls don't ring the phone, they are sent to the Auto Attendant which plays the message in user1 prompt.
When the caller dials 1 the call is put through and the phone rings, if the caller dials any other number the "goodbye" message is played and the call is disconnected.
I've included "please speak your name" prompt purely for affect, the response is obviously not recorded.

Any comments / suggestions gratefully received.
« Last Edit: October 21, 2015, 02:42:56 am by npr1 » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #4 on: October 21, 2015, 12:54:25 am »

Looks like a very neat solution   Smiley
Logged
npr1
Newbie
*
Posts: 15


« Reply #5 on: October 21, 2015, 02:59:23 am »

Yes it does appear to be working ok.
Being a new inexperienced use of the obi110 I'm just a little concerned about any potential security implications. Hopefully the AA digitmap restricting the caller to only being able to dialled numbers 1 or 0 together with setting the "Primary Line" to the unused and disabled Obitalk service is sufficient security, or perhaps it's belt and braces. Wink
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC