December 14, 2017, 09:11:38 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2] 3
  Print  
Author Topic: Single-Stage Dialing Through Any OBi Trunk  (Read 195211 times)
RonR
Forum Member

Posts: 4528


« Reply #20 on: January 06, 2012, 01:05:08 pm »

Digit Map is (Msp1)

What is the SP1 DigitMap?
Logged
lhm.
Sr. Member
****
Posts: 331


« Reply #21 on: January 06, 2012, 01:11:18 pm »

ISTP Profile A is

(<**3>011xx.|<911:6158628600>|<411:8005000000>|1xxxxxxxxxx|<1615>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|<**20118835100>xxxxxxxx|[*#0-9][*#0-9]x.|[x*][x*].|(Mipd)|[^*]@@.)
Logged
RonR
Forum Member

Posts: 4528


« Reply #22 on: January 06, 2012, 01:18:08 pm »

**318005551212 matches the {(Mcot)>(Mtg1):tg1} rule in the OBiTALK InboundCallRoute due to the |[x*][x*].| rule in SP1.  Consequently, the call goes out TG1.
Logged
lhm.
Sr. Member
****
Posts: 331


« Reply #23 on: January 06, 2012, 01:22:06 pm »

Should I remove that part to make it work? If so, what do you recommend for my digit map? If anything.

Update: Removed |[x*][x*].| and still the same. Goes out to SP1
« Last Edit: January 06, 2012, 01:34:32 pm by lhm. » Logged
RonR
Forum Member

Posts: 4528


« Reply #24 on: January 06, 2012, 01:34:47 pm »

Should I remove that part to make it work? If so, what do you recommend for my digit map?

You have a lot of rules throughout your configuration that aren't readily apparent to me what their purpose is, so I'm not in a good position to advise.

I think you're in much deeper trouble than you might suspect as you've elected to change some of the normal service route access codes from **n to *n.  The single-stage dialing configuration I posted relies on OBi-to-OBi dialing losing one of *'s in process, such that dialing **2 arrives as *2 in the receiving OBi's OBiTALK InboundCallRoute.  This will be indistinguishable from your dialing *2+number from an OBiON App.
Logged
lhm.
Sr. Member
****
Posts: 331


« Reply #25 on: January 06, 2012, 01:48:47 pm »

So what do I dial from ObiOn App? **3 or *3 ?
Logged
RonR
Forum Member

Posts: 4528


« Reply #26 on: January 06, 2012, 01:51:47 pm »

An OBiON App doesn't alter what's dialed.
Logged
lhm.
Sr. Member
****
Posts: 331


« Reply #27 on: January 06, 2012, 02:32:05 pm »

My setup is now modified from the default settings per the instructions. Do you see any problems?

SP1 Digitmap:(<**2>011xx.|<911:6158628600>|<411:8005000000>|1xxxxxxxxxx|<1615>[2-9]xxxxxx|<1>[2-9]xxxxxxxxx|011xx.|xx.|<**20118835100>xxxxxxxx|[*#0-9][*#0-9]x.|(Mipd)|[^*]@@.)

ObiTalk
{(Mcot)>(Mtg1):tg1},{(Mcot)>(<*1:>(Msp1)):sp1},{(Mcot)>(<*2:>(Msp2)):sp2},{(Mcot)>(<*3:>(Mvg1)):vg1},{(Mcot)>(<*8:>(Mli)):li}, {(Mcot)>(<*9:>(Mpp)):pp},{(Mcot)>(<**1:>(Msp1)):sp1},{(Mcot)>(<**2:>(Msp2)):sp2},{(Mcot)>(<**3:>(Mvg1)):vg1},{(Mcot)>(<**8:>(Mli)):li},{(Mcot)>(<**9:>(Mpp)):pp},{(Mcot):aa},{ph}

AA DigitMap ([1-9]x?*@@.|[1-9]|[1-9][0-9]|<00:$1>|0|**1(Msp1)|**2(Msp2)|**9(Mpp)|(Mpli))          
AA OutboundCallRoute {([1-9]x?*@@.):pp},{0:ph},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp},{(Mpli):pli}    

Phone Port
DigitMap ([1-9]x?*@@.|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|**1(Msp1)|**2(Msp2)|**9(Mpp)|(Mpli))

OutboundCallRoute {([1-9]x?*@@.):pp},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**9:>(Mpp)):pp},{(Mpli):pli}


Update: Solved. It was this [*#0-9][*#0-9]x.| that was also causing the problem of going to SP1.

Thanks, RonR for leading me to the solution.
« Last Edit: January 07, 2012, 06:58:05 am by lhm. » Logged
anythingindian
Newbie
*
Posts: 13


« Reply #28 on: August 26, 2012, 10:28:58 pm »

I've been trying to mess around with this and get this to work, and have been very unsuccessful.  Is there anyone around that could help me to set this up.  Even from my main account obiapp it won't let me do single stage calls through my sp1, sp2, or sp4 trunks, only right through with my default sp3 trunk.  I'm willing to pay for time as I've just not been able to get this done and have wasted a lot of time trying to trouble shoot.  I really wish that Obi would do as mentioned before and they probably would see a lot of improvement in sales and usability.  I wouldn't recommend this product to anyone that would want something plug and play, and easy setup that is somewhat a novice.

Hi there,It is nice,it is beautiful BUT depends how many Obis You want to sell,if the Obi meant to be for dummy end users like me ,i mean 99.999% of the population,Youl'll better consider putting all that stuff in the box,and leave us a few places where to put just REAL Phone or obi numbers and VOALA no headache!!
G'd Day from Down Under!

Straight to the point. There is a strong message here.
Logged
jimates
OBi110 Beta Testers
***
Posts: 1613


« Reply #29 on: August 27, 2012, 11:34:33 am »

Since I don't have this configuration on any of my Obi's, I just set this up on one of my Obi110's to make sure everything works.

I had problems getting it to work and found out what my problem was.
I copied the Obitalk Service InboundCallRoute and made the needed changes. I then copied the new route to the Obi's field. After messing with it for a few minutes I found that the whole call route did not paste in the field.
For some reason only the first line would paste in the field.

although I could copy and paste the full route from the post to my computer, it would only paste the first line of the route every time. I tried to copy and paste from both my computer and from the forum, both gave the same results.

I had to copy and paste one line at a time to get it all in the field.

Now it is working like it is supposed to.
Logged
mish
Jr. Member
**
Posts: 33


« Reply #30 on: September 22, 2012, 07:46:33 am »

Hi, I just acquired an Obi110 to use its line feature.

Now I have an Obi202 and a Obi110 that I would like should work together.
Such that calls to Obi110 line port are forwarded to Obi202 ph1 and ph2, and sometimes also to Obi110's ph port.
Also, I want to be able to use Obi110's line using single stage dialing.

---
Confirming my understanding before I go and make all the changes:

Based on the first post (thank you!) in this thread, I understand that I have to change inbound call route on both devices, create user defined digitmap on both devices, and change DigitMap and OutBoundCallRoute on ph and AA for both devices.
I should make these changes and on both Obi110 and Obi202 and all the phone ports (three in all) and AA ports of both devices?

Now for Obi202, I already have some routing logic built into the Sp1 and Sp2 digitmaps such that some numbers are routed to different SIP providers. I can let them be, right?
Logged
jimates
OBi110 Beta Testers
***
Posts: 1613


« Reply #31 on: September 22, 2012, 09:15:52 pm »

Such that calls to Obi110 line port are forwarded to Obi202 ph1 and ph2, and sometimes also to Obi110's ph port.
Also, I want to be able to use Obi110's line using single stage dialing


Forwarding calls to the 202
add the number of the 202 to the LINE inbound call route of the 110
{ph,pp(ob500xxxxxx)} - this will ring the phone port of the 110 plus fork all calls to the 202. You will configure the inbound call route of Obitalk Service on the 202 to direct those calls to ph1 and/or ph2

and sometimes also to Obi110's ph port.
define sometimes

Once you set up single stage dialing you can use any service of the 110. If the line is not the default for outgoing calls on the 110 you will have to prepend the trunk designation when dialing from the 202.
example:
with the 110 in speed dial slot 3 of the 202, dial 3***8+number to use the line service on the 110.
Logged
mish
Jr. Member
**
Posts: 33


« Reply #32 on: September 25, 2012, 01:01:55 am »

@jimates - thank you for the reply. i have set up call forward on Obi110 line port. It works!
« Last Edit: September 25, 2012, 07:54:32 am by mish » Logged
mish
Jr. Member
**
Posts: 33


« Reply #33 on: September 25, 2012, 08:01:24 am »

I realized that being able to do one-stage dialing such that I can call using Obi110's PSTN line would be a good thing.

However, I am nervous about making so many changes with these complicated rules.

I already have things setup such that if there is an inbound call on the Obi110 PSTN line, then Obi202 conencted phones ring. For that I had to change Inbound routes for Obi110 Line and Obi202 Obiservice.

Now, all I want to do is being able to dial using Obi110's Line from any of the two phones connected to Obi202. While keeping the inbound logic of Obi110's PSTN line in place.

Any advice as to what portion of the initial post I need to adopt? I do have a third Obi100 device on my account, but I do not want to bring that into single stage dialing. Not needed.

Thank you!!
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #34 on: September 26, 2012, 03:09:12 am »

Mish,

Jimates has given you a way forward using RonR’s “single-stage” method. RonR’s post is brilliant and a classic, but may be a lot more than you need. If your OBi110 is using its default setting of PhonePort PrimaryLine = PSTN, then the following should do what you want:

In your Obi202 set a speed dial slot (I will use speed dial slot 2 in this example):
pp(ob200123456)
Where 200123456 is the number of your Obi110.

In your Obi110 use this setting:
Voice Services -> OBiTALK Service -> InboundCallRoute : {500123456>(Mpli):pli},{500123456:aa},{ph}
Where 500123456 is the number of your Obi202.

Dialling from the Obi202:
2*11223344556 will call 11223344556 using the Obi110 PSTN line.
200123456 will connect you to the auto attendant of the Obi110. If you want calls from your Obi202 to your Obi110 to go direct to its phone port, then omit {500123456:aa}.

The above is limited in as much as you can only call out on the PrimaryLine of the Obi110. In this case, if it is PSTN, then it meets your needs.
Logged
mish
Jr. Member
**
Posts: 33


« Reply #35 on: September 26, 2012, 03:46:58 am »

@ianobi - I did what you suggested.

PSTN line is the default line for the Phone port on Obi110.

Created a speed dial at #5 using the Obitalk website. If I press 5, then the phone connected to Obi110 rings.

Also created InboundCallRoute in Obi110:
     {(290123456|300123456|500123456)>(Mpli):pli},{ph}
Did this because I am calling from Obi100 for testing purposes. Obi202 is where I need the capability.

Then I dialled 5*9812312345. However, all that happens is that ph rings. But the call does not go through to the PSTN line.

Obi110 log shows this:
Peer Name           Obi100   
Peer Number   300123456

Obi100 where I called 5*9812312345 from shows this

Terminal ID   PHONE1   OBiTALK1
Peer Name      
Peer Number   5*19812312345 5*19812312345

Notice, the 1 that is prefixed to the number by Obi100. I am thinking that this must be done in SP1 of the Obi100 that I am using to call. I wonder if I can say that if a number begins with 5* then let anything that comes after that pass through without modification.

---

As to trying to resolve the basic functioning of this setup, wondering if
Some outbound call rule also needs to change? If so, in Obi110's Phone Port?


In the PHONE Port and Auto Attendant DigitMap's, change [1-9]x?*(Mpli) to [1-9]x?*@@.

In the PHONE Port and Auto Attendant OutboundCallRoute's, change {([1-9]x?*(Mpli)):pp} to {([1-9]x?*@@.):pp}
« Last Edit: September 26, 2012, 09:11:32 am by mish » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #36 on: September 26, 2012, 12:02:14 pm »

You could make the changes to the outbound rules, but in the OBi100 not the OBi110. It will stop the 1 being prepended to outgoing numbers. So long as the number arriving at the OBi110 is in a format accepted by Mpli then it should be sent to pli.

In case there is any doubt regarding the OBi110 Primary Line use this rule:

{(290123456|300123456|500123456)>(Mli):li},{ph}

I think you are very close! Let me know how you get on. I cannot log in here for next 24 hours, but I will be back!
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #37 on: September 26, 2012, 12:09:55 pm »

I just re-read RonR's original post:

Quote
Note: Replace pli above (2 places) with the OBi's PHONE Port -> PrimaryLine trunk name (sp1,sp2,li,pp,tg1) as the OBi won't do it for you.

Looks like using pli does not work in InboundCallRoutes. I did not know that  Embarrassed

The suggested change to

{(290123456|300123456|500123456)>(Mli):li},{ph}

Is probably all that is required to fix it.
Logged
mish
Jr. Member
**
Posts: 33


« Reply #38 on: September 26, 2012, 04:29:13 pm »

@ianobi - Success at last! The change you suggested worked. Further, I had to change the digit map of ITSP A because parsing of that digitmap was prefixing a 1 to the number. Now it works!

Thank you! Before I received your reply, I had already tried a lot of options. Had changed pli to li, but not Mpli to Mli!

One more question: If I do not want PSTN line to be the default line, and if I change the default line, this routing should still work right, because the inbound route in Obi110 now seems to explicitly point to li, and has nothing to do with pli. Right?

------
And one more question: Smiley

What do these lines achieve?
Quote
In the PHONE Port and Auto Attendant DigitMap's, change [1-9]x?*(Mpli) to [1-9]x?*@@.

In the PHONE Port and Auto Attendant OutboundCallRoute's, change {([1-9]x?*(Mpli)):pp} to {([1-9]x?*@@.):pp}
« Last Edit: September 26, 2012, 04:42:19 pm by mish » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #39 on: September 27, 2012, 06:38:39 am »

Mish,

I believe that you are correct about changing the Primary Line, the (Mli):li rule should still work. I cannot test that here, maybe you would  Smiley

Let’s look at the outgoing side of what you have done:
Speed dial 5 = the Obi110 number 290123456
You dialled from your Obi100: 5*9812312345

Phone Port DigitMap rule [1-9]x?*(Mpli) decides that is a valid number. It means any one or two digit number followed by a star, then a number that fits Mpli DigitMap.

Phone Port OutboundCallRoute rule {([1-9]x?*(Mpli)):pp} routes that number to the OBiTALK trunk.

The format going out to the OBiTALK trunk must be something like:
300123456 5*9812312345
I’m guessing that the Obi servers know that 5* coming from 300123456 means use the speed dial 5 number to route the call to 290123456 and strips out the 5*. So, 9812312345 is sent to 290123456 along with the “from” info 300123456

Using these default rules, only numbers matching Mpli in the sending Obi can be sent using this method.

RonR suggests changing the rules to:
Phone Port DigitMap rule [1-9]x?*@@. This means any one or two digit number followed by a star followed by anything.

Phone Port OutboundCallRoute rule {([1-9]x?*@@.):pp} routes that number to the OBiTALK trunk.

I like RONR’s better as it allows us to send any numbers we wish – or letters!

Now let’s look at the incoming side – the “target” OBi110 in this case.
OBiTALK InboundCallRoute:
{(290123456|300123456|500123456)>(Mli):li},{ph}
If the number coming in from any of the callers in the list matches Mli, then that number will be sent out to line.

(290123456 does not need to be in its own list)

I see no reason why this should not work, if all the DigitMaps are different from each other:
{(300123456|500123456)>(Mli):li},{(300123456|500123456)>(Msp1):sp1},{(300123456|500123456)>(Msp2):sp2},….more here…{ph}

In practice the caller numbers are best put in a User Defined Digit Map, which if called “cot” then the rules would be:
{(Mcot)>(Mli):li},…more here…

If anyone would like to take on the testing of some of this, or already knows it works, then please let us know .

I’m sorry this has been long and rambling, but my thinking and my typing are not always in synch. Did I answer the question??  Roll Eyes

« Last Edit: September 27, 2012, 07:43:11 am by ianobi » Logged
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC