December 12, 2017, 06:15:33 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Question: How to Disable ObiTalk Portal Updates?  (Read 3541 times)
chilirock
Jr. Member
**
Posts: 52


« on: December 30, 2016, 12:49:29 pm »

What do I need to do to disable updates from the ObiTalk portal? I thought that all that was required was to disable ITSP and ObiTalk Auto Provisioning locally, then reboot the device. I did that but when I go on the portal, I can still see the device showing status green "online".

I can even go into Obi Expert mode on the portal and see detailed settings. This is little strange since I've changed the WebAdmin password locally to be different than that listed on the portal.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2708


« Reply #1 on: December 30, 2016, 01:18:09 pm »

That is all you need to do.  The portal will retain what previous info it had and will always show the correct on-line or off-line status.
Logged
Mango
Sr. Member
****
Posts: 498


« Reply #2 on: December 31, 2016, 08:26:05 am »

To disable the OBiTALK portal entirely, and disable automatic firmware updates, you can do the following:

System Management >> Auto Provisioning:
Auto Firmware Update >> Method: Disabled
ITSP Provisioning >> Method: Disabled
OBiTalk Provisioning >> Method: Disabled

Voice Services >> OBiTALK Service:
Enable: (Unchecked)

Physical Interfaces >> PHONE Port:
DigitMap: (add !**5S0| as the first sequence of the DigitMap)
Logged

chilirock
Jr. Member
**
Posts: 52


« Reply #3 on: January 01, 2017, 08:55:22 pm »

Thanks Mango and drgeoff,

After reading Mango's post, I realized that I forgot to disable the ObiTalk Service. I had disabled ObiTalk Provisioning, but not the ObiTalk Service. I had previously disabled it, but when I turned on ObiTalk provisioning recently to check for the firmware update, the portal provisioning must have turned the ObiTalk Service back on. I didn't think to look for it, so thanks for the reminder. Once I disabled it by unchecking the box, I rebooted and the device then showed off-line.

I haven't  yet added the "!**5S0|" string to the DigitMap as it didn't seem like it was needed. What does that string do?

Logged
Mango
Sr. Member
****
Posts: 498


« Reply #4 on: January 01, 2017, 09:15:00 pm »

That prevents someone from adding the device to OBiTALK by dialing **5.  It's up to you whether that is necessary or not.
Logged

azrobert
Hero Member & Beta Tester
*****
Posts: 3191


« Reply #5 on: January 02, 2017, 11:57:56 am »

That prevents someone from adding the device to OBiTALK by dialing **5.  It's up to you whether that is necessary or not.
Mango,

Thank you!
I thought **5 was built into the firmware and wasn't processed by the DigitMap.
With a little playing I was able to use **5 to route a call. I found **5 followed by any number of digits will be passed to the OBiTalk server, but if **5 was altered it can be used to route calls. I dialed **5222222222, changed it to **E222222222 in the DigitMap and routed it to the OBiTalk network and was connected to the Echo test. I tested with an OBi110/2886, but did NOT test the following example.

Add to the Phone DigitMap:
**<5:E>(Mvgx)|

Add to the Phone OutboundCallRoute:
{(<**E:>(Mvgx)):vgx},
« Last Edit: December 04, 2017, 02:54:20 pm by azrobert » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC