On Tuesday September 6th the forum will be down for maintenance from 9:30 PM to 11:59 PM PDT

Main Menu

Question: Standard Answering Machine Not Allowing For Messages After Greeting

Started by chilirock, March 18, 2017, 10:06:14 AM

Previous topic - Next topic


Hi Chilirock,

So I did a factory reset and rebuilt everything.  No difference.  Same fax sound.  I have Google Voice.  It sounds fax machine on 4th ring.  Any answering machine or manual pickup before the 4th ring.  No problemo!

I can't figure it out!!!  Uggg


Quote from: chilirock on August 07, 2017, 07:20:34 PM
Update: I created a new support ticket with CallCentric when I found that the issue with the answering machine occurs with inbound calls to CallCentric, but not inbound calls to Google Voice. They had me send them the date/time stamps of a couple of calls where I had the issue.

CallCentric support was able to review the call logs from their end and determine that the reason that I am hearing the beeps is that about 30 seconds into the call (e.g. after the Obi answers the call and after the answering machine plays the outgoing message) the Obi device sent a Re-INVITE packet back to CC to re-invite the call as a T.38 fax call. This explains why I'm hearing an intermittent beep tone on the line because the Obi is trying to establish a fax connection with the inbound call.

So it looks like the theories presented here that the issue had nothing to do with the Obi device are not correct. The Obi is sending a re-INVITE packet back to CallCentric after the call has been answered. All calls I have tested are coming in from a standard mobile phone, not from a fax machine.

The CallCentric support team was not able to determine why the re-INVITE message is being sent, they could just confirm that it was sent from the device. They sent me a couple of suggested configuration settings to see if it would resolve the problem. After making the suggested settings (see below), I no longer have the issue, even with the latest v5695EX firmware. The answering machine is working fine again.

If anyone is interested in trying the settings to see if it resolves the issue with your answering machine, here they are. I only had to change a couple of these as a couple of them were already set the way they suggested. Based on the suggested settings, I'm guessing that the fax capability will no longer work. For me that's not an issue as I never use the line for faxes. But it may be an issue for others, so fair warning. 

---Codec Profile A & B---

FAX Event Section
- Enable: unchecked (mine was already unchecked)

Codec Settings Section
- T38Enable: Unchecked (mine was checked)
- T38Redundancy: 0 (mine was set to 2)

---ITSP Profile X (The Callcentric one eg. ITSP B)---

SIP Sub-section
- X_SessionRefresh: Unchecked (mine was already unchecked)
- X_FaxPassThroughSignal: None (mine was set to ReINVITE)

What I still need to determine is "why" the Obi is sending the packet trying to re-establish the call as a fax. I will try creating a support ticket with Obihai to see if they can determine what might have changed in the recent firmware versions that is causing the issue. I'll post here again if I find anything new.

I normally don't post on forums, but I had to get on and send a BIG thanks to chilirock.  I have the exact same setup as you, with Callcentric taking in Inbound calls for CNAME and a Dect.6.0 Panasonic phone with an answering machine.  The setup was for my elderly parents, who rely on the old school answering machine.  I spent several days trying different solutions, and I was about to throw in the towel and just get a new phone until I came across this thread.  LIFE SAVER



I just received my Obi200 and am having the same problem you mentioned.  I also have a Panasonic DECT 6.0 phone/answering machine.
My firmware is 5735EX.
I want to hook up my FAX machine so I do not want to change settings on the Obi.

Have you any luck besides making the changes that you posted?  It might be time for a new answering phone system.

PS: After the changes you posted, all is working great!

Thanks again !!!!!!!!!!!!!!


Hi Chilirock:

Thanks for helping me out. I had an Obihai 110 with Phone Power as servicer and the Panasonic Phone/Answering machine TX-TG6531 working for a couple years without an issue. I just upgraded to an Obi202 and immediately after the upgrade I had the same Beep problem with the Phone/Answering machine. I did a Google Search and found this post. I made the config changes you received from Callcentric and everything works - no Beeping. Thanks for being persistent and sharing your solution.


Chilirock, thank you for posting your experience. I had the same problem using an Obi202, with Phone Power and a  Panasonic answering machine, after upgrading to firmware version 5757. I unchecked the T38Enable setting in the Codec Settings Section, as you described, and my answering machine is working again.

Thank you so much.


Quote from: Mooselord on November 11, 2017, 07:08:13 AM
Chilirock, thank you for posting your experience. I had the same problem using an Obi202, with Phone Power and a  Panasonic answering machine, after upgrading to firmware version 5757. I unchecked the T38Enable setting in the Codec Settings Section, as you described, and my answering machine is working again.

I also want to thank Chilirock (and Callcentric) for persevering and finding out the solution to this problem. Exact same thing happened to me. Bought a Panasonic DECT 6 "amplified" phone with answering machine for my elderly father. When trying to leave a message the caller would just hear fax tones and nothing was recorded.

Unchecking T38Enable fixed the problem. I would have never figured this out on my own. Sure glad I read this thread.

This is definitely a bug in the firmware.



HUGE thank you to chilirock!!!

I have a Obi202 connected to a Panasonic Dect 6.0 phone answering system.  Unfortunately didn't find this thread until after I disposed of my previous Panasonic phone system (after much testing trying to solve the issue, including using my google voice number with no issues).  I replaced it with a new Panasonic answering system which has the exact same issue (Caller calls, answering machine picks up, the greeting plays, and then beeping like a fax machine ensues.  Caller is unable to leave a message.)  I have Phone Power as my VOIP, and my firmware version is 5757EX.

After making the suggested change:

---Codec Profile A & B---
Codec Settings Section
- T38Enable: Unchecked (mine was checked)

NO MORE BEEPING and callers are able to leave a message!  Again thank you chilirock, and shame on those of you who gave him/her a hard time, weren't even willing to listen and resorted to making fun of someone who wanted an answering system, regardless of their reasons. 


Fax initiation tones after beep after greeting message.  Old ATT answering machine and new VTech.
Worked for almost two years, then two weeks ago FAX beeps started
Obi200, build 5757EX accessed through its IP address on my LAN
  T38 Enable at bottom of codec profiles

  Codec Profile A, T38Enable, Uncheck default, uncheck enable
  Submit, OK
  Codec Profile B, T38Enable, Uncheck default, uncheck enable
  Submit, OK
  Reboot - no more beeps, answering system works
Re-enabled T38 in both codec profiles, FAX beeps back. Disabled again.

Fix per Chilirock - thank you!


chillirock, huge thanks for getting to the bottom of this, unchecking the T38Enable setting did the trick.


AWESOME rock!  I've been banging my head against the wall, even bought a new Panasonic phone (as their tech support was useless and rude).  A PhonePower rep actually suggested to me that it might be the fax signal triggering which caused me to google and find your post.  Most of my setting were already defaulted to the settings you describe, but the last one about the re-invite seems to be the ticket for me (with PhonePower and a Panasonic phone).  New phone being returned and you just saved me a 100 bucks!

Thanks for not listening to the others, your troubleshooting was sound and you stayed the course to find a solution.

Much appreciated!


Dear chilirock,

You are indeed the BEST!  My friend and I have searched all over the net looking for a solution - we have 3 different sets of phones experiencing this very frustrating issue!  We have even bought a new set of phones thinking the voicemail unit on the phone was wonky, but it didn't fix the problem. 

Very thankful you've detailed this and how to get the voicemail to work again.  Can the techs at Obihai PLEASE read this and fix this codec ???

Kudos to you chilirock.  Thank you so much!


I have been having the same problem and assumed it was my phone, as I haven't changed anything.  I bought a new Panasonic cordless phone and the problem still persists.  I just made the Codec changes and it seems to be working.



Good going chilirock! I thought this didn't solve my problem, but I forgot to change both the A and B caller profiles. Your repeated updates months later is a thing to admire, my friend. Thanks so much for not recreating this scenario for me!


Was having the same problem on my call centric line, disabled the T38Enable and it fixed it...

Thanks so much!!!  :)


Thank to chilirock   I was at wit's end trying to figure out why my panasonic phone answering machine record only beeping sound.   

unchecking both

  Codec Profile A, T38Enable,
  Codec Profile B, T38Enable
does the trick !


Thanks chilirock!!!!

My answering machine started recording beeps and it was driving me crazy. Definitely firmware issue!!!  >:(

Thanks again!

PS. We should make it sticky with reference to Panasonic systems!


Hi All,

I've been exchanging emails recently with Obi Support. I have made an update to my previous post modifying the recommended settings based on input from Obi Support. Let me know if you have any questions.


My OBihai died after 3 years.  :-\ My new ObiHai200 with Build 5794EX sent FAX tones and broker my Panasonic Dect 6.0 ability to record messages. ???
Altering T38Reinvite to: "Callee only" fixed it.  ;D Apparently ignores the Panasonic tone now.


Solve for me with 3.2.1 5794EX and Panasonic DECT 6.0 by changing to "Callee Only".

Good job tracking down the problem!