December 11, 2017, 04:45:42 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Help! Dropped calls and flaky call waiting on GV + Callcentric  (Read 4846 times)
Lighthouse
Newbie
*
Posts: 5


« on: March 20, 2017, 08:53:28 am »

Here is what happens:

1. Often, in the middle of a phone conversation, we stop hearing the other party, although they can hear us. Rarely, the call gets dropped in the middle of a conversation.

2. Call waiting is flaky.

When a second call comes in, we press flash. Sometimes this (pressing flash) works and the phone switches to the new call. Sometimes, we get a menu to press 1 to take the call etc. If we press 1, sometimes it works as it's supposed to, but other times it will just continue with the first call as if we did not press anything.

---
What are we using?
GV+Callcentric on the Obi100 and Panasonic cordless phones. Flash time on the Panasonics are set to 700 ms.

We are almost ready to give up and switch the phone service to something else.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3190


« Reply #1 on: March 20, 2017, 04:12:39 pm »

Do you have SIP ALG enabled on your router? This option can cause strange behavior in OBi devices.
Logged
Lighthouse
Newbie
*
Posts: 5


« Reply #2 on: March 21, 2017, 09:19:28 am »

It could be that I do have SIP ALG enabled, so now I swapped the router for a different one.

Hopefully, that will solve the problem. The issues were intermittent and it will take at least a few days until I will be able to confirm that the issues are fixed.

The old router was given to me by Comcast (my ISP). Googling indicated that the old router has SIP ALG enabled and it can only be disabled on a temporary basis until the next reset.

My new router is a TP-Link TL-WR841N (v7). There was no setting for SIP ALG in the included firmware. It allows me to use the DD-WRT third party firmware, which should have this option. I hope to install DD-WRT within the next day or so.

We will see.
« Last Edit: March 22, 2017, 09:13:22 am by Lighthouse » Logged
Lighthouse
Newbie
*
Posts: 5


« Reply #3 on: March 27, 2017, 08:23:29 pm »

Okay, I can confirm that switching routers did not fix the issue.

On incoming calls, I still sometimes don't hear the other side. Sometimes this happens when I first take the phone call, and sometimes this happens in the middle of a conversation.

I was not able to set SIP ALG on either router.

The router that was provided by Optimum has a proprietary firmware (software) installed and has almost no accessible settings. Optimum has no incentive to make my VOIP work; they sell their own VOIP (for an additional $35 a month) which connects directly to the cable modem.

After installing DD-WRT on my other router (the TP-Link), I have discovered that the version of DD-WRT that works with it does not play nicely with VoIP. It also had other issues with WiFi.

Any ideas? At this point, I would buy a new router if I knew it would fix the issue.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3934



« Reply #4 on: March 28, 2017, 12:27:20 pm »

You can narrow down your troubleshooting:

Google Voice doesn't use SIP, so ALG is irrelevant.  (At least temporarily) remove Callcentric from the path:  Log into your Google Voice account on a web browser.  On the new Google Voice user interface, click the three horizontal bar "hamburger" icon on the left side, then scroll down and click "Legacy Google Voice".  Click the gear icon in the upper right corner to get to Settings.  On the Phones tab, add a check mark to the left of Google Chat, and remove the check mark next to your Callcentric number.

On the OBiTALK web portal, reconfigure your OBi to use your Google Voice SPx as the primary line for outbound calls, AND tell it to ring your phone on inbound calls.

The only thing you will lose is caller ID name.  Try this configuration for a few days or a week, and see if call quality and reliability improve.  If they do, then it's an issue with your router and/or SIP-ALG.  If the same symptoms persist, then it's something else.
Logged

mo832
Full Member
***
Posts: 216


« Reply #5 on: May 03, 2017, 08:40:48 pm »

To follow on to this topic, it seems that this issue is either identical or very closely related to what is now happening to me. I started a new topic with my issue (title begins with "Puzzling").

But in response to SteveInWA, and to add some more input to this situation, it seems to only happen when you have GV -> CC DID -> Obi *or* softphone. The Obi is not the problem and CC is not the problem. And GV as such does not seem to be a problem, when combined with a standard telco number or the gchat/obi setup. But use your GV number with a CC DID/SIP line, and Boom! No audio in one direction. Using CC directly, and bypassing GV DID altogether, the Obi hardware works and the IP soft phone works when registered to CC. As long as you don't pass the call to CC from GV. What gives?
« Last Edit: May 03, 2017, 08:42:42 pm by mo832 » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC