August 22, 2017, 05:45:19 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: How to setup for VoIP -> PSTN calls?  (Read 884 times)
helloworld
Newbie
*
Posts: 2


« on: May 19, 2017, 11:28:24 am »

Hi all, I want to connect to my OBI202 using some VoIP method and make PSTN calls from it.

I have:

- OBi202
- Static IP on the Internet and ability to open incoming ports
- OBiLINE and PSTN connection
- OBiBT and Bluetooth-enabled cellphone
- Raspberry Pi that I can load with RasPBX or whatever it required

My OBi202 setup and myself are in different countries.

Example method: I was able to make a call using the green "Call OBi" button in OBITALK to make an outgoing call from OBiBT.

Challenge: This call though went from my browser to OBiHai's server on the Internet and then to my OBi202. This could introduce latency. How do I make this work by making a VoIP call from my location directly to the OBi202 location? Do I need to setup something like this:

SIP phone at my location -> RasPBX on the RPi -> OBi202?

Or does the OBi202 has other methods I can "speak" to it directly?

Thanks!
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2378


« Reply #1 on: May 19, 2017, 11:45:52 am »

You can make a SIP call directly from the softphone or through Raspbx into the IP address of the Obi202. If the 202 is behind a NAT router you need to forward the SIP signalling port, usually 5060.

After you get it working you probably want to add some security restriction to the OBi to prevent anyone else anywhere in the world from doing the same.  Smiley
Logged
helloworld
Newbie
*
Posts: 2


« Reply #2 on: May 26, 2017, 11:35:03 am »

I got incoming calls into OBi via SIP working, without really knowing what I am doing. See the two attached screenshots.

To make sure no-one else can make calls from my OBi I pointed SP2 to the Auto Attendant and set up a PIN. Any  other methods? Only allowing incoming connections from specific IPs will not do because the IP I am calling from is not static.


* Screen Shot 2017-05-26 at 9.24.28 PM.png (44.79 KB, 662x223 - viewed 45 times.)

* Screen Shot 2017-05-26 at 9.27.38 PM.png (22.31 KB, 386x122 - viewed 43 times.)
« Last Edit: May 26, 2017, 11:36:36 am by helloworld » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3031


« Reply #3 on: May 26, 2017, 01:17:33 pm »

You can check for the UserID of the calling device.

X_InboundCallRoute:
{helloworld:aa}

You can send the call directly to a trunk:
{helloworld:sp1}

You can check the format of the dialed number:
{helloworld>(1xxxxxxxxxx):sp1}
or
{helloworld>(Msp1):sp1}
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2378


« Reply #4 on: May 26, 2017, 03:01:18 pm »

It isn't clear to me what you are doing.

You have disabled the SIP registration for SP2.  That is a how a Service Provider knows the IP address to which it should calls to you.  So it looks like you are not using an ITSP but calling directly in to your OBi.  In that case I'm not sure that the SP2 settings - including aa in the InboundCallRoute - come into play at all.  However if incoming calls hear the AA announcements and need to enter a PIN then obviously the AA and PIN are being invoked somewhere, somehow.  Wink

You can further improve security by not using port 5060.  Pick another number not near 5060.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC