December 15, 2017, 07:56:24 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Obi200 Still Not Working With Google Voice  (Read 3709 times)
echz
Newbie
*
Posts: 6


« on: August 15, 2017, 06:29:10 pm »

I've read all the problems since 8/11/2017 with Google Voice stopping working with the Obi200 and then it began working again ... Except I must be in the minority for this situation because my Obi and GV still aren't working.  

I have gone through all the steps, from factory resetting to following the same tutorial 19 times to logging out to changing my Google password (more of an undertaking than it was worth) and am still left with no GV service on my Obi.  I'm not sure where to look or where to start but I'd like to think I can handle this simply without having to think too hard.  

I keep getting "Backing Off: TCP connection to x.x.x.x failed" errors no matter what I do...

Anyone know where I should begin looking?  This all started a few days ago, around about the same time everyone else's problems started.  Thanks!
« Last Edit: August 15, 2017, 06:30:46 pm by echz » Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #1 on: August 15, 2017, 07:35:08 pm »

What "tutorial" did you follow 18 times?   Huh

Log into your Google / Gmail account, and go to the Google Voice settings page.  Do you see your inbound Google Voice number?  If not, you're using the wrong Gmail ID.  If you do see it, then go to this page:

https://myaccount.google.com/security#connectedapps

Under "Apps connected to your account", click "MANAGE APPS".  Look for the tiny OBiTALK logo next to "Google Voice", and click on it.  Then, click the "Remove" button.

Now, while still logged into the correct Google / Gmail account that holds your Google Voice number, open a new web browser tab (press Ctrl-T), and go here:  https://www.obitalk.com/obinet/pg/obhdev

Open a third browser tab, read and follow my instructions, here:  http://www.obitalk.com/forum/index.php?topic=8560.msg56460#msg56460
Logged

echz
Newbie
*
Posts: 6


« Reply #2 on: August 15, 2017, 07:55:59 pm »

I followed every single tutorial I could find with the Google machine and on these forums before I resorted to posting  Lips sealed

I definitely see my inbound GV number in the settings page, I even went as far as to go to another machine that had no association with any of my Google accounts to try.

I have an Obi app I had associated with my Google account was something along the lines of "Obi Easy Setup" or something like that and also had one that had "Google Voice" but with the Obi ico. I removed bot hand started fresh, and still got no love.

And now coming up to the last step on following up with your post, one of the most concise and thorough tutorials I followed was the one you just linked me to which was yours!!  Grin

However, after all this, I'm still coming up with "Backing Off :TCP connection to 125.204.194.173 failed" -- Those IPs change, but always fail.

Not sure if 2FA has anything to do with this, but I've tried generating an App Specific password and still got nowhere.  This all just happened out of nowhere too because it was working completely fine and then all of a sudden just seemed to take a dump right around where everyone else's did.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #3 on: August 15, 2017, 08:02:50 pm »

The IP address you posted is in Japan.  It's not Google.  Where are you located?  Are you using a VPN?
Logged

echz
Newbie
*
Posts: 6


« Reply #4 on: August 15, 2017, 08:07:23 pm »

LOL Japan?  I'm in the US, and no I'm not using a VPN.  I don't know why that would be, as all my other traffic is going through (and all my bank accounts are still full to the best of my knowledge haha).  Not sure why the Obi device would be trying to go out to Japanese servers for my connection but who knows.  I can try and capture a few of the other IPs it tries if you'd like?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #5 on: August 15, 2017, 08:09:45 pm »

Go back to the OBiTALK dashboard.  Click on your OBi 200.  Click the various buttons and warnings to get into Expert Configuration mode.  On the left side of the page, click "System Management", then "WAN Settings".

On the right side of the page, look for the two DNSServer entries.  Remove both checkmarks from the boxes to the left of those two settings.  Then, change them to 8.8.8.8 and 8.8.4.4, as shown in the screenshot below.  Click the "Submit" button at the bottom of the page.  Wait a couple of minutes for your OBi to reboot.

Now, try setup again.


* screenshot-www.obitalk.com-2017-08-15-20-06-49.png (153.89 KB, 832x494 - viewed 81 times.)
Logged

echz
Newbie
*
Posts: 6


« Reply #6 on: August 15, 2017, 08:22:36 pm »

Unfortunately, I'm still having the same problem with the "Backing Off" error. I had actually tried manually changing DNS myself because I thought it might have been just something totally off the wall that caused that to happen, but that didn't seem to change anything either.

The current failure I'm getting while connecting is "Backing Off :TCP connection to 125.207.194.173 failed" and the next address was 125.66.194.173 , if I keep refreshing I can probably get different addresses.  I have literally tried EVERYTHING I can think of and have no clue why this continues to happen.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #7 on: August 15, 2017, 08:48:02 pm »

Pick up the phone attached to your OBi, and key in ***1.  Does it read back a valid local IP address, starting with 192.168 or 10.0 ?  If not, you have a LAN problem.

Hang up.  Pick up the phone again and key in ***0 then 1#.  What is the firmware version it reads back to you?

If it did get assigned a valid IP address, pick up the phone and key in **9 222 222 222.  Do you reach the OBiTALK echo test?

Now that you have made the DNS server change, go back to the OBiTALK web portal, in Expert mode, and click on Status.  Does it show the two DNS servers I listed earlier?
Logged

echz
Newbie
*
Posts: 6


« Reply #8 on: August 15, 2017, 08:52:34 pm »

Yes, it repeats back an IP that is in my network and that I can access via the local web interface.

Current value is 3.1.1.5695.

Got the echo test just fine, everything Obi wise seems to be working fine except for anything GV related.

Yes, the Obi shows 8.8.8.8 and 8.8.4.4 as the DNS servers.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #9 on: August 15, 2017, 09:12:59 pm »

It should simply work.  I just now tested, adding another one of my Google Voice numbers to one of my OBis, and it works just as expected.

Power off your OBi, your router, and your cable or DSL modem.  Power on the modem, wait for it to boot up, then power on the router, wait for it to boot up.  On your computer's web browser, on the OBiTALK web portal, delete the OBi 200 completely off of your account.  Wait a few minutes.  Unplug all three cables from the OBi (power, phone and Ethernet).  Get and un-bend a paper clip.  Turn the OBi upside down.  Gently insert the paper clip into the reset button's hole. It is a slightly raised, round bump with a hole in it.  Feel for it to click the switch.  Continue to hold it down, while inserting only the power plug into the OBi.  This takes some manual dexterity; you may need a third hand to help you.  Continue holding down the switch for at least 10 seconds.  Release the switch.  Wait several minutes while it factory-resets.

Log into your Google Voice account on the web.  If you do not already have a forwarding/linked phone number added, add and verify one now.  It can be any 48-state US phone number.  After you do that, call your GV number from some OTHER phone number (NOT the linked number).  It should ring through to your forwarding phone, and you should be able to answer the call.  If that is successful, then...

Now, go back to the OBiTALK web portal, and follow the **5 procedure to re-add the OBi to your dashboard.  Set up Google Voice on SP1 again.  What happens?

If it doesn't work, then you have some sort of problem with your internet service.
Logged

echz
Newbie
*
Posts: 6


« Reply #10 on: August 16, 2017, 05:14:33 am »

I have tried everything at this point... I've changed the firmware on the router, I've put the obi in a dmz, etc. I've followed your instructions to the letter and still can't get it to connect to GV. I'm going to even go so far as to bring it to someone's house later tonight and try using an entirely different connection... Beyond that I'm at a total loss. Is there some kind of logging mechanism I can enable to try and better grasp what kind of errors are actually happening other than just what the dashboard says?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #11 on: August 16, 2017, 03:47:28 pm »

Taking the OBi to another location was going to be my next suggestion, so go for it.  If it works there, then you've definitely got a network issue at your location.
Logged

SteveInWA
Hero Member & Beta Tester
*****
Posts: 3970



« Reply #12 on: August 19, 2017, 07:31:44 pm »

Well?

Did taking the device to another internet connection make a difference?
Logged

clocks
Newbie
*
Posts: 1


« Reply #13 on: August 20, 2017, 09:02:04 pm »

The past few days I've been having issues with my Obi also.  It's got an IP address, and it under the google connected apps.  I've rebooted it, reconnected the cables several times.  Not sure what else I can try.  Thankfully I also have a Ooma, so that's been a solid backup.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC