September 23, 2018, 07:13:48 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2]
  Print  
Author Topic: Possible to use Obi as analog to VOIP bridge without other hardware?  (Read 8843 times)
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #20 on: March 05, 2018, 03:06:41 pm »

Try this on both ends:
Voice Services -> ITSP Profile X General -> X_SymmetricRTPEnable: Checked

If that doesn't work try this on both ends:
Voice Services -> ITSP Profile X SIP
X_DiscoverPublicAddress: Unchecked
X_PublicIPAddress: xx.xx.xx.xx

Where xx.xx.xx.xx is the local public IP address

I'm assuming you are using an unregistered dummy trunk on both sides.
Logged
GnatGoSplat
Jr. Member
**
Posts: 23


« Reply #21 on: March 06, 2018, 09:56:11 pm »

Thanks azrobert, with your help, I am making progress.
X_SymmetricRTPEnable by itself didn't do the trick, but unchecking X_DiscoverPublicAddress and adding in X_PublicIPAddress made outgoing calls work 100%.  I'm not sure if I was supposed to leave X_SymmetricRTPEnable checked or not, I'll play around and see.

Incoming calls, however, are still not working.  No ring at all.  I'm guessing this is a SIP port issue, maybe the NAT firewall on the phone end isn't port forwarding.  The phone has a Symmetric RTP option, but doesn't seem to have any way to manually enter a public IP address, or at least, nothing with the label "public IP".

By dummy trunk, do you mean the additional ITSP profile that just bridges the GV profile to the phone?  I don't have anything like that on the phone end.  It was working fine both ways when they were on the same network though.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #22 on: March 06, 2018, 10:51:45 pm »

You have the phone and OBi110 at work and OBi200 at home. Outbound calls work going from what device to what device? Same question for inbound. Have you tried OBi to OBi calls?

You should port forward 17100-17198 only at home and OBi110's RTP ports and 5004 forwarded at work. Are you port forwarding the phone's listening port at work? The phone and OBi110 might have a conflict with port 5060. If they do, change one of them. You need to have the listening ports forwarded correctly to have the device ring and the RTP ports to have audio.

Tomorrow I'll post what I meant by dummy trunk and why I made those recommendations.
Logged
GnatGoSplat
Jr. Member
**
Posts: 23


« Reply #23 on: March 07, 2018, 06:20:29 am »

Correct, I have phone and Obi110 at work on the same subnet, Obi200 at home.  The Obi110 is working as a landline-to-SIP bridge on phone's line 1.  Obi200 is to be a GV-to-SIP bridge on phone's line 2.  Both Inbound/Outbound calls are working on the Obi110 as line 1.  Outbound calls are working on the Obi200, thanks to your most recent suggestions.  Inbound calls don't ring.

I tried enabling port forwarding on port 80 at work to my IP phone, but I still can't access its web admin remotely using my public IP, so I'm starting to suspect a work firewall outside of my control is blocking ports.

UPDATE: Incoming ports appear to be blocked by my work network's firewall.  Port forwarding works if I access the IP and port using its own public IP or 127.0.0.1.  However, accessing the public IP from the internet or even intranet results in no response.
« Last Edit: March 07, 2018, 11:00:41 am by GnatGoSplat » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #24 on: March 07, 2018, 01:10:36 pm »

You must have a trunk defined on OBi200 SP3 for the bridge to the phone's line 2.

Does the trunk look something like this?
Service Providers -> ITSP Profile C -> SIP -> ProxyServer: 127.0.0.1
Voice Services -> SP3 Service -> AuthUserName: user
Voice Services -> SP3 Service -> X_RegisterEnable: unchecked
Voice Services -> SP3 Service -> X_ServProvProfile: C

The above is what I call a dummy trunk.

Are you routing inbound GV to the phone line 2 via SP3?
Does your GV InboundCallRoute look something like this:
ph,sp3(user@xx.xx.xx.xx:yyyy)

xx.xx.xx.xx is the public IP at work
yyyy is the listening port of the phone's line 2

Are you port forwarding yyyy at work?

If this is your setup and your theory that work is blocking ports, I might have a way to open the port.
Logged
GnatGoSplat
Jr. Member
**
Posts: 23


« Reply #25 on: March 07, 2018, 02:20:07 pm »

Thanks, I do have the dummy trunk.  I'm using SP4 and profile D for the dummy.
I had InboundCallRoute set to ph,sp4(line2), but didn't have the public IP and port there, though it did work like that when they were both on the same network.  I've added public IP and port, but still not working.
I'm port forwarding UDP 5004 and 5060-5063 to the phone (line 2 uses 5062).

I can't ping my public IP from outside.  I'm in a Windows Active Directory domain if that helps.  We're using our own DNS, DHCP, and gateway, none of which I have any access to.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #26 on: March 08, 2018, 05:15:13 pm »

The following suggestion is a wild guess to fix your problem. I'm thinking registering the phone to your OBi200 will open the ports. However, when SP4 is defined as a proxy you won't be able to route calls the way you're doing it. You can't define SP4 as both a trunk and a proxy. You will have to route calls to the work public IP. The phone's userid and password must match SP4's AuthUserName and AuthPassword
 
OBi200
Service Providers -> ITSP Profile D -> SIP -> ProxyServer: 127.0.0.1
Service Providers -> ITSP Profile D -> SIP -> X_Proxy:  Checked
Service Providers -> ITSP Profile D -> SIP -> X_SpoofCallerID: Checked
Voice Services -> SP4 Service -> AuthUserName : user
Voice Services -> SP4 Service -> AuthPassword: password
Voice Services -> SP4 Service -> X_ServProvProfile: D
Voice Services -> SP4 Service -> X_InboundCallRoute: same as current

Voice Services -> SP1 Service -> X_InboundCallRoute:
ph,sp4(user@local_client)
If above doesn't work use:
ph,sp4(user@xx.xx.xx.xx:5062)

Phone
User = user
Server = xx.xx.xx.xx:5063       
Password = password

You can check the status of SP4 to see if the phone is registered. It will look like this:
Registration Not Required;local_client=xx.xx.xx.xx:5062
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC