December 17, 2017, 11:40:29 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Disable Auto Attendant on Select Devices within Account Settings  (Read 24850 times)
bsdaiwa
Full Member
***
Posts: 187


« on: October 06, 2012, 10:51:52 am »

If you have multiple devices (OBiís) on your account and you setup a trusted callers you should be able to indicate which devices you want to implement the use of the OBi attendant and which you do not.

I have over 10 OBi devices on my account and I want to use the Trusted Callers/Auto Attendant on only a few of them but with the way it works now, all of them respond with the attendant if called by one of the Trusted numbers. I have tried to disable the attendants response on those OBiís that I do not want to respond to the Trusted Number but to no avail.

I am cross posting this on the request forum and this forum in the event someone knows how to do what I want to do.
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #1 on: October 06, 2012, 03:18:06 pm »

bsdaiwa,

You need to manually remove the OBi numbers on each unit that you don't want to be answered by the AA:
OBiTALK Service Settings->InboundCallRoute
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
bsdaiwa
Full Member
***
Posts: 187


« Reply #2 on: October 06, 2012, 04:16:42 pm »

bsdaiwa,

You need to manually remove the OBi numbers on each unit that you don't want to be answered by the AA:
OBiTALK Service Settings->InboundCallRoute

I see where all the OBiTalk numbers are currently listed in InboundCallRoute but if I list, say my cellular phone, in the Trusted will it list in the InboundCallRoute on all my devices. I also note that the OBiTalk numbers are shown twice so I assume I remove both numbers of the OBi I don't want to be answered by the AA.
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #3 on: October 06, 2012, 04:34:28 pm »

Make a backup of your current config before making any changes.

The part on the "OBiTALK Service Settings->InboundCallRoute", ending with ":aa" is what you need to change.

eg: {(290111222|200333444|300555666):aa}, <-- change or remove the unwelcome OBi numbers

Anything else is not relevant in order to achieve your desired result. (Assuming that I understood you correctly)
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
jimates
OBi110 Beta Testers
***
Posts: 1613


« Reply #4 on: October 06, 2012, 05:28:23 pm »

I would assume that when you add a endpoint or a number to your trusted callers or circle of trust that Obitalk automatically adds that new number to every device in your account. Perhaps it would be easier to manually add the numbers to the Obi's you wan them to use rather than using the Trusted Callers or Circle of Trust.

By creating a user defined digit map in each Obi and referencing it for the trusted callers you can just add to that list manually for each Obi.
Logged
bsdaiwa
Full Member
***
Posts: 187


« Reply #5 on: October 06, 2012, 07:10:13 pm »

I am not sure that any number that is entered into the trusted caller list is placed in the "OBiTALK Service Settings->InboundCallRoute" string. I had deleted all my trusted callers yesterday and today, after reading these suggestions I added one number to see if it showed in the InboundCallRoute and it did not. If the number does not appear then how can I stop the aa from responding when the OBi is called from that number. The number is my Cellular number not another OBi device.
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #6 on: October 06, 2012, 07:22:17 pm »

The number is my Cellular number not another OBi device.

Well in that case remove the cell number that appears in front of ":aa" that is not supposed to be picked up by the AA, in what ever inbound call route that the cell is coming in through. Look at the Call History if you need to confirm the inbound call route.
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
jimates
OBi110 Beta Testers
***
Posts: 1613


« Reply #7 on: October 06, 2012, 08:18:50 pm »

In short; remember that changes made on your dashboard are configured for you by Obitalk. That can only occur if you let Obitalk manage the field that would normally be affected. This is one reason a device has to be reset to factory default before it can be added to an account.

If you add a number to the trusted callers list, Obitalk adds that number to the inbound call routes for SP1, SP2 & Line (& SP3 , SP4 for Obi202) for every device in the account. This only occurs if Obitalk is managing that particular field. If you have manually made changes and unchecked the Obitalk Settings next to the field, Obitalk will not make any changes to that field. There is a red exclamation mark next to the fields that are being managed manually. Any trusted callers you want to use that device's SPx will have to be added manually for any field that Obitalk is not managing, even if the number has been added to the trusted callers list.

If you have the same few particular devices you want your trusted callers list to use, you can let Obitalk manage those fields. For the devices you do not want them to use you can just go in and uncheck the Obitalk Settings box for that field. You do not have to make any changes to the field for this setting to take place. You must submit the change before leaving the page. This makes it easy unless your device list changes for each particular trusted caller.

See RonR's post about trusted callers.
http://www.obitalk.com/forum/index.php?topic=3094.0

You can test this by going to a device that is managed manually and checking the Obitalk Settings box for a SP inbound call route. The call route will automatically be populated with the trusted callers in your list.
« Last Edit: October 06, 2012, 08:28:09 pm by jimates » Logged
bsdaiwa
Full Member
***
Posts: 187


« Reply #8 on: October 08, 2012, 07:05:26 am »

Thanks to all for the guidance on this issue. Based on the information supplied I went into Voice Service then selected SP1 service then X_InboundCallRoute and changed the box checked from OBiTalk Settings to Device Default. That removed the listing of Trusted Callers and replaced it with ph, then saved the process. This needs to be done on both SP1 and SP2, once that is done the AA will not respond on that specific device when a Trusted Caller calls.

Thanks again for the help.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC