December 14, 2017, 08:48:28 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2 3
  Print  
Author Topic: OBI110 and Simonics GV trouble - Unauthorized  (Read 2244 times)
TimAtHome
Newbie
*
Posts: 18


« on: November 10, 2017, 07:16:17 pm »

I just signed up for the Google Voice Gateway on simonics.com and am having trouble getting it to work on my Obi110.

I did all the steps on the pinned post on this forum, and Obitalk is reporting "Register Failed: 401 Unauthorized"

I see under account status on simonics.com that my GV account isn't connecting:

Google Voice account   Offline. Register a device or SIP URI.

Devices registered   0


What should I do? I appreciate any help.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #1 on: November 10, 2017, 07:46:57 pm »

If you were able to use your Google Voice/Gmail user ID and password to authenticate on the Simonics GVGW website, and you got to the end of that website's setup, then it should work per my sticky post.  This would be indicated by the green check mark next to the words "Google Voice account authorized."  The web page must also show "Online" status.  Did you click the button to change from offline to online?

Look again at the password on that page.  It's possible you clicked the "Regenerate" button to change the password, and then refreshed the page, which may unintentionally change the password again.  Type the exact, case-sensitive password into the form on OBiTALK.
 
Logged

TimAtHome
Newbie
*
Posts: 18


« Reply #2 on: November 11, 2017, 06:16:58 am »

Steve, thanks for the quick reply. I appreciate it.

I double checked the password, refreshed, and then copied it exactly -- same error.

I do have the green checkmark on the Simonics page that indicates "Google Voice account authorized." However, Under account status it still says that my Google Voice account is "offline." Where is the button to change its status? I can't find it on that page and I can't find it on the OBiTALK form.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2717


« Reply #3 on: November 11, 2017, 06:24:27 am »

Steve, thanks for the quick reply. I appreciate it.

I double checked the password, refreshed, and then copied it exactly -- same error.

I do have the green checkmark on the Simonics page that indicates "Google Voice account authorized." However, Under account status it still says that my Google Voice account is "offline." Where is the button to change its status? I can't find it on that page and I can't find it on the OBiTALK form.



* online.png (108.83 KB, 822x640 - viewed 169 times.)
Logged
TimAtHome
Newbie
*
Posts: 18


« Reply #4 on: November 11, 2017, 07:44:05 am »

I don't have that button:



So it seems like I need to register my device -- how and where do I do that?

Many thanks!
Logged
billsimon
Jr. Member
**
Posts: 43


« Reply #5 on: November 11, 2017, 08:08:02 am »

So it seems like I need to register my device -- how and where do I do that?

Hi Tim, it means configuring your SIP device (Obi) to register, which is part of SteveInWA's guide. Please double check your settings and note that the passwords we issue are 12 characters long so if you count 13 characters you may have grabbed a space or tab in copy/paste.

Once your device registers with GVGW you will see a status showing Devices Registered: 1 and an Online button, which you can also use to temporarily disconnect the GVGW from your Google Voice account (it just logs you out).
Logged
TimAtHome
Newbie
*
Posts: 18


« Reply #6 on: November 11, 2017, 10:05:01 am »

Checked the password again, still no go. Steve's guide is so simple, and it should be so easy, so I'm having a hard time seeing where I could be doing something wrong. So I wonder if maybe the problem has to do with the initial information that I entered -- my Simonics SIP login is my GV number. It's on SP1 and I don't have an x1 after it. Is that correct, or should that be my OBI number or something else? I have the latest 2886 firmware.
Logged
billsimon
Jr. Member
**
Posts: 43


« Reply #7 on: November 11, 2017, 10:23:58 am »

The user ID is GV1.......... filling in the dots with the rest of your GV number.
Logged
TimAtHome
Newbie
*
Posts: 18


« Reply #8 on: November 11, 2017, 10:32:49 am »

Yes, that's what I have. Still have "Register Failed: 401 Unauthorized" status on my OBI, and on the Simonics page it says "Offline. Register a device or SIP URI."
Logged
AntonS
Jr. Member
**
Posts: 37


« Reply #9 on: November 11, 2017, 12:16:17 pm »

I have the exact same problem with OBI100
Logged
TimAtHome
Newbie
*
Posts: 18


« Reply #10 on: November 11, 2017, 01:16:27 pm »

I hope an expert here can help figure this out. It's so strange, I've gone through the exact steps of the pinned post over and over again, to no avail. Rebooted the OBI, also manually removed power and rebooted, and rebooted my modem. Still the same error.
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2717


« Reply #11 on: November 11, 2017, 01:45:36 pm »

I know it is very unlikely that you made this error but just in case.

The proxy is g v g w . s i m o n i c s . c o m

I've put spaces between every character to highlight that the 4th character is a single 'w'.  it is not a pair of 'v' s.  Some fonts show little difference between w and vv.

Also if not doing a copy and paste of the password, are you falling foul of the classic 0/O and 1/l confusion?
« Last Edit: November 11, 2017, 01:53:53 pm by drgeoff » Logged
Taoman
Hero Member
*****
Posts: 943


« Reply #12 on: November 11, 2017, 01:52:38 pm »

And you guys are definitely entering the SIP login and SIP password located on the Simonics page under "YOUR SIP SETTINGS?" You're not using your Google Voice password by any chance?

"401 Unauthorized" suggests you're using the wrong SIP credentials.



* Simonics.JPG (31.18 KB, 637x237 - viewed 66 times.)
Logged
billsimon
Jr. Member
**
Posts: 43


« Reply #13 on: November 11, 2017, 02:18:45 pm »

I do not want to overcomplicate the situation, but there is another possibility that comes to mind. If you have never used the Obi with a SIP service before (only direct Google Voice), it is possible that something on your network or your ISP is interfering. Often this is called "SIP ALG" or "SIP Helper" and is no help in this case. You can try connecting to GVGW over TLS or alternate port 5070 UDP or TCP.

That said, it's still more likely the problem is somewhere in your Obi config. Be sure you don't have any other proxies defined except "gvgw.simonics.com"
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #14 on: November 11, 2017, 02:59:25 pm »

As you can see from all the replies, including from Bill Simon himself, this isn't complicated; it's just a few basic values to enter on a form.  If you have entered those values correctly, then it should simply work.

This week, I fixed another user's issue that was similar to this one, but with a different SIP service provider.  It turned out that there was some sort of left-over configuration junk in his OBi that was interfering with trying to configure the new SIP SP information.

I suggest doing this:

Log onto the OBiTALK web portal.  Delete the OBi completely off of the portal.  Wait a few minutes while the portal remotely reboots the device.  Unplug the power and Ethernet cables.  Plug in just the power cable and let it boot up.  Then, key in ***8 then 1 to reset it to factory defaults.  After it gyrates and reboots a couple of times and the LEDs become stable, plug in the Ethernet cable, and use the **5 procedure to add it back to the portal, skip the invitation to set up Google Voice, and scroll down to the bottom of the page.  Click the "OBiTALK Compatible Service Providers" link.  On the next page, enter your SIP information, and see if it works.
Logged

AntonS
Jr. Member
**
Posts: 37


« Reply #15 on: November 11, 2017, 06:55:15 pm »

I do not want to overcomplicate the situation, but there is another possibility that comes to mind. If you have never used the Obi with a SIP service before (only direct Google Voice), it is possible that something on your network or your ISP is interfering. Often this is called "SIP ALG" or "SIP Helper" and is no help in this case. You can try connecting to GVGW over TLS or alternate port 5070 UDP or TCP.

That said, it's still more likely the problem is somewhere in your Obi config. Be sure you don't have any other proxies defined except "gvgw.simonics.com"
I have on SP2 Callcentric configured (for incoming calls only), but it uses a proxyserver on port 5060 too. The two configuration pages are almost identical and the one from Calcentric works.Does this prevent GVGW from working?
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #16 on: November 11, 2017, 07:30:36 pm »

I do not want to overcomplicate the situation, but there is another possibility that comes to mind. If you have never used the Obi with a SIP service before (only direct Google Voice), it is possible that something on your network or your ISP is interfering. Often this is called "SIP ALG" or "SIP Helper" and is no help in this case. You can try connecting to GVGW over TLS or alternate port 5070 UDP or TCP.

That said, it's still more likely the problem is somewhere in your Obi config. Be sure you don't have any other proxies defined except "gvgw.simonics.com"
I have on SP2 Callcentric configured (for incoming calls only), but it uses a proxyserver on port 5060 too. The two configuration pages are almost identical and the one from Calcentric works.Does this prevent GVGW from working?

Follow my instructions above to factory reset your OBi and start over.  Use the OBiTALK portal's "OBiTALK Compatible Service Providers" tool to configure a generic service provider for SP1 for the GVGW, and then use the same portal configuration tool to set up Callcentric on SP2, using the Callcentric template.  It should make the settings you need.
Logged

AntonS
Jr. Member
**
Posts: 37


« Reply #17 on: November 13, 2017, 07:27:47 am »

Unfortunately, I am doing this remotely, so removing the unit from ethernet and obitalk portal doesn't seem an option. Any other options, as it might be several weeks before I get to the unit.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 3967



« Reply #18 on: November 13, 2017, 01:49:07 pm »

Unfortunately, I am doing this remotely, so removing the unit from ethernet and obitalk portal doesn't seem an option. Any other options, as it might be several weeks before I get to the unit.


Ten minutes or less, with a helper in front of the remote OBi, will solve this.
Logged

TimAtHome
Newbie
*
Posts: 18


« Reply #19 on: November 13, 2017, 02:14:49 pm »

Steve,

Success! Following your instructions for a complete factory reset has gotten my Obi to work with Simonics. Thanks so much -- I had just about given up on it. But I'm online and working.

I noticed that caller ID gives a number in Washington state now. Can that be overrided or is this what happens when you use the service?

Also, I'm unable to get 7-digit dialing to work. I put in my area code in the box for "7-Digit Dialing for USA & CAN" and it doesn't work -- I've got to dial 1+NPA+xxx-xxxxx even for local calls.

Under the DigitMap for ITSP Profile A, it has the recipe for 7-digit dialing (in this example, a 312 NPA):

(1xxxxxxxxxx|<1312>[2-9]xxxxxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)
Logged
Pages: [1] 2 3
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC