May 24, 2019, 07:13:09 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Syntax for a Hotline in Outbound Calling Route  (Read 6095 times)
TTCP
Jr. Member
**
Posts: 50


« on: December 06, 2017, 11:40:11 am »

Hi,

I want to create an outgoing hotline for my OBI200.

In the manual, it says:
    <:1234> – Matches an empty phone number and replaces with 1234. This is the syntax for a hotline to 1234
    <S0:1234> – Equivalent to the last example

But I found none of these two syntax works in my OBI200.

Can someone please help me here?

Do these hotline syntax require some special "DigitMap" field value in the "Physical Interfaces -> PHONE Port"?

My OBI200 firmware is 3.2.1 (Build: 5757EX)
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 4133


« Reply #1 on: December 06, 2017, 11:56:18 am »

That <:number> construct goes into the PHONE port digit map as an addition. Insert

<:number>|

immediately after the opening ( . The number will then be subject to the routeing rules in the PHONE port OutboundCallRoute just as if you had manually dialled it.  (Use the actual number after the colon.)

Are you sure you want a hotline?  Using a "warmline" introduces a delay which lets you dial a different number or gives you a chance to put the phone back on-hook if accidentally knocked off.

<S5:number> will dial the number after 5 seconds if nothing is dialled.  Change the 5 to your liking.
« Last Edit: December 06, 2017, 12:11:07 pm by drgeoff » Logged
munozj
Newbie
*
Posts: 8


« Reply #2 on: April 03, 2018, 08:46:59 am »

I'm sure this is something obvious but I can't seam to figure it out.. to make this work I'm assuming I need to replace the information in the Digit Map field of the Physical interface, Phone1 with <S0:5551212> for the device to automation dial 5551212 when the phone goes off-hook.  I've tried this but I only get dial tone when I pickup the phone.  I also tried <S1:5551212> and <S0:5551212>|

I'm assuming I'm just entering the wrong syntax in the wrong field but I'm not sure which field I should be using.

Using an Obi300
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 4133


« Reply #3 on: April 03, 2018, 09:01:53 am »

I'm sure this is something obvious but I can't seam to figure it out.. to make this work I'm assuming I need to replace the information in the Digit Map field of the Physical interface, Phone1 with <S0:5551212> for the device to automation dial 5551212 when the phone goes off-hook.  I've tried this but I only get dial tone when I pickup the phone.  I also tried <S1:5551212> and <S0:5551212>|

I'm assuming I'm just entering the wrong syntax in the wrong field but I'm not sure which field I should be using.

Using an Obi300
Please do not ask the same question more than once.
Logged
SDToddl
Newbie
*
Posts: 3


« Reply #4 on: May 18, 2019, 08:54:11 am »

I too am having the same problem.  When you say this line is an addition,  do you put it inside
User Defined DigitMap1 under the ipd 
(xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?|xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?<*::>xx?x?x?x?)

or are you suppose to create a DigitMap2?

Just so I don’t have to add a followup question.  Where exactly do I put it if I want a hotline to dial 16193641234?

Ideally, I would like to have it if someone dials 18005551234 it sends the call to 16193641234.

Could you please tell me also how to do that so it will answer my question and the previous person’s question.

Thank you for your help
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 4133


« Reply #5 on: May 18, 2019, 11:46:20 am »

See my first reply in this thread.  Which part of

That <:number> construct goes into the PHONE port digit map as an addition. Insert

<:number>|

immediately after the opening (

do you not understand?
« Last Edit: May 18, 2019, 11:48:10 am by drgeoff » Logged
SDToddl
Newbie
*
Posts: 3


« Reply #6 on: May 18, 2019, 01:23:57 pm »

I assume this is what you meant.
I tried this:

(<:16193641234>|xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?|xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?<*::>xx?x?x?x?)

I also tried this:

(<:16193641234>)

Both show an ! in red after I hit Save.
« Last Edit: May 18, 2019, 01:55:29 pm by SDToddl » Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 4133


« Reply #7 on: May 18, 2019, 03:26:46 pm »

I assume this is what you meant.
I tried this:

(<:16193641234>|xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?|xx.<*:@>xx?x?<*:.>xx?x?<*:.>xx?x?<*:.>xx?x?<*::>xx?x?x?x?)

I also tried this:

(<:16193641234>)

Both show an ! in red after I hit Save.
No.

For the 3rd time.

That <:number> construct goes into the PHONE port digit map as an addition. Insert

<:number>|

immediately after the opening (

And the red exclamation mark merely means that the field has been changed from its default value.
« Last Edit: May 18, 2019, 03:30:44 pm by drgeoff » Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3825


« Reply #8 on: May 18, 2019, 03:42:14 pm »

Ideally, I would like to have it if someone dials 18005551234 it sends the call to 16193641234.
The syntax is:
<arg1:arg2>

arg1 is used to match the dialed number and then deletes that number.
arg2 replaces the deleted number.

Add the following after the beginning ( of the Phone DigitMap:
<18005551234:16193641234>|

The Phone DigitMap is found here:
Physical Interfaces -> Phone1 Port

Edit:
Use the following if you want to dial 10 or 11 digits
<18005551234:16193641234>|<8005551234:16193641234>|
« Last Edit: May 18, 2019, 03:47:10 pm by azrobert » Logged
SDToddl
Newbie
*
Posts: 3


« Reply #9 on: May 19, 2019, 07:39:22 am »

Thank you so much, that solved the problem.

I was confused by the red exclamation point and I was entering it in the wrong DigitMap.
That was why I gave an example of what was in the field.

There is another DigitMap under Obi Expert config.

User Settings -> User Defined DigitMaps.   

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC