November 12, 2018, 09:33:25 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: I setup Simonics SIP yesterday, now getting hammered with call from 123-456-7890  (Read 11605 times)
Jeff-66
Newbie
*
Posts: 6


« on: December 08, 2017, 09:06:52 am »

was working fine yesterday after I set up my Obi100 with Simonics SIP. even now I can make calls, and receive calls. I'm getting Caller ID info on incoming calls. Normal calls I make & receive are showing up correctly on the G-Voice site.

However, every 1 to 3 minutes, I'm getting a call from '123-456-7890', with no name. If i pick up and answer, there's nothing on the other end. I can't detect anything. If I don't answer, sometimes it goes to voicemail (no msg left though) and sometimes it just hangs up before voicemail.

Normally, this would be easy to handle by going to g-voice and blocking the number, but the strange thing is these calls do not register on g-voice at all as an incoming call. G-voice does not let you block a number unless it's a registered call.

Anyone else experiencing this or know what might be wrong?
Logged
billsimon
Full Member
***
Posts: 103


« Reply #1 on: December 08, 2017, 09:12:59 am »

Some routers do not do NAT properly. When you connect your device to our SIP gateway they then open SIP from the whole world back to you Obi.

You can get a better router or change your Obi's SIP listening port so that there is not an obvious path for the SIP scanners to get to your network.

Search forums for "ghost calls" or "SIP scanners"
Logged
Jeff-66
Newbie
*
Posts: 6


« Reply #2 on: December 08, 2017, 09:52:25 am »

Hi Bill, thanks for the reply, and thanks for the service. It's much appreciated.

I will research those, and try to change the listening port. thanks again!

« Last Edit: December 08, 2017, 10:05:01 am by Jeff-66 » Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #3 on: December 08, 2017, 09:58:38 am »


Anyone else experiencing this or know what might be wrong?

You're getting hit by SIP scanners. Either of the following solutions should fix the problem:

1>Using OBi Expert, change Voice Services-->SPy Service-->X_InboundCallRoute to the following:

{>GV1XXXXXXXXXX:ph} (This is using your "SIP Login/prefix" as seen on your Simonics web page)

y=SP service number (SP1, SP2, SP3, or SP4 under Voice Services) being used for Simonics
XXXXXXXXXX=Google Voice number


2>Using OBi Expert, change Voice Services-->SPy Service-->X_UserAgentPort to a random number between 10000 and 65535, for example, 55120.

y=SP service number (SP1, SP2, SP3, or SP4 under Voice Services) being used for Simonics

Important: You must uncheck both boxes to the right of the field you are trying to edit. Make the change in the exact order shown below. You can't do Step 2 until you do Step 1 first.

Step 1: Uncheck box under OBiTALK Settings for the field you wish to edit

Step 2: Uncheck box under Device Default for the field you wish to edit

Step 3: Edit the field you wish to change

Step 4: Submit and save your settings
« Last Edit: December 11, 2017, 03:01:47 pm by Taoman » Logged
Jeff-66
Newbie
*
Posts: 6


« Reply #4 on: December 08, 2017, 10:32:27 am »


Anyone else experiencing this or know what might be wrong?

You're getting hit by SIP scanners. Either of the following solutions should fix the problem:

Using OBi Expert, change Voice Services-->SPx Service-->X_InboundCallRoute to the following:

{>GV1XXXXXXXXXX:ph} (This is using your "SIP Login/prefix" as seen on Simonics web page)

x=SP slot number being used for Simonics
XXXXXXXXXX=Google Voice number


Using OBi Expert, change Voice Services-->SPx Service-->X_UserAgentPort to a random number between 10000 and 65535, for example, 55120.

x=SP slot number being used for Simonics

Important: You must uncheck both boxes to the right of the field you are trying to edit

This was a homerun! I used your 2nd method and it worked. The scans stopped 100%. They were coming in every 10-15 seconds, tying up the phone. it was highly annoying. Thanks a ton for the info!
Logged
gccch
Newbie
*
Posts: 5


« Reply #5 on: December 08, 2017, 11:28:18 am »


Anyone else experiencing this or know what might be wrong?

You're getting hit by SIP scanners. Either of the following solutions should fix the problem:

Using OBi Expert, change Voice Services-->SPx Service-->X_InboundCallRoute to the following:

{>GV1XXXXXXXXXX:ph} (This is using your "SIP Login/prefix" as seen on Simonics web page)

x=SP slot number being used for Simonics
XXXXXXXXXX=Google Voice number


Using OBi Expert, change Voice Services-->SPx Service-->X_UserAgentPort to a random number between 10000 and 65535, for example, 55120.

x=SP slot number being used for Simonics

Important: You must uncheck both boxes to the right of the field you are trying to edit

Sad to say, this worked for about an hour for me, then I got another 1234567890 call. Must be another way they are getting in.
Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #6 on: December 08, 2017, 11:36:34 am »


Sad to say, this worked for about an hour for me, then I got another 1234567890 call. Must be another way they are getting in.

Which solution did you use that didn't work? Are you sure the edit you made actually stuck?

If one solution didn't work try the other one.

There is a third solution if neither of the above two work.

Logged
gccch
Newbie
*
Posts: 5


« Reply #7 on: December 08, 2017, 11:47:12 am »


Sad to say, this worked for about an hour for me, then I got another 1234567890 call. Must be another way they are getting in.

Which solution did you use that didn't work? Are you sure the edit you made actually stuck?

If one solution didn't work try the other one.

There is a third solution if neither of the above two work.



I implemented your solution, but it seems it is not sticking after reboot. I don't understand the solution offered by Bill Simon well enough to implement. 
Logged
gccch
Newbie
*
Posts: 5


« Reply #8 on: December 08, 2017, 11:51:11 am »

The changes are not sticking.
Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #9 on: December 08, 2017, 11:55:32 am »

The changes are not sticking.

Are you making the changes on the OBitalk website using Advanced Configuration (OBi Expert)??

After you make the changes are you hitting Submit and then saving your changes?
Logged
Jeff-66
Newbie
*
Posts: 6


« Reply #10 on: December 08, 2017, 12:06:10 pm »

The changes are not sticking.

If you make the changes directly on the Obi device, it will pull settings from the Obi "cloud". As Taoman said, you need to make the changes on the obitalk website.

I found this to be true of any changes you make on the device. Make sure the 'master' settings on the site match (or just do them from there). took me a while to figure this out yesterday when I was setting up SIP. I was getting really frustrated when I'd make 9 different edits, and then it'd just revert back to what was there before! Finally, i went to the Obitalk settings here on the site and made the edits there and they've stuck ever since.

Hours later now, still not a single SIP scan call. Thanks again Bill and Taoman!
« Last Edit: December 08, 2017, 12:09:09 pm by Jeff-66 » Logged
gccch
Newbie
*
Posts: 5


« Reply #11 on: December 08, 2017, 12:16:51 pm »

I have been making the changes only on the device. I'm on it now.
« Last Edit: December 08, 2017, 12:19:16 pm by gccch » Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #12 on: December 08, 2017, 12:32:02 pm »

I have been making the changes only on the device. I'm on it now.

I assume you had Google Voice before this? If so, you had to configure it on the OBitalk website interface.

If the above is true why are you now "making the changes only on the device?" That is your problem.
Logged
gccch
Newbie
*
Posts: 5


« Reply #13 on: December 08, 2017, 01:05:13 pm »

I have been making the changes only on the device. I'm on it now.

I assume you had Google Voice before this? If so, you had to configure it on the OBitalk website interface.

If the above is true why are you now "making the changes only on the device?" That is your problem.

True. Cause I'm not so good at this. I think I got it now. Changes are sticking.
Logged
precht
Jr. Member
**
Posts: 23


« Reply #14 on: December 08, 2017, 09:08:53 pm »


Anyone else experiencing this or know what might be wrong?

You're getting hit by SIP scanners. Either of the following solutions should fix the problem:

Using OBi Expert, change Voice Services-->SPx Service-->X_InboundCallRoute to the following:

{>GV1XXXXXXXXXX:ph} (This is using your "SIP Login/prefix" as seen on Simonics web page)

x=SP slot number being used for Simonics
XXXXXXXXXX=Google Voice number


Using OBi Expert, change Voice Services-->SPx Service-->X_UserAgentPort to a random number between 10000 and 65535, for example, 55120.

x=SP slot number being used for Simonics

Important: You must uncheck both boxes to the right of the field you are trying to edit
Thanks for the detailed instructions.

Just changed these settings for my device and looking forward to no more ringing
« Last Edit: December 08, 2017, 10:42:11 pm by precht » Logged
ThriftyDude
Newbie
*
Posts: 1


« Reply #15 on: December 08, 2017, 10:27:18 pm »

I was in a similar situation. Set up Simonics SIP a few days ago, and got hammered by SIP scanners today. I unpugged my OBi device for awhile, and just plugged it back in. The calls seem to have stopped this evening, but I changed the values for the X_InboundCallRoute and X_UserAgentPort variables as suggested in this thread.

I'm interested in also setting up the X_AccessList variable under Service Providers - ITSP Profile x SIP to limit the IP addresses that can connect to my device. Does anyone know the IP addresses used by Simonics?
Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #16 on: December 08, 2017, 11:12:24 pm »

Does anyone know the IP addresses used by Simonics?

They're all listed here. Since Bill Simon seems to keep current with his proxy server IP addresses, using X_AccessList is a viable option. I added them as soon as I saw the full list.

https://simonics.com/news/

Logged
swan2swan
Jr. Member
**
Posts: 22


« Reply #17 on: December 09, 2017, 11:49:44 pm »

The same here but I have no idea how to change settings. Had to unplug my phone to get some sleep. #'1008 calling every minute.

Update: During the night I finally unplugged my unit. In the morning more ghost calls - I have used all the suggestions and now I can not receive any calls. Please help me!! Sad
Thank you! <3
« Last Edit: December 10, 2017, 01:20:45 pm by swan2swan » Logged
KennySD
Newbie
*
Posts: 4


« Reply #18 on: December 10, 2017, 08:38:59 am »

I tried to implement the fix listed above, but I can't change Voice Services-->SPx Service-->X_InboundCallRoute or Voice Services-->SPx Service-->X_UserAgentPort. I have unchecked OBITALK Settings for both, but I can't delete the information in the field and replace. The information won't delete.

Both fields X_UserAgentPort and AuthUserName have redexclmation points to the right of the field value box.

Any thoughts or suggestions?

Thanks
Logged
Taoman
Hero Member
*****
Posts: 1144


« Reply #19 on: December 10, 2017, 08:49:35 am »

I tried to implement the fix listed above, but I can't change Voice Services-->SPx Service-->X_InboundCallRoute or Voice Services-->SPx Service-->X_UserAgentPort. I have unchecked OBITALK Settings for both, but I can't delete the information in the field and replace. The information won't delete.

Then you haven't done this which is why I used bold lettering:

Quote
Important: You must uncheck both boxes to the right of the field you are trying to edit
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC