October 22, 2018, 03:15:50 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2] 3
  Print  
Author Topic: SIP phones no longer connected after 3.2.1 (Build: 5794EX) Saturday 1/21/18  (Read 21800 times)
RFC3261
Full Member
***
Posts: 248


« Reply #20 on: May 08, 2018, 09:25:18 am »

Pretty sure that the (required) firmware upgrade for the new GV connectivity means preventing firmware upgrades for a OBi to support SIP phones has a short remaining viable lifetime (XMPP is dead, long live XMPP).

Anyway, I have opened a support ticket with OBi about the issue, and if I get any response I'll post it here.

<off topic and conjecture>
IFF the implications that were posted over on the GV support forum come to fruition, I can fantasize that it might be possible for SIP endpoints to directly connect to GV in the future (there was hints regarding standards compliance and that there may be ways for other solutions (*cough* asterisk? *cough*) to connect, but I would presume that may require an application password for the phones as many of the existing SIP phones are not going to be able to support OAUTH2).  I guess we will see what happens (maybe some info will come out of I/O this week).
</off topic and conjecture>
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #21 on: May 10, 2018, 05:54:27 am »

Hi All,

       I guess I did not do a good enough job blocking the updates.  Took another auto update last night (5859EX) and lost my SIP phones again.  It now looks like with the change to GV we will have to have new firmware.  Anyone get any response to cases open or more information on how to solve this issue?

Thank you! 
Logged
LTN1
Hero Member
*****
Posts: 512


« Reply #22 on: May 10, 2018, 06:05:32 am »

Hi All,

       I guess I did not do a good enough job blocking the updates.  Took another auto update last night (5859EX) and lost my SIP phones again.  It now looks like with the change to GV we will have to have new firmware.  Anyone get any response to cases open or more information on how to solve this issue?

Thank you! 

Explain what you mean by your "SIP phones."
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3593


« Reply #23 on: May 10, 2018, 06:12:31 am »

If your IP phone can call without registration, just uncheck X_Proxy.
Inbound calls can't be routed to local_client, use the IP address of the phone.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #24 on: May 10, 2018, 06:16:23 am »


Explain what you mean by your "SIP phones."

Cisco SPA514G - I have two Obi 200s (one with Anveo 911 and GV) the other with just GV.  Two Cisco SIP phones run lines off each Obi 200.  See first post - issue occurred in Jan.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #25 on: May 10, 2018, 06:21:32 am »

If your IP phone can call without registration, just uncheck X_Proxy.
Inbound calls can't be routed to local_client, use the IP address of the phone.


Thanks for the response.  Where does the IP address of the phone go?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3593


« Reply #26 on: May 10, 2018, 06:36:30 am »

Change the X_InboundCallRoute of your provider to:
ph,spx(AuthUserID@xx.xx.xx.xx:port)

spx is the SP number where X_Proxy was checked
AuthUserID is the Auth UserID of the Cisco phone
The rest is the IP and port of the phone
You don't need ":port" if the port is 5060

I've played with X_Proxy yesterday and Softphones Phonerlite on a PC and Zoiper on a smart phone register to my OBi200, but CsipSimple on an Android and an OBi110 fail.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #27 on: May 10, 2018, 07:31:20 am »

Change the X_InboundCallRoute of your provider to:
ph,spx(AuthUserID@xx.xx.xx.xx:port)

spx is the SP number where X_Proxy was checked
AuthUserID is the Auth UserID of the Cisco phone
The rest is the IP and port of the phone
You don't need ":port" if the port is 5060

I've played with X_Proxy yesterday and Softphones Phonerlite on a PC and Zoiper on a smart phone register to my OBi200, but CsipSimple on an Android and an OBi110 fail.

Thanks for the details.  Does not seem to work for me.  Made changes and also on the Cisco phone side changed register to no and make and Rx calls without reg to yes.  I get green on the line but fast busy when trying to dial.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #28 on: May 10, 2018, 07:37:14 am »

Anyone have the firmware 5757EX for Obi200?  I have seem to lost it and the Obi site does not seem to be responding.
Logged
ProfTech
Sr. Member
****
Posts: 415


« Reply #29 on: May 10, 2018, 07:51:13 am »

To BlakeN: I have 5757EX. PM me and I can send you a link. I thought Obi fixed it so you can't downgrade but I've never tried.
Logged
Taoman
Hero Member
*****
Posts: 1135


« Reply #30 on: May 10, 2018, 07:52:32 am »

Anyone have the firmware 5757EX for Obi200?  I have seem to lost it and the Obi site does not seem to be responding.

Just download it:

fw.obihai.com/OBi202-3-2-1-5757EX.fw
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3593


« Reply #31 on: May 10, 2018, 08:04:48 am »

The fast busy indicates the call is getting to the OBi200, but is not getting routed to your provider.
The same routing should work whether the phone is registered or not.
Temporarily change the X_InboundCallRoute to: ph
This should cause the phone port to ring.
This test is to check if the call is getting to the OBi200.

Before making this change please post the X_InboundCallRoute of the dummy trunk.

You can't downgrade the firmware. You get a checksum error.
Logged
Taoman
Hero Member
*****
Posts: 1135


« Reply #32 on: May 10, 2018, 08:20:45 am »


You can't downgrade the firmware. You get a checksum error.

Thanks for confirming this, azrobert. I was afraid to even try as both of my OBi200s are working perfectly with 3.2.2 (Build: 5859EX).
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3593


« Reply #33 on: May 10, 2018, 08:24:54 am »

Did you make any changes to block scanners, access list or block unregistered calls?
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #34 on: May 10, 2018, 08:52:29 am »

The fast busy indicates the call is getting to the OBi200, but is not getting routed to your provider.
The same routing should work whether the phone is registered or not.
Temporarily change the X_InboundCallRoute to: ph
This should cause the phone port to ring.
This test is to check if the call is getting to the OBi200.

Before making this change please post the X_InboundCallRoute of the dummy trunk.

You can't downgrade the firmware. You get a checksum error.

Turns out I have two problems.  One of my GV numbers after the upgrade is not registering properly - comes up with connecting to an IP address.  The other one after changes above received inbound calls (did not realize until my wife called) but fast busy on outbound.  Will work to debug. 

On other question - don't remember changing any of those - where are they buried in the config?.

I am getting invalid number on the Cisco phone along with fast busy when dialing.  Are the dialing rules bypassed for some reason with the new settings?  I tried 7,10 and 11 digit dialing and all gave same invalid number.


Thanks again for the help. 
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3593


« Reply #35 on: May 10, 2018, 09:34:12 am »

I'm tired of saying "The trunk where you had X_Proxy checked", so I'm assuming it's SP4.
The routing rules will be in the SP4 X_InboundCallRoute.
It should look something like:
{userid>(Msp1):sp1}

The userid is optional and must match the phone's userid. This is really for security. The (Msp1) is to validate the outbound number and is also optional.

You could change the sp4 inbound route to ph or sp1
ph will send the call to the OBi200 phone port. You don't need to have a phone attached to determine if it's ringing, the phone LED will flash.
sp1 will route the call with the outbound number unchanged to sp1.

When you send the call to the phone port, a call history entry will be created and you can see if the phone is using a different userid when unregistered.

Same with sp1, but an entry won't be created if it's not connected to GV.

I "think" the stuck in "Connecting" is a Google server problem. I'm having the same problem after a reboot. Just try another reboot. A power cycle might work better.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #36 on: May 10, 2018, 02:12:36 pm »

SP4 is a good example - that is the phone / line I am using to debug
Works fine for inbound calls PSTN to GV to (SP1) Obi200 (SP4) to Cisco phone line 2 (user 1002)
Here is my config for SP4 X_InboundCallRoute {1002>911|933:sp2},{1002>(Msp1):sp1}
Replace with {1002>Ph} and still fast busy and no call history
Even tried to dial 933 - same outcome

On the other issue - tried unplugging and replugging in device / reconfiguring through Obi Dashboard and still have - Connecting to 64.9.242.172 in status and no inbound calls on that GV line

Thanks again for the help

Oh - and about pulled what little hair I have left out before I remembered that call log is only available when you log directly into the device.  I guess I am getting too old to try to dive into this stuff only once a year.  The memory is not what it use to be and I have a nice map drawn out.

Is it possible that when new GV upgrade is rolled out we can connect direct from SIP phone? 
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5098



« Reply #37 on: May 10, 2018, 05:07:03 pm »

SP4 is a good example - that is the phone / line I am using to debug
Works fine for inbound calls PSTN to GV to (SP1) Obi200 (SP4) to Cisco phone line 2 (user 1002)
Here is my config for SP4 X_InboundCallRoute {1002>911|933:sp2},{1002>(Msp1):sp1}
Replace with {1002>Ph} and still fast busy and no call history
Even tried to dial 933 - same outcome

On the other issue - tried unplugging and replugging in device / reconfiguring through Obi Dashboard and still have - Connecting to 64.9.242.172 in status and no inbound calls on that GV line

Thanks again for the help

Oh - and about pulled what little hair I have left out before I remembered that call log is only available when you log directly into the device.  I guess I am getting too old to try to dive into this stuff only once a year.  The memory is not what it use to be and I have a nice map drawn out.

Is it possible that when new GV upgrade is rolled out we can connect direct from SIP phone? 

If your 200 series device(s) has/have firmware 5859EX or higher, and you are using Google Voice, then your Google  account has been converted to use Google's new infrastructure.  You can't go back, and you can't down-level the firmware.  There are various reports of problems (e.g. no audio on one or the other or both directions, or server connection problems).  So far, a few bugs have been identified and fixed, including one fixed yesterday.  It's difficult to identify the root cause of a problem, given that this is a moving target, and the universe of devices being updated includes many that have been user-modified locally.

I see an assortment of issues reported today, but no clear pattern.  The previous users' issues have mainly been caused by user modifications to their device configurations.  So, it's worthwhile, if you can't figure out your issue, to just factory-restore the device and start over, and stick with the defaults loaded by OBiTALK until you get it working, and optionally make changes later.

No, the Google Voice upgrade does not enable connecting to any non-OBi SIP phones.
Logged

Taoman
Hero Member
*****
Posts: 1135


« Reply #38 on: May 10, 2018, 05:25:47 pm »

The other one after changes above received inbound calls (did not realize until my wife called) but fast busy on outbound.  Will work to debug. 


Try unchecking X_EnforceRequestUserID under SIP Credentials.
Logged
Blake4913
Newbie
*
Posts: 8


« Reply #39 on: May 10, 2018, 05:39:35 pm »

Shocked Wow  

So I have two Obi 200s and 2 GV lines.  One is our home phone.  Connected to a traditional cordless system.  It still works great.  Because I have two SIP phones and 911 service I actually have both 200s connected to the same GV account.  Both are connected just fine.  With some coaching from the great people on this forum I have inbound calls from that same line to my SIP phones (no love on outbound dialing).

The second GV line is for me.  It routes to only one 200 but connects to both sip phones.  It will not connect to GV at all.

So here is the real kicker.  I have been debugging an ugly echo problem that is very intermittent (posted in GV area).  I got a message from somewhere that prime members get a great deal on a 1062.   I can use it to help troubleshoot my issue and have a phone to take to my folks house when I am there.  So it arrived this evening.  Out of the box no modes, no expert mode, just Obi dashboard config of GV accounts.  No love on either GV account.  It is giving me the backing off message.  I am betting your going to tell me that the firmware for the 1062 does not support the new GV connection yet.  

And they ask me why I drink? Smiley
Logged
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC