September 24, 2018, 01:07:23 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 2 [3]
  Print  
Author Topic: SIP phones no longer connected after 3.2.1 (Build: 5794EX) Saturday 1/21/18  (Read 20174 times)
Blake4913
Newbie
*
Posts: 8


« Reply #40 on: May 10, 2018, 05:46:35 pm »


Try unchecking X_EnforceRequestUserID under SIP Credentials.

Still no love.  It does give me a new message on the phone.  Service not available.  Inbound calls still work.

Thanks for the idea.
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5034



« Reply #41 on: May 10, 2018, 05:50:08 pm »

Shocked Wow  

So I have two Obi 200s and 2 GV lines.  One is our home phone.  Connected to a traditional cordless system.  It still works great.  Because I have two SIP phones and 911 service I actually have both 200s connected to the same GV account.  Both are connected just fine.  With some coaching from the great people on this forum I have inbound calls from that same line to my SIP phones (no love on outbound dialing).

The second GV line is for me.  It routes to only one 200 but connects to both sip phones.  It will not connect to GV at all.

So here is the real kicker.  I have been debugging an ugly echo problem that is very intermittent (posted in GV area).  I got a message from somewhere that prime members get a great deal on a 1062.   I can use it to help troubleshoot my issue and have a phone to take to my folks house when I am there.  So it arrived this evening.  Out of the box no modes, no expert mode, just Obi dashboard config of GV accounts.  No love on either GV account.  It is giving me the backing off message.  I am betting your going to tell me that the firmware for the 1062 does not support the new GV connection yet.  

And they ask me why I drink? Smiley

The 1062 certainly supports everything the 200/202 models do (except for an analog RJ-11 phone jack, of course).  This includes full support for up to six Google Voice accounts.

Your device has been sitting in a warehouse for a long time.  You just need to follow the **5 xxxx procedure to add it to the OBiTALK web portal.  When you do that, after some time, it will automatically upgrade to the new Google Voice firmware.

As of today, the 1000 series should be at version 5.1.11 (Build: 4858EX.1311) or higher.

Before making any custom changes to any parameters at all, just add it to OBiTALK and walk through the standard Google Voice setup for each SPx you want to use with Google Voice.
Logged

BlakeN
Newbie
*
Posts: 19


« Reply #42 on: May 10, 2018, 06:06:52 pm »


The 1062 certainly supports everything the 200/202 models do (except for an analog RJ-11 phone jack, of course).  This includes full support for up to six Google Voice accounts.

Your device has been sitting in a warehouse for a long time.  You just need to follow the **5 xxxx procedure to add it to the OBiTALK web portal.  When you do that, after some time, it will automatically upgrade to the new Google Voice firmware.

As of today, the 1000 series should be at version 5.1.11 (Build: 4858EX.1311) or higher.

Before making any custom changes to any parameters at all, just add it to OBiTALK and walk through the standard Google Voice setup for each SPx you want to use with Google Voice.

Thanks for the feedback.  Done and done.  This is like my 4th or 5th Obi device along with SIP phones - been doing this since google shut things back on years ago.  One of the selling points of the 1062 is that I did not need to spend my life in the expert config.  Current code on phone is 5.0.6 and it says when I select the update on the phone that there is no update available.  Phone has been on and sitting there for a couple of hours with no update.  I am calling it quits for the day.  I will dream of firmware downloads that fix all my problems.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #43 on: May 10, 2018, 06:10:51 pm »

Here is my config for SP4 X_InboundCallRoute {1002>911|933:sp2},{1002>(Msp1):sp1}

Try this:
{>911|933:sp2},{>(Msp1):sp1},{ph}
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #44 on: May 10, 2018, 06:35:18 pm »

Build 5859 supports GV on both XMPP and SIP, although there is no way to define a new GV account as XMPP. I did not wait for my OBi200 to be automatically updated. I downloaded 5859EX and manually upgraded my OBi200. 5859EX is no longer available for download. Both GV accounts on my OBi200 did not convert to SIP, but both connected. One account was switched to SIP when I deleted and redefined it. The OBi200 now had one account as SIP and the 2nd as XMPP. I verified this 2 ways. The 1st account showed as OBiTalk device in GV list of forwarding numbers and the 2nd as Google Chat. I sent an SIP URI call to the 1st account on the OBi200 and it was successful, but the same call sent to the 2nd account was rejected. I have since converted the 2nd account to SIP.

A GV account that has been converted to SIP will also connect to XMPP. I have the same GV account defined on an OBi200 as SIP and on an OBi110 as XMPP. Both are connected and working.
Logged
Taoman
Hero Member
*****
Posts: 1130


« Reply #45 on: May 10, 2018, 07:00:32 pm »

I have the same GV account defined on an OBi200 as SIP and on an OBi110 as XMPP. Both are connected and working.


You're getting incoming GV calls on your OBi110? Since you can no longer forward to Google Chat how is that possible? I knew outgoing still worked.
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #46 on: May 10, 2018, 08:58:56 pm »

Since you can no longer forward to Google Chat how is that possible? I knew outgoing still worked.

You are correct. Only outbound OBi110 works, not inbound. I'm routing inbound from my OBi200 to the OBi110. When OBi110 outbound stops working, I'll route outbound to the OBi200.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #47 on: May 11, 2018, 05:18:10 am »


Try this:
{>911|933:sp2},{>(Msp1):sp1},{ph}


Same outcome - fast busy / service unavailable (If I click back on X_EnforceRequestUserID error changes to Invalid number)
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #48 on: May 11, 2018, 08:58:27 am »

Try this:
SP4 X_InboundCallRoute: ph

When you make a call, does the OBi200 phone port ring?
If the phone doesn't ring, the call isn't getting to the OBi200 and I don't know why.
Do not do the following steps,

If the phone rings, do the following:
SP4 X_InboundCallRoute: sp4($1@192.168.1.99)

Dial a number on the IP phone, wait a few seconds and hang up.
You will not hear anything after dialing the number.

Now do this:
SP4 X_InboundCallRoute: sp4($2@192.168.1.99)

Make another call for a few seconds.

$1 contains the IP phone's userid and $2 the outbound number.
You should be able to see these in the OBi200 call history.

To access Call History:
Log directly into the OBi using the local interface.
Key the IP address of the OBi into a Web Browser and hit Enter
The UserID and default Password are both "admin".
Click Status on the left column then click Call History.

What does the call history show for those calls?
Logged
lottamoxie
Newbie
*
Posts: 16


« Reply #49 on: May 11, 2018, 05:33:15 pm »

Obi 200 here.  Was converted to new firmware several days ago.

My problem is this:

Inbound calls, my cordless phone rings once and then stops.  The caller on their end is hearing a type of "number not in service" message.

I have no problem making outbound calls, I get a dialtone and everything works normally.

My GV status shows as connected on the Obitalk dashboard.

Any ideas?



Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5034



« Reply #50 on: May 11, 2018, 10:19:05 pm »

Obi 200 here.  Was converted to new firmware several days ago.

My problem is this:

Inbound calls, my cordless phone rings once and then stops.  The caller on their end is hearing a type of "number not in service" message.

I have no problem making outbound calls, I get a dialtone and everything works normally.

My GV status shows as connected on the Obitalk dashboard.

Any ideas?


Hi there:

The "...not in service..." message takes a bit of problem isolation to determine what's wrong.

Using a desktop/laptop computer's web browser, sign into your Google / Gmail account and then go here:

https://voice.google.com/settings

Delete all the linked telephone numbers off of the list.  Turn on "do not disturb" mode.  Call your inbound Google Voice phone number from some other phone number.  What happens, exactly?  The expected behavior is that the caller will be immediately sent to your Google Voice voicemail greeting.
Logged

BlakeN
Newbie
*
Posts: 19


« Reply #51 on: May 12, 2018, 01:36:07 pm »

Try this:
SP4 X_InboundCallRoute: ph

When you make a call, does the OBi200 phone port ring?
If the phone doesn't ring, the call isn't getting to the OBi200 and I don't know why.
Do not do the following steps,

If the phone rings, do the following:
SP4 X_InboundCallRoute: sp4($1@192.168.1.99)

Dial a number on the IP phone, wait a few seconds and hang up.
You will not hear anything after dialing the number.

Now do this:
SP4 X_InboundCallRoute: sp4($2@192.168.1.99)

Make another call for a few seconds.

$1 contains the IP phone's userid and $2 the outbound number.
You should be able to see these in the OBi200 call history.

To access Call History:
Log directly into the OBi using the local interface.
Key the IP address of the OBi into a Web Browser and hit Enter
The UserID and default Password are both "admin".
Click Status on the left column then click Call History.

What does the call history show for those calls?


With forcing user ID unchecked call does get to OBI.  I get the following in the call log.  I have not had any time to further debug.  I will try your suggestion above when I have time (It has been a busy weekend).
 
Call 1   05/11/2018    11:06:16   
11:06:16   From SP4(1002)   To SP1(1234567890)
11:06:18      Call Ended (488 Not Acceptable Here)

BTW - I put a ticket in on the 1062 - no upgrade of code and no GV.  They upgraded code and now both GV on 1062 seems to work.  They said to delete and add the GV one on the 200 that would not connect.  It still does not work - same connecting to 63.9.242.172.

Thanks again for the help
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #52 on: May 12, 2018, 01:53:55 pm »

I will try your suggestion above when I have time (It has been a busy weekend).

Don't bother doing those tests. Your call history shows everything is being routed correctly. I don't know why you're getting the 488 error. Can you make a call from the phone port?
Logged
Blake4913
Newbie
*
Posts: 8


« Reply #53 on: May 13, 2018, 04:41:29 pm »

I will try your suggestion above when I have time (It has been a busy weekend).

Don't bother doing those tests. Your call history shows everything is being routed correctly. I don't know why you're getting the 488 error. Can you make a call from the phone port?
yes, the phone port works great in both directions.  Probably would be hard to sell devices if it did not.  There is likely no incentive for Polycom to allow a Cisco phone to work or any SIP phone for that matter.  I submitted a ticket and included all three of my issues.  They jumped right on the 1062 issue (its fixed), tried to give some advice on the one 200 that won't connect to GV (no luck to fix) and ignored the SIP phone issue.  Even gave the issue that one of the others in this chain figured out by sniffing the packets.   
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3568


« Reply #54 on: May 13, 2018, 07:22:27 pm »

It seems the 488 error is a codec problem.
See:
https://supportforums.cisco.com/t5/ip-telephony/message-sip-with-488-not-acceptable-here/td-p/2077189

The link suggests forcing G711a, but I know GV works with G711u. I checked my OBi200's codec profile and the G711a codec is disabled. I don't remember if I disabled it. Check which codec profile your GV is using then see whether any codecs in that profile are disabled. See if you can force G711u in your Cisco phone.
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #55 on: May 14, 2018, 01:32:34 pm »

It seems the 488 error is a codec problem.
See:
https://supportforums.cisco.com/t5/ip-telephony/message-sip-with-488-not-acceptable-here/td-p/2077189

The link suggests forcing G711a, but I know GV works with G711u. I checked my OBi200's codec profile and the G711a codec is disabled. I don't remember if I disabled it. Check which codec profile your GV is using then see whether any codecs in that profile are disabled. See if you can force G711u in your Cisco phone.


Thanks - I goofed with it a bit and setting Use Pref Codec Only to yes in the Cisco phone seemed to solve the issue.  I tried it with both G711u and G711a as the preferred vocoder - both worked.  In my 200 config I have both 711 codecs enabled, G729 and G726R32 enabled.  I tried to disable G711a and that did not solve issue.

I will work with my other phones/lines and try to document all changes to enable working SIP phone with latest connection.

BTW - what are the down sides to not having registration?  I assume you don't know if the 200 dies until you try to pick up the phone and dial?
Logged
RFC3261
Full Member
***
Posts: 248


« Reply #56 on: May 14, 2018, 06:04:15 pm »

There is likely no incentive for Polycom to allow a Cisco phone to work or any SIP phone for that matter.
If this was a request for a new feature, I would have no reason to have believed that Obihai would invest in development to add it.  In this case, however, some changes broke a capability that Obihai, themselves, documented.  Hanlon's razor suggests it is a bug introduced accidentally (perhaps due to other changes, such as support for the GV changes?).  An alternative is that violating RFC specified authentication process was introduced intentionally to break downstream SIP clients.  Only Obihai knows for sure, and as you say, they have so far not even answered the question(s).
Logged
SteveInWA
Hero Member & Beta Tester
*****
Posts: 5034



« Reply #57 on: May 14, 2018, 06:36:09 pm »

Trust me - I thought about saying I would be happy to pay them $10 to fix it.  I put this together about 3 years ago.  It probably took me 2 hours just to remember what I had done even though everything was backed up and I had drawn diagrams and tables of IP addresses, etc.  It sucks to get old.  But hey, it is better than paying Verizon $70/month for a POTS line.  Thanks again for your insight!!

So:  this thread is about five months old and three pages long, and you're still trying to experiment with those Cisco phones.  Think of how much time you've spent so far.  Are you employed?  If so, how much is your time worth per hour?  You could have bought a case of OBi IP phones by now for that much money.  I know people love to experiment and mod stuff, be it cars, boats, musical instruments, or whatever, but I can think of better things to do than play with old, discontinued, ugly-UI Cisco phones.

Clearance sale:

https://smile.amazon.com/Obihai-Gigabit-Phone-Built-Bluetooth/dp/B00TEFGVD2/ref=sr_1_1?ie=UTF8&qid=1526348107&sr=8-1&keywords=obi+1062
Logged

BlakeN
Newbie
*
Posts: 19


« Reply #58 on: May 15, 2018, 05:41:55 am »


So:  this thread is about five months old and three pages long, and you're still trying to experiment with those Cisco phones.  Think of how much time you've spent so far.  Are you employed?  If so, how much is your time worth per hour?  You could have bought a case of OBi IP phones by now for that much money.  I know people love to experiment and mod stuff, be it cars, boats, musical instruments, or whatever, but I can think of better things to do than play with old, discontinued, ugly-UI Cisco phones.

So, first let me say that Obi has been good to me.  They created a fantastic product and have evolved it over time.  Not sure about Polycom but I am starting to get the picture.

So, I did buy a 1062 and so far I am not feeling the ease of configuration.  I had to submit a ticket to get it upgraded to the latest code so that it would connect to GV (it would not upgrade).  Even thought I put in a very  recognizable label for GV it shows on the phone as some long string of characters.  I attached my iPhone to the phone in hopes to download my contacts.  Said yes to the allowing access to my contacts but no download.  It is not intuitive on how to add my iPhone to line key so that I can use it as a speakerphone for my iPhone.  I have spent some time with the manual but not feeling any savings in time so far.  Is there a quick start configuration guide somewhere that I am missing? 

So, for several years I have been using the Cisco phones with no issues.  The investment was outstanding.  A few bucks to Anveo, the hardware (which you needed anyway other than the Obi200) and no need to pay Verizon big money each month for antiquated service.  The Cisco phones are solid (Fantastic speaker phone and super durable and a simple straight forward UI).  So, in January Obi or Polycom forced my unit to upgrade software and broke my system.  I downgraded code and went back to my life.  Last week it happened again and low an behold this time someone figured out a way to ensure that you can't downgrade and maybe tossed in a new bug with the codec.  So, by incompetence or plan he we are.

So, sure I am willing to shell out some bucks for a couple of 1062s to replace my Cisco phones but give me some motivation.  Convince me they are easier to configure, new and better features and they won't be orphaned by Polycom or rendered useless by a forced software upgrade. 

BTW - why is the 1062 on "clearance"   

So, yes I have a job and yes I am a geek and kind of like doing some of this stuff.  But I rather be fishing..  Grin 
Logged
BlakeN
Newbie
*
Posts: 19


« Reply #59 on: May 15, 2018, 05:06:21 pm »

Hi All,

      To make it easier to follow I have tried to document the items I changed in one place for the Obi 200 work around for SIP phone connectivity issues with latest code (2 issues - registration bug & codec issue).  It appears that the registration issue was introduced in Jan and I am making an educated guess the codec issue in this latest release (I am making a leap here as others are complaining of no outbound calling but inbound still works).

I am coming from 5757EX and as of last week was updated automatically to 5859EX.  As of 5757EX I had Obi 200 with GV line and Cisco SPA514G SIP phone that worked perfectly with registration and no forced codec.

For reference I have GV coming in on SP1 and my SIP phone on SP4.

To work around the registration issue we are basically not requiring registration:
On Obi200 SP4 or the SPX service connected to the SIP phone
Uncheck X_RegisterEnable
Uncheck X_EnforceReguestUserID
Uncheck X_Proxy
For X_InboundCallRoute take out reference to user ID
   Mine had {1002>(Msp1):sp1}
         I changed to {>(Msp1):sp1}
On Obi200 SP1 or the SPX service connected to GV
For X_InboundCallRoute add @IPaddr:SIP port where the IP address is the IP address of the SIP phone/line and the SIP port
        Mine had {sp4(1002)}
        I changed to {sp4(1002@192.168.4.50:5064)}
On Cisco SIP phone using admin advanced login on the line tab that is connected to SP4
Change Register to No
Change Make Call Without Reg to yes
Change Answer Call Without Reg to yes

To work around the codec issue I am forcing the Cisco IP phone to only use one codec (in my case the G711u):
On Cisco SIP phone using admin login on the line that is connected to SP4
Change Use Pref Codec Only to yes (note that In the 3 slots for preferred codecs I only have the first filled in with G711u)

I assume there are downsides to this configuration over what I had.   If you have a connectivity failure or your Obi devices fails I do not believe you will know that until you pick up the phone and dial a number.  I am not sure there is any downside to forcing only one codec. 

Thanks again to azobert, Taoman and SteveInWA efforts in helping me stumble through putting this workaround. 
Logged
Pages: 1 2 [3]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC