December 15, 2018, 01:16:02 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: obitalk generates wrong digitmap for 7-digit dialing  (Read 6203 times)
wjcarpenter
Newbie
*
Posts: 11


« on: February 22, 2018, 09:58:40 pm »

When I put in my area code (425) for 7-digit dialing into the SP config in obitalk, it creates this digitmap:

(1xxxxxxxxxx|<1425>[2-9]xxxxxxxxx|011xx.|xx.|*xx||(Mipd)|[^*#]@@.)

Notice that it's pre-pending "1425" to a ten-digit number. The result is that when someone dials 425-555-1212, my obi202 sends 14254255551212 to the SP, which obviously doesn't work. If I go into expert mode and manually modify that second pattern in the digitmap to only 6 x's, things work as expected.

I last reconfigured things a week or so back, but I just tried it again today and got the same thing. Is this a known problem?
Logged
ProfTech
Sr. Member
****
Posts: 418


« Reply #1 on: February 23, 2018, 07:45:31 am »

I have 2 Obi's that I use the portal to keep an eye on but only one of them has 7 digit dialing and I didn't use the first screen in the portal to configure it. I used the expert mode entirely so can't tell you for sure if it's a bug in the portal. I wouldn't sweat it. Just fix it in the expert mode like you did and forget it. Too many variables when using that first screen.
Logged
Taoman
Hero Member
*****
Posts: 1158


« Reply #2 on: February 23, 2018, 09:16:06 am »

If I go into expert mode and manually modify that second pattern in the digitmap to only 6 x's, things work as expected.


Then do that. That is the way it is supposed to look.........with 6 x's.

If you are trying to edit an existing configuration by adding an area code on the initial configuration screen results can be inconsistent. Better to just edit it with Obi Expert.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC