December 14, 2017, 06:47:49 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: How to make X-Lite to receive calls  (Read 384893 times)
George
Newbie
*
Posts: 1


« on: August 29, 2011, 10:16:02 am »

Dear Sir/Madam,

I can make a call via X-lite 4 for PC.

But X-lite failed to receive incoming calls .

An incoming call only rings the telephone attached Obi110. But nothing happens to the X-lite 4 for PC.

How to fix it?

Thanks in advance.

 
Logged
RonR
Forum Member

Posts: 4528


« Reply #1 on: August 29, 2011, 10:27:41 am »

In the following places:

Voice Services -> SP1 Service -> X_InboundCallRoute
Voice Services -> SP2 Service -> X_InboundCallRoute
Voice Services -> OBiTALK Service -> InboundCallRoute
Physical Interfaces -> LINE Port -> InboundCallRoute

change ph or {ph} to {ph,PP(ob290123456)}

where 290123456 is your OBiON App OBiTALK number.
« Last Edit: February 15, 2012, 07:02:09 pm by RonR » Logged
jc2080
Newbie
*
Posts: 4


« Reply #2 on: August 31, 2011, 10:16:52 am »

Where is the 'InboundCallRoute' option and how to enable it?  Inside my SP1 only showing Google Voice related. 

Thanks,
Logged
RonR
Forum Member

Posts: 4528


« Reply #3 on: August 31, 2011, 10:29:56 am »

If you wish to use the OBiTALK Web Portal, you will need to go the OBi Expert area.

You may find it easier and quicker to log into the OBi itself at the IP address returned by dialing ***1.

If you decide to configure the OBi directly, you will also need to disable Auto Provisioning:


(f/w versions less than 1.3.0):

System Management -> Auto Provisioning -> Auto Provisioniing : Method : Disabled


(f/w versions 1.3.0 or greater):

System Management -> Auto Provisioning -> ITSP Provisioning : Method : Disabled
Logged
jc2080
Newbie
*
Posts: 4


« Reply #4 on: August 31, 2011, 11:09:04 am »

Thanks,  using the OBiTALK Web Portal, I found and enter the expert section, but the field values within SP1 seems not editable(would not let me type anything in it). Thanks for you help.
 
Logged
RonR
Forum Member

Posts: 4528


« Reply #5 on: August 31, 2011, 11:20:47 am »

Thanks,  using the OBiTALK Web Portal, I found and enter the expert section, but the field values within SP1 seems not editable(would not let me type anything in it). Thanks for you help.

I don't use the OBiTALK Web Portal as I find it requires much more effort than simply configuring the OBi directly.  There's also settings and status in the OBi that don't exist on the OBiTALK Web Portal.  Unless you need to configure an OBi that you don't have physical access to, in my opinion there isn't any value to using the OBiTALK Web Portal.  Consequently, I'm not the one best suited to give you instruction in this area.
Logged
jc2080
Newbie
*
Posts: 4


« Reply #6 on: August 31, 2011, 06:21:49 pm »

{ph,pp(290123456)} works for me without the ob in front.  Thanks for your help.
Logged
RonR
Forum Member

Posts: 4528


« Reply #7 on: August 31, 2011, 06:38:52 pm »

{ph,pp(290123456)} works for me without the ob in front.  Thanks for your help.

PP(ob290123456) is the documented format and the format the OBi itself uses when you dial **9290123456, so leave the 'ob' out at your own peril.   Smiley
Logged
RonR
Forum Member

Posts: 4528


« Reply #8 on: August 31, 2011, 08:16:08 pm »

I had same problem as above.

Followed directions logging into my OBI directly. 

It won't save my changes! I've tried 3 times now. Appears to save when I hit "submit" and I reboot the router, changes are never saved! I got back to {ph each time.

The solution is in Reply #3 above.  You MUST disable Auto Provisioning if you configure the OBi directly.
Logged
RonR
Forum Member

Posts: 4528


« Reply #9 on: August 31, 2011, 08:22:29 pm »

So I did this and now all incoming calls go directly to GV Voicemail.

Nothing rings.  Any ideas?

Recheck your changes.  It works.

If you can't find the problem, post the contents of the InboundCallRoute for Google Voice:

Voice Services -> SPx Service -> InboundCallRoute
Logged
traumahound
Newbie
*
Posts: 5


« Reply #10 on: August 31, 2011, 08:25:18 pm »

OK. I am a moron. 

Google Voice is automatically set to go straight to VM at 11pm which happened to coincide with this crap. Sorry.
Logged
traumahound
Newbie
*
Posts: 5


« Reply #11 on: August 31, 2011, 08:28:36 pm »

There seriously needs to be a walk through on this though.
Logged
Gabi
Newbie
*
Posts: 5


« Reply #12 on: October 22, 2011, 08:50:45 am »

Would that solution ring both phones? (physical and soft)

Thanks,

Gabi


In the following places:

Voice Services -> SP1 Service -> InboundCallRoute
Voice Services -> SP2 Service -> InboundCallRoute
Voice Services -> OBiTALK Service -> InboundCallRoute
Physical Interfaces -> LINE Port -> InboundCallRoute

change ph or {ph} to {ph,PP(ob290123456)}

where 290123456 is your OBiON App OBiTALK number.

Logged
RonR
Forum Member

Posts: 4528


« Reply #13 on: October 22, 2011, 09:41:46 am »

Would that solution ring both phones? (physical and soft)

Thanks,

Gabi


In the following places:

Voice Services -> SP1 Service -> InboundCallRoute
Voice Services -> SP2 Service -> InboundCallRoute
Voice Services -> OBiTALK Service -> InboundCallRoute
Physical Interfaces -> LINE Port -> InboundCallRoute

change ph or {ph} to {ph,PP(ob290123456)}

where 290123456 is your OBiON App OBiTALK number.


Yes.  The first one to answer receives the call.
Logged
Gabi
Newbie
*
Posts: 5


« Reply #14 on: October 22, 2011, 03:34:40 pm »

Works perfectly now. Thanks again Ron.
Logged
Santa
Newbie
*
Posts: 1


« Reply #15 on: February 02, 2012, 10:25:01 am »

First, thanks to everyone.  This is exactly what I was looking for.  A couple of variations I found with v1.3:

1) To disable auto provisioning (so I could save the changes), I had to disable:

  System Management > Auto Provisioning > ITSP Provisioning, AND
  System Management > Auto Provisioning > OBiTalk Provisioning

2) When I went to Voice Services > OBiTALK service, settings to change inbound call route, it had this big long thing in it, that already had my 290xxxxxx number in it, so I just left it alone.

3) I've got a OBi100, so there's no Physical Interface > LINE Port to change. (I'm guessing that's for the OBi110)
« Last Edit: February 02, 2012, 10:27:47 am by Santa » Logged
Tatus
Newbie
*
Posts: 3


« Reply #16 on: February 14, 2012, 06:12:55 pm »

In the following places:

Voice Services -> SP1 Service -> InboundCallRoute
Voice Services -> SP2 Service -> InboundCallRoute
Voice Services -> OBiTALK Service -> InboundCallRoute
Physical Interfaces -> LINE Port -> InboundCallRoute

change ph or {ph} to {ph,PP(ob290123456)}

where 290123456 is your OBiON App OBiTALK number.


I did everything like here, but it did not work.
When I have {ph,PP(ob290123456)} or {PP(ob290123456), ph} only the phone rings, but not X-Lite.
When just  {PP(ob290123456)} then X-Lite rings.
Logged
RonR
Forum Member

Posts: 4528


« Reply #17 on: February 14, 2012, 06:20:06 pm »

I did everything like here, but it did not work.
When I have {ph,PP(ob290123456)} or {PP(ob290123456), ph} only the phone rings, but not X-Lite.
When just  {PP(ob290123456)} then X-Lite rings.

That does not compute.
Logged
Tatus
Newbie
*
Posts: 3


« Reply #18 on: February 14, 2012, 06:24:54 pm »

I did everything like here, but it did not work.
When I have {ph,PP(ob290123456)} or {PP(ob290123456), ph} only the phone rings, but not X-Lite.
When just  {PP(ob290123456)} then X-Lite rings.

That does not compute.


Why? What should I correct?

Here is Log
Quote
Call 1   02/14/2012    20:56:35   

Terminal ID   GoogleVoice2   
Peer Name      
Peer Number   1xxxxxxxxx   
Direction   Inbound   Inbound
20:56:35   Ringing   Forking to:OBiTALK1(ob290xxxxxx), PHONE1
20:56:49   End Call   

In this case only phone rings.

Quote
erminal ID   GoogleVoice2   OBiTALK1
Peer Name      
Peer Number   1xxxxxxx   ob290xxxxxx
Direction   Inbound   Outbound
20:55:23   Ringing   
20:55:30   End Call
just  {PP(ob290123456)}
In this case X-Lite rings.
« Last Edit: February 14, 2012, 06:32:07 pm by Tatus » Logged
RonR
Forum Member

Posts: 4528


« Reply #19 on: February 14, 2012, 06:27:31 pm »

{pp(ob290123456),ph} is correct and should work.  It does for me and everyone else.  There's nothing to correct.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC