July 17, 2018, 06:43:19 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Firmware 3.2.2 Build 5898) breaks PhonePower. Need to revert to 3.2.2 build 5757  (Read 481 times)
rl4265
Newbie
*
Posts: 6


« on: July 12, 2018, 09:35:58 pm »

How do I revert my Obi 202 to 3.2.2 build 5757.  I'm out of warranty and am uncomfortable paying to fix a problem caused by Obihai's latest firmware update.

My Obi 202 and PhonePower have been rock solid for several years, but lately I have had issues:

I was on call using my home line, I got dumped and when I tried to reconnect, I got message that service provider rejected call, Code 403.  I tried another number with the same result.  Both numbers were Verizon numbers.

I reported this to PhonePower and they replied:

We have recently discovered that the most recent firmware upgrade by obihai 
is the cause of the issues that  you and other Obihai device users are currently experiencing.

Issues:

1) Constant loss of registrations (stacked registration agents showing on the account)

2) Calls dropping while in progress at random times.

3) Problems with ATT phones with built in answering machines.

The faulty version is 3.2.2 Build 5898EX   You can Check your version by dialing * * * 01#

Until Obihai releases a fix  to this version the only option is have Obihai Support assist with rolling
back the firmware to a previous version (3.2.2 build 5757) that does not have any known problems.
Logged
A_Friend
Jr. Member
**
Posts: 77


« Reply #1 on: July 13, 2018, 09:12:06 am »

There wasn't a v.3.2.2 Build 5757EX.  That build was v.3.2.1.  The first v.3.2.2 I heard about was build 5859EX. 

You can download the firmware here:  http://fw.obihai.com/OBi202-3-2-1-5757EX.fw

If you're not sure how to load it, I recommend the Device Administration Guide, here:
https://www.obitalk.com/info/documents/admin_guide/OBiDeviceAdminGuide.pdf

I've read some things suggesting you may not be able to revert to that version, though.  Something about a test in the newer firmware that prevents it.  I'm not sure, though, so you should try it.

If that doesn't work, this is the last pre-Polycom version:  http://fw.obihai.com/OBi202-3-2-2-5859EX-198839.fw  which I believe you can "downgrade" to.  it was pretty stable on my Obi200 running GV, voip.ms, and callcentric.

Best of luck.  Let us know what happens.
« Last Edit: July 13, 2018, 09:15:52 am by A_Friend » Logged
rl4265
Newbie
*
Posts: 6


« Reply #2 on: July 13, 2018, 11:53:49 am »

Thanks so much.  I downloaded the http://fw.obihai.com/OBi202-3-2-2-5859EX-198839.fw firmware as you suggested, but am concerned that I may break things.  I decided to spend the $10 for Obihai tech support.  The link didn't work well, but finally, I got an Amazon payments processing message, but no key etc. 

I went through voicemail hell at Obi trying to unsuccessfully get to a live person, but was able to leave a message.  Hopefully someone will phone me back.  This is totally unlike the support I've gotten from Obi before and very disappointing.  I hope that Obihai and Polycom can get it together.  I've been a loyal customer since Obi 100 days and have recommended them to many others but if I can't get support, I have a real problem.

I'm going to leave things alone until I get guidance from Obi (or more direction from PhonePower) because I'd rather deal with random issues than change breaking everything.

I do have the device admin guide and will review it.
Logged
BenE
Newbie
*
Posts: 1


« Reply #3 on: July 13, 2018, 09:36:06 pm »

I have the same problem as the OP (except on a new OBI200), however I was able to downgrade to 3.2.2 5859 after figuring out how to prevent the auto update back to 5898.  Unfortunately, that didn't solve the issue for me.  I was able to get registration using the template that phonepower sent me, but eventually all 4 of the registration spots  get filled up, and then gives me the 403 error.

I tried downgrading to 5757, but you get a checksum error

Kind of a bummer as my old OBI100 was working fine with phonepower until June, until GV failed, so I had to get the OBI200.  Now the situation has flipped... no phonepower, but GV works.
Logged
HunterGatherer
Newbie
*
Posts: 6


« Reply #4 on: July 14, 2018, 04:06:23 pm »

I'm in the same boat.  Obi needs to take a look at this.
Logged
soobong
Newbie
*
Posts: 5


« Reply #5 on: July 16, 2018, 05:08:21 pm »

Hello! I also have been using Obi110 for a very long time and all of a sudden, I am Offline so I was forced to purchase the Obi200. I tried to connect and register, but unfortunately, I failed. I had to ask phonepower for e-mail and they gave me all the instructions for the full hand config while the SIP Credential is open at phonepower,(which I did not have to before)... Anyhows, currently, I am trying to retry and after many tries, and to re-config and revert and resets, I still have no 100% connection with phonepower.  Also, Phonepower is just waiting for obitalk to figure this problem, until then phonepower is asking too see if i can roll back to the previous firmware which there is no problem.

1. Anyone know how to roll back to previous firmware? I was able to download the previous firmware which is 3.2.1. 5757?

2. any good results? please share...

3. am i doing something wrong? Please help me!!!   
Logged
Mango
Hero Member
*****
Posts: 547


« Reply #6 on: July 16, 2018, 05:38:21 pm »

There have been no firmware updates to the OBi110 for months/years.  The changes that require purchase of an OBi200 are only related to Google Voice, which does not affect you since you use PhonePower.  Barring a hardware failure (lighting strike, power surge, etc) your 110 should still work.

Unless you're the same dude on DSLR under a different name, you are the second person who reports issues with the 110 as well as the 2xx's new firmware.  Conspiracy theory: PhonePower made some fundamental change to how their switches work and this is not an Obihai problem at all.

Until someone does a SIP trace to find out exactly why their setup is failing, any troubleshooting will be a shot in the dark.
Logged

soobong
Newbie
*
Posts: 5


« Reply #7 on: July 16, 2018, 05:55:11 pm »

Hello

Thank you for the reply...

Yes, I have no problems with Obi, I believe phonepower is saying that Obihai had updated firmware and it is causing the problem... that Obitalk/Polycom should fix the problem.  Anyhoos, I am still stuck with no phone line... Boo Hoo Hoo...   anyone else with any other thoughts. Please reply...
Logged
soobong
Newbie
*
Posts: 5


« Reply #8 on: July 16, 2018, 06:39:05 pm »

Hello,

Anyone, who has the problem with Phonepower... about 5 minutes ago, I had Google voice setup in SP1 and Phonepower on SP2 with SP2 that has no re-configuration.  It has been 7 minutes.  I want to see how long it will last, but they only problem is that I have to keep SIP Credential open(why?, otherwise, the system will be disconnected...) maybe in about 30 minutes or so, i will try to close, i will share any results later. Currently, GV is Connected, phonepower is registered and I can make calls OK. did not try incoming calls yet.
Logged
soobong
Newbie
*
Posts: 5


« Reply #9 on: July 16, 2018, 07:09:28 pm »

Hello,

Phonepower at SP2 and GV on SP1 is currently working A-OK, but the odd thing is that I have to keep SIP Credentials at Phonepower, why? I am going to try to shut down at 1 hour 1 min./  Currently, I have been on for 39 minutes.
Logged
soobong
Newbie
*
Posts: 5


« Reply #10 on: July 16, 2018, 07:12:22 pm »

Sorry. Phonepower SP2 has failed after about 15 minutes or so...

hmmm...
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC