November 12, 2018, 11:19:36 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: "Do not ring" on 1032/1062  (Read 2508 times)
Marc
Full Member
***
Posts: 83



« on: July 13, 2018, 09:17:46 pm »

I've been looking for a way to set a single SP on "Do not ring."  I have only found a way to set it for the entire device.

Anyone know how to set it for an SP and not the whole phone?

Thank you.

[Edit: Sorry about the quadruple post. I kept getting an error, "Couldn't get mail server response codes" when I submitted the post and assumed they weren't getting posted.  I've deleted all the extra topics.]
« Last Edit: July 13, 2018, 09:22:17 pm by Marc » Logged

OBi110 (stored in closet now,) OBi202 x 14, OBi1032 x 3, OBi1062 x 3
N7AS
Sr. Member
****
Posts: 376



« Reply #1 on: July 14, 2018, 02:21:05 am »

If you do not want a specific sp not ring.

Go to
Voice Services > SPx

change

X_InboundCallRoute: {ph}

to

X_InboundCallRoute: {}

« Last Edit: July 14, 2018, 02:26:04 am by N7AS » Logged

Grant N7AS
Prescott Valley, AZ
Marc
Full Member
***
Posts: 83



« Reply #2 on: July 14, 2018, 12:18:31 pm »

Thanks for the reply.

I made the change, rebooted the phone... but for some reason it's still ringing.

Logged

OBi110 (stored in closet now,) OBi202 x 14, OBi1032 x 3, OBi1062 x 3
azrobert
Hero Member & Beta Tester
*****
Posts: 3626


« Reply #3 on: July 14, 2018, 12:58:45 pm »

Your inbound route is blank and not {}
Did you forget to enter it or did OBiTalk not accept it?
Blank will default to ph
Do you want to turn this blocking on/off without making config changes?
Logged
Marc
Full Member
***
Posts: 83



« Reply #4 on: July 14, 2018, 02:16:51 pm »

I misunderstood the need for the brackets since ph was the default, not {ph}

I put {} in and it no longer rings but appears to be doing so by sending the ITSP some sort of signal that it's not there.  That results in the ITSP ringing the failover line.

I guess I should explain what I'm trying to accomplish...  I live in a rural area where internet and/or power outages are somewhat common.  I have my primary VoIP lines ringing ring groups that consist of a local extension that I use and the extension on SP2.  When the internet or power is down, the server won't be able to communicate with with the phones/ATAs and thus the failover for this one service will ring the home copper line.  I maintain the copper line for emergencies.

My main number is google voice.  Unfortunately GV doesn't have hunt groups.  So this is the next best option... but only if I can figure out a way to silence the ring on this 1 SP.

Thanks.
Logged

OBi110 (stored in closet now,) OBi202 x 14, OBi1032 x 3, OBi1062 x 3
azrobert
Hero Member & Beta Tester
*****
Posts: 3626


« Reply #5 on: July 14, 2018, 03:01:13 pm »

I still don't understand what you're doing. I assume you don't want the device to ring, but the calling service think it's ringing.

Setup a ring pattern to ring for 0 seconds and silence for 60
Ring Settings -> Ring Profile A -> Ring Pattern 10
RingPattern: 60;(0+60)

Point SP2 to this ring pattern
SP2 Service -> DefaultRing: 10

Set the phone to ignore it's ring tone and use the ring patterns
User Settings => User Preferences -> DefaultRingtone:
/data/ringtones/Bell C.dat

Edit:
You can change the RingTone from the phone's display under Preferences to make SP2 ring again.

Edit2:
I forgot to tell you to change the inbound route back to ph.
« Last Edit: July 14, 2018, 03:33:06 pm by azrobert » Logged
Marc
Full Member
***
Posts: 83



« Reply #6 on: July 14, 2018, 07:07:01 pm »

Thank you.  That makes sense and sounds like the solution I've been looking for.  I'll give it a go.

You're right about what I'm looking to do.

Thanks!

Edit:  That worked perfectly!  Thanks again for the help.
« Last Edit: July 14, 2018, 07:26:04 pm by Marc » Logged

OBi110 (stored in closet now,) OBi202 x 14, OBi1032 x 3, OBi1062 x 3
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC