December 16, 2018, 07:12:32 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Setting up with service from OnSip.com  (Read 12684 times)
GuyOnTheAir
Newbie
*
Posts: 3


« on: September 01, 2011, 11:41:39 am »

I'm trying to set up my Obi to use service from OnSip.com.  OnSip has provided me these credentials:

Address of Record: username@company.onsip.com
SIP Password: randomcharacters 
Auth Username: company_username
Username: username
Proxy/Domain: company.onsip.com

I've put the proxy/domain address above in the Service Provider Proxy Server, and Outbound Proxy Server and the Auth Username above in the Username field.  At first it says it's not configured.  Then eventually I'll get a "Register Failed: 403 Forbidden".

Any ideas on this?  I'm kind of a newbie to setting up stuff like this, and wouldn't consider myself an advanced user that understands most of what I'm doing, here!
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #1 on: September 01, 2011, 12:09:14 pm »

Starting with the OBi at factory defaults, the following settings should get you registered with OnSIP on SP1:


Service Providers -> ITSP Profile A -> General -> Name : OnSip

Service Providers -> ITSP Profile A -> SIP -> ProxyServer : (onsip proxy server hostname)

Voice Services -> SP1 Service -> AuthUserName : (your sip username)

Voice Services -> SP1 Service -> AuthPassword : (your sip password)

Voice Services -> SP1 Service -> CallerIDName : (your callerid name)

Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service
Logged
GuyOnTheAir
Newbie
*
Posts: 3


« Reply #2 on: September 07, 2011, 09:41:25 am »

Hi, RonR.

Thanks for your response.

I'd set up SP1 to be a Google Voice number, so tried to configure, using your instructions with ITSP Profile B, and SP2.

At first I tried through the expert configuration of the Obitalk Web site, but as that was not working, I logged in via my Obi IP address, and configured there.  I rebooted when finished. 

I did not need OnSip to be my primary line, so left that setting alone.

The ObiTalk web site still shows nothing configured for Service Provider 2, and when I dial **2 to force a call out OnSip I end up with a "no service provider configured" message.

I used company_username for my AuthUserName, and put my name for the callerid name.  Have I messed something up?  Would the ObiTalk Web site show the configuration created directly via IP address?

Thanks for your response.
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #3 on: September 07, 2011, 09:45:14 am »

When you logged into the OBi directly and configured it, did you also disable Auto Provisioning?  If not, the OBiTALK Web Portal will overwite the OBi's settings as soon as you reboot.
Logged
OBiSupport
Administrator
****
Posts: 259


« Reply #4 on: September 09, 2011, 08:34:10 am »

We suggest you use the OBi Expert configuration pages to make modifications such as this -- No need to disable provisioning.

This is especially useful when you have OBi devices dispersed throughout a country or the world. From your single OBiTALK web portal log-in you may control your OBi devices with a great deal of granularity and control.
Logged
kb_hunter
Newbie
*
Posts: 9


« Reply #5 on: September 10, 2011, 03:33:41 pm »



I have read the above 4 posts, but I am still not sure how to configure Onsip.

I have GV working on port 1.

For second port, I just got my Onsip credentials.

The SIP credentials they sent me are:
=======================
Username: ununun
Authentication Username: getonsip_ununun
SIP address: ununun@getonsip.com
SIP Password: w8bQpwrmsziYbKQx7
Domain: getonsip.com
Outbound Proxy: sip.onsip.com
========================

Can someone please let me know how to match the above with what obihai is asking me to fill in?
=========================
Configuration Name : (I guess this is up to me: I will call this OnSIP)   
Make This the Primary Line to Call Out   : (I will answer this No)
7-Digit Dialing for USA & CAN   (Optional)      (If I have 408 as my actual physical area code, and the number linked with with this SIP is 425, what should I enter here? 408, or 425)
Service Provider Proxy Server   (PLEASE HELP)
Service Provider Proxy Server Port   (auto filled to 5060; is that correct?)
Outbound Proxy Server   (PLEASE HELP)
Outbound Proxy Server Port   (auto filled to 5060; is that correct?)
User Name    (PLEASE HELP)
Password    (PLEASE HELP)
URI    (PLEASE HELP)
 =================================

I have tried various plausible combinations. Nothing seems to work; I keep getting
Register Failed: 403 Forbidden (server=199.7.175.100:5060; retrying)

At this time, I am not using any soft phone at all. Just trying to use the connected physical device  (cordless phones).

Thanks much.
Logged
Everton
Full Member
***
Posts: 163


« Reply #6 on: September 10, 2011, 05:32:00 pm »

Do you have a spare ATA lying around that you can use to test your Onsip Credentials?  If not, can you try one of the free softphones like X-Lite?  Maybe the password/username is incorrect?  Have you contacted OBi Support for help or Onsip and/Onsip forum(?)?
Logged
kb_hunter
Newbie
*
Posts: 9


« Reply #7 on: September 10, 2011, 06:24:12 pm »


No I don't have a spare ATA.

But I did try downloading a softphone for the exact same reason you mentioned. Looking at the user rating for x-lite on CNET and I went with 3CX. But I had a similar problem there too.

I don't think my issue is invalid credentials (although it is a definite and distinct possibility). I am just not familiar with the terminology of SIP lingo. So I don't think I am entering the correct values for the fields requested. That is the reason I gave the format in which I received, and all the fields that need to be filled in and was asking what goes in where. Things like "domain name", "Proxy server", "Authentication USER_ID" etc. etc.

3CX configuration is asking a whole set of different questions which also I am not sure how they map to the values I received the SIP service provider. I have no reason to doubt the validity of the credentials as the sign up went smoothly and I received a "success" confirmation mail with all the credentials from OnSIP.
Logged
Everton
Full Member
***
Posts: 163


« Reply #8 on: September 11, 2011, 05:16:04 am »

I will give it a try:  Using RonR's settings above and modifying it for SP2:


Starting with the OBi at factory defaults, the following settings should get you registered with OnSIP on SP2:


Service Providers -> ITSP Profile B -> General -> Name : OnSip

Service Providers -> ITSP Profile B -> SIP -> ProxyServer : getonsip.com;  (Is it "getonsip.com" or "get.onsip.com"?)

Voice Services -> SP2 Service -> AuthUserName : ununun

Voice Services -> SP2 Service -> AuthPassword : w8bQpwrmsziYbKQx7

Voice Services -> SP2 Service -> CallerIDName : whatever you like

Voice Services -> SP2 Service -> X_ServProvProfile : B

Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service
----------------------------------------------------------------------------------------------------------
From Onsip Information:  For most SIP devices, there are only five fields which must be entered in order for the SIP device to register with Junction Networks. Those fields are:

+ SIP Address (Address of Record)
+ SIP Password
+ Auth Username
+ Username
+ Proxy/Domain

Each SIP device may call these fields something different. Here are some examples:

SIP Address may be called => address
SIP Password may be called => auth password or just password
Auth Username may be called => authorization username or auth user id
Username may be called => user, phone number or user id
Proxy/Domain may be called => proxy, domain, registrar, registrar server or SIP server

Your device provides support for using an "outbound proxy" and it should be set. However, in many cases this setting is not in the same configuration section as the user settings. Nonetheless, set it to:

sip.onsip.com
----------------------------------------------------------------------------------------------------------

Configuration Name : OnSIP   
Make This the Primary Line to Call Out   : No
7-Digit Dialing for USA & CAN : 425 or leave Blank
Service Provider Proxy Server: getonsip.com; (Is it "getonsip.com" or "get.onsip.com"?)
Service Provider Proxy Server Port (ProxyServerPort): 5060
RegistrarServerPort: 5061
Outbound Proxy Server (OutboundProxy): sip.onsip.com
Outbound Proxy Server Port:5061
User Name: ununun
Password:    w8bQpwrmsziYbKQx7
URI:           leave blank

See:

http://www.junctionnetworks.com/knowledgebase/onsip/phones-routers-and-devices/phone-configuration/linksys/linksys-and-sipura-phones
« Last Edit: September 11, 2011, 06:08:16 am by Everton » Logged
kb_hunter
Newbie
*
Posts: 9


« Reply #9 on: September 11, 2011, 02:59:52 pm »

At this point, I am not sure what to do.

I have tried the suggestions give by Everton.. Still doesn't want to register.

At this point, I think the one that will be of most help, and probably the only one that will help is to hear from  someone who has actually registered an getonsip sip registration. Their website is www.getonsip.com

Of course if Obihai would add Onsip to one of the supported SIP providers and provide a named configuration page that would help too.

Again the problem seems to be is what to enter in each of the fields although I seem to have all the information.

For username I have the following options:
username, username@getonsip.com, getonsip_username
For ports I am not sure whether to enter: 5060 or 5061 (above one of them is marked as 5061)
Not sure what to enter for or if to enter anything for: Service provider proxy server
Outbound proxy server: I am entering sip.onsip.com (this one appears to be correct)

I have pretty much exhausted all possible combinations at this time.
-------------------------------------------------

Okay.. this is the update I have..

I downloaded X-lite
I also downloaded the Obi-PC App. (apparently this is needed; not sure of the mechanics)
I ran the Obi-PC App; I also fired up the X-lite

I entered my Onsip credentials into the X-lite config.

Voila.. I am able to receive calls made to the number I registered with ipKall, which links to the onSIP registration. The call rings in X-lite and I am able to talk/hear both ways.

So that is a massive improvement and kind of validates a lot of things.

But, still I am not able to make outgoing calls from X-lite.

The problem of being unable to configure SIP-2 using the On-SIP credentials on the Obi box still very much remains.  
====================
After mulling over it a bit, I realized that Obi PC-App wasn't doing anything at all in my case, as the X-lite is connecting directly to the SIP service provider. I feel really stupid... I logged out of Obi-Pc-App and exited it, and everything else worked as before..

I also realized that I am not able to make outgoing calls because OnSIP doesn't provide for dialing PSTN numbers. It appears dialing SIP addresses works fine as I dialed my own address, and the call is looping back and I show an incoming call which I can attend, and my original call is put on hold!! Pretty cool, but right now practically useless! :=)

BACK TO SQUARE 1.  The root topic of this forum.. configuring Obi Box to set up the SIP provider (OnSIP) that is failing.. Any help would be appreciated. Thanks.
====================
« Last Edit: September 11, 2011, 07:17:37 pm by kb_hunter » Logged
OBiSupport
Administrator
****
Posts: 259


« Reply #10 on: September 13, 2011, 02:19:38 pm »

Please contact our support team at support@obihai.com if you still experience the problem, and inform us the 9-digit number in your support ticket. We like to assist you on the registration issue.
Logged
kb_hunter
Newbie
*
Posts: 9


« Reply #11 on: September 14, 2011, 06:42:38 pm »


All right. I contacted Obi support and with their help this issue is now resolved.
Thanks Obi support.


This is what I had to do:
The ones on the left are Obitalk names; and the ones on the right are onsip terminology. The ports can be left at the default number 5060.

What threw me off completely and not very intuitive were the username fields. I still don't know what URI means. But I can live with that for a while!
==============================
Proxy Server = getonsip.com
Outbound Proxy Server = sip.onsip.com
User Name =  "Authentication username"
Password = "SIP Password"
URI= "Username"
==============================
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2317



« Reply #12 on: September 14, 2011, 07:47:21 pm »

What is a SIP-URI? ( http://www.3cx.com/PBX/SIP-URI.html )

A SIP URI is the SIP addressing schema to call another person via SIP. In other words, a SIP URI is a userís SIP phone number. The SIP URI resembles an e-mail address and is written in the following format:

SIP URI = sip:x@y:Port
Where x=Username and y=host (domain or IP)

Examples:
sip:joe.bloggs@212.123.1.213
sip:support@phonesystem.3cx.com
sip:22444032@phonesystem.3cx.com

The SIP URI standard has been defined in the RFC 3261 standard.
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC