Incoming calls don't ring on Obi

Started by qwer, July 31, 2018, 01:03:10 PM

Previous topic - Next topic

qwer

Hi all. I set up my obi 200 with Google Voice. I can make calls with the phone without a problem, but incoming calls don't ring on the phone. I saw in these posts that the standard fix for this is to check the "forward to chat" box in Google voice, but I don't have such a box. Instead, there is a box that says "forward to Obi...." and the box is checked. I tried resetting the obi but nothing seems to work. Please help!

bill-cary

IF you started from scratch with a factory default 200, added it to OBI, then configured to GV it should be setup properly. IF you changed things, all bets are off and it may be easier to start over.
However, you can check that Voice Services/SPx Services/X_InboundCallRoute = ph

That, and possibly your handset ringer is bad OR maybe you have too many handsets connected. I think it only support about 3 ringer equivalence == maybe less.

qwer

Thanks for your reply.
The obi 200 was new and unused and I did't change anything on it. I checked, and X_InboundCallRoute = ph
The phone ringer worked fine yesterday, before I connected it to the obi, and I have only one handset connected. Any ideas?

SteveInWA

The first troubleshooting step is to delete the Google Voice SP off of the OBiTALK dashboard, then add it back again.  Does that fix it?


SteveInWA

#5
Updated on 4/20/2021:


  • You will be transferring the Google Voice number back and forth, between two different Google accounts (A Google account is accessed via a signing in with a Gmail address and password).
  • If you already happen to have another Google account that does not have its own Google Voice number, then you'll use that account.  If you don't have another Google account, then create one just for this purpose.  You can just abandon and/or delete the second Google account when you're done.
  • Sign into the new/temporary Google account.  Go to the Google Voice page:  https://voice.google.com/.  Follow the steps to get a new Google Voice phone number, up to, and including the step where you will agree to Google's Terms of Use.  After you have done that, exit out of the procedure (you don't want to get another Google Voice number, but you can only transfer a number to a Google account that has "accepted ToS" status.
  • Sign into the Google account that holds the problematic GV number ("Account #1") and go to the settings page:  https://voice.google.com/settings, and click the "TRANSFER" link next to the GV number.  Press Ctrl-T to open another browser tab, and sign into the other Google account ("Account #2").  Follow the instructions to transfer the number from one account to the other:  https://support.google.com/voice/answer/1065667#googlexfer
  • Open another browser tab, and sign into your OBiTALK dashboard:  http://www.obitalk.com/obinet/pg/obhdev
  • Click on the SPx that is now configured to use Google account #1.  Click the link to change the Google account credentials.  Follow the instructions, to select account #2 instead of account #1.  After it completes configuring the Google Voice number, test calling both ways.
  • If it now works properly, then reverse the steps above, to transfer the number back to the account #1.  Test calls again. It should now work on account #1.
  • If any of these steps fail, please describe the step you are on, and what, exactly, happens.

qwer


SteveInWA

Quote from: qwer on July 31, 2018, 06:30:27 PM
It works! Thanks a million!

Yayyyy!!!  You got me to document the fix, so now I can just point people to it.  Thanks.

Redw00d

Another thing that DIDN"T work.. sigh

Quote from: SteveInWA on July 31, 2018, 06:00:23 PM
OK, then the next steps are:

  • You will be transferring the Google Voice number back and forth, between two different Google accounts (A Google account is accessed via a signing in with a Gmail address and password).
  • If you already happen to have another Google account that does not have its own Google Voice number, then you'll use that account.  If you don't have another Google account, then create one just for this purpose.  You can just abandon and/or delete the second Google account when you're done.
  • Sign into the Google account that holds the problematic GV number ("Account #1") and go to the settings page:  https://voice.google.com/settings, and click the "TRANSFER" link next to the GV number.  Press Ctrl-T to open another browser tab, and sign into the other Google account ("Account #2").  Follow the instructions to transfer the number from one account to the other:  https://support.google.com/voice/answer/1065667#googlexfer
  • Open another browser tab, and sign into your OBiTALK dashboard:  http://www.obitalk.com/obinet/pg/obhdev
  • Click on the SPx that is now configured to use Google account #1.  Click the link to change the Google account credentials.  Follow the instructions, to select account #2 instead of account #1.  After it completes configuring the Google Voice number, test calling both ways.
  • If it now works properly, then reverse the steps above, to transfer the number back to the account #1.  Test calls again. It should now work on account #1.
  • If any of these steps fail, please describe the step you are on, and what, exactly, happens.

SteveInWA

Again:  stop cross-posting in other people's discussions.

Redw00d

Quote from: SteveInWA on August 06, 2018, 06:58:48 PM
Again:  stop cross-posting in other people's discussions.

Again,  Waiting for solutions.....just want my brand new Obi202 to Work with Google, AS Advertized....

thank you