November 17, 2018, 04:09:32 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2] 3
  Print  
Author Topic: Routing li1 Calls Between obi212 and obi202 Devices  (Read 4061 times)
dboling
Jr. Member
**
Posts: 72



« Reply #20 on: September 01, 2018, 09:20:32 am »

I have the same setup (routing line calls to another device) except I'm using an OBi110 and an OBi200. I tried to reproduce your problem and couldn't get a 404 error. Your devices have the same subnet. Are you running them in bridge mode? I don't own an OBi2x2 and not familiar with all the settings, so you might need to get someone else to help.

You can get it to work over the OBiTalk network until you fix this.

## OBI212 Config
Physical Interfaces>LINE Port
InboundCallRoute:  ph,pp(510111111)

Replace 510111111 with the OBi number of the OBi202

## OBI202 Config
Voice Services>OBiTalk Service
InboundCallRoute: ph

This is the default, but the setup process might add code to send calls to the Auto Attendant.


I think the problem is with the OBI202. In order for the OBI212 to connect to it must have and open port to connect to. I'm not sure if it's UDP or TCP or if the OPI202 has firewall rules for each terminal. My first port scan was with fing which I don't trust. Currently I'm running a full UDP scan from the server using nmap, it's going to take a bit to complete.

[root@athome ~]# nmap -v -sU 192.168.3.61
PORT      STATE         SERVICE
53/udp    open|filtered domain
67/udp    open|filtered dhcps
10000/udp open|filtered ndmp

[root@athome ~]# nmap -v -r -sT 192.168.3.61
PORT   STATE SERVICE
53/tcp open  domain
80/tcp open  http

For some reason the OBI202 isn't providing a port.
« Last Edit: September 01, 2018, 09:31:05 am by dboling » Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #21 on: September 01, 2018, 10:39:20 am »

It's UDP

ServicesProviders>ITSP Profile x SIP ProxyServerTransport: UDP
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #22 on: September 01, 2018, 11:41:03 am »

I have the same setup (routing line calls to another device) except I'm using an OBi110 and an OBi200. I tried to reproduce your problem and couldn't get a 404 error. Your devices have the same subnet. Are you running them in bridge mode? I don't own an OBi2x2 and not familiar with all the settings, so you might need to get someone else to help.

You can get it to work over the OBiTalk network until you fix this.

## OBI212 Config
Physical Interfaces>LINE Port
InboundCallRoute:  ph,pp(510111111)

This works for a temp fix. I'm guessing it won't work if Internet connection is down ?
 

Replace 510111111 with the OBi number of the OBi202

## OBI202 Config
Voice Services>OBiTalk Service
InboundCallRoute: ph

This is the default, but the setup process might add code to send calls to the Auto Attendant.

Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #23 on: September 01, 2018, 12:33:12 pm »

This works for a temp fix. I'm guessing it won't work if Internet connection is down ?

It won't work when the internet is down or the OBiTalk network is having problems.
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #24 on: September 01, 2018, 02:16:35 pm »

This works for a temp fix. I'm guessing it won't work if Internet connection is down ?

It won't work when the internet is down or the OBiTalk network is having problems.

I don't know about you, but I'm tired with trying to get this to work correctly and need to take a break Smiley .

Either there's a bug in the software or OBI changed something in it's default configs. As a beta tester, maybe OBI will send you a OBI202 and OBI212 for you to test (N/C). I know on my end there is NO ports/IP's that are blocking and requests to the OBI units. 
Logged

-Diane
dboling
Jr. Member
**
Posts: 72



« Reply #25 on: September 04, 2018, 08:41:17 am »

I have the same setup (routing line calls to another device) except I'm using an OBi110 and an OBi200. I tried to reproduce your problem and couldn't get a 404 error. Your devices have the same subnet. Are you running them in bridge mode? I don't own an OBi2x2 and not familiar with all the settings, so you might need to get someone else to help.

You can get it to work over the OBiTalk network until you fix this.

## OBI212 Config
Physical Interfaces>LINE Port
InboundCallRoute:  ph,pp(510111111)

Replace 510111111 with the OBi number of the OBi202

## OBI202 Config
Voice Services>OBiTalk Service
InboundCallRoute: ph

This is the default, but the setup process might add code to send calls to the Auto Attendant.



I scanned all 65K+ ports on the OBI202 and found port 5083 to be open/filtered.

The wiki located at https://en.wikipedia.org/wiki/List_of_SIP_response_codes list the SIP error codes and for a 404 error code it says:

404 Not Found
The server has definitive information that the user does not exist at the domain specified in the Request-URI. This status is also returned if the domain in the Request-URI does not match any of the domains handled by the recipient of the request.[1]:21.4.5

What does the 0 represent in the config sp4(0@192.168.3.61:5083) ?

 
Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #26 on: September 04, 2018, 09:16:25 am »

The zero is data that is passed to the OBi202. This is a requirement of the SIP URI syntax. Calls will pass data and CallerID. You can test for these in the SP4 X_InboundCallRoute.

Format of an inbound route rule:
{ CallerID > data : dest}
 > is a separator
If only testing CallerID, separator is not required.

Examples:

{>0:ph}

Data = 0 and any CallerID will be sent to ph

{8005551212>800:ph}

Only CallerID 8005551212 and data 800 sent to ph

{8005551212:ph}

Only CallerID 8005551212 with any data sent to ph

ph or {ph}

All calls sent to ph
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #27 on: September 04, 2018, 09:37:25 am »

The zero is data that is passed to the OBi202. This is a requirement of the SIP URI syntax. Calls will pass data and CallerID. You can test for these in the SP4 X_InboundCallRoute.

Format of an inbound route rule:
{ CallerID > data : dest}
 > is a separator
If only testing CallerID, separator is not required.

Examples:

{>0:ph}

Data = 0 and any CallerID will be sent to ph

{8005551212>800:ph}

Only CallerID 8005551212 and data 800 sent to ph

{8005551212:ph}

Only CallerID 8005551212 with any data sent to ph

ph or {ph}

All calls sent to ph


sp4(0@192.168.3.61:5083)
OK, I thought the 0 in this line was like user@192.168.3.61:5083 .



The verizon PSTN(LI) port on the 212 does not have caller ID. The line only has dial tone and 911.
Does the line not having callerID make a difference  ?

I also do have a WIFI repeater between the OBI202 and the OBI212, when traffic is sent to the servers WIFI via the repeater, it uses the repeaters MAC address.

I've also enabled syslog for better diagnostics .
« Last Edit: September 04, 2018, 10:05:04 am by dboling » Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #28 on: September 04, 2018, 01:08:37 pm »

Is it possible for a test to put both devices on the same router? If you can't because of the Line connection, you can define a speed dial with the same rule to test.
sp4(0@192.168.3.61:5083)

I assume you are running the devices in Bridge mode because they have the same subnet. Is this correct?
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #29 on: September 04, 2018, 01:42:25 pm »

Is it possible for a test to put both devices on the same router? If you can't because of the Line connection, you can define a speed dial with the same rule to test.
sp4(0@192.168.3.61:5083)

I assume you are running the devices in Bridge mode because they have the same subnet. Is this correct?


They are both on the same subnet.

wlan0     Link encap:Ethernet  HWaddr F8:D1:11:6E:78:38 
          inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
          inet6 addr: fe80::fad1:11ff:fe6e:7838/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:119458670 errors:0 dropped:0 overruns:0 frame:0
          TX packets:150943485 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:94065641101 (87.6 GiB)  TX bytes:96751918482 (90.1 GiB)

I tested it a few dozen times today. I ran a tcpdump on wlan0 looking for the OBI212 to try and contact the OBI202 on port 5083. However there was no network traffic coming from the OBI212 on port 5083. I also unpluged the TP-link cpe210 (wireless relay) so both the OBI212  and OBI202 would be connected directly to the same access point, I still had the results.

There must be a bug in the firmware. Is there anyway to get OBI to check this out ?   
Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #30 on: September 04, 2018, 02:51:24 pm »

This is the setting I asked about:

Router Configuration -> Lan Settings -> OperationMode: Bridge
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #31 on: September 04, 2018, 03:00:37 pm »

This is the setting I asked about:

Router Configuration -> Lan Settings -> OperationMode: Bridge


Both OBI's are set to OperationMode:Router.

Both the OBI's have the wifi5G adapters installed and are not networked via LAN.
Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #32 on: September 04, 2018, 03:27:54 pm »

Maybe someone with an OBi2x2 can chime in on how to configure your setup. I still think you need to be in Bridge mode.
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #33 on: September 04, 2018, 03:54:05 pm »

Maybe someone with an OBi2x2 can chime in on how to configure your setup. I still think you need to be in Bridge mode.

I set both OBI's to bridge, but no connection.

syslog for the call is:

Sep  4 18:49:06 obi212  [DAA]: FXO ring off
Sep  4 18:49:18 obi212  [DAA]: FXO ring on
Sep  4 18:49:22 obi212  CCTL:NewCallOn Term 10[3] ->,0@192.168.3.61:5083
Sep  4 18:49:22 obi212  [DAA]: FXO ONHOOK MONITOR
Sep  4 18:49:22 obi212  RTP:Del Channel
Sep  4 18:49:53 obi212  [DAA]: FXO ring off
Logged

-Diane
dboling
Jr. Member
**
Posts: 72



« Reply #34 on: September 16, 2018, 08:54:17 am »

Maybe someone with an OBi2x2 can chime in on how to configure your setup. I still think you need to be in Bridge mode.

OK, I got this to work, well 1/2 work. I seem have call control issues .
Here are the following setting I used.

# Device IPs
OBI202: 192.168.3.61
OBI212: 192.168.3.60
SP4: Callcentric on both devices

## OBI212 Config
Physical Interfaces>LINE Port
InboundCallRoute:  ph,sp4(17771234567@192.168.3.61:5083)

Service Providers>ITSP Profile D>SIP
X_SpoofCallerID: Checked

## OBI202 and OBI212 Config
Service Providers>ITSP Profile D>SIP
X_DiscoverPublicAddress: Unchecked


Needed to use the username for callcentric instead of (0@192.168.3.61:5083).

Also needed to uncheck X_DiscoverPublicAddress: on both devices. Basically the OBI202 would get both rx and tx traffic and the OBI212 could only send tx traffic with no receive.

The issue that I seem to be having now is controlling the call between devices.
When I call I can talk and hear the call fine for 1/2 minute and I start getting (disconnect tone) but the call doesn't disconnect.

 The OBI212 does not recognize when either the incoming (LI) call hangs up or when the OBI202 hangs up. It seems to take about 3 minutes for the OBI212(LI) to go onhook after the call ends.

If I hang up the OBI202 first the OBI212 call log gives the error: Call Ended (481 Call Leg/Transaction Does Not Exist)

If I hang up the OBI212(LI) first I don't get any errors.

Either way the OBI212 will not go onhook unless both side of the call hangs up and even then the OBI212 takes about 3 minutes to go onhook.

## Syslog LOG ##
Sep 16 06:13:02 obi212  [DAA]: FXO ring on
Sep 16 06:13:06 obi212  CCTL:NewCallOn Term 10[3] ->,17771234567@192.168.3.61:5083
Sep 16 06:13:06 obi202  CCTL:NewCallOn Term 1[0] ->,17771234567
Sep 16 06:13:06 obi202  fxst_ccapi_new_call: 17771234567->17771234567 name
Sep 16 06:13:06 obi202  [SLIC] CID to deliver: '' 17771234567
Sep 16 06:13:06 obi202  PARAM Cache Write Back(256 bytes)
Sep 16 06:13:29 obi202  GAPI:Refreshing tk
Sep 16 06:13:29 obi202  GAPI:Refreshing tk
Sep 16 06:13:29 obi202  GAPI:Refreshing tk
Sep 16 06:13:29 obi202  TCP:Connect OK(lhttpc)47
Sep 16 06:13:29 obi202  Trying to connect ssl
Sep 16 06:13:29 obi202  TCP:Connect OK(lhttpc)48
Sep 16 06:13:29 obi202  Trying to connect ssl
Sep 16 06:13:29 obi202  TCP:Connect OK(lhttpc)49
Sep 16 06:13:29 obi202  Trying to connect ssl
Sep 16 06:13:30 obi202  TC:ssl connected
Sep 16 06:13:30 obi202  TC:ssl connected
Sep 16 06:13:30 obi202  TC:ssl connected
Sep 16 06:13:30 obi202  LHC:Response OK
Sep 16 06:13:30 obi202  GAPI:refresh tk ok
Sep 16 06:13:30 obi202  LHC:Response OK
Sep 16 06:13:30 obi202  PARAM Cache Write Back(256 bytes)
Sep 16 06:13:30 obi202  GAPI:refresh tk ok
Sep 16 06:13:30 obi202  LHC:Response OK
Sep 16 06:13:30 obi202  GAPI:refresh tk ok
Sep 16 06:13:31 obi202  PARAM Cache Write Back(512 bytes)
Sep 16 06:13:33 obi212  [DAA]: FXO ring off
Sep 16 06:13:33 obi212  RTP:Del Channel
Sep 16 06:13:33 obi202  RTP:Del Channel
Sep 16 06:13:33 obi212  [DAA]: FXO ONHOOK MONITOR
Sep 16 06:13:43 obi212  OB==>CRLFCRLF
Sep 16 06:13:43 obi212  OB==>CRLFCRLF
Sep 16 06:13:44 obi212  OB:<==CRLF
Sep 16 06:13:44 obi212  OB:<==CRLF 1
Sep 16 06:13:44 obi212  OB:<==CRLF
Sep 16 06:13:44 obi212  OB:<==CRLF 1
Sep 16 06:14:12 obi212  [DAA]: FXO ring on
Sep 16 06:14:16 obi212  CCTL:NewCallOn Term 10[3] ->,17771234567@192.168.3.61:5083
Sep 16 06:14:16 obi202  CCTL:NewCallOn Term 1[0] ->,17771234567
Sep 16 06:14:16 obi202  fxst_ccapi_new_call: 17771234567->17771234567 name
Sep 16 06:14:16 obi202  [SLIC] CID to deliver: '' 17771234567
Sep 16 06:14:22 obi202  [SLIC]:Slic#0 OFF HOOK
Sep 16 06:14:22 obi202  [CNG] cng_det_init 0.
Sep 16 06:14:22 obi202  RTP:DtmfTxMtd:1(1),0
Sep 16 06:14:22 obi202  [DSP]: set FXS(0) DTMF detection level to (3)
Sep 16 06:14:22 obi212  RTP:DtmfTxMtd:1(1),0
Sep 16 06:14:22 obi212  [DAA]: FXO OFFHOOK
Sep 16 06:14:22 obi212  [DAA]: detecting disconnect tone, reinit: 1
Sep 16 06:14:22 obi212  RTP:Start->c0a8033d:17102(80 160);0;0;0:0:0;0(43)
Sep 16 06:14:22 obi212  [DAA] FXO ring off
Sep 16 06:14:22 obi202  RTP:Start->c0a8033c:17104(80 160);0;0;0:0:0;0(45)
Sep 16 06:14:52 obi202  OB==>CRLFCRLF
Sep 16 06:14:52 obi202  OB:<==CRLF
Sep 16 06:14:52 obi202  OB:<==CRLF 1
Sep 16 06:15:09 obi202  OB==>CRLFCRLF
Sep 16 06:15:10 obi202  OB:<==CRLF
Sep 16 06:15:10 obi202  OB:<==CRLF 1
Sep 16 06:15:14 obi202  TCP:Broken Connection(HTTPD) 44 0
Sep 16 06:15:22 obi202  [SLIC]:Slic#0 ONHOOK
Sep 16 06:15:22 obi202  RTP:Del Channel
Sep 16 06:15:28 obi212  [LI0]  ---- S/W TONE ON (level: default) : , @ 354020 ----
Sep 16 06:15:35 obi202  OB==>CRLFCRLF
Sep 16 06:15:35 obi202  OB:<==CRLF
Sep 16 06:15:35 obi202  OB:<==CRLF 1
Sep 16 06:15:53 obi202  PRD:1st down
Sep 16 06:15:54 obi202  PRD:1st success
Sep 16 06:15:54 obi202  PRD:NOPriFbToTry
Sep 16 06:15:54 obi202  DLG:Retry1->cc0bc0a9:5080
Sep 16 06:15:59 obi212  Send() error 104
Sep 16 06:15:59 obi212  HTTPD: SendHeader Failed
Sep 16 06:16:40 obi212  IPC: Event 8
Sep 16 06:16:40 obi212  IPC: Event 7




 
Logged

-Diane
dboling
Jr. Member
**
Posts: 72



« Reply #35 on: September 17, 2018, 09:08:28 am »


OBi212 Line InboundCallRoute: ph,sp4(0@xx.xx.xx.xx:pppp)
xx.xx.xx.xx = IP address of OBi202
pppp = X_UserAgentPort of OBi202 SP4 Service

ITSP Profile D SIP
X_SpoofCallerID: Checked
Needed to pass CallerID

OBi202
ITSP Profile D SIP
X_DiscoverPublicAddress: Unchecked


I was able to get this to work  with sp4(0@xx.xx.xx.xx:pppp)
On the OBI202 I need to go to Voice Services>SP4 Service>X_EnforceRequestUserID and UnCheck it.

There is a bug on the OBI212 that causes it not to release the Line Port. I'm going to start a new topic in firmware regarding the bug.
Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #36 on: September 17, 2018, 10:14:28 am »

I was able to get this to work  with sp4(0@xx.xx.xx.xx:pppp)
On the OBI202 I need to go to Voice Services>SP4 Service>X_EnforceRequestUserID and UnCheck it.
The default is unchecked, so why was it checked? Did you use a wizard to define CC and it checked the setting?

Outbound OBi202 calls can be routed to Line. I can show you how if you're interested. I'm doing this on my OBi200/OBi110 and use a "9" prefix to identify these calls.
Logged
dboling
Jr. Member
**
Posts: 72



« Reply #37 on: September 17, 2018, 10:20:53 am »

I used the OBItalk web interface. The plan was to get it setup then dump the web interface. it was checked on both the OBI202 and OBI212.


I just posted at http://www.obitalk.com/forum/index.php?topic=14971.0 with the issue I'm having.
« Last Edit: September 17, 2018, 11:29:31 am by dboling » Logged

-Diane
dboling
Jr. Member
**
Posts: 72



« Reply #38 on: September 18, 2018, 06:01:27 am »

I was able to get this to work  with sp4(0@xx.xx.xx.xx:pppp)
On the OBI202 I need to go to Voice Services>SP4 Service>X_EnforceRequestUserID and UnCheck it.
Outbound OBi202 calls can be routed to Line. I can show you how if you're interested. I'm doing this on my OBi200/OBi110 and use a "9" prefix to identify these calls.

Yes, I'd like to set it up for when the internet in down, so I can dial 911 from the obi202 to the obi212 Line Port.

I only have incoming calls and 911 service on the Verizon landline.

Since nobody on this forum has any ideas what the issue is with my OBi212 I decided it must be defective and called Amazon for a replacement. It should be here in a few days.
« Last Edit: September 18, 2018, 07:29:51 am by dboling » Logged

-Diane
azrobert
Hero Member & Beta Tester
*****
Posts: 3632


« Reply #39 on: September 18, 2018, 10:40:14 am »

Yes, I'd like to set it up for when the internet in down, so I can dial 911 from the obi202 to the obi212 Line Port.

OBi202

Voice Services -> Gateways and Trunk Groups -> Voice Gateway 1
Name: OBi212
Access Number: sp4(xx.xx.xx.xx:pppp)
DigitMap: (911)
AuthUserID: dboling

xx.xx.xx.xx = IP address of OBi212
pppp = X_UserAgentPort of OBi212 SP4 Service

Physical Interfaces -> Phone1/2 Port
Add following to the beginning of the OutboundCallRoute:
{(Mvg1):vg1},

OBi212

ITSP Profile D SIP
X_DiscoverPublicAddress: Unchecked

SP4 Service -> X_InboundCallRoute:
{dboling>911:li},{ph}
Logged
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC