Nonstop phantom calls from PP1 / OBiTALK Service

Started by Mike1111111, January 19, 2021, 06:15:57 AM

Previous topic - Next topic

Mike1111111

I have been using my OBITalk202 with Google Voice for many years. Starting around 3 am ET (US) this morning I have been getting a constant stream of phantom calls from PP1 and these calls are sent to both my PH1 and PH2 phones. I get around one call every 10 minutes. These calls are dead air when I answer them. These calls are not showing up in the Google Voice call history and appear to be originating from the OBITalk network. According the the manual PP1 is the OBITalk service.

The calls are from these numbers:
PP1(ob37*910000002156)
PP1(ob184*6489)
PP1(ob184*9720000002156)

What are these call and how do I get them to stop? I tried unplugging my phone and OBITalk and plugging them back in.


***UPDATE with the fix
If other people are experiencing this issue, a fix is to go to the obitalk.com portal, enter the Expert Configuration, go to Voice Services > OBiTALK Service and change the InboundCallRoute value after unchecking the default checkbox. Values that work in this field are:
1. {(xxxxxxxxx):ph} /*only allow nine-digit phone numbers to ring phone 1*/
2. {} /*ignore all these OBiTALK service calls*/
3. {(290944186)>(xx.):SP1},{(290944186):aa} /*a modification of the default value to remove phone 1 and phone 2 from the call route*/

Other options along these lines would also work.

alivoiper

I have also been getting them. Any suggestions how to get them to stop? They keep coming in every 10 minutes.

azrobert

Send them to NoMoRobo the same way you send spam calls.

Voice Services -> ObiTalk Service -> InboundCallRoute :
{sp4(1877659xxxx@switch.starcompartners.com;ui=12126628642)}

Mike1111111

#3
I tried turning off Voice Services -> OBiTalk Service -> Enable : Uncheck
This setting change does not stick. It becomes checked again after the reboot.

I think the problem is something has gone wrong at OBitalk and hopefully they will fix the problem centrally. What I have been doing was immediately answering the call and hanging up. The other strategy is to update Google Voice to ring my cell phone instead of the OBITalk device and turn off the OBITalk modem until the issue is fixed.

I can try setting up a black list for these calls, but that takes some testing to see if I get the pattern correct. The calling numbers also change, but from what I see all of them have either ob184 or ob37 in them. I have a busy day at work today, so I don't have time to do this experiment until later.

I have a second OBi200 device on my network and that device is not experiencing this issue.

Mike1111111

I now realize that I misinterpreted your suggestion. It was to modify the InboundCallRoute of the OBiTalk service, which does not require a blacklist.

I tried changing this field, but like the enable checkbox, my change appears to revert to the default after the reboot. I was making the changes using the device IP address admin page. I will try changing this using the OBitalk portal to see if that helps.

azrobert

Use OBi Expert, not the local interface to modify the config.

These calls have a non-standard OBi number, so you can only allow 9 digit OBi numbers to ring.
Voice Services -> ObiTalk Service -> InboundCallRoute :
{(xxxxxxxxx):ph}

johnhattan

Same thing happening here. Started around 3am. It's been calling every few minutes. The phone displays it's coming from 1-190-000-4600.

These calls are not showing up in my GV call log, so there's no way to block them there.

For now, I'm just going to unplug the phone and keep an eye on this thread in the hopes that someone can figure out what's happening.

jsg68

Same problem here.  I submitted a ticket to support.

First call, 9:42pm eastern last night.  Googled for info, found to change routing to "{}" to block all calls.  Tried, but as reported doesn't seem to stick.  What i observed was that the first time i changed and rebooted, it reverted.  Second time, it seemed to stick.  But then my Google Voice inbound wasn't working, so I rebooted again.  (Perhaps not necessary, still wasn't working, so I made an outbound call, which worked, and then inbound worked again.)  Checked the setting, and it had reverted.  Repeated the process, and it took two reboots again, for the setting to stick.

But it somehow reverted during the night, because at 3:17am, I was awakened byt he phone ringing, then again a minute later, and again a minute after that.  At that point, I unplugged my phone from the OBI.

Plugged the phone back in this morning and it immediate rang again.  The call history shows ~50 calls overnight.  What the hell?  They continue to come roughly every 10 minutes according to the call history--I had to unplug my phone again, because of it.

Waiting for a response from support.  Good news is, if it's not an isolated incident, that ought to mean they will make a priority of fixing it.

Even if it's some weird backend system problem, I want a permanent fix to be able to disable the OBITalk calls at my device.  have no use for the service, and am not interest in being awoken in the middle of the night again, because they had some kind of backend system meltdown.

How does one access OBI expert?

drgeoff

Expert mode is accessed from your dashboard at obitalk.com.

jsg68

Yeah, it just wasn't exactly obvious how to get there.  You have to click on the device name, then the device info page that comes up has a button at the bottom to get to OBI Expert Configuration, then enter OBI Expert config.  (Porbably best to save your config first, so you have a backup inc ase you screw it up.)

Then it appears that  you have to go into the Voice Services->OBITalk Service.  On InboundCallRoute, Uncheck "OBITalk settings," it will automatically check "Device Default" and revert to "ph" as the setting.  You need to end up unchecking that, so you can edit the field.  I put in {} as I had seen suggested elsewhere.

(Note, I can't recall if it didn't allow me to uncheck Device Default, so I could edit it at first.  But it definitely did allow me to do that after I had been through a few reboot cycles and trying to change the setting on the device.  Perhaps you just need to submit at the OBI expert,and it will allow you to uncheck and modify the setting after that.)

So far, seems to be sticking through reboots, after the above OBI Expert changes.

Will post a follow up with whether or not it stops the calls from ringing through.

alivoiper

Same problem here. Rining every 7 min or so since 3am. If anyone figures out what is going on, please post here.

Sheffield_Steve

How is the Obi connected to the Internet?

a) Is it behind a router/firewall of connected directly to the modem.

b) Have you made any changes to your router/firewall to "accommodate" the Obi?

SergeL

Same here, started ringing last night, I was trying to change the value in InboundCallRoute, but I cannot ender anything there in the Chrome browser. This is very annoying, turned off OBi, using call forwarding to my cell from GVoice.

Mike1111111

Some things I tried that did NOT work
Setting Voice Services > OBiTALK Service > InboundCallRoute = blank (this still rang ph1, but not ph2)
Directing UDP port 10000 to a non-existent device in my router.
Setting Voice Services > OBiTALK Service > TryMultiplePorts = unchecked

I am still experimenting with the InboundCallRoute entry.

For reference these are the default values I have
OBI202: {(290944186)>(xx.):SP1},{(290944186):aa},{ph,ph2}
OBI200: {(290065332)>(xx.):SP1},{(290065332):aa},{ph}

Regarding the question about how my OBI is connected, I have a Netgear Nighthawk Router running DD-WRT firmware and I have UDP port 10,000 pointed at the OBI202's static IP address.
I am using Google Voice with two phones plugged in.

drgeoff

The simplest way to prevent any call coming in over the obitalk network is to untick its "Enable" box in the top line of Voice Services, Obitalk Service.

Mike1111111

I tried unchecking that box twice and it didn't work. The device reboots and the box becomes checked again. That box only appears when logging into the device directly. It does not show up in the OBiTalk portal.

SergeL

I've followed @azrobert suggestion to put {(xxxxxxxxx):ph} into Voice Services -> ObiTalk Service -> InboundCallRoute. So far it's been quite.

Mike1111111

I have gone 20 minutes without a call, so I think the change I made to InboundCallRoute worked.
I removed {ph,ph2} from the list.
old: {(290944186)>(xx.):SP1},{(290944186):aa},{ph,ph2}
new: {(290944186)>(xx.):SP1},{(290944186):aa}

The other suggestion of using {(xxxxxxxxx):ph} likely works as well.

Sheffield_Steve

The Obi boxes are normally used as SIP clients and thus no special setup is required for the Internet on consumer devices.

If the Obi is given a direct open inbound connection to the internet, then that will allow VoIP spammers to make the calls you have experienced.  (And is bad for security in general)

Quote from: Mike1111111 on January 19, 2021, 09:20:33 AM
Regarding the question about how my OBI is connected, I have a Netgear Nighthawk Router running DD-WRT firmware and I have UDP port 10,000 pointed at the OBI202's static IP address.
I am using Google Voice with two phones plugged in.

Mike1111111

#19
In my case, where my OBI is behind a router with a firewall and NAT service, that would not be the case that these calls are from a spammer. These are not spam calls, but rather dead-air scheduled calls from some automated process that went haywire.

The only port number that exposes my OBI to the outside world is UDP 10000, and disabling that port in my router did not stop these calls. To enhance security, I will change this to a non-default port now that I know where the setting is. I am assuming that changing the LocalPort in the portal changes both the source and destination. If the local port is now 12345, I would either map 12345 external to 12345 internal or map 10000 external to 12345 internal. I am not sure which is correct, so I will pick the first option and see if anything breaks.

I don't know what the OBiTALK Service does or what disabling it impacts. My phone has been working fine with none of these unusual calls for the past couple hours.