October 22, 2021, 11:22:19 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: OBi device just stopped working? -- just wait ... and wait ... and wait  (Read 1432 times)
SiEntomologist
Newbie
*
Posts: 3


« on: October 14, 2021, 09:09:58 am »

I received a message from Google in June 2021 about Google Voice changes to be made in August, and nothing at all from OBitalk about an August firmware update for my OBi200.  Everything appeared to work as it had for the past couple of years until 9 or 10 days ago when it just stopped working.  I got a dial-tone from the OBi200, and my mobile phone continued to work with Google Voice, but I could not make or receive calls through the OBi200 device.  After apparently wasting 30-40 hours or so, I learned:
a. that there had been a firmware update to my OBi200 at some point in time without my being made aware of it;
b. that a "factory reset" does not revert to an older firmware version (in case anyone is wondering);
c. that a manual firmware update attempt reported that no action was taken because the new and old versions were the same (I hope there was at least a check that the "old" version was intact -- it didn't say)
d. that tests of the completely reset OBi200 indicated it was ok, but
e. many attempts at linking to Google Voice (probably a couple of dozen altogether, after restarting at various points in the process) simply timed out, without success --
f. until, early this morning, when one more try succeeded without further incident!

In the process I did clean out a couple of old, nonfunctional OBi100 device links, but that was early on.

I have no idea why it stopped working or what was different this morning. (I'm quite certain I didn't do anything different.)  Maybe some weird Google glitch last week or dead server got fixed overnight, or there was less load on their system.

There were echo and network tests of the OBi200 device that turned up nothing, and if Google Voice settings haven't changed, there may be nothing a user can do.  Whatever happened, I just thought others might want to know.

Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 5484


« Reply #1 on: October 14, 2021, 10:11:40 am »

FYI. In common with most electronic devices a "factory reset" of an upgraded OBi does not return it to the state it was in when it left the factory.  The flash chip holds a single version of the firmware.  A firmware update overwrites the previous version.  Any previous firmware - the original fitted in the factory or any subsequent upgrade - is gone.  No way a reset can bring it back.

What a "factory reset" does do is to return all configuration settings to the default values that apply to the firmware version that is in the device at the time of the reset.  That is, the device becomes reset to the same state as that of a new device, fitted with that firmware, leaving the factory.
« Last Edit: October 14, 2021, 10:14:45 am by drgeoff » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC

Advertisement
Advertisement