OBi202 reboots after completing call via Asterisk

Started by DarthRay, December 01, 2021, 11:34:46 AM

Previous topic - Next topic

DarthRay

Hello,

I believe my OBi202 is rebooting upon completion of a call involving my Asterisk server. The scenario plays out like this:


  • Use phone on PH1 port of OBi202 to make a call to my cell phone
  • Call progresses through my Asterisk server and my cell phone rings.
  • I answer the call on my cell phone and notice that no audio is flowing through in neither direction. On the phone connected to the PH1 port on the OBi202, after a few seconds of silence I hear a noise followed by a dial tone.

After configuring the OBi to send syslogs to my server, I'm now seeing what seems to be the OBi rebooting:

[...]
>>>> Phone is ringing

2021-12-01T10:58:22.683507-08:00 obi202  OBi202: TDM_stop_dma: fd #17
2021-12-01T10:58:22.683608-08:00 obi202  OBi202: TDM_stop_dma: done
2021-12-01T10:58:22.684312-08:00 obi202  OBi202: TDM_stop_dma: fd #18
2021-12-01T10:58:22.684410-08:00 obi202  OBi202: TDM_stop_dma: done

>>>> Sometime around here, the call is completed and after a few seconds, I hear the dial tone. I'm going to
>>>> guess the 6sec gap below (between 10:58:30.753138 and 10:58:36.302084) is when that happens.

2021-12-01T10:58:30.253042-08:00 obi202  OBi202: DNS SERVER: 192.168.1.1
2021-12-01T10:58:30.352508-08:00 obi202  OBi202: ==== Networking is ready ====
2021-12-01T10:58:30.352594-08:00 obi202  OBi202: IP Address= 192.168.1.101
2021-12-01T10:58:30.352708-08:00 obi202  OBi202: Gateway   = 192.168.1.1
2021-12-01T10:58:30.352864-08:00 obi202  OBi202: Netmask   = 255.255.255.0
2021-12-01T10:58:30.352976-08:00 obi202  OBi202: PARAM: Daemon is up ... state: 9 (d7874)
2021-12-01T10:58:30.753138-08:00 obi202  OBi202: PARAM Cache Write Back(256 bytes)
2021-12-01T10:58:36.302084-08:00 obi202  OBi202: BASESSL:Load custom CA certs
2021-12-01T10:58:36.302522-08:00 obi202  OBi202: BASESSL: Can not find custom CA file 0 0
2021-12-01T10:58:36.302718-08:00 obi202  OBi202: ZT: CustomID 1

>>>> HERE IT IS!

2021-12-01T10:58:36.303379-08:00 obi202  OBi202: SYSTEM REBOOTED (lifecycle: 3448)

2021-12-01T10:58:36.338289-08:00 obi202  OBi202: [DSP] MPE init done!
2021-12-01T10:58:36.343359-08:00 obi202  OBi202: [MPM] channel - 0: T.38 Initialization done!
2021-12-01T10:58:36.343701-08:00 obi202  OBi202: [MPM] channel - 1: T.38 Initialization done!
2021-12-01T10:58:36.344253-08:00 obi202  OBi202: [DSP] mpe initialization done!
2021-12-01T10:58:36.347423-08:00 obi202  OBi202: [si3226x] ring amplitude: 70
2021-12-01T10:58:36.347701-08:00 obi202  OBi202: [SLICSI] channel: 0, tx gain: -5, rx gain: -4
2021-12-01T10:58:36.347825-08:00 obi202  OBi202: [si3226x] ring amplitude: 70
2021-12-01T10:58:36.347970-08:00 obi202  OBi202: [SLICSI] channel: 1, tx gain: -5, rx gain: -4
[...]

I'm running firmware 3.2.2 (Build: 8680EX).

Has anyone run into any similar issues?

Thanks!

DarthRay

I have a feeling this may have something to do with ICE support in Asterisk. Disabling it (icesupport=no in sip.conf) stops my OBi202 from crashing.

I suspect it is because icesupport causes Asterisk to send some large SDP messages back and forth. My server has multiple IP addresses (most private ones due to the various containers running locally) and the SDP messages list every single IP as a candidate (30 "a=candidate" lines total). I wonder if these long SDP messages may be causing the OBi202 to crash.