December 19, 2014, 03:55:12 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Placing calls on Broadvoice (RESOLVED)  (Read 2683 times)
Carlos
Newbie
*
Posts: 5


« on: January 05, 2012, 10:33:42 pm »

I tried setting up Broadvoice on an Obi100 using the Broadvoice option on OBiTALK but it didn't work for me, the device never registered. I got the device to register using a generic service provider on SP1 and so far I can receive calls fine, the problem is making calls. The SP1 is set as the default and I've tried prefixing the number with **1 and direct dialing but in every case I get a male voice saying "the number you dial **** was rejected by the service provider, reason is 403". The call log is below (phone number changed to @ to protect privacy). Can someone help?
Call 101/06/2012 00:04:46Remove
Terminal IDSP1PHONE1
Peer NameUnavailable
Peer Number
DirectionInboundInbound
00:04:46Ringing
00:04:51 Call Connected
00:05:07 End Call
Call 201/06/2012 00:03:54Remove
Terminal IDPHONE1SP1
Peer Name
Peer Number1916@@@@@@@1916@@@@@@@
DirectionOutboundOutbound
00:03:54New Call
00:03:54 End Call (403 Forbidden)
« Last Edit: January 07, 2012, 02:23:36 pm by Carlos » Logged
RonR
Forum Member

Posts: 4528


« Reply #1 on: January 05, 2012, 10:51:29 pm »

Log into the OBi directly using the IP address returned by dialing ***1 (username/password = admin/admin unless the password was changed by the OBiTALK Web Portal) and verify the following settings (everything else should be at Default):

Service Providers -> ITSP Profile A -> General -> Name : (BroadVoice)
Service Providers -> ITSP Profile A -> SIP -> ProxyServer : proxy.$$$.broadvoice.com
Service Providers -> ITSP Profile A -> SIP -> OutboundProxy : proxy.$$$.broadvoice.com
Voice Services -> SP1 Service -> AuthUserName : (10 digit BroadVoice number)
Voice Services -> SP1 Service -> AuthPassword : (10 digit authentication Password generated by BroadVoice)
Voice Services -> SP1 Service -> CallerIDName : (callerid name)
Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service

where $$$ is one of the following:

lax
dca
mia
atl
chi
bos
nyc

You should not need to use **1 when dialing numbers for SP1.

If you find it necessary to change anything and wish to make that change in the OBi instead of on the OBiTALK Web Portal, you will also need to set:

System Management -> Auto Provisioning -> ITSP Provisioning -> Method : Disabled
System Management -> Auto Provisioning -> OBiTALK Provisioning -> Method : Disabled
Logged
Carlos
Newbie
*
Posts: 5


« Reply #2 on: January 06, 2012, 09:03:41 am »

Ron, I appreciate the help. I verified that all settings (save for the profile name) are as you suggested yet I still can't place calls. I'm using lax as the server which is what I had with the old Sipura ATA. The device registers and receives calls so the username/password should be correct. Cound there be another setting affecting outbound calls?
Logged
RonR
Forum Member

Posts: 4528


« Reply #3 on: January 06, 2012, 09:56:53 am »

If possible, temporarily bypass your router by connecting the OBi directly to the modem.  Power-cycle both the modem and the OBi after making the direct connection, allowing the modem to acquire sync before powering up the OBi.  Then see if you can make outgoing calls.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #4 on: January 06, 2012, 07:58:35 pm »

Please post a screenshot of all Line page settings in the Sipura.  Of course, mask personal info such as phone number and name (password should already be masked), but leave all other settings visible.
Logged
Carlos
Newbie
*
Posts: 5


« Reply #5 on: January 07, 2012, 02:23:10 pm »

Thanks guys for the suggestion. It turned out that connecting the OBi100 directly to the modem was nearly impossible. The reason is that every device that connects to the modem needs to login to my ISP and the ATA can't do that. I tried several workarounds but nothing worked.

I decided to look at the configuration of my SPA3000 which luckily still works. After porting the settings to the OBi100 I can finally make and receive calls. Here are the settings in case others have the same problem.

[Generic Service Provider]
Service Provider Proxy Server: sip.broadvoice.com
Service Provider Proxy Server Port: 5060 (default)
Outbound Proxy Server: proxy.xxx.broadvoice.com (where xxx is one of lax, dca, mia, atl, chi, bos, nyc)
Outbound Proxy Server Port: 5060 (default)
User Name: 10 digit Broadvoice number (e.g. 8009990000)
Password: 10 character Broadvoice password (from tech support, e.g. Gh2Fr1am2c)
URI: *blank* (default)

I'd like for OBi to update the website to save users the hassle of figuring out what the settings should be. Especially since Broadvoice is a supported service.
« Last Edit: January 07, 2012, 02:24:45 pm by Carlos » Logged
RonR
Forum Member

Posts: 4528


« Reply #6 on: January 07, 2012, 03:29:38 pm »

Carlos,

With the exception of ProxyServer (which Broadvoice says to set the same as OutboundProxy), aren't these the settings I suggested in Reply #1 above?
Logged
Carlos
Newbie
*
Posts: 5


« Reply #7 on: January 07, 2012, 11:49:53 pm »

Ron,
That's correct. However, until I changed the ProxyServer to sip.broadvoice.com I was having the problem described in the original post. I have no idea why Broadvoice recommends having both proxies the same; their own configuration scripts do otherwise. Perhaps other BV users can share their settings.
Logged
RonR
Forum Member

Posts: 4528


« Reply #8 on: January 08, 2012, 10:54:41 am »

However, until I changed the ProxyServer to sip.broadvoice.com I was having the problem described in the original post.

Carlos,

That can't be the answer because sip.broadvoice.com is actually the same as proxy.atl.broadvoice.com, proxy.chi.broadvoice.com, and proxy.mia.broadvoice.com.

They all resolve to the same IP address : 147.135.32.221
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #9 on: January 08, 2012, 11:11:08 am »

That can't be the answer because sip.broadvoice.com is actually the same as proxy.atl.broadvoice.com, proxy.chi.broadvoice.com, and proxy.mia.broadvoice.com.
IMO, that is not correct, because when URI is blank, the OBi (like most ATAs) uses the ProxyServer value to form the text in the URI, e.g.
INVITE sip:12121234567@sip.broadvoice.com SIP/2.0
In many cases, the server is sensitive to the domain name and will reject the call if it's not as expected.

IMHO, Carlos is correct on this one.
Logged
Carlos
Newbie
*
Posts: 5


« Reply #10 on: January 08, 2012, 05:28:50 pm »

Just for the sake of trying I went back and changed the Service Provider Proxy Server to proxy.lax.broadvoice.com and had the problem. Changed it to sip.broadvoice.com and things work. I don't know the technical reason of why that is but I can confirm that this single change solves my problem. I hope this helps others.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC