September 15, 2019, 11:33:33 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: specifying an intranet proxy  (Read 4388 times)
matthewk
Newbie
*
Posts: 18


« on: January 07, 2012, 02:14:19 pm »

can the obi device be connected through a proxy? i didn't see this option, but i plan to take the obi to another location where a proxy is required for internet access. so, i wanted to test things here, and later on, know what to do when i am having to go through the intranet proxy for the internet access.
thank you!
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #1 on: January 07, 2012, 06:34:57 pm »

can the obi device be connected through a proxy? i didn't see this option, but i plan to take the obi to another location where a proxy is required for internet access. so, i wanted to test things here, and later on, know what to do when i am having to go through the intranet proxy for the internet access.
thank you!
If the proxy is only needed for outbound HTTP (web) access, it shouldn't be a problem, since the OBi does not require that.

However, many corporate firewalls block all services, except those required for business purposes.  In that case, the OBi won't work at all.  From a PC on the corporate LAN, you could do some tests to determine what is and is not likely to work.  For example, can you place a call via Gmail?  Via a softphone registered to a SIP provider?  Via a softphone and OBiAPP?
Logged
matthewk
Newbie
*
Posts: 18


« Reply #2 on: January 08, 2012, 08:41:00 pm »

ok, where do i specify the ip address for the proxy for my obi device? when i use my computer to browse, i specify it in the internet options for ie or the browser preferences for other browsers.
Logged
RevKev
Full Member
***
Posts: 86


« Reply #3 on: January 09, 2012, 06:18:04 pm »

matthewk, the OBI isn't a browser. When you specify an IP address for your computer browser, your specifying an http proxy - used for http/web requests. As far as I know, the OBI could only accept a proxy for SIP requests and the proxy would have to relay requests to and from a specific SIP server. I think it's unlikely that you would have to proxy your OBI. It is quite possible that the needed ports for SIP and RTP might be blocked by your firewall though.
Logged
matthewk
Newbie
*
Posts: 18


« Reply #4 on: January 10, 2012, 08:40:13 am »

the internet provider has an intranet proxy that must be specified in the browser for internet access.

i am planning to rely on google voice as provider with the obi.

if i need to specify the intranet proxy as mentioned above in order for the obi device to be able to connect outside the intranet that i am receiving internet access through, then what should i do?

i am not using a firewall.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #5 on: January 10, 2012, 08:58:22 am »

the internet provider has an intranet proxy that must be specified in the browser for internet access.
No, the proxy must be specified in the browser to access the World Wide Web.  That's only one of many services available on the Internet.

The OBi does not access the Web and could not make use of such a proxy.

If the only service provided by this ISP is Web access (and you need a proxy for that), then the OBi won't work, period.

However, if they allow most services to pass normally, and require a proxy only for Web access, e.g. because they do some censorship or put their own ads on pages, then the OBi should work fine.

If you want more specific advice, please post: In what country will the OBi be installed?  Which ISP will you be using?  Have you successfully used any sort of VoIP from there (Skype, Gmail, etc.)?  Do you have a contact there who can assist you with some testing?
« Last Edit: January 10, 2012, 09:00:07 am by Stewart » Logged
matthewk
Newbie
*
Posts: 18


« Reply #6 on: January 10, 2012, 09:12:48 am »

i will be using it on a university campus in china. that university requires the intranet proxy to have internet access.

i find it hard to believe that the obi device is not connecting to the internet. in order to have an internet connection, this intranet proxy is required in my situation. the obi, for one, needs to connect to verify my gtalk settings i would assume, each time i make a call -- as well as make the connection through gtalk for the call to happen.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #7 on: January 10, 2012, 09:57:53 am »

I don't know the details of the XMPP protocol used by GV, but I don't believe that it uses any of the standard ports that a proxy would intercept.

In any case, you should have a SIP provider as a backup, in case of difficulty with GV.  One possibility is CallWithUs, as they offer the option to connect via a VPN, which might work if both GV and SIP are blocked.  Though it won't work with the OBi, Skype is very good at penetrating restricted connections and may be another option.

Finally, if GV can work with the aid of a proxy, you should be able to use it from Gmail, with a computer headset.
Logged
matthewk
Newbie
*
Posts: 18


« Reply #8 on: January 10, 2012, 10:00:19 am »

i will look into those options to use with obi; thanks.

one thing to note, is my situation is not about blocked ports. it's about specifying an intranet proxy as a requirement for my obi to connect to anything outside of the local network.
Logged
matthewk
Newbie
*
Posts: 18


« Reply #9 on: January 10, 2012, 02:17:05 pm »

so, if anyone has a suggestion about how i can specify the required proxy to simply give the device the ability to have outside connections, then please let me know  Huh
Logged
RevKev
Full Member
***
Posts: 86


« Reply #10 on: January 10, 2012, 06:21:57 pm »

Quote
i find it hard to believe that the obi device is not connecting to the internet.

It is connecting to the internet but it's not connecting to the web (i.e. it's not using http). When you connect through a browser you're using the http protocol to connect to the web. The OBI doesn't. It uses SIP or XMPP (for Google Voice) protocols. If the intranet blocks SIP and/or XMPP you may be out of luck.

The only proxy setting in the OBI config are for a SIP proxy that works for a specific SIP server. For example, "siprovider.com" might use a proxy of "proxy.sipprovider.com".
Logged
matthewk
Newbie
*
Posts: 18


« Reply #11 on: January 14, 2012, 07:04:39 pm »

i've hooked up the obi device on this network i've written of in the above posts.

i can login via the wifi on my phone to my obitalk account, but it just keeps saying acquiring service.

in order to use the wifi on my phone, i've had to specify the intranet proxy as mentioned. this allows me to have internet access on my phone/computer. can someone describe how i can get the obi device connected with a way to specify the intranet proxy to have a connection?  Huh
Logged
matthewk
Newbie
*
Posts: 18


« Reply #12 on: January 14, 2012, 07:53:22 pm »

for my situation, i have replied also to http://www.obitalk.com/forum/index.php?topic=537.0 , because the echo test (222-222-222 and **9-222-222-222) is failing for me. "no service available to ... ". any ideas  Huh
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #13 on: January 14, 2012, 08:36:54 pm »

Start by getting some sort of VoIP to work from a PC -- you have much better tools available, both for penetrating the firewall and for troubleshooting.  Once we find something that works, we can see if there is a way for the OBi to do it.

I recommend trying:  Skype, Yahoo! Voice, Gmail, a free PBXes account (try port 5060 and port 36999, then their VPN, use X-Lite to test).

If none of the above works, see if any kind of VPN works; then try a SIP provider through that.

You might ask the university if there is a SIP proxy on the intranet.

If you can't get any kind of VoIP to work, some sort of calling card or callback system may be best.  Do you have a way to receive a call at no cost, on your mobile or a school phone?
Logged
matthewk
Newbie
*
Posts: 18


« Reply #14 on: January 14, 2012, 09:02:47 pm »

from a pc, i have specified the intranet proxy in my browser. there are 4 of the intranet proxies the university has provided (all on port 8000), but i don't know if they are all for http. with the proxy specified, i can browse gmail (as well as use its gv web app). since this is the case, how would you like me to test gmail with the obi since it works on my computer?

there is no cost to receive phones on the school phone line i have.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #15 on: January 14, 2012, 09:41:51 pm »

If GV through Gmail works, the UDP ports for RTP must be unblocked (I seriously doubt anything could be proxying them). So, I'd expect PBXes (on port 36999) to work; standard SIP might also work.

Does your OBi show the correct date/time (in some timezone) in System Status?  If not, there is something wrong with the Internet setup.  Does it have a valid gateway, DNS servers etc?

I don't know why OBiTALK is not working.  Do you have a SIP account set up in the OBi?  What does it show in System Status?

Assuming that it has its own DID, you should be able to call from your school phone using any service with click-to-call.  For example, using Localphone calling the US, you'd pay $0.01 or $0.012/min. for the China leg, depending on what city you're in, plus $0.005/min. for the US leg.

Logged
matthewk
Newbie
*
Posts: 18


« Reply #16 on: January 14, 2012, 11:01:13 pm »

about the system status, how do i see that in obitalk configuration on my profile? i had the obi device added before i left america. now, when i click "Add an OBi Device", i key in the code via the phone interface, and the autoresponder says "the key was sent to the server" (or something of that sort). but, the countdown on the wizard doesn't stop like it did when i added the obi when i was in america. so, i think the code is never getting sent to the server.

i want to reiterate that in order for me to use the internet on my computer, i have to specify a proxy address in my internet settings. otherwise, i can not connect to outside sources. so, since i am not specifying this anywhere in my obitalk configurations, i think this is why my obi device is probably not really sending the code to the server, but it may be.... obitalk never shows my device found though after i've typed the code then hearing that the code was sent to the server.

when i had the obi device added when i was in america, i did have GV setup as the sip account. above mentioned shows that i removed the device and tried to readd it from a test i saw in another thread. so, i don't know how to check the system status if i don't have a device listed.

the power light of my obi is solid green and the internet light has a series of multiple green flashes every few seconds.
Logged
matthewk
Newbie
*
Posts: 18


« Reply #17 on: January 15, 2012, 12:29:17 am »

i found out about checking the system status. dialing *** 1 worked to get the intranet ip of my device, and i connected to it and see:
ModelName   OBi110   
SerialNumber   88B01NA00FPF   
OBiNumber   200 883 878   
HardwareVersion   3.4   
SoftwareVersion   1.3.0 (Build: 2651)   
SystemTime   16:29:40 01/01/2010, Friday

so, the date is not accurate, but the time is.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #18 on: January 15, 2012, 01:10:51 am »

I'm puzzled about the time, becuase NTP sends both date and time in the same long number, so it's hard to imagine how the date could be wrong.  Possibly, the time being about right was accidental.  Did you change LocalTimeZone for China?  If not, the time isn't right, anyhow.  You migh try cycling power, waiting a minute for it to boot completely and see whether the time is still correct.

GV is not a SIP service.  I don't know whether the XMPP protocol it uses may conflict with the (lack of) proxy on the OBi.  Get a free Callcentric or PBXes account and test whether it works correctly in X-Lite on your PC.  If so, try that on your OBi and report results.

For Callcentric, test by calling 17771234567 (should ring TellMe).

For PBXes, if you just set up one extension, you can reach the echo test on *43.  If connecting to the standard port 5060 fails, try port 36999.
Logged
matthewk
Newbie
*
Posts: 18


« Reply #19 on: January 15, 2012, 01:14:46 am »

would the IP Freedom ("Unlimited free calling between all Callcentric members with no monthly fees.") work for callcentric for this test?

downloading x-lite (http://www.counterpath.com/x-lite-download.html) to try.
« Last Edit: January 15, 2012, 01:40:48 am by matthewk » Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC