September 19, 2019, 08:38:12 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Help with iptel and ipkall  (Read 11434 times)
freeatlast
Newbie
*
Posts: 8


« on: January 12, 2012, 12:36:39 pm »

I already have GoogleVoice setup on SP1 thanks to the great set of instructions on the ObiTalk site.  I would now like to set up SP2 to receive calls in case GoogleVoice is out of commission. I was able to set up accounts at both iptel and ipkall, but am having great difficulty configuring SP2.

I chose the Generic Service Provider, since iptel did not appear as a selection under Service Providers (perhaps Obihai can add them on the next revision of their firmware).  Thus I have to fill out the following fields:

Service Provider Proxy Server:       sip.iptel.org   
Service Provider Proxy Server Port   : 5060
Outbound Proxy Server   
Outbound Proxy Server Port   
User Name :                                  foobar@iptel.org   
Password :                                    mypassword
URI  :                                           sip:foobar@iptel.org

I left the Outbound proxy server and port numbers empty, as I am for the moment only interested in receiving inbound calls.

With these settings though, I get the message

Registered (server=217.9.36.145:5060; expire in 29s)

But when I dial the ipkall number that I had setup earlier, I get ... nothing. NO ring, just dead silence.

Can someone tell me how to set up obitalk (and perhaps ipkall) correctly so that I can get inbound calls on my Obi?
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #1 on: January 12, 2012, 12:49:10 pm »

Assuming you have iptel working properly, you will need to configure IPKall to forward calls to:

SIP username: (use anything here, for example, OBI)

Hostname or IP address: (use your hostname or public IP address:5061)

You will need to forward SIP ports 5060-5061 in your router to your OBI's LAN IP address.

If you have a dynamic IP address that changes periodically, you will probably want to set up a DynDNS account so you can use a hostname instead of an IP address at IPKall.
Logged
freeatlast
Newbie
*
Posts: 8


« Reply #2 on: January 12, 2012, 04:42:53 pm »

Assuming you have iptel working properly, you will need to configure IPKall to forward calls to:

SIP username: (use anything here, for example, OBI)

Hostname or IP address: (use your hostname or public IP address:5061)

You will need to forward SIP ports 5060-5061 in your router to your OBI's LAN IP address.


That seems a bit strange to me.  I thought ipkall was supposed to map the assigned telephone number to the DID provided by iptel.  From the above description, it appears that ipkall does not need to know about iptel's DID at all.

Here is my current configuration page for ipkall:

Account type:   SIP   or  IAX
SIP Phone Number: iptelusername
SIP Proxy:   sip.iptel.org
Email Address: me@myemail.com
Password:   iptelpassword
Seconds to Ring before Hang Up:   120

Following the above instructions is this how I should fill in the following fields?

Account type:   SIP   or  IAX
SIP Phone Number: iptelusername
SIP Proxy:   myipaddr.host.com:5601
Email Address: me@myemail.com
Password:   <----------------     [which password goes here?]
Seconds to Ring before Hang Up:   120
Logged
freeatlast
Newbie
*
Posts: 8


« Reply #3 on: January 12, 2012, 05:12:36 pm »

Update: I got it working with the old ipkall settings

Here is my current configuration page for ipkall:

Account type:   SIP   or  IAX
SIP Phone Number: iptelusername
SIP Proxy:   sip.iptel.org
Email Address: me@myemail.com
Password:   iptelpassword
Seconds to Ring before Hang Up:   120

What I also did was configure port forwarding on my router so that port 5601 would get forwarded to the Obi (as RonR suggested). I did not need to provide my IP address to ipkall.  Evidently, configuring SP2 on the Obi for iptel is sufficient to pass the Obi's external IP address to the iptel DID, which ipkall is then able to look up using the credentials for iptel. Or at least, that's what I think is going on ...
« Last Edit: January 12, 2012, 05:14:10 pm by freeatlast » Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #4 on: January 12, 2012, 06:07:18 pm »

That seems a bit strange to me.  I thought ipkall was supposed to map the assigned telephone number to the DID provided by iptel.  From the above description, it appears that ipkall does not need to know about iptel's DID at all.

IPKall DID's have to be forwarded via SIP URI to somewhere.  I assumed you were trying to have it come directly to the OBi, in which case nothing else needs to be in between.  I don't presently use IPKall, but I've had IPKall numbers in the past forwarded directly to the OBi with no problems.

You can also forward an IPKall DID to an intermediate like iptel and have iptel forward it on to the OBi.
Logged
freeatlast
Newbie
*
Posts: 8


« Reply #5 on: January 12, 2012, 11:59:51 pm »

That seems a bit strange to me.  I thought ipkall was supposed to map the assigned telephone number to the DID provided by iptel.  From the above description, it appears that ipkall does not need to know about iptel's DID at all.

IPKall DID's have to be forwarded via SIP URI to somewhere.  I assumed you were trying to have it come directly to the OBi, in which case nothing else needs to be in between.  I don't presently use IPKall, but I've had IPKall numbers in the past forwarded directly to the OBi with no problems.

Interesting. I didn't know that.

Evidently, I also didn't know what a DID is.  The telephone number assigned by ipkall IS the DID, not the SIP address as I had thought.

Quote
You can also forward an IPKall DID to an intermediate like iptel and have iptel forward it on to the OBi.

I think that's how I have it configured presently. I thought that was the only way to do it, but you've pointed out an alternate arrangement.   I think I prefer my current configuration, though,  because, as you've indicated earlier, having ipkall forward directly to the Obi requires that I have a static IP or set up dynamic DNS.  Having ipkall forward to iptel avoids this additional step.

Thanks for your help and insights.
« Last Edit: January 13, 2012, 04:40:24 am by freeatlast » Logged
Seattleweather
Newbie
*
Posts: 15


« Reply #6 on: January 13, 2012, 10:07:48 pm »

That seems a bit strange to me.  I thought ipkall was supposed to map the assigned telephone number to the DID provided by iptel.  From the above description, it appears that ipkall does not need to know about iptel's DID at all.

I don't presently use IPKall, but I've had IPKall numbers in the past forwarded directly to the OBi with no problems.


Could you please let us know your setup?  I have done this with Pap2.  The Obi just can not go through.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #7 on: January 13, 2012, 10:13:06 pm »

Could you please let us know your setup?  I have done this with Pap2.  The Obi just can not go through.
On an attempted call, what does Call History show?  If nothing, what does syslog (with X_SipDebugOption set) show?  If nothing, how do you know that the initial INVITE is reaching the OBi?
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #8 on: January 13, 2012, 10:14:46 pm »

That seems a bit strange to me.  I thought ipkall was supposed to map the assigned telephone number to the DID provided by iptel.  From the above description, it appears that ipkall does not need to know about iptel's DID at all.

I don't presently use IPKall, but I've had IPKall numbers in the past forwarded directly to the OBi with no problems.


Could you please let us know your setup?  I have done this with Pap2.  The Obi just can not go through.

Simply forward ports 5060 - 5061 to your OBi in your router.

Set the IPKall 'SIP username' to anything (for example, OBI).

Set the IPKall 'Hostname or IP address' to your public IP address or hostname.  If SP1 on your OBi is configured for SIP, no port number is required (default is port 5060).  If SP2 on your OBi is configured for SIP, append :5061 to the hostname or IP address for port 5061.
Logged
Seattleweather
Newbie
*
Posts: 15


« Reply #9 on: January 13, 2012, 10:29:11 pm »

Thank you RonR and Stewart's quick reply.  After forward the port to Obi address, the call went through, but no sound on both sides.  It's no problem if I call Sp1.  Any suggestions?  Thanks.
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #10 on: January 13, 2012, 10:34:49 pm »

It's no problem if I call Sp1.

I'm not sure what this means.

Try forwarding ports 16600 - 16998 also.
Logged
Seattleweather
Newbie
*
Posts: 15


« Reply #11 on: January 13, 2012, 10:43:37 pm »

I have setup my Sp1 as me@vbuzzer.com.  If I forward the IPKall to Sp1, both sides can hear each other clearly. Call Obi directly seems have problem.  Could bt NAT?
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #12 on: January 13, 2012, 10:46:50 pm »

Could bt NAT?

Yes.  Did you forward the port range 16600 - 16998 to see if that corrects the audio problem?

You can confirm the problem is with your router by temporarily connecting your OBi directly to your modem, eliminating the router.  Power both units off after making the direct connection.  Power the modem up first and wait for it to sync.  Then power up the OBi and make a test call.
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #13 on: January 13, 2012, 10:48:11 pm »

I have setup my Sp1 as me@vbuzzer.com.  If I forward the IPKall to Sp1, both sides can hear each other clearly.

Do you mean you're forwarding IPKall to Vbuzzer or to the OBi using your public IP address?
Logged
Seattleweather
Newbie
*
Posts: 15


« Reply #14 on: January 13, 2012, 11:15:57 pm »

I enableed DMZ on my Obi, still has audio problem.  I setup IPKall to Vbuzzer, and registry vbuzzer on Obi.  In this case, there is no audio problem. Huh
Logged
RonR
Hero Member
*****
Posts: 4527


« Reply #15 on: January 13, 2012, 11:18:11 pm »

Did you try bypassing the router?
Logged
Seattleweather
Newbie
*
Posts: 15


« Reply #16 on: January 14, 2012, 01:43:33 pm »

I did try to bypass the router, still no audio. Angry
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC