December 18, 2017, 12:22:15 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: OBI200 + OBI202 + 2 Google Voice #s + Snom 370  (Read 1357 times)
sandsofdorn
Newbie
*
Posts: 4


« on: September 28, 2017, 01:09:28 pm »

New to Obi and really like it - I have an OBI200 at my office connected to a Google Voice # and I have an OBI202 at home connected to a different Google Voice #, both using analogue handsets. They work great in this config.

I have a spare Snom 370 IP phone at home. I'd love to be able to connect this to both OBI boxes, so that I can make and received calls from either GV number.

Any starting points on how to do this? Is NAT going to be issue - will I need to put the remote OBI200 in a DMZ?

I'm a software engineer but VOIP is new to me.

Any help appreciated - Thanks!
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #1 on: September 28, 2017, 01:33:31 pm »

You can register an IP phone to an OBi2xx
Start with the home OBi202
Assumption: GV defined on SP1

Use OBi Expert to make the following config changes.

OBi202:
Service Providers -> ITSP Profile D  SIP -> ProxyServer: 127.0.0.1
Service Providers -> ITSP Profile D  SIP -> X_SpoofCallerID: Checked
Voice Services -> SP4 Service -> AuthUserName: OBi202
Voice Services -> SP4 Service -> AuthPassword: OBi202PW
Voice Services -> SP4 Service -> X_RegisterEnable: Unchecked
Voice Services -> SP4 Service -> X_ServProvProfile: D
Voice Services -> SP4 Service -> X_Proxy: Checked 
Voice Services -> SP4 Service -> X_InboundCallRoute: {OBi202>(Msp1):sp1}

Voice Services -> SP1 Service -> X_InboundCallRoute:
SP4(OBi202@local_client)

IP Phone:
Proxy: 192.168.1.100  (IP address of the OBi202)
Proxy Port: 5063     (X_UserAgentPort of OBi202 SP4 trunk)
UserID: OBi202
Password: OBi202PW
Logged
sandsofdorn
Newbie
*
Posts: 4


« Reply #2 on: September 28, 2017, 01:37:11 pm »

thanks much! going to try this now.

Based on what you've written I'm going it looks like the remote OBI200 w/ need a public and static IP (or maybe I can forward that port through the router on that side).
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #3 on: September 28, 2017, 01:57:01 pm »

I think an IP phone using the above technique will work for outbound calls on the remote OBi200, but I don't think inbound calls will work. You will need to point the IP phone to the Public IP address of the office and then do port forwarding of port 5063 in the office router.

If outbound calls don't work, try the following change on the OBi200:

Service Providers -> ITSP Profile D  General -> X_SymmetricRTPEnable: Checked

Another technique is to have the IP phone connected only to the local OBi202 and route inbound and outbound calls over the OBiTalk network from/to the OBi200.

or

Have a hybrid setup. Outbound on a direct connect and inbound routed over the OBiTalk network. This might be the best choice if direct connect outbound works.

You can solve the dynamic DNS problem with a free account at Freedns. The OBi200 can be configured to update the IP address.

http://freedns.afraid.org/zc.php?from=L21lbnUv
Logged
mrjoe
Sr. Member
****
Posts: 262


« Reply #4 on: October 01, 2017, 01:50:08 am »

See this: https://www.ukvoipforums.com/viewtopic.php?f=25&t=235&p=391
Logged
sandsofdorn
Newbie
*
Posts: 4


« Reply #5 on: October 02, 2017, 01:06:21 pm »

No luck at all with this.

With the default setup of the OBI202, Google Voice works fine using analogue handset.

Adding Snom IP phone and updating settings as described above results in:

- incoming calls to GV number no longer ring analogue handset
- outgoing GV calls from analogue handset still work
- Snom phone - doesn't react at all to income calls, outgoing calls all result in busy signal

How can I debug?
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #6 on: October 02, 2017, 01:26:40 pm »

My mistake on the sp1 inbound route. You should add the code, not replace the existing code. If you want to route calls to ph1 and the IP phone it should look like this:

Voice Services -> SP1 Service -> X_InboundCallRoute:
ph,SP4(OBi202@local_client)

This will only correct inbound calls not ringing the Phone1 port.

Does the Snom show registered?

In OBi Expert go to Status -> System Status
The SP4 Status should look something like this:
Registration Not Required;local_client=192.168.1.100:5060

If the Snom is not registering, can it be configured to call without registration?
Logged
sandsofdorn
Newbie
*
Posts: 4


« Reply #7 on: October 02, 2017, 01:58:33 pm »

thanks,

that still doesn't fix incoming calls - also tried ph1,SP4(OBi202@local_client)

SP4 Status simply says "Registration Not Required"
Logged
azrobert
Hero Member & Beta Tester
*****
Posts: 3204


« Reply #8 on: October 02, 2017, 04:46:33 pm »

"Registration Not Required" indicates the Snom is not registering to your OBi202

Maybe you should change the SP1 X_InboundCallRoute back to ph until we resolve the registration problem.

What does your network look like?
Do you have another router?
Are you running the OBi202 in Router or Bridge mode?
Is the Snom connected to the OBi202 or a different router?
If you are running in Router mode, can you connect the Snom directly to the OBi202?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC