December 14, 2017, 09:13:22 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2]
  Print  
Author Topic: Single-Stage Dialing Through Any OBi Trunk Using SIP  (Read 78130 times)
infin8loop
Full Member
***
Posts: 219


My code doesn't abend, it loops to ∞


« Reply #20 on: June 12, 2012, 11:09:44 am »

Thanks infin8loop for your help. It's not working. If I place a call from "line", it's working. But If I place a call through SP1 or SP2, I can't hear the other party.  I've changed everything. Ports forwarding, full duplex etc...
I'm running out of suggestions.  If you haven't already tried, you might remove the router out of the path and connect the Obi directly to your modem.   Power off both the modem and the Obi.   Power on the modem first and wait until it's fully up and then power on the OBi and wait until it's fully up.  Then try a **9 222 222 222 ObiTalk echo test.  If that works, then try test SP1 and/or SP2 calls. If calls work (two-way voice) with the router out of the picture, then your issues are router related, otherwise something else is going on. 

1) I have 2 Obi's (One set in a remote place)

   Obi1: local IP is 192.168.0.14 hostname obi1xxx.no-ip.biz
   Obi2: local IP is 192.168.0.101 hostname obi2xxx.no-ip.biz

I need help to configure this part

User Settings -> User Defined DigitMaps -> User Defined Digit MapX
Label : p2p
DigitMap : (<n*:>(@@.)<:@192.168.1.140:sip_port>|<n*:>(@@.)<:@hostname:sip_port>)

Can you please tell me if it's correct ?

Obi1's Digitmap: (<1*:>(@@.)<:@192.168.0.14:5061>|<2*:>(@@.)<:@obi2xxx.no-ip.biz:5061>)
Obi2's Digitmap: (<1*:>(@@.)<:@192.168.0.101:5061>|<2*:>(@@.)<:@obi1xxx.no-ip.biz:5061>)

I use the "other" non-sip Single-Stage Dialing Through Any OBi Trunk method but I'd try:

Obi1's Digitmap: (<2*:>(@@.)<:@obi2xxx.no-ip.biz:5061>)
Obi2's Digitmap: (<1*:>(@@.)<:@obi1xxx.no-ip.biz:5061>)

I read this to mean, from Obi1 you dial 2**etc to go out Obi2 and from Obi2 you dial 1**etc to go out Obi1.  SP2 (5061) on the target Obi would be used.

I think the original example was simply giving both formats (IP and host name) and only one needs to be coded per target Obi. However, I could be interpreting the intent of the original instructions of this thread incorrectly.

2) Can we use speed dials with this method ? I've tried it but it's not working. Do we need change anything to make it work.

To use a speed dial on the target Obi requires going through the Auto Attendant on the target.  From Obi1 dial 2**0 to get to Obi2 AA, dial 2 "make a new call", enter PIN if prompted, and then enter speed dial number defined on Obi2 followed by a #.     

From PDF Version 11.04.12 11 April 2012 of OBi Device Administration Guide page 151:
      "Speed dials may be dialed from the PHONE port or via the Auto Attendant."

Maybe there's another trick to get to the target Obi speed dial that I'm not aware of.


Logged

"This has not only been fun, it's been a major expense." - Gallagher
carlm
Newbie
*
Posts: 2


« Reply #21 on: January 12, 2016, 07:26:08 pm »

I just got this working. Thanks, RonR!

I have two additions (not corrections) to the setup instructions.

In the following, <proxy> refers to the slot used for the SIP proxy.
Similarly, <Google Voice> refers to the slot used for Google Voice.

First, in Voice Services -> SP<proxy> Service, under SIP Credentials, ensure that X_EnforceRequestUserID is not checked, else you'll get an instant NOT FOUND error on every attempted call.

Second, with both ITSP Profile <Google Voice> -> General -> DTMFMethod and ITSP Profile <proxy> -> General -> DTMFMethod set to Auto (the default), DTMF wasn't working for me. I changed both to RFC2833 and that fixed it. I don't know if it was necessary to change both, but it did no harm.
Logged
enochian
Newbie
*
Posts: 1


« Reply #22 on: October 01, 2017, 09:43:02 pm »

Solved: Using Obion Softphone to make calls to other obi devices (Obi110) as the gateway: (title may differ from this thread but it works)
Solution:
1. Go to www.obitalk.com
2. login to your account
3. left click on "Obi Dashboard" then left click on the device name for your Obi110
4. Left click OBi Expert Configuration when prompted click "OK" then click on Enter OBi Expert
5. click voice services then click on Auto Attendant
6. (Actual Change to make this work) Under Auto Attendant 1 - make sure the check mark is present for Enable.
7. on that same line make sure the other two labelled device default and OBiTALK settings are NOT checked.
8. Look for PrimaryLine and use the dropdown menu to select "OBiTALK Service"

You must Scroll down to the bottom of the page and click on "SUBMIT" for the change to take place.

After a few seconds to a few minutes later you will be able to call other obi devices with your OBION softphone on you android device.

You are all welcome.  (Please keep in mind I read all the forum entries and still had no luck until I did this)

The default is set to "PTSN LINE" because that is how to use the OBI110 to "Bridge" to your existing wall phone line from MA Bell or AT&T etc....
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 2717


« Reply #23 on: October 02, 2017, 03:35:28 pm »

6. (Actual Change to make this work) Under Auto Attendant 1 - make sure the check mark is present for Enable.
The default on a new OBi or one that has been reset is that the Auto Attendant is enabled.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC