Weird incoming Google Voice problem

Started by dhobi, March 01, 2012, 05:16:14 PM

Previous topic - Next topic

dhobi

I have a strange incoming calls via Google Voice problem: the phone rings, I pick up the phone but somehow the OBI device/GV do not realize I picked up and the caller keeps hearing the rings and is eventually sent to the GV voicemail.

Outgoing calls work fine, so it's not a broken phone. This started happening today and I am not sure what setting I may have broken to cause it to do this.

Any ideas what to check?

Stewart

Oops, I answered your other thread before seeing this one.  They seem to be the same problem!  Possibly, an issue with your network equipment.  Modem make/model?  Separate router, if any?  Can you test with OBi connected directly to modem?

Or, it may be something corrupted in the OBi.  You might try a factory reset, then restoring your configuration.

dhobi

I really have no idea what happened. It worked fine for a week and now it stopped working. I tried everything I could think of, reset the config, I tried a different GV account, I have another OBI box and tried that one too, they all behave the same way: the call comes in, the phone rings, I pick up the phone and the call keeps ringing for the caller. It seems that the OBI can't notify GV that the call has been answered. I connected the OBI straight to the ISP bypassing my router and still no go.

Anyone else running into the same issue? Has GV changed anything that may be causing this?

I wish sipgate still had free incoming numbers so I could try a different VOIP provider. Anyone have a spare spigate number they could "donate" even on a temporary basis to try some things out?  ;)

RonR

dhobi,

Does pressing the '1' key on your phone after answering the call on the OBi cause the call to complete?

dhobi

Quote from: RonR on March 01, 2012, 09:46:27 PM
dhobi,

Does pressing the '1' key on your phone after answering the call on the OBi cause the call to complete?


Wow! That does it. What is going on here? It seems like it broke over night. Obviously I'd like it to work without the '1' key but at least I have a usable phone again...

dhobi

#5
Weird part is that I have Call Screening set to Off in the GV Calls preferences tab, so I'm not sure why I'm required to press '1' to accept a call. X_SkipCallScreening is also enabled on the OBI which from what I understand does exactly that, it sends a '1'.

I messed with the Trusted Callers today and that's how I noticed that the AA was not picking up my calls, they were being sent to GV voicemail. And after that I could not pickup any incoming GV calls. I would say that's when the trouble started and adding my mobile as a Trusted Caller caused it though it might be just a coincidence.

I have nothing on the list of Trusted Callers now but things are still not working without pressing '1' to accept incoming calls. Any ideas what changes to the OBI the Trusted Callers list may have made? I even removed the device, reset the settings and added it again to OBiTalk and still not working. It seems that something is still persisted and gets changed on the device again.

RonR

Quote from: dhobi on March 01, 2012, 10:59:53 PM
Weird part is that I have Call Screening set to Off in the GV Calls preferences tab, so I'm not sure why I'm required to press '1' to accept a call. X_SkipCallScreening is also enabled on the OBI which from what I understand does exactly that, it sends a '1'.

Even with Call Screening disabled, Google Voice still expects a '1' to be pressed in order to accept the call when the XMPP interface is used.  It's the way the Google Voice folks implemented it.  Simply enable X_SkipCallScreening and this problem will be solved.

Quote from: dhobi on March 01, 2012, 10:59:53 PM
I have nothing on the list of Trusted Callers now but things are still not working without pressing '1' to accept incoming calls. Any ideas what changes to the OBI the Trusted Callers list may have made?

There is absolutely no relationship between Trusted Callers and pressing '1' to accept incoming Google Voice calls.  When you specifiy a Trusted Caller, it simply causes the OBiTALK Web Portal to configure the OBi's InboundCallRoute with rules to allow single-stage calling through the PrimaryLine as well as go to the Auto Attendant.  Nothing about Trusted Callers is related to pressing '1' to accept a Google Voice incoming call.

dhobi

Quote from: RonR on March 01, 2012, 11:18:37 PM
Quote from: dhobi on March 01, 2012, 10:59:53 PM
Weird part is that I have Call Screening set to Off in the GV Calls preferences tab, so I'm not sure why I'm required to press '1' to accept a call. X_SkipCallScreening is also enabled on the OBI which from what I understand does exactly that, it sends a '1'.

Even with Call Screening disabled, Google Voice still expects a '1' to be pressed in order to accept the call when the XMPP interface is used.  It's the way the Google Voice folks implemented it.  Simply enable X_SkipCallScreening and this problem will be solved.

X_SkipCallScreening is already enabled, but it seems to have stopped working. Strange that it worked for about a week and it stopped working today. I think there may be a bit of a delay before the connection is established and the very first packets that send the '1' don't make it to GV.

RonR

Quote from: dhobi on March 01, 2012, 11:29:11 PM
[X_SkipCallScreening is already enabled, but it seems to have stopped working. Strange that it worked for about a week and it stopped working today.

Are you verifying this by logging into the OBi directly or are you looking at the OBiTALK Web Portal?  The OBiTALK Web Portal doesn't always reflect what's actually in the OBi.  The only settings that really count are those in the OBi itself.

If X_SkipCallScreening is actually enabled in the OBi itself, you might try resetting the OBi to factory defaults and then reconfiguring it.  The OBi occasionally gets corrupted internally with no outward evidence of such in any of its settings.

dhobi

I verified both on the device and on OBiTalk. I also unchecked the setting, let it sync and reboot, tried a call then checked the setting again, let it sync and reboot and tried a call.

Still not working without pressing '1', something is broken somewhere.

I tried resetting the device, deleting it from OBiTalk, re-adding it and configuring again and still the same behavior. I might try just removing it from OBiTalk and just managing it locally so nothing else pushes any settings into it. But I have to figure out how to configure GV "by hand" straight on the device. Are the settings posted anywhere?

RonR

System Management -> Auto Provisioning -> ITSP Provisioning -> Method : Disabled
System Management -> Auto Provisioning -> OBiTALK Provisioning -> Method : Disabled

Service Providers -> ITSP Profile A -> General -> Name : Google Voice
Service Providers -> ITSP Profile A -> General -> SignalingProtocol : Google Voice

Voice Services -> SP1 Service -> AuthUserName : (Google Voice username)
Voice Services -> SP1 Service -> AuthPassword : (Google Voice password)
Voice Services -> SP1 Service -> X_SkipCallScreening : (checked)

Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service

dhobi

Thanks. I'll give it a try tomorrow and report back.

dhobi

UPDATE: If I configure the OBI box manually per RonR's instructions above, it seems to work correctly, I do not need to press '1' to take an incoming GV call. But if I let the OBiTalk portal do it, then I have to press '1' for incoming GV calls. In both cases X_SkipCallScreening is enabled but it seems to work only if I configure my OBI manually. There must be something in my OBiTalk online profile that is messing up the configuration and I have no idea what that might be.

This is very strange! I do believe that messing around with that circle of trust yesterday started causing the problem, as strange as it may sound.

RonR

Unless you have a compelling reason to use the OBiTALK Web Portal, it's much quicker and easier to configure the OBi directly/manually.  Then you know what you're getting and don't waste days of your time trying to solve a mystery that you have no control over.

dhobi

Quote from: RonR on March 02, 2012, 12:06:43 PM
Unless you have a compelling reason to use the OBiTALK Web Portal, it's much quicker and easier to configure the OBi directly/manually.  Then you know what you're getting and don't waste days of your time trying to solve a mystery that you have no control over.


I agree with you, except I'm no expert in the strange device syntax or its features. I like the shortcuts the OBiTalk wizards provide, things like "local area code" for 7-digit dialing, enable GV voicemail notifications, etc. I would not have known these features even existed if it were not for OBiTalk.

I wrote to support, let's say if they find anything.

Huib

Good info in this thread! I'm experiencing the same issue! GoogleVoice was working but all of sudden incoming calls were silent. The OBi call status shows a call is in progress but the other end kept ringing. I'll give this a try! Thanks.

dhobi

Quote from: Huib on March 02, 2012, 12:52:47 PM
Good info in this thread! I'm experiencing the same issue! GoogleVoice was working but all of sudden incoming calls were silent. The OBi call status shows a call is in progress but the other end kept ringing. I'll give this a try! Thanks.

Does it work for you if you press '1' after you answer the phone?

Huib

I didn't even try that. I just check the call screening box and voilĂ , it worked!

NameerObi

I am having the same problem where I would have to press 1 in order to accept the incoming call.  I tried the manual setting as it was mentioned earlier:
System Management -> Auto Provisioning -> ITSP Provisioning -> Method : Disabled
System Management -> Auto Provisioning -> OBiTALK Provisioning -> Method : Disabled

Service Providers -> ITSP Profile A -> General -> Name : Google Voice
Service Providers -> ITSP Profile A -> General -> SignalingProtocol : Google Voice

Voice Services -> SP1 Service -> AuthUserName : (Google Voice username)
Voice Services -> SP1 Service -> AuthPassword : (Google Voice password)
Voice Services -> SP1 Service -> X_SkipCallScreening : (checked)

Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service

It worked for few calls then I went back to having to enter the 1 to accept a call again.  By the way, I couldn't find the BOTiTALK provisioning field, the only thing I was able to change under system management is the method.

Stewart

When you log into the OBi directly (at the IP address given when you dial ***1) and go to System Management -> Auto Provisioning, you should see a section named ITSP Provisioning and another named OBiTalk Provisioning.  In both of these sections, set the Method to Disabled, click Submit.  Reboot the device, then confirm that X_SkipCallScreening is checked.

If you still have trouble, report whether you are prompted to press 1, or if you hear silence, but pressing 1 connects the call anyway.