September 01, 2014, 06:35:49 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Basic setup, GV outbound voice quality choppy, inbound generally good  (Read 3334 times)
winger13
Newbie
*
Posts: 17


« on: March 08, 2012, 08:12:44 pm »

My network comprises of a 50MBbps down, 5MBps up (although it can be as slow as 2.3Mbps up) connection via a Motorola Surfboard SB6120. That is connected to a D-Link DIR-655 and that is connected to the Obi110.  I am using the latest Obi110 firmware (downloaded last night).  I am using GoogleVoice on SP1 (setup as the "Primary Line") and a PTSN connection as well.

I have noticed outbound SP1 calls generally have been choppy tonight.  Inbound seems good.

No computer on the network is on except this and it is NOT doing really much traffic.

I have seen Ron's post on:
http://www.obitalk.com/forum/index.php?topic=2203.0

Quote
1. Dial *** 0
2. Enter option 27 and press #
3. Press 1 to set a new value
4. Enter a value of 1 and press #
5. Press 1 to confirm/save
6. Hang up
7. Wait for the OBi to reboot

but I wanted to know what this does before I even try it.

====
Here is a test I just ran to see if this is a problem with Google Voice itself or it is an issue with the Obi110-initiated-call through the SP1 port (Google Voice).

I dialed **8 followed by my GV#
When GV picks up, I dial 2 to place a call to my test destination's phone no. (happens to be a voicemail system)
When the call is connected, the outbound audio this time is really good; no choppiness at all

This proves the outbound audio quality issue lies with the Obi110-initiated-call through the SP1 port.

Any advice how to proceed on clearing up the outbound audio quality?
« Last Edit: March 08, 2012, 08:35:28 pm by winger13 » Logged
RonR
Forum Member

Posts: 4528


« Reply #1 on: March 08, 2012, 09:21:52 pm »

I have seen Ron's post on:
http://www.obitalk.com/forum/index.php?topic=2203.0

Quote
1. Dial *** 0
2. Enter option 27 and press #
3. Press 1 to set a new value
4. Enter a value of 1 and press #
5. Press 1 to confirm/save
6. Hang up
7. Wait for the OBi to reboot

but I wanted to know what this does before I even try it.

It simply changes the OBi's Ethernet port from 10 mb/s half-duplex to 100 mb/s full-duplex.  There's nothing risky about the change and it can be undone by repeating the steps but using a value of 0 in step 4 instead (or restoring factory defaults).

Even if it makes no improvement, it's probably a good change.
Logged
winger13
Newbie
*
Posts: 17


« Reply #2 on: March 19, 2012, 07:06:03 pm »

OK, so I have tested this almost every day for the past week+ since I got this unit.

Almost every weeknight around 5pm-6pm, for all calls to and from my OBI110 unit the outbound voice quality gets really choppy; however, during the day, voice seems crystal clear.  I have not tested much on the weekend, but at least when I did after dinner, same result.

As it currently stands, the unit is not usable (I'd safely say) after 5PM every day.

Could I get some advice with this?  Very light internet use in the house all day/night. My cable service is rated at 50Mbps/5Mbps.  I have new'ish Motorola Surfboard 6120 modem, and a D-Link DIR-655 router.

As I mentioned above, SP1 is setup to Google Voice (as primary). When I Dial **8 + My GV # (forces calling GV via my connected PTSN/landline), then initiate a call using GV's option 2, the call quality is perfect.

This points to something with the internet and/or Google Chat (which my OBI connects to).

HELP!

Logged
RevKev
Jr. Member
**
Posts: 89


« Reply #3 on: March 20, 2012, 05:19:39 pm »

I would try a trace or ping to the google server and check the latency during these bad periods. Although you have high upload speed (which drops to half at times), the latency of a shared cable line could still be a problem.
Logged
winger13
Newbie
*
Posts: 17


« Reply #4 on: March 20, 2012, 08:58:51 pm »

Good suggestion. Can someone point me  out to the ip addy of the server which obi calls (gv) connect to
Also, what is a good latency value to stay under to ensure good quality?
Logged
RevKev
Jr. Member
**
Posts: 89


« Reply #5 on: March 21, 2012, 03:43:27 pm »

I believe you want talk.google.com (173.194.68.125).

Less than 100ms ping time should be good. I'm getting around 30-35ms right now (6:42pm EDT).  I'd check it when things work well and compare to when they don't.
Logged
lk96
Full Member
***
Posts: 147


« Reply #6 on: March 21, 2012, 04:07:42 pm »

I would also suggest that you do some profiling of your connectivity for voip.
Even though you do have plenty of bandwidth (in theory), it's good to
see if during the hours of chopiness you observe packet losses, re-ordered pkts, etc.

If you google for something like "voip bandwidth testing" you will get few sites that
give you access to some web applet to test out your connection.

whichvoip.com seems to be one of them (just throwing a recommendation to make it easier).

L.
Logged
winger13
Newbie
*
Posts: 17


« Reply #7 on: March 21, 2012, 09:28:41 pm »

Thanks for the tips guys. I'll try the ping test and voip applet tests this week when I get home from my trip.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC