December 14, 2017, 07:09:30 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: obi110 not working via VPN  (Read 4462 times)
veames
Newbie
*
Posts: 9


« on: November 14, 2012, 01:47:02 pm »

Hi,
I have an obi110 using voip.ms and google voice. Obi works fine via my usual cable internet connection, but when I am connected via my VPN I cannot establish a connection. My other voip devices work fine. Is there a setting somewhere I need to enable for the obi? Cannot find anything relevant.

VPN connection is using openvpn on my linux router.

Error on the obi:
Register Failed: No Response From Server (server=67.205.74.164:5060; retrying)
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #1 on: November 14, 2012, 04:12:13 pm »

I assume you are using Tomato or DDWRT OpenVPN. Not certain that it might work, try disabling the following setting on the server side if it is enabled:
Direct clients to redirect Internet traffic
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
veames
Newbie
*
Posts: 9


« Reply #2 on: November 15, 2012, 06:31:43 am »

I am running a client only. so that option is not available. Sad My SIP phones work fine over the VPN, just not the OBI, so I am assuming there's some kind of config I need to change on the obi side.?
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #3 on: November 15, 2012, 07:51:16 am »

veames,

A few things to try
1) Set up a stun server on the OBi. It may help find your WAN and RTP ports automatically.
2) If the softphone works, try to find the RTP ports that it is using and reproduce it on the OBi. Phonerlite has a debug feature which works similar to wireshark. It can help identify the ports being used, or perhaps your router may have a feature to identify this. http://phonerlite.de/index_en.htm

Perhaps you can give more info about your VPN setup? Is it Home brew/commercial?
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
veames
Newbie
*
Posts: 9


« Reply #4 on: November 15, 2012, 09:15:33 am »

thanks, I will try the STUN server. My setup is

|Obi110
|Snom 300
|Softphones
 - Netgear WNDR 3700 running OpenWRT -
    - OpenVPN Client Connection to privateinternetaccess.com -
        - Google Voice XMPP
        - voip.ms SIP
« Last Edit: November 15, 2012, 09:36:34 am by veames » Logged
veames
Newbie
*
Posts: 9


« Reply #5 on: November 15, 2012, 01:07:51 pm »

No go for STUN.

Registration works right away on my Snom phone. here's the log

15/11/2012 17:04:34 [DEBUG0] PHN: Trusted IP Addresses: udp:67.205.74.164
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: recv 100 REGISTER (3: 386d43b61c46-97fmu2031zs6) <- udp:67.205.74.164:5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: registration report 100/0: ''
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: recv 401 REGISTER (3: 386d43a61c46-97fmu2031zs6) <- udp:67.205.74.164:5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: clear message repetition 1000005 386d43a61c46-97fmu2031zs6
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: sip::process_auth Identity=0
15/11/2012 17:04:34 [WARN  ] PHN: SIP: process_registrar_packet: 401 needs 128 bit nonce
15/11/2012 17:04:34 [NOTICE] PHN: SIP: process auth:Match challenge for user=MYUSERNAME, realm=montreal.voip.ms
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: Routing to explicit plan udp 67.205.74.164 5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: route pending packet 1000007: entry=udp 67.205.74.164 5060 all 3
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: send REGISTER (4: 386d43a61c46-97fmu2031zs6) -> udp:67.205.74.164:5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: result of get_ip_adr:67.205.74.164 192.168.1.210
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: result of get_ip_adr:67.205.74.164 192.168.1.210
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: recv 100 REGISTER (4: 386d43b61c46-97fmu2031zs6) <- udp:67.205.74.164:5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: registration report 100/0: ''
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: recv 200 REGISTER (4: 386d43b61c46-97fmu2031zs6) <- udp:67.205.74.164:5060
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: clear message repetition 1000007 386d43a61c46-97fmu2031zs6
15/11/2012 17:04:34 [CRITIC] PHN: SIP: Registered at registrar as MYUSERNAME@montreal.voip.ms (Expires: 180 secs)
15/11/2012 17:04:34 [DEBUG2] GUI: If_Registration(REGISTRAR, CONFIRMED, 0, MYUSERNAME@montreal.voip.ms,OK)
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: Registration Metrics: 200, sip:MYUSERNAME@192.168.1.210:2048;line=uu1qy1q0, 180, 300
15/11/2012 17:04:34 [DEBUG2] PHN: SIP: registration report 200/0: ''
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC