December 14, 2017, 09:10:14 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 [2] 3 4 5
  Print  
Author Topic: Setting Up Caller ID shown Name and Number on OBI110 !!! HELP  (Read 193204 times)
windoverwater
Newbie
*
Posts: 5


« Reply #20 on: June 13, 2012, 06:54:12 pm »

Well, I followed the above and everything works as described!  My GV number now calls the free callcentric NY number which now comes in via SP2 with CNAM enabled - cool.

However, it appears that the Obi110 by default configures sp2 tones/rings for Australian 'standards' and sp1 for US/North American 'standard' tones/rings.  In other words, the ring tones for sp2 and call waiting tones for sp2 are different than those for sp1.  In particular, it seems that the sp2 defaults for call waiting has the tone constantly interrupting the line every few seconds.  And the sp1 tones/rings are what my family is used to.

Looking at the tones/rings A/B profiles seems to back this up - they are different.  And using the magic Obi secret decoder ring supplied in the admin manual, the settings appear to match the observed tones/rings.

Are other people getting the same affect?  Is there an easier way have sp2 mirror sp1 tones/rings other then manually overriding the ~40 settings!?

Thanks in advance!
Logged
pc44
Sr. Member
****
Posts: 429


« Reply #21 on: June 13, 2012, 07:25:09 pm »

Hi windoverwater,

This will probably not help with the tone settings, but it may help a little with the ring settings.  What setting do you have for the following?

Voice Services -> SP2 Service -> X_RingProfile -> ?

Mine is set for "A" on both SP1 and SP2 Services.  I'm wondering if you can't just change it here to match up with the X_RingProfile for SP1?  I also have my X_ServProvProfile on SP2 set to A.  Not sure if this would help, but it's just a thought! Smiley

What do you think?
pc44
Logged

babobi
Jr. Member
**
Posts: 55



« Reply #22 on: July 09, 2012, 12:10:57 am »

So if I do this, how do I forward incoming calls from GV to this Callcentric number in order to have CNAM appear on my phone?

Tom,

Add your Callcentric number to your Google Voice account as a new forwarding number.  Then, configure Google Voice to forward all incoming calls to your Callcentric number.  Also, un-check Google Chat, so it is not selected as your forwarding device.

Once that is done, configure your OBI for Callcentric.  They have a configuration guide for the OBI with instructions on the Callcentric site.  Once that is done, you should be able to receive GV calls via the Callcentric service (with CNAM).  For outgoing calls, you will need to keep GV configured in the OBI.

Basically, you will have GV on SP1 and Callcentric on SP2 or vice-versa if you so choose.

Hope this makes sense,
pc44

Hello pc44, I am trying to emulate the instructions you gave tome so I can get Caller ID WITH NAME to show up on my landline phone connected to my Obi 110. BTW I only want the NAME Caller ID for INCOMING calls, NOT outgoing. I opened an account with Callcentric and added it to my Obi 110 on the SP2 port. I was a little confused about the number/s Callcentric gave to me, there is a 1777xxxxxxx number and a NY # 1917xxxxxxx. First I tried entering the 917 # with my password into Obi SP2 port and kept getting error messages, then I tried the 777 # with password and that worked. Obi dashboard now says: "SP1 Google Voice™ Account   Connected" and underneath that it says: "SP2 (Optional) Callcentric account Registered"

I have added the new Callcentric number to my Google Voice forwarding numbers (the 917 #, not the 777 #, is that right?) and checked the GV Callcentric checkbox. But when I make test INCOMING calls, only the number is showing up, NOT the NAME on Caller ID. What am I doing wrong? Note that I did this setup with the web portal as I am currently in a different city than the location of the Obi 110 and landline phone. Do I have to be at the physical location where my Obi 110 is in order to configure the Callcentric with SIP? Thanks so much for your guidance!
Logged
Dixon
Jr. Member
**
Posts: 65


« Reply #23 on: July 09, 2012, 03:48:10 am »

Did you uncheck "Forward Calls to: Google Chat" in

https://www.google.com/voice/b/0/?pli=1#phones

Shoud be unchecked. Seems like that is your only problem.

The 917 is correct. Web portal is fine.
Logged
Fasttimes
Jr. Member
**
Posts: 44


« Reply #24 on: July 09, 2012, 04:24:02 am »

So if I do this, how do I forward incoming calls from GV to this Callcentric number in order to have CNAM appear on my phone?

Tom,

Add your Callcentric number to your Google Voice account as a new forwarding number.  Then, configure Google Voice to forward all incoming calls to your Callcentric number.  Also, un-check Google Chat, so it is not selected as your forwarding device.

Once that is done, configure your OBI for Callcentric.  They have a configuration guide for the OBI with instructions on the Callcentric site.  Once that is done, you should be able to receive GV calls via the Callcentric service (with CNAM).  For outgoing calls, you will need to keep GV configured in the OBI.

Basically, you will have GV on SP1 and Callcentric on SP2 or vice-versa if you so choose.

Hope this makes sense,
pc44

I don't understand part of this.  How does CC know to forward calls to your obi unit???
Logged
pc44
Sr. Member
****
Posts: 429


« Reply #25 on: July 09, 2012, 05:03:15 am »

Hello pc44, I am trying to emulate the instructions you gave tome so I can get Caller ID WITH NAME to show up on my landline phone connected to my Obi 110. BTW I only want the NAME Caller ID for INCOMING calls, NOT outgoing. I opened an account with Callcentric and added it to my Obi 110 on the SP2 port. I was a little confused about the number/s Callcentric gave to me, there is a 1777xxxxxxx number and a NY # 1917xxxxxxx. First I tried entering the 917 # with my password into Obi SP2 port and kept getting error messages, then I tried the 777 # with password and that worked. Obi dashboard now says: "SP1 Google Voice™ Account   Connected" and underneath that it says: "SP2 (Optional) Callcentric account Registered"

I have added the new Callcentric number to my Google Voice forwarding numbers (the 917 #, not the 777 #, is that right?) and checked the GV Callcentric checkbox. But when I make test INCOMING calls, only the number is showing up, NOT the NAME on Caller ID. What am I doing wrong? Note that I did this setup with the web portal as I am currently in a different city than the location of the Obi 110 and landline phone. Do I have to be at the physical location where my Obi 110 is in order to configure the Callcentric with SIP? Thanks so much for your guidance!

Hi babobi,

So far, it sounds as though you have followed the right initial steps.  As Dixon mentioned, you need to un-check Google Chat as your forwarding phone from inside your Google Voice account settings page (http://www.google.com/voice).  Then, make sure your Callcentric number is checked as a forwarding phone from inside your Google Voice account settings page.

You can also double-check the following settings, but it sounds like you already have this part setup correctly, since you said SP2 is registered successfully:
Service Providers > ITSP Profile B > SIP -> ProxyServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> RegistrarServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> UserAgentDomain: callcentric.com
Service Providers > ITSP Profile B > SIP -> OutboundProxy: callcentric.com

The following fields should be filled out with your name, your callcentric number beginning with 1 (e.g. 17775551212), and then your password:
Service Providers > ITSP Profile B > General -> Name:
Voice Services > SP2 Service -> AuthUserName:
Voice Services > SP2 Service -> AuthPassword:

Please report back to us with your status, Smiley
pc44
Logged

pc44
Sr. Member
****
Posts: 429


« Reply #26 on: July 09, 2012, 05:07:59 am »

I don't understand part of this.  How does CC know to forward calls to your obi unit???

Then, configure Google Voice to forward all incoming calls to your Callcentric number.

...

Basically, you will have GV on SP1 and Callcentric on SP2 or vice-versa if you so choose.

Fasttimes,

You will need to add your Callcentric number as a Forwarding Phone from inside Google Voice's account settings page (http://www.google.com/voice).  After you have added your CC number to your GV account, you should make sure there is a check mark in the box for forwarding calls to your Callcentric number (again, this is all done inside Google Voice's account settings page).  Also, un-check the box for forwarding calls to Google Chat.  Now, incoming calls to your Google Voice number should be automatically forwarded to your Callcentric number.

pc44 Smiley
Logged

Fasttimes
Jr. Member
**
Posts: 44


« Reply #27 on: July 09, 2012, 05:18:21 am »

pc44:

I understand this part, my question is how does CC know to send calls to the Obi unit?  (I'm trying to understand the process)

I assumed that you have to go into CC and forward to the OBI someow.  Is this incorrect?  Are we configuring "on the obi side" so that the Obi takes calls from CC?

Logged
pc44
Sr. Member
****
Posts: 429


« Reply #28 on: July 09, 2012, 05:57:16 am »

Basically, you will have GV on SP1 and Callcentric on SP2 or vice-versa if you so choose.

Fasttimes,

You will need to set up your Callcentric account in your OBI.  Most people seem to use SP2.  Once this is done, your Obi is then 'connected' so to speak with CC.  See the other post above regarding how to set up CC on SP2.  This is how Callcentric 'knows' to send the call to your OBI.

Hope it helps, Smiley
pc44
« Last Edit: July 09, 2012, 05:58:59 am by pc44 » Logged

babobi
Jr. Member
**
Posts: 55



« Reply #29 on: July 09, 2012, 08:53:59 am »

Hello pc44, I am trying to emulate the instructions you gave tome so I can get Caller ID WITH NAME to show up on my landline phone connected to my Obi 110. BTW I only want the NAME Caller ID for INCOMING calls, NOT outgoing. I opened an account with Callcentric and added it to my Obi 110 on the SP2 port. I was a little confused about the number/s Callcentric gave to me, there is a 1777xxxxxxx number and a NY # 1917xxxxxxx. First I tried entering the 917 # with my password into Obi SP2 port and kept getting error messages, then I tried the 777 # with password and that worked. Obi dashboard now says: "SP1 Google Voice™ Account   Connected" and underneath that it says: "SP2 (Optional) Callcentric account Registered"

I have added the new Callcentric number to my Google Voice forwarding numbers (the 917 #, not the 777 #, is that right?) and checked the GV Callcentric checkbox. But when I make test INCOMING calls, only the number is showing up, NOT the NAME on Caller ID. What am I doing wrong? Note that I did this setup with the web portal as I am currently in a different city than the location of the Obi 110 and landline phone. Do I have to be at the physical location where my Obi 110 is in order to configure the Callcentric with SIP? Thanks so much for your guidance!

Hi babobi,

So far, it sounds as though you have followed the right initial steps.  As Dixon mentioned, you need to un-check Google Chat as your forwarding phone from inside your Google Voice account settings page (http://www.google.com/voice).  Then, make sure your Callcentric number is checked as a forwarding phone from inside your Google Voice account settings page.

You can also double-check the following settings, but it sounds like you already have this part setup correctly, since you said SP2 is registered successfully:
Service Providers > ITSP Profile B > SIP -> ProxyServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> RegistrarServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> UserAgentDomain: callcentric.com
Service Providers > ITSP Profile B > SIP -> OutboundProxy: callcentric.com

The following fields should be filled out with your name, your callcentric number beginning with 1 (e.g. 17775551212), and then your password:
Service Providers > ITSP Profile B > General -> Name:
Voice Services > SP2 Service -> AuthUserName:
Voice Services > SP2 Service -> AuthPassword:

Please report back to us with your status, Smiley
pc44

Hi pc44. My Callcentric WAS registered yesterday, but when I tried to log in to my Callcentric account late last night it kept saying my password was incorrect, and I KNOW I was entering the right one because I had done it umpteen times before no problem and even wrote it down. Long story short, I had to change my CC password, which rendered my CC account on Obi 110 null. I've tried at least a dozen times to reregister and NOW the Obi dashboard says: "SP2 (Optional)   Callcentric account   Service Not Configured"

AAARRRGGGHHH!!!  Huh Embarrassed

It was so easy yesterday, just entered my CC # and pasword and it registered no problem. NOW, I can't register CC to save my life. WTF??? I called Obihai support and left a voicemail asking to call me back, I'd really like to speak with a live person. So I can't test the Caller ID with name until this issue is settled. I will report back with status when I can figure out how to put the dang CC account back onto the Obi 110. Sheesh! Thanks so much pc44 for your time and help!

p.s. -- just refreshed Obi Dashboard and SP2 NOW says:
"SP2 (Optional)   Callcentric account   Register Failed: 403 Incorrect Authentication"
« Last Edit: July 09, 2012, 08:57:10 am by babobi » Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #30 on: July 09, 2012, 09:19:48 am »

On Callcentric dashboard -> general tab -> phone password, you can change your SIP password to match what you have in the OBi, even if that is different from your CC web login password.

Or, change the CC password on the OBiTalk portal to match what you have on CC.

Or, if you are sure what they are, set them both to the same value.
Logged
pc44
Sr. Member
****
Posts: 429


« Reply #31 on: July 09, 2012, 09:35:31 am »

Hi babobi,

Sorry to hear about your frustration there.  Please try following Stewart's advice in the post above this one.  Then, please report back with your status.

Also, double-check that you are using the 1777 number for SP2 AuthUserName and not the 1917 number.  If you like, you could also verify that there are no typo's when you entered "callcentric.com" throughout the SIP section.

pc44 Smiley
Logged

babobi
Jr. Member
**
Posts: 55



« Reply #32 on: July 09, 2012, 10:11:36 am »

Hi babobi,

Sorry to hear about your frustration there.  Please try following Stewart's advice in the post above this one.  Then, please report back with your status.

Also, double-check that you are using the 1777 number for SP2 AuthUserName and not the 1917 number.  If you like, you could also verify that there are no typo's when you entered "callcentric.com" throughout the SIP section.

pc44 Smiley
Thanks pc44 and Stewart, but I feel like I am in The Twilight Zone here: OK, I changed the SIP password again and reregistered CC onto Obi 110 and finally got the "SP1 Google Voice™ Account   Connected" message on Obi Dashboard. NOW about 10 minutes later, it says: "SP2 (Optional)   Callcentric account   Register Failed: 403 Incorrect Authentication" What in the wide wide world of sports is a goin' on here?!?!

WWWHHHHHAAAAAA!!! 
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #33 on: July 09, 2012, 10:18:55 am »

babobi,

What in the wide wide world of sports is a goin' on here?!?!

Is that a reference to your age? The younger folks here will not even realize the reference.  Smiley

Perhaps just create another CC account. They are free to setup. Consider it a disposable DID.
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
babobi
Jr. Member
**
Posts: 55



« Reply #34 on: July 09, 2012, 10:34:35 am »

Hello pc44, I am trying to emulate the instructions you gave tome so I can get Caller ID WITH NAME to show up on my landline phone connected to my Obi 110. BTW I only want the NAME Caller ID for INCOMING calls, NOT outgoing. I opened an account with Callcentric and added it to my Obi 110 on the SP2 port. I was a little confused about the number/s Callcentric gave to me, there is a 1777xxxxxxx number and a NY # 1917xxxxxxx. First I tried entering the 917 # with my password into Obi SP2 port and kept getting error messages, then I tried the 777 # with password and that worked. Obi dashboard now says: "SP1 Google Voice™ Account   Connected" and underneath that it says: "SP2 (Optional) Callcentric account Registered"

I have added the new Callcentric number to my Google Voice forwarding numbers (the 917 #, not the 777 #, is that right?) and checked the GV Callcentric checkbox. But when I make test INCOMING calls, only the number is showing up, NOT the NAME on Caller ID. What am I doing wrong? Note that I did this setup with the web portal as I am currently in a different city than the location of the Obi 110 and landline phone. Do I have to be at the physical location where my Obi 110 is in order to configure the Callcentric with SIP? Thanks so much for your guidance!

Hi babobi,

So far, it sounds as though you have followed the right initial steps.  As Dixon mentioned, you need to un-check Google Chat as your forwarding phone from inside your Google Voice account settings page (http://www.google.com/voice).  Then, make sure your Callcentric number is checked as a forwarding phone from inside your Google Voice account settings page.

You can also double-check the following settings, but it sounds like you already have this part setup correctly, since you said SP2 is registered successfully:
Service Providers > ITSP Profile B > SIP -> ProxyServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> RegistrarServer: callcentric.com
Service Providers > ITSP Profile B > SIP -> UserAgentDomain: callcentric.com
Service Providers > ITSP Profile B > SIP -> OutboundProxy: callcentric.com

The following fields should be filled out with your name, your callcentric number beginning with 1 (e.g. 17775551212), and then your password:
Service Providers > ITSP Profile B > General -> Name:
Voice Services > SP2 Service -> AuthUserName:
Voice Services > SP2 Service -> AuthPassword:

Please report back to us with your status, Smiley
pc44

Hi pc44, reporting back with my status -- OK, back to square one: managed to reregister CC onto Obi 110 successfully, now I'm checking the other things you told me to do:

Service Providers > ITSP Profile B > SIP -> ProxyServer: callcentric.com CHECK, BUT TINY RED EXCLAMATION MARK TO THE RIGHT, IS THAT NORMAL?
Service Providers > ITSP Profile B > SIP -> RegistrarServer: callcentric.com IT's BLANK SHOULD I ENTER "callcentric.com"?
Service Providers > ITSP Profile B > SIP -> UserAgentDomain: callcentric.com IT's BLANK SHOULD I ENTER "callcentric.com"?
Service Providers > ITSP Profile B > SIP -> OutboundProxy: callcentric.com CHECK, BUT TINY RED EXCLAMATION MARK TO THE RIGHT, IS THAT NORMAL?

AND

The following fields should be filled out with your name, your callcentric number beginning with 1 (e.g. 17775551212), and then your password:
Service Providers > ITSP Profile B > General -> Name: IT'S BLANK, DO I ENTER JUST MY FIRST AND LAST NAME?
Voice Services > SP2 Service -> AuthUserName: CHECK, MY 177XXXXXXXX NUMBER IS ALREADY ENTERED
Voice Services > SP2 Service -> AuthPassword: IT'S BLANK, SHOULD I MANUALLY ENTER IT? I NOTICE MY GOOGLE VOICE ON SP1 HAS THIS BLANK TOO, YET IT WORKS WITHOUT BEING FILLED IN

I'm scared to enter the information in the blanks for fear of messing something up, but if you give me the go ahead I will enter the information, Thanks tons pc44!
« Last Edit: July 09, 2012, 10:37:25 am by babobi » Logged
pc44
Sr. Member
****
Posts: 429


« Reply #35 on: July 09, 2012, 01:12:54 pm »

Babobi,

For your SP2, yes, you do need to enter those settings, especially the RegistrarServer entry.  So, first enter the correct settings as described previously, then Submit, and then Reboot the OBI.  After that, you can check the red exclamation mark status again.  But first give this a try, and then let us know what your status is for SP2.

For Name, yes you can enter your name, however you like.  For AuthPassword, definitely put your correct password in here.  (However, leave Google Voice on SP1 the way it already is... GV does not use SIP to my understanding.)

So... please update all of these settings, and then report back,
pc44

p.s. I remember the wide wide world of sports.
« Last Edit: July 09, 2012, 01:14:46 pm by pc44 » Logged

babobi
Jr. Member
**
Posts: 55



« Reply #36 on: July 09, 2012, 04:38:32 pm »

Babobi,

For your SP2, yes, you do need to enter those settings, especially the RegistrarServer entry.  So, first enter the correct settings as described previously, then Submit, and then Reboot the OBI.  After that, you can check the red exclamation mark status again.  But first give this a try, and then let us know what your status is for SP2.

For Name, yes you can enter your name, however you like.  For AuthPassword, definitely put your correct password in here.  (However, leave Google Voice on SP1 the way it already is... GV does not use SIP to my understanding.)

So... please update all of these settings, and then report back,
pc44

p.s. I remember the wide wide world of sports.

Hi again pc44. Okay, I unchecked Google Chat and made all the changes as you specified, yet only numbers show up on the Caller ID, not numbers WITH name. Question: How does the Obi 110 know to show the Callcentric NAME Caller ID and not the Google Voice NUMBER ONLY Caller ID?

Please note that I made these adjustments using the web portal as I am currently in a different city than the location of the Obi 110 and landline phone. Do I have to be at the physical location where my Obi 110 is in order to configure the Callcentric with SIP? Does the Obi need the ISP of the computer where the Obi is physically located? Thanks so much for your help!

p.s. -- http://www.youtube.com/watch?v=d0VNHe5fq30  LOL!
Logged
pc44
Sr. Member
****
Posts: 429


« Reply #37 on: July 09, 2012, 05:42:59 pm »

Hi babobi,

I could be mistaken, but I do not believe you need to be at the physical location of your OBI.  As long as you have been able to make all of the configuration changes that we have discussed so far, via the Obitalk Web Portal, then I think you should be fine.

If I recall correctly, you have GV on SP1 and CC on SP2.  With that assumption in mind, we do not want the OBI to receive any incoming calls on SP1.  We want all incoming calls to be received on SP2.

Overview:
*A friend calling you* -> Your GV Number -> Forwards to your CC Number -> CC sends call to your OBI SP2

That's the big picture of what we are trying to accomplish.  So,
1) Please make sure that your GV Number is set to Forward to your CC 1917 Number
2) Please make sure that your GV Number is not set to Forward to any other phone (including Google Chat)
3) Please make sure that CC is successfully registering on SP2 (Status -> System Status -> SP2 Service Status)

While possibly oversimplified, if you can achieve those 3 steps, you 'should' be able to view CNAM on your incoming calls. Smiley

Make sense?
pc44

p.s. Thanks for the video clip... was funny Cheesy
« Last Edit: July 09, 2012, 05:48:07 pm by pc44 » Logged

babobi
Jr. Member
**
Posts: 55



« Reply #38 on: July 09, 2012, 06:16:25 pm »

Ah -- stupid me! I remembered to uncheck Google Chat but didn't have Callcentric checked. Doh! I'll let you know if it works next time a call comes in. Thanks for the explanation too -- yes, makes sense! Thanks again pc44!
Logged
JohnBowler
Jr. Member
**
Posts: 72


« Reply #39 on: July 09, 2012, 10:43:08 pm »

voip.ms offers a free iNum and this has the option of caller-id name lookup for 0.8c each time.  They also don't charge if the caller matches an entry in the address book, which might save someone quite a lot of money (only about 25c a month in my case!)

I'm not sure if voip.ms charge for incoming calls though; I've never used them for incoming.

John Bowler <jbowler@acm.org>
Logged
Pages: 1 [2] 3 4 5
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC