September 21, 2014, 01:05:05 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Can anyone help me with my VOIP connection - is this the normal quality?  (Read 13366 times)
Ann404
Newbie
*
Posts: 7


« on: May 01, 2012, 07:34:58 pm »

Hi, I'm hoping someone can point me in the right direction. I am having some problem with the configuration for my OBI110 device. I've emailed the VOIP service (Callcentric) who said the problem lies with the ISP provider. They ( ISP Provider ATT) say there's nothing wrong with their end. I am so confused, I'm I just expecting too much??
I just brought the obi110 phone adaptor for amazon. I was trying to hook it up to google voice but when that wasn't working I tried callcentric and they both sound the same. It's like talking on a two way radio. Like I can't hear anything from the other person when I'm talking, and there's a slight pose when they start talking. When they start talking they can't hear anything from my side. If we try to talk at the same time you can't really make it out (like it's cutting in and out). There is also a beep the other person hears every now and then. The calls do not drop and I can hear them speaking fine. But you have to keep saying are you still there, as the lack of sound makes you think they were disconnected.

Anyway I have a 2wire router, with att u-verse fiber optic, my download speed is 11.24mbps - upload is 1.41mbps. I did a ping test like 6 times and only once ( a few days ago) did it show any lost packets. I also tried to change the Codec Profile configuration to G729 Codec as its suppose to use less bandwidth. I also installed X-lite softphone to make sure it wasn't the obi110. The softphone was so choppy that it was unusable. Now Callcentric wants me to go into the routers firewall page and disable SIP ALG, and Stateful Packet Inspection (SPI). Which I don't even think I can do without my ISPs help. As I couldn't find it on my routers homeportal page.
Any thought?? Ann
Logged
carl
Sr. Member
****
Posts: 445


« Reply #1 on: May 02, 2012, 08:48:06 am »

The U-verse 2 wire router is a *bitch with VOIP and do not expect any help whatsoever fro9m ATT.
I would not botherwith the SIP ALG and SPI, but what you should do is to go into the gateway and put it in DMZ mode ( just for your Obi, not for the computer !)  Site map>System Links>firewall> Pinholes, DMZ,applications .Once done that, you go to services>voice>line and click ring. After that, you may want to reboot the gateway.

For all of that, you will need your gateway password . You should create a very strong one. To access the gateway put in the search window the number on the side of your gateway, where it says " For advanced configuration" .
There is no manual and no support for the gateway. You will have to figure it out on your own. AT&Tea will not help with anything once they get the slightest suspicion that you want use VOIP.
Logged
Ann404
Newbie
*
Posts: 7


« Reply #2 on: May 02, 2012, 10:27:37 am »

Thanks for the reply.  I'll post back and let you know if it works.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #3 on: May 02, 2012, 11:20:00 am »

IMO, setting DMZ or changing any other RG settings will not fix either of your two specific problems, though they they may help with other issues.

The beeps heard by the remote party are known as "DTMF talkoff".  Southsound has a fairly good explanation in http://www.ooma.com/forums/viewtopic.php?f=4&t=8068 .  However, the OBi is a lot more flexible than Ooma and there are some settings that may fix it for you.  For ITSP Profile A (or B, as appropriate) -> General, try changing DTMFMethod from Auto to InBand.  This should eliminate the beeps, but may make DTMF control of voicemail or IVR systems less reliable or even non-functional, so test that with some systems that you regularly use.  If no luck, undo that change and try setting Phone Port -> DTMFRxMode to software.  That may not eliminate the beeps, but they should occur less often.  Again, test to be sure that IVR access isn't broken.

I have U-Verse at home (i3812V gateway) and have no VoIP troubles.  I doubt that your problems, at least the ones mentioned so far, are related to AT&T.  To confirm, take your OBi to a friend's or neighbor's with a different ISP.  Or, try X-Lite there.

Your other issue, poor double-talk performance, plagues VoIP in general.  It's unfortunately quite complex.  The Introduction to VoIP document referenced in http://forums.whirlpool.net.au/archive/1516052 is reasonably non-technical.  If you are familiar with the terminology, see http://www.cisco.com/en/US/docs/ios/solutions_docs/voip_solutions/EA_ISD.html for a more detailed explanation.

AFAIK, there is no way to greatly improve OBi's handling of double-talk, but if your outbound voice is heard louder than needed by your contacts, lowering Phone Port -> ChannelRxGain will reduce the effect of your outbound voice on incoming audio.  If you have a good headset, try turning off AEC in X-Lite.  If the result is acceptable, getting a decent IP phone should give you similar results with a regular handset.  As a bonus, IP phones don't have DTMF talkoff problems.
« Last Edit: May 02, 2012, 11:22:41 am by Stewart » Logged
carl
Sr. Member
****
Posts: 445


« Reply #4 on: May 02, 2012, 02:06:10 pm »


I have U-Verse at home (i3812V gateway) and have no VoIP troubles. 

I have the 2WIRE 3600HGV and I had major issues getting it working with VOIP( currently still in DMZ and no x-lite or similar) and I know that a number of people gave up on it entirely.
Off course, with you level of experience and knowledge things probably look differently, but for an average ( prospective) VOIP customer those things are overwhelming. The vast majority of people I know either gave up on VOIP or, in most cases, do not even want to start with it and that especially applies to the generation which was not born next to a computer.
I agree with you that changing router settings probably will not fix the specific problems OP mentioned, I just followed the line of Callcentric's customer service advise.
One thing I also noticed after ATT changed me from regular to U verse DSL was that while the speed improved( especially upload) some the other results were not all that impressive  and the QoS fluctuates.
Logged
Ann404
Newbie
*
Posts: 7


« Reply #5 on: May 02, 2012, 04:52:54 pm »

Thank you both for your help. I can now give a name to my problem. Anyway I am trying to set my obi110 device to DMZ but it gives 3 choices, Maximum protection, Allow individual applications, and Allow all applications (DMZplus mode). Can you tell me what one to set. And if there is any other steps I need to take to complete this type of setup? I understand it may not slove my problem but it may also help. I don't have a lot of computer experiance, so I am concerned that I'll make a bigger headache for myself.
 Also, am I right in guessing that even if I went with another service like vonage I would have the same problems with double-talk and dtmf takeoff?? Would a different adaptor help like the one vonage would send or simular company send make any difference? Thanks again for your help, I will post back with my results, Ann
Logged
carl
Sr. Member
****
Posts: 445


« Reply #6 on: May 02, 2012, 05:03:54 pm »

I would do the DMZ plus because it is the easiest things you can do and unlike anything else it really solved my problem, but like Stewart pointed out it may not solve your specific  problems which are different than my problems were. I think that Obi is a good product and I do not believe that any other non proprietary VOIP adapter will do any better job.
I would definitely try your obi on a different broadband provider in a friend's house( probably the cable company in your area) just to compare the results.
Logged
Felix
Sr. Member
****
Posts: 345


« Reply #7 on: May 02, 2012, 11:01:04 pm »

Even easier... try to set up Google Voice in addition to Callcentric. See how it sounds. My neighbor has uverse, and hasn't have a problem with his Voip service... At least, it will point you with more confidence towards either AT&T or Callcentric
Logged
Ann404
Newbie
*
Posts: 7


« Reply #8 on: May 03, 2012, 11:11:57 am »

I just wanted to post back that I set the obi to DMZ plus mode and reset my router. I still have the same problem with the walkie talkie effect BUT the person I called did say I was much clearer. Also we didn't hear any beeping, but I did set it back g711 mode for google voice. I looked at what I THINK is the phone port and ChannelRxGain on the Obi advance configuration is set to "0" also the DTMFPlaybackLevel is set to "-18". These are default settings.
  Is there anything else I can try as far as the walkie talkie sound? It's weird because I even tried counting and having the other person count at the same time and we could hear each other fine. Now when I tried humming it did break up a little. It's when I'm talking and stop that the phone sounds silent like it was disconnected. As soon as the other person starts to talk I can hear them and any back ground noise again just fine. The same is true for them. It really interfers with the conversation. I will try taking it to another house with different connection as soon as I can. But are there any other things I can try? Again thank for all your help, Ann
Logged
Ann404
Newbie
*
Posts: 7


« Reply #9 on: May 03, 2012, 11:14:28 am »

Even easier... try to set up Google Voice in addition to Callcentric. See how it sounds. My neighbor has uverse, and hasn't have a problem with his Voip service... At least, it will point you with more confidence towards either AT&T or Callcentric

Both Callcentric and Google voice sound the same. Would vonage or simular sound any different?
Logged
carl
Sr. Member
****
Posts: 445


« Reply #10 on: May 03, 2012, 11:16:17 am »

Even easier... try to set up Google Voice in addition to Callcentric. See how it sounds. My neighbor has uverse, and hasn't have a problem with his Voip service... At least, it will point you with more confidence towards either AT&T or Callcentric
Not quite. except that I cannot use the soft phone, I never had any problems with GV. It was the SIP providers where I had the problems.
Logged
Stewart
Hero Member
*****
Posts: 1125


« Reply #11 on: May 03, 2012, 11:36:09 am »

DTMFPlaybackLevel is the volume at which incoming DTMF is rendered, for example if you had an answering machine connected to the Phone port and were retrieving its messages remotely.  If you are hearing occasional beeps when your contact speaks, you can make them less obnoxious by reducing the level.  However, this setting won't affect what beeps the remote party may hear when you speak.  For that, if you still have the trouble, see the settings in my earlier post.

ChannelRxGain affects the volume of your voice sent to the remote party.  If they hear you louder than needed, you might try changing it to -3 or -6.  By reducing the level of your outbound voice, you will also reduce the effect of it attenuating the incoming audio.

IMO, Vonage will likely be no better.  If you have a friend or co-worker with Vonage (or VOIPo, Phonepower, etc.), you could go over there to compare.  Otherwise, I believe that they do offer a free trial, but you will need to go through the hassle of installing and then returning their equipment.

Logged
Ann404
Newbie
*
Posts: 7


« Reply #12 on: May 04, 2012, 07:59:27 pm »

Just wanted to post that I changed the channelRXgrain to -6 and things seem better. It's still there but it doesn't seem as bad. I want to thank everyone for their help. I have just two more questions. One by leaving the obi in DMZ plus mode does it in anyway make my computer open to attack, virus or whatever? I'm thinking not since the obi is not hooked up to the computer, but the computer IS hooked up to the router? Finally I heard there is a way to limit any computer downloads so the obi will have enough bandwidth. IS there a way to do that so it ONLY limits the bandwidth when needed (when I'm on the phone)? Thanks so much, Ann
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC