December 13, 2017, 03:18:09 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: 1 2 [3] 4 5 ... 10
  Print  
Author Topic: Dial plan explanation  (Read 1837951 times)
andrewp
Newbie
*
Posts: 10


« Reply #40 on: June 02, 2011, 11:59:38 am »

Hi all,

I'm trying to change DigitMap for ITSPB which is configured for SIP to make international calls.
I'd like to have following phone number transformation:
Dialed phone number: **201123334445566
Phone to send to SP2 : 23334445566

SP2 is configured with ITSPB
Primary line is set to to SP1 which is GV

I have default OutboundCallRoute on PHONE port "...,{(<**2:>(Msp2)):sp2},..." and changed ITSPB DigitMap to: (<011:>2333xxxxxxx)

When I try to place a call, I get an error that there is no route. Am I doing something wrong here?

Logged
RonR
Forum Member

Posts: 4528


« Reply #41 on: June 02, 2011, 12:32:47 pm »

andrewp,

Is this your whole ITSPB DigitMap value? : (<011:>2333xxxxxxx)

If so:

When the PHONE Port DigitMap is processed, your dialed number of **201123334445566 will be transformed to **223334445566 by the ITSPB DigitMap rule (<011:>2333xxxxxxx).  When **223334445566 is then processed by the PHONE Port OutboundCallRoute, the **2 will be removed but the remaining number (23334445566) will not match your ITSPB DigitMap rule (<011:>2333xxxxxxx) because the 011 has already been removed.  Consequently, the {(<**2:>(Msp2)):sp2} rule cannot be executed.
Logged
andrewp
Newbie
*
Posts: 10


« Reply #42 on: June 02, 2011, 01:30:38 pm »

Thanks a lot RonR,

I was suspecting something like that, but was not sure if PHONE port DigitMap is applied automatically or only when referenced from the Call Route.

When I was placing a call, the Call Status page of OBi110 was showing phone number as **223334445566 i.e already processed by PHONE -> ITSPB DigitMap transfromation.

I guess that the correct digit map for ITSPB will be: (<011:>2333xxxxxxx|2333xxxxxxx)

It would be less confusing if DMP would apply phone number transformation only when DigitMap is referenced from the Call Route rule.

Thanks again for your quick help.
Logged
RonR
Forum Member

Posts: 4528


« Reply #43 on: June 02, 2011, 01:35:37 pm »

I guess that the correct digit map for ITSPB will be: (<011:>2333xxxxxxx|2333xxxxxxx)

That should work.
Logged
yiucsw
Newbie
*
Posts: 4


« Reply #44 on: June 21, 2011, 08:57:38 am »

Want to implement a fix number dialing, when one pick up home phone, directly call to my mobile number thru Line phone.

Can i set as following, where 9999999 is my mobile number? so when someone pick up my home codeless phone, obi will dial out 999999 for me?
OutboundCallRoute (:99999999)
Logged
RonR
Forum Member

Posts: 4528


« Reply #45 on: June 21, 2011, 09:19:36 am »

yiucsw,

You want to leave the OutboundCallRoute configured normally and set:

Physical Interfaces -> PHONE Port -> DigitMap : (<S0:12341234567>)

where 12341234567 is your mobile number.
Logged
RossL
Newbie
*
Posts: 3


« Reply #46 on: June 25, 2011, 09:08:13 am »

Hi guys,
Iíve recently purchased a couple of Obi110ís which I am setting up for use within Australia (replacing SPA3000's) but Iím having problems getting my head around the DigitMaps etc. At present, the Phone Port DigitMap and Phone Port OutboundCallRoute are still set to their default values.

As the bulk of all my calls are made via my VoIP provider (I only use one), I have their details set under ITSP Profile A and also have set:
Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service

My current SPA3000 dial plan (which I would like to replicate) is as follows:
(000S0<:@gw0>|1100S0<:@gw0>|1800xxxxxxS0<:@gw0>|13[19]xxxS0|1300xxxxxxS0|1900xxxxxx!
|77[1578]S0|0011xx.|[45689]xxxxxxxS0|0[23478]xxxxxxxxS0|xx.)

This translates to:
   
000 (the Australian equivalent of 911), 1100 and 1800xxxxxx via PSTN
13[1-9]xxx, 1300xxxxxx, 77[1578], 0011xx. , [45689]xxxxxxx and 0[23478]xxxxxx via SP1
1900xxxxxx barred
xx. (anything else via SP1)

Can you advise what I need to achieve this. Thanks.
Logged
RonR
Forum Member

Posts: 4528


« Reply #47 on: June 25, 2011, 02:25:14 pm »

Physical Interfaces -> PHONE Port -> DigitMap:

([1-9]x?*(Mpli)|[1-9]|[1-9][0-9]|000|**0|***|#|**1(Msp1)|**2(Msp2)|**8(Mli)|**9(Mpp)|(Mpli))


Physical Interfaces -> PHONE Port -> OutboundCallRoute:

{([1-9]x?*(Mpli)):pp},{(<#:>|000):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},
{(<**2:>(Msp2)):sp2},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}


Service Providers -> ITSP Provider A -> General -> DigitMap:

(<**8>1100|<**8>1800xxxxxx|!1900xxxxxx|13[1-9]xxx|1300xxxxxx|77[1578]|
0011xx.|[45689]xxxxxxx|0[23478]xxxxxx|
xx.|(Mipd)|[^*]@@.)


Physical Interfaces -> LINE Port -> DigitMap:

(xxxxxxS4|1xxxxxxxxx|xx.)


Note: The rules in boldface can be omitted as they'll be caught by the xx. rules.


                 000  ->  PSTN
               1100  ->  PSTN
1800 + 6 digits  ->  PSTN

1900 + 6 digits  ->  Barred

Everything else  ->  SP1
Logged
RossL
Newbie
*
Posts: 3


« Reply #48 on: June 25, 2011, 07:07:55 pm »

Hi RonR,

Thanks for the response. All seems to be working OK, but obviously I can't test 000.

Prior to making these changes, I could press # on the phone and it would immediately swap to the PSTN line with the PSTN line dial tone so I could make calls manually. Now when I press #, there is a pause of about 10 secs, then the OBi110 seems to reset; the OBi phone and line lights start blinking, they go off and the power light turns red; then all the lights come back green. At the point the power light goes red, the PSTN dial tone is heard but when the lights come back green then the OBi generated dial tone returns.

Is another entry required to re-enable the # connecting immediately to the PSTN line?
Logged
RonR
Forum Member

Posts: 4528


« Reply #49 on: June 25, 2011, 07:13:55 pm »

Pressing only a # should not have changed.  It still should bridge you immediately to the LINE Port.

The OBi should not be rebooting.  Recheck your DigitMaps and OutboundCallRoute for a typo.

There is no error checking in the OBi, so incorrect entries can cause the OBi to simply reboot.

« Last Edit: June 25, 2011, 07:22:40 pm by RonR » Logged
RossL
Newbie
*
Posts: 3


« Reply #50 on: June 25, 2011, 08:10:54 pm »

Hi RonR,

I checked all the changes I made (including the config settings for use in Australia) but couldn't see any error. So I deleted the device from ObiTalk and re-added it then made the changes again, checking after each change. The end result is it is now working correctly so there must have been a mistake that I didn't see.

Thanks for your help.
Logged
yiucsw
Newbie
*
Posts: 4


« Reply #51 on: June 27, 2011, 02:20:55 am »

thanks for all the explanation:
Can i have a more direct approach:
I have four OBI110 in four different location:china(Beijing), China(Guangzhou),Hong Kong and Macau
what i want is call forward all mobile call from China(Beijing) and China(Guanghzhou) to both Hong Kong and Macau Mobile number.

So the 1st thing i do is call forward my China(beijing) mobile to a fixiine in China(beijing) and China(guangzhou) mobile to a fixline (Guangzhou) which each connect to an individual OBI110.

The 1st concept to to put what i type in the InboundCallRoute? which 6356XXXX is my macau mobile phone number and 9643XXXX is my hong kong phone number.

{S0:3*6356XXXX};{S0:2*9643XXXX}

Is it possible, or i am in a wrong direction
Logged
RonR
Forum Member

Posts: 4528


« Reply #52 on: June 27, 2011, 10:10:36 am »

{S0:3*6356XXXX};{S0:2*9643XXXX}

This is not valid anywhere in an OBi, so that's a bad start.

I've read your post a number of times, but I'm still not sure I fully understand what you're trying to accomplish.

I understand you have four OBi110 devices, each in a different locaion: Beijing, Guangzhou, Hong Kong, and Macau.

I understand there are at least two PSTN lines involved, each connected to an OBi (Beijing and Guangzhou).

I understand there are two mobile phone numbers involved (Hong Kong: 9643XXXX and Macau: 6356XXXX).

Is this the physical layout?:

OBi #1 -> Beijing PSTN

OBi #2 -> Guangzhou PSTN

OBi #3 -> Hong Kong PSTN

OBi #4 -> Macau PSTN

Are you wanting all incoming PSTN calls to OBi #1 to cause OBi #3 to call 9643XXXX using PSTN as well as OBi #4 to call 6356XXXX using PSTN, bridging the first one that answers?

Are you wanting all incoming PSTN calls to OBi #2 to cause OBi #3 to call 9643XXXX using PSTN as well as OBi #4 to call 6356XXXX using PSTN, bridging the first one that answers?

If so, this may be problematic, as OBi #3 and OBi #4 will report the call completed as soon as it's initiated because they're not able to tell if/when the called party actually answers.
Logged
yiucsw
Newbie
*
Posts: 4


« Reply #53 on: June 27, 2011, 07:14:20 pm »

This is not valid anywhere in an OBi, so that's a bad start.

The purpose of this arrangement is to avoid roaming charge for my mobile phone and reduce customer's concern to call my mobile phone when i am in hk or macau. So i need to bridge all my mobile phone together.

Yes, four OBi110 devices, in a different location: Beijing, Guangzhou, Hong Kong, and Macau.
Each location has one PSTN line, BJ, GZ, HK, Macau

I understand there are four mobile phone numbers involved
(BJ:139XXXXXXXX, GZ:133XXXXXXXX Hong Kong: 9643XXXX and Macau: 6356XXXX).


OBi #1 -> Beijing PSTN
OBi #2 -> Hong Kong PSTN
OBi #3 -> Macau PSTN
OBi #6 -> Guangzhou PSTN

want obi#1(PSTN)->obi#2(9643XXXX) + obi#3(6356XXXX) and bridge the first one that first answers.
want obi#6(PSTN)->obi#2(9643XXXX) + obi#3(6356XXXX) and bridge the first one that first answers.

If multiple call forward is not possible or problematic, is there any easy way that i can switch call forward when i travel to different location?
i.e. when i am in macau, i can answer switch all call forward in Macau, and when i hk, i can switch all call forward to HK. when i am in GZ, i can turn all call forward off?
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #54 on: June 27, 2011, 08:26:54 pm »

yiucsw,

You might consider using a forking "simultaneous call approach". Have a look here for an idea.
http://www.obitalk.com/forum/index.php?topic=1072.msg6737#msg6737

You can avoid messing around with call forwarding settings using this method, as several phones can ring at the same time.
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
Dogzipp
Newbie
*
Posts: 14


« Reply #55 on: September 08, 2011, 03:26:04 pm »

I am trying to wrap my head around this... unsuccesfully ;-)

I have two Service Providers. My local SIP provider on #1, and Google Voice on #2.

How do I create a Dial plan (Digit Map), that all 10 and 11 digit numbers, go through Google Voice (US Numbers), and everything else through my local SIP Provider (3, 4 and 8 digit numbers).

Thanks for any help.
Logged
RonR
Forum Member

Posts: 4528


« Reply #56 on: September 08, 2011, 03:56:17 pm »

I have two Service Providers. My local SIP provider on #1, and Google Voice on #2.

How do I create a Dial plan (Digit Map), that all 10 and 11 digit numbers, go through Google Voice (US Numbers), and everything else through my local SIP Provider (3, 4 and 8 digit numbers).

Physical Interfaces -> PHONE Port -> PrimaryLine : SP1 Service


Service Providers -> ITSP Profile A -> General -> DigitMap:

(xxx|xxxx|xxxxxxxx|<**2>1xxxxxxxxxx|<**21>[2-9]xxxxxxxxx|(Mipd)|[^*]@@.'@'@@.)


Service Providers -> ITSP Profile B -> General -> DigitMap:

(1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|011xx.|(Mipd)|[^*]@@.'@'@@.)


3/4/8 digits  ->  SP1 Service
10/11 digits  ->  SP2 Service
Logged
Dogzipp
Newbie
*
Posts: 14


« Reply #57 on: September 08, 2011, 07:22:25 pm »

It seemed to work for a while. I changed the DigitMap, rebooted the unit. But after a while, the default settings are being used again...

Am I getting updated with other settings from the mothership? Do I have to turn off Obitalk provisioning?
« Last Edit: September 08, 2011, 08:00:33 pm by Dogzipp » Logged
RonR
Forum Member

Posts: 4528


« Reply #58 on: September 08, 2011, 08:45:57 pm »

It seemed to work for a while. I changed the DigitMap, rebooted the unit. But after a while, the default settings are being used again...

Am I getting updated with other settings from the mothership? Do I have to turn off Obitalk provisioning?

To configure the OBi directly, you must disable Auto Provisioning or the OBiTALK Web Portal will overwrite your settings with its.
Logged
OBiSupport
Administrator
****
Posts: 250


« Reply #59 on: September 08, 2011, 10:37:01 pm »

We suggest you use the OBi Expert configuration pages to make modifications such as this -- No need to disable provisioning.

This is especially useful when you have OBi devices dispersed throughout a country or the world. From your single OBiTALK web portal log-in you may control your OBi devices with a great deal of granularity and control.
Logged
Pages: 1 2 [3] 4 5 ... 10
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC