December 10, 2017, 06:19:51 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Call forward on Busy not working ...  (Read 7404 times)
maihoodon
Newbie
*
Posts: 6


« on: December 03, 2012, 07:22:36 pm »

I have setup GV as SP1 on my OBI-100 which is connected to a cordless phone, which is working fine. My GV has 2 forwarding numbers, one is my cell phone and another is gmail Chat. When my GV number is called both phones (cell and cordless attached to OBI) ring as expected. Below is the scenario of my problem :

1. My GV# is called and both phones ring (cell and cordless)
2. I pickup cordless and talk
3. While I'm talking, a second call on GV comes in, my cell doesn't ring and I hear call waiting on cordless phone.

In order to fix this problem, I'm trying to forward the second incoming call to cell if my cordless is busy. I tried all options but this is not working. I checked Call forward on Busy option and entered the cell number as SP1(1xxxxxxxxxx) etc, also tried *60 option but no luck at all. Can anyone please tell me what I'm doing wrong, or this is even possible to achieve.

Thanks in advance....
Logged
maihoodon
Newbie
*
Posts: 6


« Reply #1 on: December 07, 2012, 07:14:43 am »

I had requested OBI's support team for help, below is the reply from them :

No, it is not possible to Call forward when/on busy, since there is
no “busy” for Google Voice.
If you are on a call, incoming call will be a call waiting.
You can post a question to find out more
http://support.google.com/voice
 
Regards,
Obihai Technology

I don't think this is true, if OBI can't do this, why do they claim it can forward calls on Busy. Can please any expert help me on this.

Thanks...
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #2 on: December 07, 2012, 09:49:46 am »

maihoodon,

It might be because GV is not a sip service. You might be able to use this work around in order to convert the GV protocol voice call to a sip voice call. As a bonus, you will also be getting CNAM. The idea is that GV will forward all calls to Callcentric, which will ring your phone or hopefully forward if busy. At this point everything is on the sip protocol. The OBi should now be able to process the calls as you intend it.

Callcentric and Google Voice Setup Guide (with CNAM)
http://www.obitalk.com/forum/index.php?topic=3640.msg24265#msg24265
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
maihoodon
Newbie
*
Posts: 6


« Reply #3 on: December 07, 2012, 05:36:54 pm »

Thanks for the reply. I followed the instructions and I got a callcentric number, but now the callcentric SIP service is not getting configured. Every time I try to reconfigure it on SP2, submit and then rebooting, I get the following message in the status :

Status   :   Registered (server=204.11.192.162:5060; expire in 52s)

After some time, it shows "service not configured". Here is what I did :

1. Removed the Gmail Chat from GV forwarding numbers
2. Got a new free callcentric number (charged my CC $3 upfront)
3. Got callcentric numbr registered and verified it through the softphone
4. Previous step confirms that my user id and password are correct.
5. Followed the instructions in your link to setup callcentric on OBI-100 on SP2 (as GV is on SP1)
6. Every time I try to configure callcentric, I get the message mentioned above, and all changes go away.

Please help ....
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #4 on: December 07, 2012, 06:21:00 pm »

6. Every time I try to configure callcentric, I get the message mentioned above, and all changes go away.

You might be suffering the following condition. We should come up with a medical term to identify this, as it happens frequently to new users.

Managing Your OBi Device Configuration: OBiTALK or OBi Web Page but NOT Both
http://www.obitalk.com/forum/index.php?topic=92.0
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
Ostracus
Hero Member
*****
Posts: 581


« Reply #5 on: December 07, 2012, 06:49:46 pm »

Coming unglued? Grin
Logged
infin8loop
Full Member
***
Posts: 219


My code doesn't abend, it loops to ∞˛


« Reply #6 on: December 07, 2012, 10:09:55 pm »

.... We should come up with a medical term to identify this, as it happens frequently to new users. ....

Voipus interruptus
Logged

"This has not only been fun, it's been a major expense." - Gallagher
maihoodon
Newbie
*
Posts: 6


« Reply #7 on: December 07, 2012, 10:17:13 pm »

Ok, I could setup Callcentric on SP2 via Obitalk portal, which is working fine. Now, if my GV is called, my cordless phone (connected to device on SP2 via Callcentric) as well as my cell phone ring as expected. But my original problem still remains. On the second GV call, I get the call waiting tone on cordless but my cell phone doesn't ring. The Call forward on Busy still not working, infact even unconditional call forwarding is not working.
Logged
Everton
Full Member
***
Posts: 163


« Reply #8 on: December 08, 2012, 02:34:21 am »

Here is the issue:  Both GV and (I think) Callentric DID both have two channels.  When you are on a call, you are using the first channel and a second incoming call will use the second channel and hence the call waiting beep/tone.  The person making the second call to your DID will not hear a "busy" signal and as far as that calling party is concerned, you are NOT on the phone and will hear ring tones until the call is answered or simply goes to voicemail.  So, the OBi100 does not see a "busy" situation and will not transfer the call.

You can see what happens when both channels are in use and a third call is placed to your GV/Callcentric DID, where the caller gets a busy signal, does the third call gets transferred?
« Last Edit: December 08, 2012, 02:37:47 am by Everton » Logged
maihoodon
Newbie
*
Posts: 6


« Reply #9 on: December 08, 2012, 07:58:42 am »

How can I make both channels busy in OBI, I have only one phone attached to OBI, is there any way, please let me know. I think now the question is how can we make OBI send a busy tone to an incoming call. Also, is there anyone here who has successfully got "Call forward on busy" working in OBI-100. Thanks for all experts here who are trying to help resolve this issue.
Logged
hwittenb
Sr. Member
****
Posts: 332


« Reply #10 on: December 08, 2012, 08:10:22 am »

Have you tried disabling CallWaitingEnable on the PhonePort?
PhonePort-->CallingFeatures-->CallWaitingEnable
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2322



« Reply #11 on: December 08, 2012, 08:19:30 am »

You can use GTALK/CHAT (using a different acct ex name@gmail.com in contact list) to call your OBi, and a cell phone. This will make occupy both voice channels. You will need to make a 3rd call using either another GTALK/CHAT or cell phone. I'm not certain if you can make 2 GTALK/CHAT calls at the same time, however you can have two instances running with two accts. I've used it before.

Google Talk: Run Multiple Instances or Log In as Multiple Users
http://www.tech-recipes.com/rx/975/google-talk-run-multiple-instances-or-login-as-multiple-users/
 
Run Google Talk with the following switch: /nomutex.

If you installed Google Talk to the default location, you can easily create a shortcut to this setting.

    1. Right-click on the desktop.
    2. Select New.
    3. Select Shortcut.
    4. Paste this into the text box:
    "c:\program files\google\google talk\googletalk.exe" /nomutex
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
maihoodon
Newbie
*
Posts: 6


« Reply #12 on: December 09, 2012, 08:31:07 am »

Thank you guys, disabling Callwaiting on phone port did the magic. Below is what is happening :

1. My GV# is setup to forward calls to Callcentric# and my cell phone
2. GV is setup as SP1, and Callcentric is setup as SP2 on my OBI-100
3. My GV# is called, the cordless phone attached to OBI (SP2 Callcentric)  and my cell ring
4. I pick-up call at cordless phone
5. While on this call, GV# is called again, as per GV rules call is forwarded to Callcentric but doesn't forward call to cell phone this time
6. As I have setup "call forward on busy" on SP2(Callcentric), this call is forwarded by OBI to my cell via SP1 (GV).
7. So my cell phone rings as expected

But there is still one issue with this, on my cell I see my GV# as CALLER ID rather than the original caller id. Is there any way to get around this as well.

Thanks a lot...


Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC