October 15, 2019, 10:07:11 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: Setting voip phone in Canada  (Read 8440 times)
Maple
Newbie
*
Posts: 1


« on: November 29, 2012, 05:40:30 am »

Hi everyone,

I wonder if some of you have experience in setting up a voip phone using oni110 in Canada. I bought my Obi110 through amazon.com yesterday. I connected it behind my router. While I tried to use the voip service provided by my internet provider (Acanac), I had problem with connecting the server. The info I got from Acanac for setting up my Voip phone are as follows:

Display name: xxxxxxxxx (my phone number with area code)
Username: xxxxxxxxx (my phone number with area code)
Password: yyyyyyy
Authorization user name: xxxxxxxxx (my phone number with area code)
Domain: voip8.acanac.com

When I used the setting above to setup a phone software (X-Lite 3.0), I could make and receive calls through my computer, suggesting the setting is working. However, when I input these setting into my obi110, the ata adapter keeps telling my it received no signal from the server. The way I setup the obi110 is as follows:

ITSP SIPProxyServer: voip8.acanac.com
ITSP SIPProxyServerPort: 5060
ITSP AuthUserName: xxxxxxxxx (my phone number with area code)
ITSP AuthPassword: yyyyyyy
ITSP URI:

Your help will be greatly appreciated.

Logged
ONCANADA
Newbie
*
Posts: 4


« Reply #1 on: November 30, 2012, 09:23:01 am »

Hello,

I having the same problem setting up my OBI202 with Acanac as well.

I would appreciate if someone could help us out.

Thanks
Logged
QBZappy
Hero Member & Beta Tester
*****
Posts: 2317



« Reply #2 on: November 30, 2012, 11:56:46 am »

Hi guys

Welcome to both,

This image shows the Acanac settings on another ATA. Looks like you might be able to get some ideas from this.
https://community.acanac.com/acanac/viewtopic.php?f=16&t=22311
Logged

Owner of the 1st OBi110/100 units in service in Canada & South America. 1st OBi202 on my street. 1st OBi1032 in Montreal.
hwittenb
Sr. Member
****
Posts: 332


« Reply #3 on: November 30, 2012, 12:19:05 pm »

Without knowing anything specific about Acanac, the entries you posted look reasonable.  It could be some other setting giving you trouble.

Can you do an OBi echo test by dialing **9 222 222 222 ?

This uses the OBiTalk network and doesn't require anything except power and cabling and using the basic default settings but if it doesn't work it will tell you something basic is incorrect.

If you are still having problems, I would run a syslog to see if you are getting some error return from the proxy server, or are getting no return at all.  To do this you need to download and install a syslog server program on your computer, and make a couple of configuration settings.

An OBihai FAQ describes the process:

Step 1. Find your OBi's IP address. From phone handset attached to the OBi, press ***1. The OBi's IP address will be announced.

Step 2. Configure the OBi's parameters for where to send debug messages. Open the OBi's web page (http://OBi-IP-address) and navigate to System Management/Device Admin/Syslog. Fill-in the 'Server' parameter with x.y.w.z, and 'Port' parameter ppppp . if different than default (514). Note that ppppp must be in the range 1 - 65535.


Note: The Syslog LEVEL should be set to 7

Step 3. Enable logging of SIP Messages for SP1 (or SP2) From the OBi device web page Voice Services settings, go to the SP1 Service (or SP2 Service) settings. Change the 'X_SipDebugOption' parameter to 'Log All Messages.'

You can download a simple Windows pc program here:
http://www.obihai.com/docs/syslogd.zip


Note: If your OBi device is managed from within OBiTALK, you have the option of configuring the syslog parameters from the OBiTALK-based OBi Expert Configuration web pages.[/i]

I believe you have to reboot your adapter after making changes and of course if your configuration is managed from within OBiTALK you need to setup the syslog there and not set it up using your local OBi web page because your OBiTalk configuration will override any changes you make.
Logged
ONCANADA
Newbie
*
Posts: 4


« Reply #4 on: December 01, 2012, 09:03:30 pm »

Thanks,
I just got it working for now.
Logged
ONCANADA
Newbie
*
Posts: 4


« Reply #5 on: December 03, 2012, 06:00:31 am »

Hi QBZappy and hwittenb,

I just got my Freephoneline hooked up.  They recommended: 

(911|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xxxxxxxxxxxx.|98*|[6-7]x*xxxxxxxxxxx.)

for LINKSYS dial string.

Can you please show me to change the settings correspond to OBI202.

Sorry for a newbie question.  I tried to read a lot in the forum but they are so confusing.

Thank you.
Logged
zapattack
Full Member
***
Posts: 137


« Reply #6 on: December 03, 2012, 04:32:22 pm »

Until a Real Dial Plan Expert responds, let me put your mind at ease.
Most of this is 'standard practice' and is already in the Obi:
(911|                     Emergency number
[2-9]xxxxxxxxx|     local 10 digit calling 
1xxxxxxxxxx|         1+ Long Distance calls
011xxxxxxxxxxxx.|  011 International calls
98*|                       Voice Mail access
[6-7]x*xxxxxxxxxxx.)       No idea what this is for!!!!

In other words you should be able to make all typical calls without changeing anything.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #7 on: December 04, 2012, 05:07:54 am »

zapattack has explained most of it. I guess the [6-7]x*xxxxxxxxxxx. Is to allow a two-digit code beginning with 6 or 7 followed by star, then a 11 digit number. Maybe to set up call diversions  etc.

The correct OBi format for the DigitMap is:

(911|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xx.|98*|[6-7]x*xx.)

It looks like that you now have at least two providers, probably on sp1 and sp2. To provide you with better DigitMaps you would need to tell us:

Which provider is on which spX (sp1, sp2 etc).

Physical Interfaces -> PHONE Port 1&2 -> PrimaryLine : (SP1 Service is default)

Service Providers -> ITSP Profile A -> General -> DigitMap:

Service Providers -> ITSP Profile B -> General -> DigitMap:

Which numbers you would like to route through which service providers.

Which service is dealing with 911.
Logged
ONCANADA
Newbie
*
Posts: 4


« Reply #8 on: December 04, 2012, 04:58:50 pm »

zapattack has explained most of it. I guess the [6-7]x*xxxxxxxxxxx. Is to allow a two-digit code beginning with 6 or 7 followed by star, then a 11 digit number. Maybe to set up call diversions  etc.

The correct OBi format for the DigitMap is:

(911|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xx.|98*|[6-7]x*xx.)

It looks like that you now have at least two providers, probably on sp1 and sp2. To provide you with better DigitMaps you would need to tell us:

Which provider is on which spX (sp1, sp2 etc).

Physical Interfaces -> PHONE Port 1&2 -> PrimaryLine : (SP1 Service is default)

Service Providers -> ITSP Profile A -> General -> DigitMap:

Service Providers -> ITSP Profile B -> General -> DigitMap:

Which numbers you would like to route through which service providers.

Which service is dealing with 911.

Thanks!

I appreciate your help.

I have Acanac and Freephoneline.  Acanac gave me that for free for joining them with the 1 year cable internet.  They will start charging after 1 year period.  Both Acanac and Freephoneline have the same features so I just pick one, which is Freephoneline.

Is the DigitMap you listed above good enough with just one phone line?

Anyway, I did enter DigitMap codes as you suggested above.  I also notice there are two more lines that require similar codes.  By default they are:

Phone1 DigitMap      :   ([1-9]x?*(Mpli)|[1-9]S9|[1-9][0-9]S9|911|**0|***|#|**8(Mbt)|**1(Msp1)|**2(Msp2)|**3(Msp3)|**4(Msp4)|**9(Mpp)|(Mpli))

Phone1 OutboundCallRoute:    {([1-9]x?*(Mpli)):pp},{(<#:>):ph2},{(<**8:>(Mbt)):bt},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Msp3)):sp3},{(<**4:>(Msp4)):sp4},{(<**9:>(Mpp)):pp},{(Mpli):pli}

Do I have to change anything at all?

Thanks again.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1831


« Reply #9 on: December 05, 2012, 05:34:25 am »

FreePhoneLine recommended this (adapted for OBi):
(911|[2-9]xxxxxxxxx|1xxxxxxxxxx|011xx.|98*|[6-7]x*xx.)
So it should go in the DigitMap for the spX which FreePhoneLine is on.

sp1 = Service Providers -> ITSP Profile A -> General -> DigitMap
sp2 = Service Providers -> ITSP Profile B -> General -> DigitMap

It is normally best to not alter the Phone DigitMaps or their OutboundCallRoutes.

You should set your Phone Port 1 PrimaryLine and/or Phone Port 2 PrimaryLine and Auto Attendant PrimaryLine to the SP Service of the provider that you intend to make most calls. This way, when using that service, you will not need to prefix the numbers with ** codes.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC