July 27, 2014, 09:12:22 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: Incoming calls to Android  (Read 13486 times)
SteveL
Newbie
*
Posts: 18


« on: March 26, 2011, 05:05:54 pm »

Hello,

I'm using GV with both my Android phone and with my OBi110.

I configured the OBi app on my Android to make outgoing calls through the OBi110 router; works like a champ.

Problems begin when I forward all calls from the OBi110 to my Obi Android softphone. Since both the Android phone and the OBi Softphone receive GV calls, both the cell and the softphone ring simultaneously. When I slide the 'answer' on the Android display, the call is answered via the cell service, not the OBi Softphone.

Any suggestions how I can control whether the incoming call is answered by the cell provider or by the OBi Softphone? thanks!!
Logged
SomeDude
Newbie
*
Posts: 37


« Reply #1 on: March 30, 2011, 09:46:40 pm »

What app are you using, or just the Obion?
Logged
SteveL
Newbie
*
Posts: 18


« Reply #2 on: March 30, 2011, 09:50:21 pm »

I'm using OBiON App. Since GV is configured to forward to my Android phone, both the cellular call and the OBiOn call arrive simultaneously. Without a way to give preference to OBiOn, the cellular wins.
Logged
SomeDude
Newbie
*
Posts: 37


« Reply #3 on: March 30, 2011, 10:06:44 pm »

Not sure why you forward calls from your Obi, when you can just have GV handle all those phones. Unless of course I am missing something (which of course is possible) Smiley
Logged
SteveL
Newbie
*
Posts: 18


« Reply #4 on: March 30, 2011, 10:16:26 pm »

GV + cellular = toll charge by wireless carrier
GV + OBiON over WiFi = free
Logged
jimates
OBi110 Beta Testers
*****
Posts: 1610


« Reply #5 on: March 31, 2011, 08:20:28 am »

Somedude,

his google voice is forwarding calls to his cell and to his Obi. His Obi is then forwarding the call to his Obion app. So he has 2 calls coming into his phone at the same time, one from google and one from the Obi.
Answering from the initial screen connects to the cellular provider and not the Obion app.
Logged
SteveL
Newbie
*
Posts: 18


« Reply #6 on: March 31, 2011, 12:04:09 pm »

Some SIP apps have a workaround, so the SIP app answers ahead of the cellular service. Other features include battery-saving options such as controlling whether the WiFi is always on (so all SIP calls are received).

I look forward to OBiON including a richer feature set to overcome these limitations.
Logged
guisar
Newbie
*
Posts: 4


« Reply #7 on: April 01, 2011, 04:01:50 pm »

Is it just me or does OBI disconnect from the server whenever the screen goes to sleep (on 3/4/wifi). I realize it would use more battery but it would be great if there were an option to keep the link alive for ringing purposes. As it's setup obion is kind of useless since it disconnects whenever I'm not actively using the phone. Anyone found a work around?
Logged
emailbvd
Newbie
*
Posts: 2


« Reply #8 on: April 14, 2011, 03:10:36 pm »

Sorry if this is a dumb question, but am I supposed to be able to receive calls on the obi app on my android phone?  I am using google voice for both my android and my obi110 at home using a cordless phone.  When someone calls my gv number the obi110 rings my cordless phone and home, and my cell phone rings (because it is set to use gv for all calls).  However if I have the obi android app running...it never rings for incoming calls.  I can make calls from the obi app with no problems...

Been looking through the forums and can find no clear answer as to how this is supposed to work...  Thanks in advance!

-Bill
Logged
RonR
Forum Member

Posts: 4528


« Reply #9 on: April 14, 2011, 04:06:25 pm »

emailbvd,

Incoming calls to the OBi can be forked to the Android OBiAPP from the InboundCallRoute of the desired service(s).  By default, the InboundCallRoute is set to ph, which sends any incoming calls on the associated service to the OBi PHONE Port.  If you wish to have your Android also receive the call, you would need to add the Andoid's phone number to the InboundCallRoute:

XXX -> InboundCallRoute : {ph,PP(200123456)}

where XXX is:

Voice Services -> SP1 Service
Voice Services -> SP2 Service
Voice Services -> OBiTALK Service
Physical Interfaces -> LINE Port
Logged
emailbvd
Newbie
*
Posts: 2


« Reply #10 on: April 15, 2011, 09:57:24 am »

Ok, and I am assuming this is done on the web interface of the obi110?  I am not seeing it anywhere in config of my online obitalk profile...  Right?

Thanks!
-Bill

emailbvd,

Incoming calls to the OBi can be forked to the Android OBiAPP from the InboundCallRoute of the desired service(s).  By default, the InboundCallRoute is set to ph, which sends any incoming calls on the associated service to the OBi PHONE Port.  If you wish to have your Android also receive the call, you would need to add the Andoid's phone number to the InboundCallRoute:

XXX -> InboundCallRoute : {ph,PP(200123456)}

where XXX is:

Voice Services -> SP1 Service
Voice Services -> SP2 Service
Voice Services -> OBiTALK Service
Physical Interfaces -> LINE Port

Logged
RonR
Forum Member

Posts: 4528


« Reply #11 on: April 15, 2011, 10:16:14 am »

Ok, and I am assuming this is done on the web interface of the obi110?  I am not seeing it anywhere in config of my online obitalk profile...
It can probably be done through the OBi Expert extension, but I find that to be an extra complication that serves little or no purpose.

The example I gave can be entered directly into your OBi, but you will have to also disable Provisioning in the OBi to prevent the OBiTALK configuration facility from overwriting your changes when you reboot.
Logged
MooseDude
Newbie
*
Posts: 1


« Reply #12 on: May 13, 2011, 08:36:54 am »

@SteveL --  So ... my understanding, is incoming call to your GV #, rings both your cell (via GV) and your obi app on your phone at the same time. 

If you are always running the obi app, then in your google voice settings under "phones" tab, where "Forwards calls to:" section is, deselect your cell #. 

I have GV setup as attached to my home phone (yes still have one because its cheaper to be on promotion with the bundle of 3 (cable/internet/phone) then just the two(internet/cable)... stupid but I digress... Anyhow, I deselected home phone since GV will be ringing on OBI.
Logged
jimates
OBi110 Beta Testers
*****
Posts: 1610


« Reply #13 on: May 13, 2011, 05:57:01 pm »

No caller id if the cell phone itself doesn't ring from Google Voice. The caller id in the app is the id of the Obi110 that is forking the call.
Logged
kleinberger
Newbie
*
Posts: 11


« Reply #14 on: May 17, 2011, 11:57:39 am »

So, my Obitalk inbound call route is currently:

{(290980148|200941930)>(xx.):SP1},{(290980148|200941930):aa},{ph}

What do I change it to in order for it to go directly to my obion app? The app is at:
290980148

Ok, and I am assuming this is done on the web interface of the obi110?  I am not seeing it anywhere in config of my online obitalk profile...
It can probably be done through the OBi Expert extension, but I find that to be an extra complication that serves little or no purpose.

The example I gave can be entered directly into your OBi, but you will have to also disable Provisioning in the OBi to prevent the OBiTALK configuration facility from overwriting your changes when you reboot.
Logged
RonR
Forum Member

Posts: 4528


« Reply #15 on: May 17, 2011, 01:03:51 pm »

So, my Obitalk inbound call route is currently:

{(290980148|200941930)>(xx.):SP1},{(290980148|200941930):aa},{ph}

What do I change it to in order for it to go directly to my obion app? The app is at:
290980148

kleinberger,

The OBiTALK Service InboundCallRoute controls what happens to calls coming into your OBi from other OBi's or OBiON apps.  What's quoted above sends calls from 290980148 or 200941930 out on SP1 for single-stage dialing or to the Auto Attendant for two-stage dialing.  Calls from anyone else go to the PHONE Port.

It's not cleat what 'it' is that you want to go directly to 290980148.  If it's incoming calls on SP1, then you could use call forwarding:

Voice Services -> SP1 -> CallForwardUnconditionalEnable : (checked)

Voice Services -> SP1 -> CallForwardUnconditionalNumber : PP(ob290980148)

or you could use an SP1 InboundCallRoute rule:

Voice Services -> SP1 -> X_InboundCallRoute : {pp(ob290980148)}
Logged
kleinberger
Newbie
*
Posts: 11


« Reply #16 on: May 17, 2011, 02:35:42 pm »

Sorry for not being clear on what I'm trying to do. I purchased a sole obi100 and have no phone hooked up to it. It sits in my closet with my google voice account configured for sp1.

I was hoping to make/receive calls on my android device using the obion app. So far, I can make calls using it and the obi100...but when I call my google voice number from a landline...the obion app never rings. How do I make it ring?

The end goal is to have wifi calling on my android device using the obi100 sitting at my house. For both incoming and outgoing from the obion app.

Thanks for your help on this.
Logged
SomeDude
Newbie
*
Posts: 37


« Reply #17 on: May 17, 2011, 02:45:42 pm »

Kleinb - same question too. Same setup. I'll be interested to see what the answer is. If it's that simple, I'll be moving the entire family over to this. I already canceled my land-line and was lucky enough to get another # with the same last four digits. Smiley
Logged
RonR
Forum Member

Posts: 4528


« Reply #18 on: May 17, 2011, 02:47:10 pm »

I think we're in sync.

Use either the call forwarding approach or the SP1 InboundCallRoute approach I posted and see if that gets you there.
Logged
kleinberger
Newbie
*
Posts: 11


« Reply #19 on: May 18, 2011, 09:34:03 am »

In Obitalk Setup wizard, for the OBiTALK InboundCallRoute field I changed it to:

{(290980148|200941930)>(xx.):SP1},{(290980148|200941930):aa},{pp(290980148)}

correct?

I think we're in sync.

Use either the call forwarding approach or the SP1 InboundCallRoute approach I posted and see if that gets you there.

Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC