Using OBi Voice Gateways with SIP Providers

Started by RonR, March 29, 2011, 01:01:35 PM

Previous topic - Next topic

JonG

Thank you Obi  for adding this feature. 
The Obi now does more than ATAs costing five times as much, and so I have ordered my first OBi box. 
Lots of frustrated Linksys users will soon join too.

Obihai must be a great place to work.
You included GoogleVoice when customers asked, and now you put this user request into a firmware upgrade in just a month!

Now please update the Admin Manual.





Riyas

Hi !!! First of all, thanks for this wonderful tip. I've configured it... It's working great... Thanks a lot

My settings:

SP1 => Pbxes.org
SP2 => Google talk
VG3 => Free (French internet provider)

Everything is working fine now. But my internet provider announced that he will restrict the sip account only from my IP address (I have a static IP address). I know that if I use my "free" account with SP1 or SP2, it will be my IP address. But in VG3, will it go through Pbxes.org IP address ? In that case, it won't work for me. I don't know if it's clear ?

Thanks

RonR

#42
SP1 will be communicating directly with PBXes using SIP.

and

VG3 will be communicating directly with whoever is configured at Voice Gateway3 -> AccessNumber using SIP.

neilio

Not sure what I'm doing wrong, but when I add the two new strings in the Phone Port section

DigitMap
|**1(Msp1)|**2(Msp2)|**3(Mvg3)|**4(Mvg4)|**6(Mvg6)|**7(Mvg7)|**8(Mli)|**9(Mpp)|

and

OutboundCallRoute
{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Mvg3)):vg3},{(<**4:>(Mvg4)):vg4},{(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7},{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}

I get red exclamation points beside both of those fields, and dialing **# stops working.

Have I missed something obvious?

RonR

Phone Port DigitMap:

|**1(Msp1)|**2(Msp2)|**3(Mvg3)|**4(Mvg4)|**6(Mvg6)|**7(Mvg7)|**8(Mli)|**9(Mpp)|

PHONE Port OutboundCallRoute:

{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Mvg3)):vg3},{(<**4:>(Mvg4)):vg4},
{(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7},
{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}

The bolded rules are additions to what's already there (you sandwich them in).

neilio

#45
Quote from: RonR on August 03, 2011, 07:55:01 PM
Phone Port DigitMap:

|**1(Msp1)|**2(Msp2)|**3(Mvg3)|**4(Mvg4)|**6(Mvg6)|**7(Mvg7)|**8(Mli)|**9(Mpp)|

PHONE Port OutboundCallRoute:

{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},{(<**3:>(Mvg3)):vg3},{(<**4:>(Mvg4)):vg4},
{(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7},
{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}

The bolded rules are additions to what's already there (you sandwich them in).


That's what I have currently in those textfields - I simply copied and pasted right from the original post, making sure there were no phantom linebreaks. Or am I missing the point?

RonR

You start with the default values and blend this into them at the appropriate places:

|**3(Mvg3)|**4(Mvg4)|**6(Mvg6)|**7(Mvg7)|

and

{(<**3:>(Mvg3)):vg3},{(<**4:>(Mvg4)):vg4},{(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7}

These are ADDITIONS to the default values, not replacements for the default values.

RonR

The net results should be:

([1-9]x?*(Mpli)|[1-9]|[1-9][0-9]|911|**0|***|#|**1(Msp1)|**2(Msp2)|
**3(Mvg3)|**4(Mvg4)|**6(Mvg6)|**7(Mvg7)|**8(Mli)|**9(Mpp)|(Mpli))

and

{([1-9]x?*(Mpli)):pp},{(<#:>|911):li},{**0:aa},{***:aa2},{(<**1:>(Msp1)):sp1},{(<**2:>(Msp2)):sp2},
{(<**3:>(Mvg3)):vg3},{(<**4:>(Mvg4)):vg4},{(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7},
{(<**8:>(Mli)):li},{(<**9:>(Mpp)):pp},{(Mpli):pli}

neilio

Thanks again, RonR. Dialing works again, but when I try to dial out on **3 now I get a "no service available" error.

Here's what I have configured:

http://neil.io/9292

And here's what I have in the User Defined DigitMaps:

http://neil.io/92o2

Strange that I get the red ! everywhere. I must have missed a setting.

RonR

Quote from: neilio on August 03, 2011, 08:31:12 PM
http://neil.io/9292

SPx is supposed to SP1 or SP2, which has to configured for SIP.

Quote from: neilio on August 03, 2011, 08:31:12 PM
Strange that I get the red ! everywhere. I must have missed a setting.

I can't help you with that.  I don't use the OBiTALK Web Portal.

Obvdobi

Quote from: RonR on March 29, 2011, 01:01:35 PM

Next, let's configure Voice Gateway6 for calling via Sip Broker:

Name : Sip Broker
AccessNumber : SPx(sipbroker.com)
DigitMap : (<*>[x*][x*].|*[x*][x*].)


Next, let's configure Voice Gateway7 for iNum calling:

Name : iNum
AccessNumber : SPx(sip.inum.net)
DigitMap : (<8835100>xxxxxxxx|8835100xxxxxxxx)


Following a reboot, the OBi should be ready to use its new capabilities.


Dialing **6 + SIP code + number should place a VoIP call via Sip Broker.

For example:

Dialing **6 011 188888 should connect you with the Sip Broker test announcement.
Dialing **6 010 123456 should connect you with the Voxalot number 123456.
Dialing **6 747 17471234567 should connect you with the Gizmo5 number 1-747-123-4567.

For more details on Sip Broker, please visit : http://www.sipbroker.com/

Dialing **7 + number should place a VoIP call to an iNum number.

NOTE: Use only the last 8 digits of the iNum number (8835100 will be prepended for you).

For example:

Dialing **7 00000091 should connect you with the iNum echo test.
Dialing **7 04123456 should connect you with the Voxalot number 123456.
Dialing **7 71234567 should connect you with the Gizmo5 number 1-747-123-4567.

For more details on iNum, please visit : http://www.inum.net/


When I set it up for vg6 and vg7 with the instructions above, no test call can be completed for anything start with **6/**7.

What am i doing wrong? Setup in attached image.


RonR

#51
Quote from: Obvdobi on October 21, 2011, 03:42:35 PM
When I set it up for vg6 and vg7 with the instructions above, no test call can be completed for anything start with **6/**7.

What am i doing wrong? Setup in attached image.

Do you have |**6(Mvg6)|**7(Mvg7)| in your PHONE Port DigitMap?

Do you have {(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7} in your PHONE Port OutboundCallRoue?

Is SP2 configured for SIP and reporting 'Connected' if it's a real SIP provider or 'Registration not required' if it's a dummy SIP configuration?

What are you dialing and what is the response you're getting?

**6 011 188888 should reach the SIP Broker Test Announcement.

**7 0000 0091 should reach the Inum Echo Test.

Obvdobi


QuoteDo you have |**6(Mvg6)|**7(Mvg7)| in your PHONE Port DigitMap?
yes

QuoteDo you have {(<**6:>(Mvg6)):vg6},{(<**7:>(Mvg7)):vg7} in your PHONE Port OutboundCallRoue?
yes
QuoteIs SP2 configured for SIP and reporting 'Connected' if it's a real SIP provider or 'Registration not required' if it's a dummy SIP configuration?
SP2 is shown as "Registered (server=64.xxx.xxx.xxx:5060; expire in 38s)"

QuoteWhat are you dialing and what is the response you're getting?

**6 011 188888 should reach the SIP Broker Test Announcement.

**7 0000 0091 should reach the Inum Echo Test.
I dialed both when I was at work dialing in through AA. Neither one work. The prompt is a male voice like "The number you dialed **6 011 188888 is not valid".  I noticed that after pressing **, the two "*" turned into 'P' on the display.

But when I get home and dialed directly through  my home phone, it works! :)  What's the difference? I guess the remote system's ** are not interpreted properly.

RonR

#53
Quote from: Obvdobi on October 21, 2011, 05:28:57 PM
I dialed both when I was at work dialing in through AA. Neither one work. The prompt is a male voice like "The number you dialed **6 011 188888 is not valid".  I noticed that after pressing **, the two "*" turned into 'P' on the display.

But when I get home and dialed directly through  my home phone, it works! :)  What's the difference? I guess the remote system's ** are not interpreted properly.

The difference is the Auto Attendant has it's own DigitMap and OutboundCallRoue.  If you want the Auto Attendant to behave similar to the PHONE Port, you must make corresponding changes there.

Obvdobi

This makes perfect sense.  Thank you, Ron. You are so HELPFUL! I learned a lot from you in the last couple of days.

Quote from: RonR on October 21, 2011, 05:37:04 PM

The difference is the Auto Attendant has it's own DigitMap and OutboundCallRoue.  If you want the Auto Attendant to behave similar to the PHONE Phone, you must make corresponding changes there.


pooh-bah

#55
Has anybody successfully used localphone on one of the gateways? I got callcentric to work fine, but localphone gives me a 407 error.

I've got GV on SP1 and Anveo on SP2. I'm trying to "route" (not sure that's the right word) the localphone calls through SP2.

RonR

Quote from: pooh-bah on January 17, 2012, 04:11:45 PM
Has anybody successfully used localphone on one of the gateways? I got callcentric to work fine, but localphone gives me a 407 error.

I'd have to do a forum search to be sure, but I'm almost posiive Localphone works on Voice Gateways.

Are you sure you have the correct AuthUserID and AuthPassword entered in the Voice Gateway settings?

pooh-bah

I think I found my problem. Localphone's website seems to bury the AuthUserName and AuthPassword in an odd place on their website. I can't try the connection until later, but it should work now.

Stewart's post here helped: http://www.obitalk.com/forum/index.php?topic=1731.0

RonR

Quote from: pooh-bah on January 17, 2012, 04:11:45 PM
I've got GV on SP1 and Anveo on SP2. I'm trying to "route" (not sure that's the right word) the localphone calls through SP2.

I assume you're planning on using Localphone on a Voice Gateway to make outgoing calls?

pooh-bah

Yes, I am setting up localphone on gateway #3. I was using the wrong long/pass since I couldn't find the proper login/pass on the website.

It's all up and running, and now I'm searching for a way to have localphone send a different caller ID. This may not be possible, but I did get callcentric and anveo to send different caller ID's.

Thanks