December 10, 2017, 04:28:52 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: New Zealand ITSPs  (Read 67949 times)
Islander48
Jr. Member
**
Posts: 24


« on: March 27, 2013, 02:24:12 pm »

We are setting up a VoIP service for and island that has a New Zealand POTS and have encountered the following problem. Sometimes the Obi110 does not detect the incoming LINE call at all, sometimes it will detect it after a large number (e.g. 9) rings. Believeing the the NZ and Australia systems are similar we use the Australian (as per this blog) settings. Are correct? What settings could we alter to possibly alleviate the problem?
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #1 on: March 28, 2013, 07:13:11 am »

Physical Interfaces > LINE Port > Ring Detection

There are seven variables here. The most likely to make a difference is RingThreshold. Try a lower value. The other less likely candidate is RingValidationTime. Again try a lower value.


Physical Interfaces > LINE Port > Ring Detection > RingDelay

By default this is set to 4000 (4 seconds). This means the person calling will hear ringing tone four seconds before the OBi starts ringing its attached phone. This is set to allow the CallerID to be captured. Once you get Ring Detection sorted, you may wish to experiment in reducing this delay. I'm in the UK and find that 2000 is more than enough time to capture CallerID.

Logged
Islander48
Jr. Member
**
Posts: 24


« Reply #2 on: March 28, 2013, 01:33:53 pm »

Thanks for that advise.
We already use the lowes setting for RingThreshold (13.5 - 16.5) but I will experiment with the ring delay.
Logged
Islander48
Jr. Member
**
Posts: 24


« Reply #3 on: March 28, 2013, 09:47:58 pm »

Reducing the delay to 2000 seemed to have no effect but using ring profile B for both ring and tone seemed to do the trick. Does that make sense??
« Last Edit: March 28, 2013, 09:50:23 pm by Islander48 » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #4 on: March 29, 2013, 05:10:37 am »

Ring Profile B is set to default Australian formats, so whatever is plugged into the Phone Port may be happier. However, It does not really affect the ring detect side of things, which is all to do with the Line Port.

Your RingThreshold does seem to need to be at a very low setting. Is this OBi the only device on this line or does it share the line with other devices in parallel? Also, is this a very long line many miles from the telco telephone exchange?
Logged
Islander48
Jr. Member
**
Posts: 24


« Reply #5 on: March 29, 2013, 04:19:16 pm »

The phone port is connected to one only portable phone base station. Pehaps this one did not like the ring.
I have another Obi110 which is happily sharing the line with a Linksys SPA3102. We are about 3Km from the PBX.
« Last Edit: April 04, 2013, 07:47:06 pm by Islander48 » Logged
Islander48
Jr. Member
**
Posts: 24


« Reply #6 on: April 04, 2013, 07:52:35 pm »

Update:
The above user has found that his base station portable phone connetced to an Obi110 does not ring whenever it is being called from a mobile phone. For this reason he only connects the Obi110 when he wants to call overseas. This is not good.
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #7 on: April 05, 2013, 04:27:32 am »

I'm not sure here whether we are looking at a "ring detect" problem on the Line Port, or a "ringer" problem on the Phone Port.

Is it possible for the user to plug in a normal corded phone to see if that rings ok on an incoming call?

Would the user be prepared to look at his local OBi web page (ip address can be found by dialling ***1 from a phone attached to the OBi)? If so, then Status > Call History might show what is going on.

If the ringing is being detected then changing settings here may help:
Physical Interfaces > PHONE Port > Ringer
There are three settings here to try changing. These will only be useful if the incoming ringing is being detected on the Line Port.

Logged
Islander48
Jr. Member
**
Posts: 24


« Reply #8 on: April 11, 2013, 07:09:05 pm »

The problem appears to be intermittent. I visited the client who reported the error but I could not replicate it. It worked every time.
Now I have another client at a very distant location who has disconnected the obi110 for the same reason; this phone does not ring on incoming calls. I verified this being the case by calling phone to obi110. All the settings are for Australia. I could hear the ring tone but the phone did not ring. Eventually an answer-phone answered which means that the phone did detect the incoming call but for some reason did not ring. I guess the next test is to see if it rings if we connect a simpler POTS phone to the Obi.
« Last Edit: April 12, 2013, 02:51:32 pm by Islander48 » Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #9 on: April 13, 2013, 08:05:36 am »

If the answerphone is connected to the Phone Port of the OBi, then that does confirm that RingDetect is ok and the Phone Port is putting some sort of ringing out to the attached phones.

Testing with a simple corded phone would be the best idea. I wonder if the existing phone is adjustable to receive different ringing patterns? The OBi is very configurable for ringing patterns. Under Ring Profile B there are ten different ring patterns. The ring pattern to ring the Phone Port is set on whichever service the incoming call is received on. For an OBi110 sp1, sp2 and Line Port are all set up independantly. For instance to set ring pattern for incoming calls on sp1 set:

Voice Services > SP1 Service > X_RingProfile: B
Voice Services > SP1 Service > X_DefaultRing: n
n = pattern number 1 to 10.

I'm guessing that the devices are set to Profile B (Australian), DefaultRing 1 (default).

DefaultRing 1 is the same as UK standard ringing (I use it myself here in UK for one of my services). It has two rings of .4 seconds followed by a 2 second gap. Maybe the attached phones prefer a longer ring before the gap. You might experiment by trying different X_DefaultRing settings, or simply switch to X_RingProfile A which will give North American style ringing. Maybe the phones were manufactured with North American standards in mind.

Anyhow, there are a few things to try.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC