Obi202 - Using two-line phone with one Google Voice number

Started by danthecan, June 01, 2013, 10:04:53 PM

Previous topic - Next topic

danthecan

I have an Obi202.  I set up SP1 with my Google Voice number.  I set up SP1 to ring both Phone 1 and Phone 2 like this:
                     Phone 1   Phone 2
Primary Line for Outgoing Calls Route to:   SP1      SP1
Phone Rings on Incoming Calls from:       SP1      SP1

A plugged a 2-line Vtech phone into the Obi.  Now, when someone calls my Google Voice number both line 1 and line 2 light up on my Vtech phone.  I can answer either line to take the call.  Then, I can use the other line to either make or receive a second call over the same Google Voice number.  Very cool!  Two people in my family can make/receive calls at the same time using the same Google Voice number.

I have just one question.  Is there way to program the Obi202 so that Phone 2 only rings if Phone 1 is already being used?  It is a little confusing having both lines ring at once.  It would be better for only line 1 to ring, unless line 1 is already in use, in which case I would then want line 2 to ring.

Much thanks,

Koby

If you find a way that works I hope you'll post it.  In the meantime, since no one else has answered, I will suggest a way that might give you what you want.

First, try setting it so that incoming calls do NOT ring Phone 2.  Now place an incoming call to your GV number.  When it rings, pick up Phone 2 and you should hear dial tone.  Press # only and after a second or so it should answer the call.

Now go into OBi Expert Configuration / Enter OBi Expert and go to SP1 Service.  You are interested in two settings under Calling Features.  The first is CallForwardOnBusyEnable which should be checked.  The second is CallForwardOnBusyNumber and that is the one I am not entirely certain of.  Try ph2 and if that doesn't work, try ph2(#) as suggested by mife in the thread at http://www.obitalk.com/forum/index.php?topic=5525.0

Note that you need to make sure that the two checkboxes at the right hand side of the page (under Device Default and OBiTALK Settings) are unchecked next to those two lines before you can change the values.  You may have to first submit the page with the boxes unchecked before it will let you enter new values.

If it works, you should get the behavior you want, and if it doesn't, I'd try e-mailing support@obihai.com with your question.  It actually seems like there should be an easier way to do this, but try this and let us know if it works.

If it does work, be aware that one drawback of this method is that someone could disable the call forwarding on busy by dialing *61, or change it by dialing *60.  To avoid that possibility, you could go into Star Code Profile A and find these two entries:

*60, Cfwd Busy, coll($Cfbn), set($Cfb,1)
*61, Disable Cfwd Busy, set($Cfb, 0)

Make sure the two checkboxes at the right hand side of the page (under Device Default and OBiTALK Settings) are unchecked next to those two lines, then just erase the contents of those fields and submit the page.  If you ever want them back, just recheck the "OBiTalk Settings" checkbox on both lines and submit the page again.

One other thought that occurs to me is you MIGHT have to go into PHONE 1 and uncheck the box next to CallWaitingEnable,  or dial *57 from PHONE 1 to disable Call Waiting.  Otherwise the person talking on the first line might get a call waiting beep when the second call comes in.  I don't know offhand which feature takes precedence - Call Waiting or Call Forward on Busy.

danthecan

Hi Koby,

You know your stuff.  I followed your instructions and they worked.  I did have to go into PHONE 1 and uncheck the box next to CallWaitingEnable.
I also needed to enter "ph2(#)" in the CallForwardOnBusyNumber box.  (I think.  I can't remember if I actually tried it again without the "(#)" after I unchecked the CallWaitingEnable box, but either way "ph2(#)" worked.)

I don't think I am especially worried about someone disabling or changing call forwarding by dialing *61 or *60, so I didn't complete your last steps.  Why would anyone want to do this?  Is this something a hacker would do?  Wouldn't they need to dial *61 or *60 from my phone in order to mess around with call forwarding?

Much thanks,
Daniel

Koby

You're welcome, Daniel.  But I can't take any credit for that - everything I posted was suggested by others in previous threads.  I'm glad it worked for you, though.

Quote from: danthecan on June 03, 2013, 08:56:40 PMI don't think I am especially worried about someone disabling or changing call forwarding by dialing *61 or *60, so I didn't complete your last steps.  Why would anyone want to do this?  Is this something a hacker would do?  Wouldn't they need to dial *61 or *60 from my phone in order to mess around with call forwarding?

Yes, they would.  I just did not know if you were the only user of your phone or not.  If you have kids that like to play with the phone, it could be an issue, but otherwise probably not.  I was just mentioning it on the off chance that it might be a potential problem for you.