Can't connect Obi to server [SOLVED]

Started by Ozweepay, July 22, 2013, 07:05:20 PM

Previous topic - Next topic

Ozweepay

Greetings all!

Obi has green light.  **9 222 222 222 connects and echos.

When I try to configure with gmail, I configure gmail acct according to (outdated) instructions that shipped with obi. www.obihai.com then tells me to dial *5 xxxx (xxxx is the secret code).  I get "number has been sent to server" and then ...

... it times out.  

I know my way around computers, but haven't a clue how to troubleshoot this.  Seems like obi's server has heard from the obi device in my house, but yet cannot connect to it?!

Shale

In http://www.obihai.com/FAQ.php , see the GV and Troubleshooting sections in the left column.

Ozweepay

Thanks.

I did manage to find that page before I posted here.  The GV section has nothing describing my situation (unless I' m blind).  The one link for "GV setup problems" refers to a tutorial... and the tutorial assumes nothing goes wrong.

So I'm stuck.

I could open a ticket with the company, but thought I'd post here in case this is a well-known issue.

Ozweepay

I don't really have a map in my mind of how the various pieces of technology are connecting together.  But it seems that the step that's failing for me (adding Obi to Obitalk account) is not related to GV.  If I uncheck the "set up with google voice" box, it still has me call with **5 xxxx and it still fails.

This is perplexing to me because I'm imagining:

   1) Obi uses DHCP to acquire non-routeable IP address from my home router
   2) Obi makes outbound TCP connection to ObiTALK server (via NAT box of course)
   3) I type **9 222 222 222 and the phone connects to the Obi which sends my voice to the server which echos it back via the TCP connection
   4) I log into the ObiTALK website, say I want to connect my device, type **5 xxxx.  It says it's sent to server (which I assume means the outbound TCP connection is alive and working).
   5) Their server is unable to connect back to my Obi to acquire device info

This seems like it must be on their end (their server can't talk to their other server) or it's trying to initiate a connection to my Obi (which can't happen through a NAT box without hole-punching or port forwarding, neither of which I'm supposed to have to do).

I don't get it?!

Shale

Quote from: Ozweepay on July 22, 2013, 08:39:57 PM
Thanks.

I did manage to find that page before I posted here.  The GV section has nothing describing my situation (unless I' m blind).  The one link for "GV setup problems" refers to a tutorial... and the tutorial assumes nothing goes wrong.

So I'm stuck.


Did you see "Make a Call Using the Gmail Call Phone Feature
To use the Google Voice communications service on your OBi, you must have made at least one call from your Gmail account's "Call Phone" feature. To do this, sign-in to Gmail at: www.gmail.com and place a call from your computer's browser with the Gmail "Call Phone" function located on the lower left side of the Gmail window."

How did that call work? At what step in the process did things fail?

Did you see http://www.obitalk.com/forum/index.php?topic=62.0?
Maybe you said you did. I forget.


Ozweepay

Tx Shale.  My problem is resolved.

It had nothing to do with GV.  It was simply that the Obi was unable to be reached from the server.  I discovered the "self troubleshooting" link and followed that.  It said

1) Dial ***6 and update firmware if available.  I did that and there was an update available, but updating did not solve the problem.

2) Dial ***1 to obtain the IP address of the Obi (it speaks the IPv4 into your ear).

2a) Use a browser to connect to this IP and you will get a web page.

WRONG!  You will be prompted for a login and password, which is not given by the troubleshooting guide.  I guessed a few times and got it: "admin" and "admin".  That got me in.

2b) Set the Obi's DNS to 4.2.2.2 (a public DNS server).

2c) Reboot.

Then it worked.

I guess this VoIP stuff isn't exactly "just plug it in and go".  I mean, they could config the DNS in the factory for you, but they don't.  That means your DHCP has to serve the device a DNS that will work for it, and apparently that didn't happen.

FaithDugan

Quote from: Ozweepay on July 22, 2013, 09:24:49 PM
Tx Shale.  My problem is resolved.

It had nothing to do with GV.  It was simply that the Obi was unable to be reached from the server.  I discovered the "self troubleshooting" link and followed that.  It said

1) Dial ***6 and update firmware if available.  I did that and there was an update available, but updating did not solve the problem.
This worked for me :) Once the firmware was updated (which was pretty fast) I tried again and instantly connected my OBi100 device to the network. Thanks Oz!

Mouse


Lavarock7

The DNS server used by your ISP may not have been working correctly.

Although I prefer to set DNS to Google, the Obis should get a valid DNS server from your router which should be getting it from your ISP.
My websites: Kona Coffee: http://itskona.com and Web Hosting: http://planetaloha.info
A simplified Voip explanation: http://voip.planet-aloha.com

FoHo95

I have the same problem and I have gone through all these steps but still it times out after telling me it has sent the **5 # to the server.

Please help!

drgeoff

Quote from: FoHo95 on October 04, 2018, 03:07:04 PM
I have the same problem and I have gone through all these steps but still it times out after telling me it has sent the **5 # to the server.

Please help!
http://www.obitalk.com/forum/index.php?topic=15094.msg95042#msg95042

Tauneutrino

Does anyone know if this issue has been resolved? Also, is there a better method one can use or setup in order to be notified when there are service interruptions or other problems?

FoHo95

Quote from: Tauneutrino on October 05, 2018, 12:58:34 PM
Does anyone know if this issue has been resolved? Also, is there a better method one can use or setup in order to be notified when there are service interruptions or other problems?

I just had success 30 min back setting up my Obi200 device.  I had send a service request yesterday just like the OBisupport had asked me to do, so I dont know if mine worked because of that or it was just luck.

tstmerchant

Quote from: Ozweepay on July 22, 2013, 09:24:49 PM
Tx Shale.  My problem is resolved.

It had nothing to do with GV.  It was simply that the Obi was unable to be reached from the server.  I discovered the "self troubleshooting" link and followed that.  It said

1) Dial ***6 and update firmware if available.  I did that and there was an update available, but updating did not solve the problem.

2) Dial ***1 to obtain the IP address of the Obi (it speaks the IPv4 into your ear).

2a) Use a browser to connect to this IP and you will get a web page.

WRONG!  You will be prompted for a login and password, which is not given by the troubleshooting guide.  I guessed a few times and got it: "admin" and "admin".  That got me in.

2b) Set the Obi's DNS to 4.2.2.2 (a public DNS server).

2c) Reboot.

Then it worked.

I guess this VoIP stuff isn't exactly "just plug it in and go".  I mean, they could config the DNS in the factory for you, but they don't.  That means your DHCP has to serve the device a DNS that will work for it, and apparently that didn't happen.



Worked for me also! Thank you!!!

Kiaj

I am having same issue, after dialing **5 1234 , nothing happens, how do I change DNS servver from obi202 browser ? I don't see DNS server under system status can be modified?

Thanks for your help.

drgeoff

Quote from: Kiaj on December 07, 2020, 07:46:38 PM
I am having same issue, after dialing **5 1234 , nothing happens, how do I change DNS servver from obi202 browser ? I don't see DNS server under system status can be modified?

Thanks for your help.
Look under System Management.

Kiaj

Thx, under System mgmt: I have below options. but DNS setting is not there.
Auto Provisioning
Device Admin
Device Update

Taoman

Quote from: Kiaj on December 08, 2020, 05:15:45 AM
Thx, under System mgmt: I have below options. but DNS setting is not there.
Auto Provisioning
Device Admin
Device Update

What OBi device do you have and what version of firmware are you on?
Under System Management you should see a setting that says "WAN Settings."

Kiaj

Firmware version is  3.2.2 (Build: 5921EX) and device is obi202. first time setting it up, echo works but **5 getting time out.

Kiaj

DNS server for me was under router configuration / WAN setting. chnage DNS to 4.2.2.2 and reboot , however still can't register my obi202.