September 02, 2014, 02:14:35 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1] 2
  Print  
Author Topic: Ringing Incoming Calls and Google Chat in Gmail  (Read 4567 times)
ruel
Newbie
*
Posts: 15


« on: April 12, 2011, 02:11:55 pm »

hello. i'm new here and looking around at messages. i've just received my OBi100 and have it set up sitting next to my cable modem and plugged into my router. i've set up GV in the OBitalk settings.

i can make calls going out. joy. and incoming calls seem to be ringing in AFTER a while. initially, very discouraging when the only ringing occurred on my iphone. but the phone connected to the OBi100 eventually began ringing with incoming calls. knock on wood. joy. hope that keeps happening.

but i have a question about the documentation at:
https://docs.google.com/viewer?url=http://www.obihai.com/docs/GoogleVoiceOBiTALK.pdf&pli=1

that documentation says to sign out of Google Chat in Gmail. it says: "Very Important: Be sure to sign-out of Google Chat if you want to receive calls on the phone attached to your OBi device."

yes, i can read that, but really do i actually have to do that? i'm finding that i'm getting the phone to ring on incoming calls even if Google Chat is turned on in Gmail in an open browser on my computer -- although, sadly, there is no ringing for an incoming call in Gmail. are there any other consequences for not signing out of Google Chat in Gmail?

sorry if this is an obviously dumb question. thank you so much for reading.
 
Logged
ruel
Newbie
*
Posts: 15


« Reply #1 on: April 12, 2011, 04:05:44 pm »

okay. it looks like i have to turn off Google Chat in Gmail to get the phone attached to the OBi100 to ring. well, i'll get more experience as i use this thing some more with Google Voice since it's only my first day with this OBi100. i thought this OBi100 would be as easy to use as my dad's ooma. in some ways it is, but the uncertainty of if an incoming call will actually ring is something else....
Logged
jimates
OBi110 Beta Testers
***
Posts: 1611


« Reply #2 on: April 12, 2011, 08:26:56 pm »

The way the Obi works is it acts just like your chat in gmail. You can't sign into your gmail from 2 different places at the same time.

This means that if you have your gmail open that calls may not be routed to the Obi. Some have reported no problems with incoming calls when gmail is open. But receiving calls to both the Obi and your gmail is probably not likely.

You can't go into your mail settings and turn off chat calling because that will disable the whole chat calling process.

This is why it is recommended to have a separate gmail account just for your google voice calling. This is just a recommendation to increase the optimum operation of the Obi.
Logged
ruel
Newbie
*
Posts: 15


« Reply #3 on: April 12, 2011, 10:55:48 pm »

hmm. i did set up a separate new gmail account just for google voice.

okay, i'm understanding what you're saying. at the moment, i turned google chat back on in gmail. and the calls may ring on the phone connected to the obi100 but not in gmail. but at other times, it may be the reverse where it rings in gmail but not on the phone connected to the obi100. and yet at other times, it would not ring at all in gmail or on the phone connected to the obi100.

so that's what happens if you have both turned on. wacky.

but fortunately, at all times, the calls would also ring on my iphone. i guess that's what counts for me in the end as a failsafe since google voice was meant to send calls to regular phones in the first place.

i'm more used to what happens with skype where incoming calls to my skype number would simultaneously ring on my computer, ipevo phone, ipad, iphone, but that's skype. i guess i should use something like sipgate instead of gmail if i want to continue taking incoming GV calls on the computer.

so have to turn the google chat off in gmail. then the issue for me becomes whether the phone (that's connected to the obi100) will ring all the time for incoming calls. i'll have to play a little more to see what happens with that tomorrow....
« Last Edit: April 12, 2011, 10:57:40 pm by ruel » Logged
jimates
OBi110 Beta Testers
***
Posts: 1611


« Reply #4 on: April 12, 2011, 11:54:58 pm »

You don't want to turn off google chat in gmail. What you want to do is not open that gmail account in your browser while you are wanting calls to ring the Obi.

If you do use gmail for email you should have a separate account linked to your google voice number and forwarded to the Obi (google chat). And then your main gmail account that you use for email. Of course this eliminates the interaction of your contacts between your gmail and google voice if you did use that feature.

The Obi can fork calls to multiple phones or apps simultaneously like skype or google. But since it wasn't really designed for that feature it isn't as user friendly to set up since there is no GUI for it.
Logged
ruel
Newbie
*
Posts: 15


« Reply #5 on: April 13, 2011, 01:18:35 pm »

@jimates
so i can keep google chat turned on in gmail. but just don't have gmail be open in a browser. so, if the computer is turned off, and therefore the browser is not even open, then it doesn't matter if google chat is set to be logged on inside gmail. okay.

understood regarding having one gmail account for GV, while having another separate gmail account for email. that's what i have, although i also have other email accounts elsewhere for most of my email. but that's all for the same purpose of keeping things separate.

oh, when i was doing a little more testing, either with (1) Google Chat turned on in Gmail, and (2) Google Chat turned on in Gmail but with the browser closed (or the computer turned off), and also (3) Google Chat not turned on in Gmail, it seemed to again be random if the phone connected to my OBi100 would actually ring. it now seems like no ringing most of the time (but as previously mentioned, my iphone always rang). it's somewhat disappointing and discouraging if it's hit-and-miss with whether the phone connected to the OBi100 rings or not. the no-ringing is kind of a big FAIL for my OBi100 device. sorry obi.

btw, i don't think i have anything out of the ordinary with my set-up: GV+gmail, OBi100, analog phone connected directly into the OBi100, and my iphone. and forwarding to google chat was set in the GV settings. nothing else. before i got my OBi100, the google chat in Gmail would first definitely ring followed by the ringing of my iphone. now with the OBi100 hooked up, the ringing is random, if it rings at all, for the phone connected to my OBi100. wacky.

anyways, the result FOR ME after this initial tryout is that i've went into the GV settings and now have GV not forwarding to Google Chat at all. really shortens the number of rings before my iPhone starts ringing. two rings that the caller hears and then my iPhone actually rings. i think for now, i'm going to use my OBi100 as a not-ready-for-primetime toy for at least making outgoing GV calls when i'm at the house while keeping my iPhone as the main phone that happens to more reliably take forwarded incoming GV calls as well as making outgoing GV calls.

 
« Last Edit: April 13, 2011, 01:21:05 pm by ruel » Logged
GeorgeObi
Newbie
*
Posts: 17


« Reply #6 on: January 19, 2012, 12:57:40 am »

I know this is an old thread but i just wanted to state for the record that this feature now works with the current firmware.
i.e.  I am logged on gmail with chat online.  i even have the "call phone" window open.  When someone call my GV# (SIP1), the Obi rings.  ofcourse, gmail does not take the call but at least now you can keep your email open, chat, even make call from the gmail interface, and still accept call on obi!
Logged
oremguy
Newbie
*
Posts: 13


« Reply #7 on: January 19, 2012, 07:14:41 am »

Sorry, but this doesn't work for me. I have the latest software and have been trying for several days to get my primary phone to ring with incoming calls. So far, customer support has not been of any help. I finally had to set up a separate SIP account and number and forward my incoming calls through it, but this adds a delay that is very annoying to my wife. If someone has a solution I would certainly like to know what it is.

Tom
Logged
GeorgeObi
Newbie
*
Posts: 17


« Reply #8 on: January 19, 2012, 08:58:16 am »

Sorry, but this doesn't work for me. I have the latest software and have been trying for several days to get my primary phone to ring with incoming calls. So far, customer support has not been of any help. I finally had to set up a separate SIP account and number and forward my incoming calls through it, but this adds a delay that is very annoying to my wife. If someone has a solution I would certainly like to know what it is.

Tom

Very odd.  Maybe other folks can chime in with their experience.


another work around is to use the Gmail HTML interface so that chat is not enabled. 
http://gmail.google.com/gmail/h/
or maybe sign out of chat.

I realize this does not solve the issue especially if you want to be able to chat at the same time as having your obi phone ring.

Logged
oremguy
Newbie
*
Posts: 13


« Reply #9 on: January 19, 2012, 09:23:29 am »

GeorgeObi,

I did sign out of Chat. This did not have any effect. Still no ring on phone connected to Obi. BTW, when Chat is on and I call GV number no ring on my computer. Don't know if this means anything.
Logged
jimates
OBi110 Beta Testers
***
Posts: 1611


« Reply #10 on: January 19, 2012, 09:48:12 am »

oremguy,

did it ever work?

1 - did you enable calling with chat in your gmail
2 - did you successfully make at least one call from within gmail
3 - did you check google talk as a forwarding phone in your google voice account
Logged
oremguy
Newbie
*
Posts: 13


« Reply #11 on: January 19, 2012, 10:02:41 am »

jimates,

Google Voice and Obi did work when I first installed it (for maybe a day), then it stopped working. I have done all three of your suggestions (more than once).
Logged
GeorgeObi
Newbie
*
Posts: 17


« Reply #12 on: January 19, 2012, 10:11:49 am »

jimates,

Google Voice and Obi did work when I first installed it (for maybe a day), then it stopped working. I have done all three of your suggestions (more than once).

if you go to obitalk.com, login, click on the end point associated with your obi hardware, then look for "Configure Voice Services", does it say connected next to the Service Provider configured with GV account?
Logged
oremguy
Newbie
*
Posts: 13


« Reply #13 on: January 19, 2012, 11:18:35 am »

GeorgeObi,

Yes, Google Voice is connected now and was connected before I did the following.

Let me explain what I just did. Removed power to modem and Obi 110, connected ethernet cable from Obi to modem, restored power to modem, waited, restored power to Obi. Made a call to GV number. No ring. About 45 seconds later the phone connected to Obi rang. I hung up and tried again. This time I got my voice mail. Tried this several times with same results. Reconnect Obi to router. and restored power. Obi kept reseting. Manually reset Obi. Went into ObiTalk GoogleVoice not connected. Had a devil of a time getting it reconnected. Now as I write, my Obi110 is constantly resetting. Bottom line, I seem to have accomplished nothing and am worse off than I was before.
Logged
oremguy
Newbie
*
Posts: 13


« Reply #14 on: January 19, 2012, 12:02:49 pm »

As noted in another thread, solved repeated resetting (rebooting?) problem by again doing a factory reset. Now back to the issue of phone connected to Obi not ringing. Any further suggestions?
Logged
oremguy
Newbie
*
Posts: 13


« Reply #15 on: January 19, 2012, 12:21:45 pm »

Oh, oh. Spoke to soon. Both of my service providers have gone to "service not configured." I repeatedly try to activate both of them to no avail. Sure would like to know what is going on.
Logged
GeorgeObi
Newbie
*
Posts: 17


« Reply #16 on: January 19, 2012, 01:34:13 pm »

Very Weird..  All looks good on mine. 
my first hunch was that maybe the obi go corrupte and you should re-load the firmware... but now you are saying that the web interface shows that SP is not connected to GV ...
not sure.  maybe someone else with more experience can chime in
Logged
RonR
Forum Member

Posts: 4528


« Reply #17 on: January 19, 2012, 01:47:26 pm »

Both of my service providers have gone to "service not configured." I repeatedly try to activate both of them to no avail.

In the case where Google Voice is the ITSPx SignalingProtocol, you must have AuthUserName set on the corresponding SPx for the service to be considered 'configured'.

In the case where SIP is the ITSPx SignalingProtocol, you must have ProxyServer set as well as AuthUserName set on the corresponding SPx for the service to be considered 'configured'.

You have apparently lost one or more of your OBi settings.
Logged
oremguy
Newbie
*
Posts: 13


« Reply #18 on: January 19, 2012, 02:02:23 pm »

Apparently some of my problems were self caused and some were because of the Obi servers going down. As soon as they went back up my SP accounts showed up as configured. Still unresolved is the issue of my phone not ringing and having to forward my GV incoming calls through Callcentric in order to get my phone to ring. Would really like to resolve this issue.
Logged
RonR
Forum Member

Posts: 4528


« Reply #19 on: January 19, 2012, 02:44:07 pm »

Apparently some of my problems were self caused and some were because of the Obi servers going down. As soon as they went back up my SP accounts showed up as configured.

The next time you get suspicious status from the OBiTALK Web Portal, log into the OBi directly and check the status there.  The OBiTALK Web Portal status is often incorrect or not current and can greatly confuse the issue when you're trying to troubleshoot a problem.  The OBi is a standalone device and doesn't need the OBiTALK Web Portal to function.  It's the settings and status in the OBi itself that determine what is actually going on.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC