December 16, 2017, 04:58:42 am *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: ObiTalk and X-Lite Failes to establish call  (Read 42954 times)
mhonard
Newbie
*
Posts: 6


« on: September 24, 2013, 01:40:44 pm »

I've tried everything I can find in the forum's and cannot establish a call.  I'm really lost on what to debug/try next. Any takers on working with me to resolve this issue? Some key points:
*GV works for outcalls and inbound calls via Obi.
*Xlite shows active (green)
*I tired changing the port from 5060 to 5065. Lost the green status
*tried different computers, same result
*tried other expert settings suggested in the forum, no luck.
*Tried Phonerlite but wasn't clear on set up. Need help here.

I really need this to work but need help debugging?
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #1 on: September 25, 2013, 06:24:25 am »

mhonard - welcome to the forum.

I don't use Xlite - many of us got annoyed with the pop-ups etc - but I do have PhonerLite working.

I guess that you are running OBiAPP ok on your PC. This alone should give you the green status on your OBi Dashboard. Any softphone you use connects to OBiAPP and OBiAPP then connects to OBiTALK.

PhonerLite settings:

Server > Proxy/Registrar: 127.0.0.1
Server > Register: checked

User > User Name: 290123456
User > Displayed Name: anything
User > Authentication Name: 290123456

Where 290123456 is your softphone number. All other settings at default.


I use PhonerLite for testing/debugging, which looks like what you need just now. My preferred softphone of the free ones on offer is 3CX.


Logged
mhonard
Newbie
*
Posts: 6


« Reply #2 on: September 25, 2013, 09:22:31 am »

Thanks I'll give it a try. if this doesn't work what type of information should I look for?
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #3 on: September 25, 2013, 10:13:03 am »

If OBiAPP has loaded ok on your PC, then your OBi Dashboard should show green status next to your softphone number (you may need to refresh the Dashboard page to see this).

If that works, then there's nothing much to stop the PhonerLite connecting to OBiAPP, as they are both on the same PC. You could right click on the OBiAPP symbol and look at Properties > Status. It will show if the PhonerLite has registered with the OBiAPP.
Logged
mhonard
Newbie
*
Posts: 6


« Reply #4 on: September 25, 2013, 10:24:36 am »

Confirmed Obi110 and softphone show green status on Obi dashboard

Ok use your PhonerlIte settings and got the green sip notice at the bottom.  Dialed out and immediatly got a "486:Busy Here" cause.

ObiApp status (right click) on PC shows

System State: Normal
Call State: No Call
Softphone Client State:Not Registered
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #5 on: September 25, 2013, 10:43:36 am »

Check OBiAPP "My OBi" tab that all details are correct. Voice Gateway should be your OBi110 number.

Check OBiAPP "Advanced" tab that SIP Port is 5060.

Check PhonerLIte Network > Local Port is 5060.

Also OBiAPP needs to open before PhonerLite opens. Close PhonerLite, then reopen see if OBiAPP shows it is registered.
Logged
mhonard
Newbie
*
Posts: 6


« Reply #6 on: September 25, 2013, 12:16:06 pm »

FIXED, thanks a million.  Smiley

Everything checked out as you noted except the "My Obi" tab voice gateway was blank. I want into the Obi dashboard and edited the softphone entry to add the Obi110 number (not softphone number). Reopened Obiapp first and Phonerlite and dialed out perfectly.

Again thanks. i'm going to try out 3CX next
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #7 on: September 25, 2013, 12:29:52 pm »

Good to see you up and running   Smiley

Now for your next question, which will be about incoming calls - yes I do have second sight   Cheesy

For incoming calls to be “forked” to your softphone as well as your OBi connected phone you need to change the relevant InboundCallRoute. For instance, if the incoming call is on sp1, then change to this:

Voice Services > SP1 Service > X_InboundCallRoute:
{ph,pp(ob290123456)}

Where 290123456 is your softphone number.


The nice things about 3CX is that you can register several accounts at one time and have video. I would keep PhonerLite for testing. Only have one open at a time. Search for 3CX on this forum, the settings are in here somewhere.

Logged
mhonard
Newbie
*
Posts: 6


« Reply #8 on: September 25, 2013, 03:19:02 pm »

Good to see you up and running   Smiley

Now for your next question, which will be about incoming calls - yes I do have second sight   Cheesy

For incoming calls to be “forked” to your softphone as well as your OBi connected phone you need to change the relevant InboundCallRoute. For instance, if the incoming call is on sp1, then change to this:

Voice Services > SP1 Service > X_InboundCallRoute:
{ph,pp(ob290123456)}

Where 290123456 is your softphone number.



Thanks for anticipating my needs. Unfortunately these settings did not result in incoming calls been forked over to my computer softphone.  Only my connected phone rings.  Do you have any other suggestions?

Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #9 on: September 26, 2013, 10:40:11 am »

No new suggestions needed. This will work:

Voice Services > SP1 Service > X_InboundCallRoute:
{ph,pp(ob290123456)}

Did you update your OBi in the approved manner (approved by Obihai, but not everyone else!):

Make changes via the Obi Expert Configuration pages. From your OBi Dashboard, click on your OBi number and follow the prompts to get there. To change a value uncheck both boxes to the right of the value and leave them unchecked. After changing the values on one page, press submit at the bottom of the page and wait a few minutes for the Obi to reboot.


If you did that, then please consult Status > Call History via you OBi web page. This is only available via your web page - dial ***1 for the ip address. It should show the call going to phone and forked to OBiTALK1.

If all this works, then there is a problem with the softphone end of the call. That seems unlikely if the softphone is registered with OBiAPP.
Logged
mhonard
Newbie
*
Posts: 6


« Reply #10 on: September 26, 2013, 11:18:07 am »

Got to admit I'm confused now.

I did make cahnges in expert mode with boxes unchecked and submit.

Call history is empty.

Not sure I understand "This is only available via your web page - dial ***1 for the ip address. It should show the call going to phone and forked to OBiTALK1"
Logged
ianobi
Hero Member & Beta Tester
*****
Posts: 1828


« Reply #11 on: September 26, 2013, 11:32:04 am »

If you have found Call History, then you don't need the ***1 advice on how to find it.

If you answer an incoming call on the phone connected to the OBi, then it is recorded in Call History. This is regardless of whether or not it is forked to another destination. Every successful call that passes through your OBi is recorded.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC