January 24, 2020, 11:57:16 pm *
Welcome, Guest. Please login or register.
News:
 
   Forum Home   Search Login Register OBiTALK  
Pages: [1]
  Print  
Author Topic: ENABLE anonymous calls on Obi110  (Read 6291 times)
redzep
Newbie
*
Posts: 6


« on: May 15, 2014, 04:19:41 pm »

Hi

I'm having a hard time enabling the right settings for my Obi110 to let anonymous calls through. I have 2 GV --> Future9 numbers --> SP1 & SP2

*77 & *87 seem to have no effect.

Furthermore I did this:

Voice Services -> SP1 Service -> AnonymousCallBlockEnable : (unchecked)
Voice Services -> SP1 Service -> AnonymousCallEnable : (checked)

Voice Services -> SP2 Service -> AnonymousCallBlockEnable : (unchecked)
Voice Services -> SP2 Service -> AnonymousCallEnable : (checked)

Voice Services -> OBiTALK Service -> AnonymousCallBlockEnable : (unchecked)
Voice Services -> OBiTALK Service -> AnonymousCallEnable : (checked)

Physical Interfaces -> LINE Port -> AnonymousCallBlockEnable : (unchecked)

- I've tried it with both AutoAttendant enabled and not.
- I've rebooted each time ***9
- I've isolated it to the Obi (unplugging it), if I do that, teh calls ring through to GV VM.

Any thoughts? All help MUCH APPRECIATED!
Logged
gderf
Sr. Member
****
Posts: 489



« Reply #1 on: May 15, 2014, 05:21:41 pm »

Are the calls being blocked at Future9?
Logged

Help me OBiHai PhoneOBi. You’re my only hope.
redzep
Newbie
*
Posts: 6


« Reply #2 on: May 15, 2014, 05:25:36 pm »

thanks for your response...

No, according to Nitzan at Future 9, who looked at the logs on his end, it's the Obi picking up. I'm totally baffled.
Logged
giqcass
Hero Member & Beta Tester
*****
Posts: 1436


« Reply #3 on: May 15, 2014, 09:30:16 pm »

Did you change the inbound call route on the Obi?  Anonymous calls can be blocked there as well.
Logged

Long live our new ObiLords!
drgeoff
Hero Member & Beta Tester
*****
Posts: 4551


« Reply #4 on: May 16, 2014, 04:52:44 am »

FYI the AnonymousCallEnable settings are only relevant to calls from your OBi.

I'm not sure if anonymous incoming calls show up in the Obi's call log or not.  Worth a quick look.

I'm reasonably sure they do appear in the events sent to the syslog server if you have one set up.
« Last Edit: May 16, 2014, 04:57:28 am by drgeoff » Logged
giqcass
Hero Member & Beta Tester
*****
Posts: 1436


« Reply #5 on: May 16, 2014, 06:08:43 am »

FYI the AnonymousCallEnable settings are only relevant to calls from your OBi.

I'm not sure if anonymous incoming calls show up in the Obi's call log or not.  Worth a quick look.

I'm reasonably sure they do appear in the events sent to the syslog server if you have one set up.

Call history is worth a check however you are incorrect about *77 and *87.  Those are for inbound anonymous blocking.  *81, *82, *67, and *68 are for outbound anonymous calling features.  I know because I accidentally set the incoming anonymous blocking before when I accidentally dialed *77.
Logged

Long live our new ObiLords!
drgeoff
Hero Member & Beta Tester
*****
Posts: 4551


« Reply #6 on: May 16, 2014, 07:12:49 am »

If the "incorrect about *77 and *87" was intended for me, I respectfully point out that I made no reference to those.
Logged
redzep
Newbie
*
Posts: 6


« Reply #7 on: May 16, 2014, 04:52:02 pm »

Thanks to everyone for trying to help me solve this. My call log is full of my attempts to get through, a typical one looks like this:

Call 28   05/14/2014    16:00:00   

Terminal ID           SP1           PHONE1
Peer Name           asterisk   
Peer Number   asterisk   
Direction           Inbound   Inbound
16:00:00           Ringing   
16:00:04                      Call Connected
16:00:08           End Call   

Did you change the inbound call route on the Obi?  Anonymous calls can be blocked there as well.

I don't believe I touched that. Where would that be? Here are the instructions I followed for F9:

Login to your Obi, and go to Service Providers > ITSP Profile A > SIP, and set:
ProxyServer: incoming.future-nine.com
RegistrarServer: incoming.future-nine.com
UserAgentDomain: sip.future-nine.com

Then go to Service Providers > ITSP Profile > General, and set:
Name: your name (or any name)
Digit Map:
(*xx.|911|1xxxxxxxxxx|<1>[2-9]xxxxxxxxx|[2-9]xxxxxx|011xx.|xx.|(Mipd)|[^*#]@@.)

Then go to Voice Services > SP Service, and set:
X_KeepAliveEnable: yes
X_KeepAliveExpires: 60
AuthUserName: see username in the SIP INFO screen
AuthPassword: see secret field in the SIP INFO screen
Logged
drgeoff
Hero Member & Beta Tester
*****
Posts: 4551


« Reply #8 on: May 16, 2014, 06:03:44 pm »


Did you change the inbound call route on the Obi?  Anonymous calls can be blocked there as well.

I don't believe I touched that. Where would that be?
Voice Services/SP1 Service/X_InboundCallRoute.  Default is 'ph' (without the quote marks).

But looks to me that your call history is showing that the phone was rung for 4 seconds, then it was picked up and after another 4 seconds the call was terminated. What sort of phone is connected to the OBi?
« Last Edit: May 16, 2014, 06:06:52 pm by drgeoff » Logged
redzep
Newbie
*
Posts: 6


« Reply #9 on: May 16, 2014, 06:35:23 pm »

Thanks for sticking with me on this.

so I noticed that the X_InboundCallRoute is different for SP1 & SP2

SP1: ph
SP2: {>*********:ph}

where the asterisks represent one of my F9 account numbers

is that right? could that be why the Obi is rejecting anon calls on SP1?
Logged
giqcass
Hero Member & Beta Tester
*****
Posts: 1436


« Reply #10 on: May 17, 2014, 12:23:08 am »

If the "incorrect about *77 and *87" was intended for me, I respectfully point out that I made no reference to those.
I respectively point out I misread your post. lol!

Thanks for sticking with me on this.

so I noticed that the X_InboundCallRoute is different for SP1 & SP2

SP1: ph
SP2: {>*********:ph}

where the asterisks represent one of my F9 account numbers

is that right? could that be why the Obi is rejecting anon calls on SP1?

That is the setting I was talking about earlier.  To break it down the rule in Sp2 says
When a sip call comes in to the user name ********* then send it to phone port 1.  If the call is to any other user name ignore it.  As long as these anonymous calls are being routed through your F9 account that rule should not block them.

You may want to perform this test for troubleshooting.
Here is a trick you can do to determine the username.
Temporarily add {sp1($2)} to the beginning of your SP2 X_InboundCallRoute, then call your SP2 phone number.
$2 is a variable that contains the username of SP2.
The above rule will attempt to bridge the inbound call out SP1 using the username as the outbound phone number.
This call will obviously fail, but the call history will show the username as the outbound number.



« Last Edit: May 17, 2014, 12:32:11 am by giqcass » Logged

Long live our new ObiLords!
redzep
Newbie
*
Posts: 6


« Reply #11 on: May 17, 2014, 07:40:54 am »

OK --

SO it turned out it was the phone (panasonic KXGT7731) which had a "block incoming calls without phone numbers" (apparently turned on)

I disabled it, and the calls go through. I feel like an idiot that the explanation was so simple, but I really appreciate the help and advice on the forum here.

Thanks again!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC